• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 全部
  • 全部
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
高级搜索

S5820 IPV6 OSPFV3与ISIS路由重分布典型组网配置案例

2020-03-15发表
  • 3关注
  • 9收藏,57浏览
粉丝:102人 关注:0人

组网及说明



组网说明:

本案例采用H3C HCL模拟器的S5820来模拟IPV6 ospfv3ISIS路由重分布的典型组网配置。SW1SW2运行OSPFV3路由协议,SW2SW3运行ISIS路由协议,为了实现物理机能够PINGSW3,因此需要在SW2配置OSPFV3ISIS路由重分布。

 

配置步骤

1、按照网络拓扑图正确配置IP地址

2、SW1SW2运行OSPFV3路由协议

3、SW2SW3运行ISIS路由协议

4、SW2配置OSPFV3ISIS路由重分布

配置关键点

SW1:

<H3C>sys

System View: return to User View with Ctrl+Z.

[H3C]sysname SW1

[SW1]int gi 1/0/2

[SW1-GigabitEthernet1/0/2]port link-mode route

[SW1-GigabitEthernet1/0/2]ipv6 address 1::1 64

[SW1-GigabitEthernet1/0/2]quit

[SW1]int gi 1/0/1

[SW1-GigabitEthernet1/0/1]port link-mode route

[SW1-GigabitEthernet1/0/1]description <connect to SW2>

[SW1-GigabitEthernet1/0/1]ipv6 address 2::1 64

[SW1-GigabitEthernet1/0/1]quit

[SW1]int loopback 0

[SW1-LoopBack0]ip address 1.1.1.1 32

[SW1-LoopBack0]quit

[SW1]int loopback 1

[SW1-LoopBack1]ipv6 address 4::1 64

[SW1-LoopBack1]quit

 

SW1 OSPFV3关键配置点:

[SW1]ospfv3 1

[SW1-ospfv3-1]import-route direct

[SW1-ospfv3-1]router-id 1.1.1.1

[SW1-ospfv3-1]quit

[SW1]int loopback 1

[SW1-LoopBack1]ospfv3 1 area 0

[SW1-LoopBack1]quit

[SW1]int gi 1/0/1

[SW1-GigabitEthernet1/0/1]ospfv3 1 area 0

[SW1-GigabitEthernet1/0/1]quit

[SW1]int gi 1/0/2

[SW1-GigabitEthernet1/0/2]ospfv3 1 area 0

[SW1-GigabitEthernet1/0/2]quit

 

 

SW2

<H3C>sys

System View: return to User View with Ctrl+Z.

[H3C]sysname SW2

[SW2]int loopback 0

[SW2-LoopBack0]ip address 2.2.2.2 32

[SW2-LoopBack0]quit

[SW2]int loopback 1

[SW2-LoopBack1]ipv6 address 5::1 64

[SW2-LoopBack1]quit

[SW2]int gi 1/0/1

[SW2-GigabitEthernet1/0/1]port link-mode route

[SW2-GigabitEthernet1/0/1]des <connect to SW1>

[SW2-GigabitEthernet1/0/1]ipv6 address 2::2 64

[SW2-GigabitEthernet1/0/1]quit

[SW2]int gi 1/0/2

[SW2-GigabitEthernet1/0/2]port link-mode route

[SW2-GigabitEthernet1/0/2]des <connect to SW3>

[SW2-GigabitEthernet1/0/2]ipv6 address 3::2 64

[SW2-GigabitEthernet1/0/2]quit

 

SW2 OSPFV3ISIS重分布关键配置点:

[SW2]ospfv3 1

[SW2-ospfv3-1]import-route direct

[SW2-ospfv3-1]import-route isisv6 1 allow-direct

[SW2-ospfv3-1]router-id 2.2.2.2

[SW2-ospfv3-1]quit

[SW2]isis 1

[SW2-isis-1]is-level level-1

[SW2-isis-1]network-entity 10.0000.0000.0001.00

[SW2-isis-1]address-family ipv6 unicast

[SW2-isis-1-ipv6]import-route direct

[SW2-isis-1-ipv6]import-route ospfv3 1 level-1

[SW2-isis-1-ipv6]quit

[SW2-isis-1]quit

[SW2]int gi 1/0/1

[SW2-GigabitEthernet1/0/1]ospfv3 1 area 0

[SW2-GigabitEthernet1/0/1]quit

[SW2]int gi 1/0/2

[SW2-GigabitEthernet1/0/2]isis ipv6 enable 1

[SW2-GigabitEthernet1/0/2]quit

 

SW3

<H3C>sys

System View: return to User View with Ctrl+Z.

[H3C]sysname SW3

[SW3]int loopback 0

[SW3-LoopBack0]ip address 3.3.3.3 32

[SW3-LoopBack0]quit

[SW3]int loopback 1

[SW3-LoopBack1]ipv6 address 6::1 64

[SW3-LoopBack1]quit

[SW3]int gi 1/0/2

[SW3-GigabitEthernet1/0/2]port link-mode route

[SW3-GigabitEthernet1/0/2]des <connect to SW2>

[SW3-GigabitEthernet1/0/2]ipv6 address 3::1 64

[SW3-GigabitEthernet1/0/2]quit

 

SW3 ISIS关键配置点:

[SW3]isis 1

[SW3-isis-1]is-level level-1

[SW3-isis-1]network-entity 10.0000.0000.0002.00

[SW3-isis-1]address-family ipv6 unicast

[SW3-isis-1-ipv6]import-route direct

[SW3-isis-1-ipv6]quit

[SW3-isis-1]quit

[SW3]int LoopBack 1

[SW3-LoopBack1]isis ipv6 enable 1

[SW3-LoopBack1]quit

[SW3]int gi 1/0/2

[SW3-GigabitEthernet1/0/2]isis ipv6 enable 1

[SW3-GigabitEthernet1/0/2]quit

 

测试:

物理机填写IPV6地址:



物理机能PINGSW3loopback 1:



分别查看R1R2OSPFV3邻居信息:





分别查看R2R3ISIS邻居信息:





分别查看R1R2R3IPV6路由表:

<SW1>dis ipv6 routing-table

 

Destinations : 12       Routes : 12

 

Destination: ::1/128                                     Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 1::/64                                      Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : GE1/0/2                                     Cost      : 0

 

Destination: 1::1/128                                    Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 2::/64                                      Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : GE1/0/1                                     Cost      : 0

 

Destination: 2::1/128                                    Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 3::/64                                      Protocol  : O_ASE2

NextHop    : FE80::50BB:ADFF:FE4E:206                    Preference: 150

Interface  : GE1/0/1                                     Cost      : 1

 

Destination: 4::/64                                      Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : Loop1                                       Cost      : 0

 

Destination: 4::1/128                                    Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 5::/64                                      Protocol  : O_ASE2

NextHop    : FE80::50BB:ADFF:FE4E:206                    Preference: 150

Interface  : GE1/0/1                                     Cost      : 1

 

Destination: 6::/64                                      Protocol  : O_ASE2

NextHop    : FE80::50BB:ADFF:FE4E:206                    Preference: 150

Interface  : GE1/0/1                                     Cost      : 1

 

Destination: FE80::/10                                   Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: FF00::/8                                    Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : NULL0                                       Cost      : 0

<SW1>

 

[SW2]dis ipv6 routing-table

 

Destinations : 13       Routes : 13

 

Destination: ::1/128                                     Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 1::/64                                      Protocol  : O_INTRA

NextHop    : FE80::50BB:A5FF:FE92:106                    Preference: 10

Interface  : GE1/0/1                                     Cost      : 2

 

Destination: 2::/64                                      Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : GE1/0/1                                     Cost      : 0

 

Destination: 2::2/128                                    Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 3::/64                                      Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : GE1/0/2                                     Cost      : 0

 

Destination: 3::2/128                                    Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 4::/64                                      Protocol  : O_ASE2

NextHop    : FE80::50BB:A5FF:FE92:106                    Preference: 150

Interface  : GE1/0/1                                     Cost      : 1

 

Destination: 4::1/128                                    Protocol  : O_INTRA

NextHop    : FE80::50BB:A5FF:FE92:106                    Preference: 10

Interface  : GE1/0/1                                     Cost      : 1

 

Destination: 5::/64                                      Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : Loop1                                       Cost      : 0

 

Destination: 5::1/128                                    Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 6::/64                                      Protocol  : IS_L1

NextHop    : FE80::50BB:B1FF:FED0:307                    Preference: 15

Interface  : GE1/0/2                                     Cost      : 10

 

Destination: FE80::/10                                   Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: FF00::/8                                    Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : NULL0                                       Cost      : 0

[SW2]

 

[SW3]dis ipv6 routing-table

 

Destinations : 10       Routes : 10

 

Destination: ::1/128                                     Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 1::/64                                      Protocol  : IS_L1

NextHop    : FE80::50BB:ADFF:FE4E:207                    Preference: 15

Interface  : GE1/0/2                                     Cost      : 10

 

Destination: 3::/64                                      Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : GE1/0/2                                     Cost      : 0

 

Destination: 3::1/128                                    Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 4::/64                                      Protocol  : IS_L1

NextHop    : FE80::50BB:ADFF:FE4E:207                    Preference: 15

Interface  : GE1/0/2                                     Cost      : 10

 

Destination: 4::1/128                                    Protocol  : IS_L1

NextHop    : FE80::50BB:ADFF:FE4E:207                    Preference: 15

Interface  : GE1/0/2                                     Cost      : 10

 

Destination: 6::/64                                      Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : Loop1                                       Cost      : 0

 

Destination: 6::1/128                                    Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: FE80::/10                                   Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: FF00::/8                                    Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : NULL0                                       Cost      : 0

[SW3]

 

至此,S5820 IPV6 OSPFV3ISIS重分布典型组网配置案例已完成!

 

 

0 个评论

该案例暂时没有网友评论

编辑评论

举报

×

侵犯我的权益 >
对根叔知了社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔知了社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明

提出建议

    +
<

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作