• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 全部
  • 全部
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
高级搜索

★ L2tp VPN multi-branch mutual access

2020-12-15 Published
  • 0关注
  • 0收藏,69浏览
粉丝:0人 关注:0人

Network Topology

Demand

Branch MSR2 and branch MSR3 establish L2TP VPN with headquarters MSR1 respectively, and the branches can communicate with each other through the headquarters. 

 

Configuration Steps

LNS

#

interface LoopBack0

 ip address 192.168.1.1 255.255.255.0

#

interface GigabitEthernet0/0

 port link-mode route

 combo enable copper

 ip address 1.1.1.2 255.255.255.252

 nat outbound

#

 ip pool huqi 66.66.66.3 66.66.66.65

#

interface Virtual-Template1

 ppp authentication-mode pap chap

 remote address pool huqi

 ip address 66.66.66.66 255.255.255.0

#

l2tp-group 1 mode lns

 allow l2tp virtual-template 1

 undo tunnel authentication

 tunnel name H3C-LNS

#

l2tp enable

#

local-user huqi class network

 password simple huqi

 service-type ppp

 authorization-attribute user-role network-operator

#

ip route-static 0.0.0.0 0 1.1.1.1

ip route-static 192.168.2.0 24 66.66.66.1

ip route-static 192.168.3.0 24 66.66.66.2

#

LAC1:

#

interface LoopBack0

 ip address 192.168.2.1 255.255.255.0

#

interface GigabitEthernet0/0

 port link-mode route

 combo enable copper

 ip address 2.2.2.2 255.255.255.252

 nat outbound

#

interface Virtual-PPP0

 ppp chap password simple huqi

 ppp chap user huqi

 ip address 66.66.66.1 255.255.255.0

 l2tp-auto-client l2tp-group 1

#

l2tp-group 1 mode lac

 lns-ip 1.1.1.2

 undo tunnel authentication

 tunnel name H3C-LAC1

#

l2tp enable

#

ip route-static 0.0.0.0 0 2.2.2.1

ip route-static 192.168.1.0 24 Virtual-PPP0

ip route-static 192.168.3.0 24 Virtual-PPP0

#

 

LAC2:

#

interface LoopBack0

 ip address 192.168.3.1 255.255.255.0

#

interface GigabitEthernet0/0

 port link-mode route

 combo enable copper

 ip address 3.3.3.2 255.255.255.252

 nat outbound

#

interface Virtual-PPP0

 ppp chap password simple huqi

 ppp chap user huqi

 ip address 66.66.66.2 255.255.255.0

 l2tp-auto-client l2tp-group 1

#

l2tp-group 1 mode lac

 lns-ip 1.1.1.2

 undo tunnel authentication

 tunnel name H3C-LAC2

#

l2tp enable

#

 ip route-static 0.0.0.0 0 3.3.3.1

ip route-static 192.168.1.0 24 Virtual-PPP0

ip route-static 192.168.2.0 24 Virtual-PPP0


Key Configuration

LNS

[LNS]dis l2tp tunnel

LocalTID RemoteTID State        Sessions RemoteAddress   RemotePort RemoteName

31954    65062     Established  1        3.3.3.2         1701       H3C-LAC2  

47746    55251     Established  0        2.2.2.2         1701       H3C-LAC1  

 

LAC1

[LAC1]dis l2tp tunnel

LocalTID RemoteTID State        Sessions RemoteAddress   RemotePort RemoteName

55251    47746     Established  0        1.1.1.2         1701       H3C-LNS   

 

[LAC1]ping -a 192.168.2.1 192.168.1.1

Ping 192.168.1.1 (192.168.1.1) from 192.168.2.1: 56 data bytes, press CTRL_C to break

56 bytes from 192.168.1.1: icmp_seq=0 ttl=255 time=2.000 ms

56 bytes from 192.168.1.1: icmp_seq=1 ttl=255 time=1.000 ms

56 bytes from 192.168.1.1: icmp_seq=2 ttl=255 time=1.000 ms

56 bytes from 192.168.1.1: icmp_seq=3 ttl=255 time=2.000 ms

56 bytes from 192.168.1.1: icmp_seq=4 ttl=255 time=1.000 ms

 

--- Ping statistics for 192.168.1.1 ---

5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss

round-trip min/avg/max/std-dev = 1.000/1.400/2.000/0.490 ms

[LAC1]%Jun 23 00:52:37:991 2020 LAC1 PING/6/PING_STATISTICS: Ping statistics for 192.168.1.1: 5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss, round-trip min/avg/max/std-dev = 1.000/1.400/2.000/0.490 ms.

 

[LAC1]ping -a 192.168.2.1 192.168.3.1

Ping 192.168.3.1 (192.168.3.1) from 192.168.2.1: 56 data bytes, press CTRL_C to break

56 bytes from 192.168.3.1: icmp_seq=0 ttl=254 time=3.000 ms

56 bytes from 192.168.3.1: icmp_seq=1 ttl=254 time=2.000 ms

56 bytes from 192.168.3.1: icmp_seq=2 ttl=254 time=3.000 ms

56 bytes from 192.168.3.1: icmp_seq=3 ttl=254 time=2.000 ms

56 bytes from 192.168.3.1: icmp_seq=4 ttl=254 time=5.000 ms

 

--- Ping statistics for 192.168.3.1 ---

5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss

round-trip min/avg/max/std-dev = 2.000/3.000/5.000/1.095 ms

 

LAC2

[LAC2]dis l2tp tunnel

LocalTID RemoteTID State        Sessions RemoteAddress   RemotePort RemoteName

65062    31954     Established  0        1.1.1.2         1701       H3C-LNS

 

[LAC2]ping -a 192.168.3.1 192.168.1.1

Ping 192.168.1.1 (192.168.1.1) from 192.168.3.1: 56 data bytes, press CTRL_C to break

56 bytes from 192.168.1.1: icmp_seq=0 ttl=255 time=1.000 ms

56 bytes from 192.168.1.1: icmp_seq=1 ttl=255 time=2.000 ms

56 bytes from 192.168.1.1: icmp_seq=2 ttl=255 time=2.000 ms

56 bytes from 192.168.1.1: icmp_seq=3 ttl=255 time=1.000 ms

56 bytes from 192.168.1.1: icmp_seq=4 ttl=255 time=3.000 ms

 

--- Ping statistics for 192.168.1.1 ---

5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss

round-trip min/avg/max/std-dev = 1.000/1.800/3.000/0.748 ms

 

[LAC2]ping -a 192.168.3.1 192.168.2.1

Ping 192.168.2.1 (192.168.2.1) from 192.168.3.1: 56 data bytes, press CTRL_C to break

56 bytes from 192.168.2.1: icmp_seq=0 ttl=254 time=3.000 ms

56 bytes from 192.168.2.1: icmp_seq=1 ttl=254 time=3.000 ms

56 bytes from 192.168.2.1: icmp_seq=2 ttl=254 time=2.000 ms

56 bytes from 192.168.2.1: icmp_seq=3 ttl=254 time=2.000 ms

56 bytes from 192.168.2.1: icmp_seq=4 ttl=254 time=2.000 ms

 

--- Ping statistics for 192.168.2.1 ---

5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss

round-trip min/avg/max/std-dev = 2.000/2.400/3.000/0.490 ms

0 comments

No comments

Add Comments:

举报

×

侵犯我的权益 >
对根叔知了社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔知了社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明

提出建议

    +
<

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作