• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 漏洞说明
  • 全部
  • 全部
  • 大数据引擎
  • 知了引擎
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
搜索引擎
匹配模式
高级搜索

V9 无线控制器WLAN本地转发配置方法(WEB版)

2022-09-08 发表
  • 0关注
  • 0收藏 322浏览
闫宁 九段
粉丝:27人 关注:0人

组网及说明

1 配置需求或说明

1.1  适用产品系列

本手册适用于如下产品:V9 AC系列产品,包含:WX3500X

设备默认LAN口地址是192.168.0.100

1.2  需要的工具环境及注意事项

Switch作为DHCP服务器为APClient(客户端)分配IP地址。给ap下发的注册vlanvlan1,注册vlan1网段:192.168.0.0/24,给无线客户端下发的业务vlan200,业务vlan200网段:192.168.200.0/24,交换机充当无线客户端的网关。

现要求:为了使AP能够直接转发Client报文,需要在AC上开启本地转发功能,同时通过下发map-configuration文件来对AP进行配置实现本地转发,使Client的数据流量不经过AC,直接由AP转发给vlan200的网关。

2 组网图


配置步骤

3 配置步骤

3.1  apcfg.txt的配置并且上传到ac

#提示: 在编辑map-configuration文件时需注意,文件的某个命令行后面不要有Tab键或者大量空格出现,否则会出现该行配置配不成功的情况

#新建一个txt,命名为apcfg.txtapcfg.txt的内容,要求为文本文件,按照命令行配置的顺序编写文本文件上传至AC即可,ACAP关联后,通过map-configuration命令下发至AP生效。从而完成对AP的配置。

# apcfg.txt配置文件为:

system-view   //进入系统视图

vlan 200   //创建业务vlan 200

quit   //退出

interface GigabitEthernet 1/0/1   //进入1/0/1配置视图

port link-type trunk   //配置接口为trunk模式

port trunk permit vlan 200   //放通业务vlan 200

quit   //退出

#通过ACWEB页面把apcfg.txt传到AC设备上

电脑网卡设置为:192.168.0.10 /24 ,确保AC和电脑之间路由可达。

#打开浏览器后登录设备,输入:https://192.168.0.100,设备默认的登录用户名和密码都是“admin”。

#首次登陆设备需要修改密码,密码至少10位且至少包含两类元素组合。

#进入ACWEB页面后,点击 “系统”> “文件管理”,点击上传按钮,选择写好的apcfg.txt文档,点击确定上传。

#选中刚刚创建的apcfg.txt文件,点击确定,即可将map文件上传至AC中。

3.2  配置AC

3.2.1  AC上配置相关VLAN和对应虚接口地址,并放通对应接口。

# AC将使用VLAN1接口的IP地址与AP建立注册隧道。

# 创建VLAN 200作为Client接入的业务VLAN。点击 “网络配置” VLAN”,然后点击“加号”按钮,创建业务vlan200.

点击,输入200,创建vlan 200

选中刚才创建的VLAN,配置VLAN 200的接口IP地址。

在“网络配置”>“接口”视图中,选中和核心交换机互联接口GigabitEthernet1/0/2接口,并点击“编辑”按钮设置接口的类型。

配置ACSwitch相连的GigabitEthernet1/0/2Trunk模式,允许VLAN 1VLAN 200通过。

3.2.2   配置无线服务

SSIDWIFI名字:本地转发,开启对vlan200的本地转发功能,并设置业务VLANVLAN200,无线服务模板配置静态的PSK认证方式。

 (3) 配置AP,开启AC中的自动AP和自动固化功能,让AP自动上线。

#首次注册可能等待15分钟左右,在 “无线配置”>AP管理”>AP”中查看AP是否上线成功,AP如果已经上线会在状态中显示为在线状态。

#AP上线后默认会归到default-group组,在“无线配置”>AP管理”>AP组”中,选择组网中的AP型号,并在右下角开启该类型AP射频口。

3.2.3  配置APmap文件

在“AP管理”中选择默认的“default-group”,然后在默认的AP组中,选择配置“MAP文件设置”,选择“apcfg.txt”的文件。

3.3  保存AC的配置

#点击右上角的“admin>“保存”

#也可以点击 “系统”>“设备管理”>“配置文件”>“保存当前配置”。

3.4  Switch的配置

# 创建相关VLAN,配置switchAP相连的接口为Trunk类型,PVIDAP 管理VLAN,开启DHCP server功能,AP、无线客户端Client都能通过DHCP server自动获取IP地址

# 创建VLAN 1VLAN 200,其中VLAN 1用于转发ACAP间隧道内的流量,VLAN 200为无线客户端接入的VLAN

# 创建VLAN 1及其对应的VLAN接口,并为该接口配置IP地址。AC将使用该接口的IP地址与AP建立注册隧道。

< Switch > system-view   //进入系统视图

[Switch] interface vlan-interface 1   //创建vlan 1的虚接口

[Switch-Vlan-interface1] ip address 192.168.0.1 24   //配置vlan 1接口ip地址

[Switch-Vlan-interface1] quit   //退出

# 创建VLAN 200作为Client接入的业务VLAN,配置VLAN 200的接口IP地址。

[Switch] vlan 200   //创建vlan 200

[Switch-vlan200] quit   //退出

[Switch] interface vlan-interface 200   //创建vlan 200的虚接口

[Switch-Vlan-interface200] ip address 192.2.1.2 24   //配置vlan 200接口ip地址

[Switch-Vlan-interface200] quit   //退出

配置DHCP服务

# 创建名为vlan1DHCP地址池,动态分配的网段为192.168.0.0/24,给ap下发注ip地址,网关地址为192.168.0.1

[Switch] dhcp server ip-pool vlan1   //创建dhcp地址池vlan1

[Switch-dhcp-pool-vlan1] network 192.168.0.0 mask 255.255.255.0   //配置下发的地址网段

[Switch-dhcp-pool-vlan1] gateway-list 192.168.0.1   //下发网关地址

[Switch-dhcp-pool-vlan1] quit   //退出

# 创建名为vlan200DHCP地址池,动态分配的网段为192.168.200.0/24,给无线客户端下发ip地址,网关地址为192.168.200.1

[Switch] dhcp server ip-pool vlan200   //创建dhcp地址池vlan200

[Switch-dhcp-pool-vlan200] network 192.168.200.0 mask 255.255.255.0   //配置下发的地址网段

[Switch-dhcp-pool-vlan200] gateway-list 192.168.200.1   //下发网关地址

[Switch-dhcp-pool-vlan200] dns-list 114.114.114.114    //下发DNS

[Switch-dhcp-pool-vlan200] quit   //退出

# 使能DHCP服务。

[Switch] dhcp enable    //开启dhcp功能

# gigabitethernet 1/0/1连接AC的接口,配置SwitchAC连接的GigabitEthernet1/0/1接口属性Trunk,允许VLAN 1VLAN 200通过。

[Switch] interface gigabitethernet 1/0/1   //进入1/0/1配置视图

[Switch-GigabitEthernet1/0/1] port link-type trunk   //配置接口为trunk模式

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 1 200   //放通vlan 1200

[Switch-GigabitEthernet1/0/1] quit   //退出

# gigabitethernet 1/0/2连接AP的接口,配置SwitchAP相连的GigabitEthernet1/0/2接口属性为Trunk,当前Trunk口的PVID1允许VLAN 1VLAN 200通过。

[Switch] interface gigabitethernet 1/0/2   //进入1/0/2配置视图

[Switch-GigabitEthernet1/0/2] port link-type trunk   //配置接口为trunk模式

[Switch-GigabitEthernet1/0/2] port trunk permit vlan 1 200   //放通vlan 1200

[Switch-GigabitEthernet1/0/2] port trunk pvid vlan 1   //配置接口pvid为管理vlan

4 验证配置

# Client1上线获取到地址是192.168.200.2的地址。

 


该案例对您是否有帮助:

您的评价:1

若您有关于案例的建议,请反馈:

0 个评论

该案例暂时没有网友评论

编辑评论

举报

×

侵犯我的权益 >
对根叔知了社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔知了社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明

提出建议

    +

亲~登录后才可以操作哦!

确定

亲~检测到您登陆的账号未在http://hclhub.h3c.com进行注册

注册后可访问此模块

跳转hclhub

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作