• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 漏洞说明
  • 全部
  • 全部
  • 大数据引擎
  • 知了引擎
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
搜索引擎
匹配模式
高级搜索

策略路由两种常用组网案例

2016-01-31 发表
  • 0关注 ,4181浏览
粉丝:0人 关注:0人

1.组网(一)

内网用户网关在RT路由器上面,内网两个子网网段,在ROUTER上做策略路由,实现负载分担和备份,以及两个网段的用户可以互相访问:

192.168.1.0/24网段优先从G0/2口出去上网,G0/3接口作为备份,

192.168.2.0/24网段优先从G0/3口出去上网,G0/2接口作为备份。

2. 组网(二)

内网用户网关在SW交换机上面,内网两个子网网段,在SWITCH上做策略路由,实现负载分担和备份,以及两个网段的用户可以互相访问:

192.168.1.0/24网段优先从G1/0/2口出去上网,G1/0/3接口作为备份,

192.168.2.0/24网段优先从G1/0/3口出去上网,G1/0/2接口作为备份。

交换机版本:Version 7.1.045, Release 2311P02

路由器版本:version 7.1.059, Release 0305P04

1.

#

 sysname H3C

#

 telnet server enable

#

 dhcp enable

#

 password-recovery enable

#

vlan 1

#

policy-based-route policy permit node 1         //定义PBR策略节点1

 if-match acl 3010                        //匹配acl 3010的报文

#

policy-based-route policy permit node 5         //定义PBR策略节点5

 if-match acl 3001                        //匹配acl 3001的报文

 apply next-hop 10.1.1.1                 //指定下一跳地址

#

policy-based-route policy permit node 10         //定义PBR策略节点10

 if-match acl 3002                         //匹配acl 3002的报文

 apply next-hop 20.1.1.1                  //指定下一跳地址

#

interface Aux0

#

interface NULL0

#

interface GigabitEthernet0/0

 port link-mode route

#

interface GigabitEthernet0/1.1

 port link-mode route

 ip address 192.168.1.1 255.255.255.0

 ip policy-based-route policy            //在内网接口应用policy策略

#

interface GigabitEthernet0/1.2

 port link-mode route

 ip address 192.168.2.1 255.255.255.0

 ip policy-based-route policy            //在内网接口应用policy策略

#

interface GigabitEthernet0/2

 port link-mode route

 ip address 10.1.1.2 255.255.255.0

#

interface GigabitEthernet0/3

 port link-mode route

 ip address 20.1.1.2 255.255.255.0

#

 scheduler logfile size 16

#

line class aux

 user-role network-admin

#

line class tty

 user-role network-operator

#

line class vty

 user-role network-operator

#

line aux 0

 user-role network-admin

#

line vty 0 4

 authentication-mode scheme

 user-role level-15

 user-role network-operator

#

line vty 5 63

 user-role level-15

 user-role network-operator

#

 ip route-static 0.0.0.0 0 10.1.1.1           //配置缺省路由

 ip route-static 0.0.0.0 0 20.1.1.1           //配置缺省路由

#

 ntp-service enable

#

acl advanced 3001                                //定义acl 3001

 rule 0 permit ip source 192.168.1.0 0.0.0.255   //允许192.168.1.0/24源地址网段

#

acl advanced 3002                                //定义acl 3002

 rule 0 permit ip source 192.168.2.0 0.0.0.255   //允许192.168.4.0/24源地址网段

#

acl advanced 3010                      //定义acl 3010

 rule 0 permit ip source 192.168.1.0 0.0.0.255 destination 192.168.2.0 0.0.0.255                        //允许192.168.1.0/24源地址目的192.168.2.0/24网段

 rule 5 permit ip source 192.168.2.0 0.0.0.255 destination 192.168.1.0 0.0.0.255                        //允许192.168.2.0/24源地址目的192.168.1.0/24网段

#

domain system

#

 domain default enable system

#

role name level-0

 description Predefined level-0 role

#

role name level-1

 description Predefined level-1 role

#

role name level-2

 description Predefined level-2 role

#             

role name level-3

 description Predefined level-3 role

#

role name level-4

 description Predefined level-4 role

#

role name level-5

 description Predefined level-5 role

#

role name level-6

 description Predefined level-6 role

#

role name level-7

 description Predefined level-7 role

#

role name level-8

 description Predefined level-8 role

#

role name level-9

 description Predefined level-9 role

#

role name level-10

 description Predefined level-10 role

#

role name level-11

 description Predefined level-11 role

#

role name level-12

 description Predefined level-12 role

#

role name level-13

 description Predefined level-13 role

#

role name level-14

 description Predefined level-14 role

#

user-group group1

 authorization-attribute sslvpn-policy-group pgroup

#

user-group system

#

local-user admin class manage

 password hash $h$6$iu1wBsf3MlCQRF6F$HTkWAc/mKsHWRO5Y1R2BYPNz3zzq1L48b6nGHkgyqDCLDi3VwuFKHgIH1AMJjWfHECAROGe/fPcewce+Ki8W/g==

 service-type telnet http

 authorization-attribute user-role network-operator

#

 ip http enable

#

return

 

 

2.

#

 sysname H3C

#

 clock timezone beijing add 08:00:00

#

 telnet server enable

#

 irf mac-address persistent timer

 irf auto-update enable

 undo irf link-delay

 irf member 1 priority 1

#

 dhcp enable

#             

 lldp global enable

#

 system-working-mode standard

 password-recovery enable

#

vlan 1

#

vlan 10

#

vlan 20

#

vlan 100 to 101

#

policy-based-route policy permit node 1         //定义PBR策略节点1

 if-match acl 3010                        //匹配acl 3010的报文

#

policy-based-route policy permit node 5         //定义PBR策略节点5

 if-match acl 3001                        //匹配acl 3001的报文

 apply next-hop 10.1.1.1                 //指定下一跳地址

#

policy-based-route policy permit node 10         //定义PBR策略节点10

 if-match acl 3002                         //匹配acl 3002的报文

 apply next-hop 20.1.1.1                  //指定下一跳地址

#

interface NULL0

#

interface LoopBack0

#

interface Vlan-interface1

#

interface Vlan-interface2

#

interface Vlan-interface10

 ip address 10.1.1.2 255.255.255.0

#

interface Vlan-interface20

 ip address 20.1.1.2 255.255.255.0

#

interface Vlan-interface100

 ip address 192.168.1.1 255.255.255.0

 ip policy policy-based-route policy      //在内网接口应用policy策略

#

interface Vlan-interface101

 ip address 192.168.2.1 255.255.255.0

ip policy policy-based-route policy       //在内网接口应用policy策略

#

interface GigabitEthernet1/0/1

 port link-mode bridge

 port link-type trunk

 port trunk permit vlan 1 100 101

#

interface GigabitEthernet1/0/2

 port link-mode bridge

 port access vlan 10

#

interface GigabitEthernet1/0/3

 port link-mode bridge

 port access vlan 20

#

interface GigabitEthernet1/0/4

 port link-mode bridge

#

interface GigabitEthernet1/0/5

 port link-mode bridge

#

interface M-GigabitEthernet0/0/0

 ip address 10.153.42.91 255.255.255.0

#

interface Ten-GigabitEthernet1/0/49

 port link-mode bridge

#

interface Ten-GigabitEthernet1/0/50

 port link-mode bridge

#

interface Ten-GigabitEthernet1/0/51

 port link-mode bridge

#

interface Ten-GigabitEthernet1/0/52

 port link-mode bridge

#

 scheduler logfile size 16

#

line class aux

 user-role network-admin

#

line class vty

 user-role network-operator

#

line aux 0

 user-role network-admin

#

line vty 0 63

 authentication-mode scheme

 user-role network-admin

 user-role network-operator

#

 ip route-static 0.0.0.0 0 10.1.1.1              //配置缺省路由

 ip route-static 0.0.0.0 0 20.1.1.1              //配置缺省路由

#

acl number 3001                                //定义acl 3001

 rule 0 permit ip source 192.168.1.0 0.0.0.255   /允许192.168.1.0/24源地址网段

#

acl number 3002                                //定义acl 3002

 rule 0 permit ip source 192.168.2.0 0.0.0.255   /允许192.168.2.0/24源地址网段

#

acl number 3010                                //定义acl 3010

 rule 0 permit ip source 192.168.1.0 0.0.0.255 destination 192.168.2.0 0.0.0.255                     //允许192.168.1.0/24源地址目的192.168.2.0/24网段

 rule 5 permit ip source 192.168.2.0 0.0.0.255 destination 192.168.1.0 0.0.0.255                     //允许192.168.2.0/24源地址目的192.168.1.0/24网段

#

 header incoming %

Hello!!! %

 header shell %

Hello %       

#

domain system

#

 domain default enable system

#

role name level-0

 description Predefined level-0 role

#

role name level-1

 description Predefined level-1 role

#

role name level-2

 description Predefined level-2 role

#

role name level-3

 description Predefined level-3 role

#

role name level-4

 description Predefined level-4 role

#

role name level-5

 description Predefined level-5 role

#

role name level-6

 description Predefined level-6 role

#

role name level-7

 description Predefined level-7 role

#

role name level-8

 description Predefined level-8 role

#

role name level-9

 description Predefined level-9 role

#

role name level-10

 description Predefined level-10 role

#

role name level-11

 description Predefined level-11 role

#

role name level-12

 description Predefined level-12 role

#

role name level-13

 description Predefined level-13 role

#

role name level-14

 description Predefined level-14 role

#

local-user admin class manage

 password hash $h$6$Ys/xMVzmPLvHHZZL$xUvnj060vouleH5Tgd8ySowN7cj+Fiq7ch1zPtDkCQ4ttl1fgQD/PjoSyYWcLivenZnGolOTQAX/IM+3uJvvCA==

 service-type telnet terminal http https

 authorization-attribute user-role level-15

 authorization-attribute user-role network-admin

 authorization-attribute user-role network-operator

#

 ip http enable

 ip https enable

#

return

1、通过配置策略路由和缺省路由实现链路的备份

2、内部多个网段的时候,如果在设备上面做了策略路由,内网互访的流量上来之后,优先匹配策略路由,流量直接被丢到公网,所以会导致内网用户访问的时候不通;需要先将内网访问的流量放通

0 个评论

该案例暂时没有网友评论

编辑评论

举报

×

侵犯我的权益 >
对根叔知了社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔知了社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明

提出建议

    +

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作