• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 漏洞说明
  • 全部
  • 全部
  • 大数据引擎
  • 知了引擎
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
搜索引擎
匹配模式
高级搜索

AR28/AR46系列路由器MSDP综合组网的典型配置

2006-09-12 发表
  • 0关注 ,138浏览
粉丝: 关注:

AR28/AR46系列路由器MSDP综合组网的典型配置

【需求】

在如下网络中,组播源位于PIM-SM域1,接收者位于PIM-SM域2、3、4,接收“影视热线”节目。域间运行MSDP,在PIM-SM域1内配置Anycast RP,PIM-SM各个域的RP建立MSDP对等体关系,域间使用MBGP组播扩展路由协议。

【组网图】

【配置脚本】

RouterA配置脚本

# 启动组播。

<RTA> system-view

[RTA] multicast routing-enable

# 配置接口loopback0 IP地址,启动PIM-SM

[RTA] interface loopback0

[RTA-LoopBack0] ip address 10.25.1.1 255.255.255.255

[RTA-LoopBack0] pim sm

[RTA-LoopBack0] quit

# 配置接口loopback10 IP地址,启动PIM-SM

[RTA] interface loopback10

[RTA-LoopBack10] ip address 10.1.1.1 255.255.255.255

[RTA-LoopBack10] pim sm

[RTA-LoopBack10] quit

# 配置接口ethernet 0/0/0 IP地址,启动PIM-SM

[RTA] interface ethernet 0/0/0

[RTA-Ethernet0/0/0] ip address 10.25.2.3 255.255.255.0

[RTA-Ethernet0/0/0] pim sm

[RTA-Ethernet0/0/0] undo shutdown

[RTA-Ethernet0/0/0] quit

# 配置接口serial 1/1/0 IP地址,启动PIM-SM

[RTA] interface serial 1/1/0

[RTA-Serial1/1/0] ip address 10.25.3.1 255.255.255.0

[RTA-Serial1/1/0] pim sm

[RTA-Serial1/1/0] undo shutdown

[RTA-Serial1/1/0] quit

# 配置OSPF

[RTA] ospf

[RTA-ospf-1] area 0

[RTA-ospf-1-area-0.0.0.0] network 10.25.2.0 0.0.0.255

[RTA-ospf-1-area-0.0.0.0] network 10.1.1.1 0.0.0.0

[RTA-ospf-1-area-0.0.0.0] network 10.25.1.1 0.0.0.0

[RTA-ospf-1-area-0.0.0.0] quit

[RTA-ospf-1] quit

# 配置IBGP对等体RTE

[RTA] bgp 100

[RTA-bgp] undo synchronization

[RTA-bgp] group rte internal

[RTA-bgp] peer 10.26.1.2 group rte

[RTA-bgp] peer rte connect-interface loopback0

[RTA-bgp] peer rte next-hop-local

[RTA-bgp] ipv4-family multicast

[RTA-bgp-af-mul] peer rte enable

[RTA-bgp-af-mul] peer 10.26.1.2 group rte

[RTA-bgp-af-mul] peer rte next-hop-local

[RTA-bgp-af-mul] quit

# 配置IBGP对等体RTF

[RTA-bgp] group rtf internal

[RTA-bgp] peer 10.27.1.2 group rtf

[RTA-bgp] peer rtf connect-interface loopback0

[RTA-bgp] peer rtf next-hop-local

[RTA-bgp] ipv4-family multicast

[RTA-bgp-af-mul] peer rtf enable

[RTA-bgp-af-mul] peer rtf next-hop-local

[RTA-bgp-af-mul] quit

# 配置EBGP对等体RTG

[RTA-bgp] group rtg external

[RTA-bgp] peer 10.28.1.1 group rtg as-number 200

[RTA-bgp] peer rtg next-hop-local

[RTA-bgp] peer rtg default-route-advertise

[RTA-bgp] peer rtg ebgp-max-hop 255

[RTA-bgp] ipv4-family multicast

[RTA-bgp-af-mul] peer 10.28.1.1 group rtg

[RTA-bgp-af-mul] peer rtg enable

[RTA-bgp-af-mul] peer rtg next-hop-local

[RTA-bgp-af-mul] quit

[RTA-bgp] quit

# 配置MSDP对等体、全连接组和Originating RP

[RTA] msdp

[RTA-msdp] static-rpf-peer 10.28.1.1

[RTA-msdp] peer 10.28.1.1 connect-interface loopback 0

[RTA-msdp] peer 10.26.1.2 connect-interface loopback 0

[RTA-msdp] peer 10.27.1.2 connect-interface loopback 0

[RTA-msdp] peer 10.26.1.2 mesh-group net

[RTA-msdp] peer 10.27.1.2 mesh-group net

[RTA-msdp] originating-rp loopback0

[RTA-msdp] quit

# 配置候选RPBSR

[RTA] pim

[RTA-pim] c-rp loopback 10

[RTA-pim] c-bsr loopback 0 30

 

RouterB配置脚本

# 启动组播。

[RTB] multicast routing-enable

# 配置接口IP地址,启动PIM-SM

[RTB] interface ethernet 0/0/0

[RTB-Ethernet0/0/0] ip address 10.25.2.4 255.255.255.0

[RTB-Ethernet0/0/0] pim sm

[RTB-Ethernet0/0/0] undo shutdown

RouterE配置脚本

# 启动组播。

[RTE] multicast routing-enable

# 配置接口IP地址,启动PIM-SM

[RTE] interface loopback0

[RTE-LoopBack0] ip address 10.26.1.2 255.255.255.255

[RTE-LoopBack0] pim sm

[RTE-LoopBack0] quit

# 配置接口IP地址,启动PIM-SM

[RTE] interface loopback10

[RTE-LoopBack10] ip address 10.1.1.1 255.255.255.255

[RTE-LoopBack10] pim sm

[RTE-LoopBack10] quit

# 配置接口IP地址,启动PIM-SM

[RTE] interface ethernet 0/0/0

[RTE-Ethernet0/0/0] ip address 10.26.2.3 255.255.255.0

[RTE-Ethernet0/0/0] pim sm

[RTE-Ethernet0/0/0] undo shutdown

[RTE-Ethernet0/0/0] quit

# 配置接口IP地址,启动PIM-SM

[RTE] interface serial 1/0/0

[RTE-Serial1/0/0] ip address 10.26.3.1 255.255.255.0

[RTE-Serial1/0/0] pim sm

[RTE-Serial1/0/0] undo shutdown

[RTE-Serial1/0/0] quit

# 配置OSPF

[RTE] ospf

[RTE-ospf-1] area 0

[RTE-ospf-1-area-0.0.0.0] network 10.26.2.0 0.255.255.255

[RTE-ospf-1-area-0.0.0.0] network 10.1.1.1 0.0.0.0

[RTE-ospf-1-area-0.0.0.0] network 10.26.1.2 0.0.0.0

[RTE-ospf-1-area-0.0.0.0] quit

[RTE-ospf-1] quit

# 配置IBGP对等体RTA

[RTE] bgp 100

[RTE-bgp] undo synchronization

[RTE-bgp] group rta internal

[RTE-bgp] peer 10.25.1.1 group rta

[RTE-bgp] peer rta connect-interface loopback0

[RTE-bgp] peer rta next-hop-local

[RTE-bgp] ipv4-family multicast

[RTE-bgp-af-mul] peer 10.25.1.1 group rta

[RTE-bgp-af-mul] peer rta enable

[RTE-bgp-af-mul] peer rta next-hop-local

[RTE-bgp-af-mul] quit

# 配置IBGP对等体RTF

[RTE-bgp] group rtf internal

[RTE-bgp] peer 10.26.1.2 group rtf

[RTE-bgp] peer rtf connect-interface loopback0

[RTE-bgp] peer rtf next-hop-local

[RTE-bgp] ipv4-family multicast

[RTE-bgp-af-mul] peer 10.26.1.2 group rtf

[RTE-bgp-af-mul] peer rtf enable

[RTE-bgp-af-mul] peer rtf next-hop-local

[RTE-bgp-af-mul] quit

[RTE-bgp] quit

# 配置MSDP对等体、全连接组和Originating RP

[RTE] msdp

[RTE-msdp] peer 10.29.1.1 connect-interface loopback 0

[RTE-msdp] static-rpf-peer 10.29.1.1

[RTE-msdp] peer 10.25.1.1 connect-interface loopback 0

[RTE-msdp] peer 10.27.1.2 connect- interface loopback 0

[RTE-msdp] peer 10.25.1.1 mesh-group net

[RTE-msdp] peer 10.27.1.2 mesh-group net

[RTE-msdp] originating-rp loopback0

[RTE-msdp] quit

[RTE] ip route-static 10.29.1.1 255.255.255.0 serial1/0/0

# 配置候选RPBSR

[RTE] pim

[RTE-pim] c-rp loopback 10

[RTE-pim] c-bsr loopback 0 30

RouterG配置脚本

# 启动组播。

<RTG> system-view

[RTG] multicast routing-enable

# 配置接口loopback0 IP地址,启动PIM-SM

[RTG] interface loopback0

[RTG-LoopBack0] ip address 10.28.1.1 255.255.255.255

[RTG-LoopBack0] pim sm

[RTG-LoopBack0] quit

# 配置接口serial 1/0/0 IP地址,启动PIM-SM

[RTA] interface serial 1/0/0

[RTA-Serial1/0/0] ip address 10.25.3.2 255.255.255.0

[RTA-Serial1/0/0] pim sm

[RTA-Serial1/0/0] quit

# 配置接口ethernet0/0/0 IP地址,启动PIM-SMIGMP

[RTG] interface ethernet0/0/0

[RTG-ethernet0/0/0] ip address 20.1.1.1 255.255.255.255

[RTG-ethernet0/0/0] pim sm

[RTG-ethernet0/0/0] igmp enable

[RTG-ethernet0/0/0] quit

# 配置MSDP对等体和Originating RP

[RTA] msdp

[RTA-msdp] static-rpf-peer 10.28.1.1

[RTA-msdp] peer 10.25.1.1 connect-interface loopback 0

[RTA-msdp] originating-rp loopback0

[RTA-msdp] quit

# 配置候选RPBSR

[RTA] pim

[RTA-pim] c-rp loopback 0

[RTA-pim] c-bsr loopback 0 30

 

组播源的配置

在组播源上逐一配置组播节目对应的组播地址,如“影视热线”节目对应组播地址224.0.1.1

接收者的配置

Receiver首先跟组播源建立http连接,然后在客户端软件上选择“影视热线”节目即可。

 

0 个评论

该案例暂时没有网友评论

编辑评论

举报

×

侵犯我的权益 >
对根叔知了社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔知了社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明

提出建议

    +

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作