• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 漏洞说明
  • 全部
  • 全部
  • 大数据引擎
  • 知了引擎
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
搜索引擎
匹配模式
高级搜索

AR28/AR46系列路由器MBGP组播扩展的典型配置

2006-09-13 发表
  • 0关注 ,129浏览
粉丝: 关注:

AR28/AR46系列路由器MBGP组播扩展的典型配置

【需求】

本例说明如何通过MBGP属性来管理路由选择。

所有路由器都配置MBGP。AS200中的IGP使用OSPF。路由器A在AS100中,并作为AS200中的路由器B和路由器C的MBGP邻居。路由器B和路由器C对路由器D运行IBGP,路由器D也在AS200中。

【组网图】

【配置脚本】

RouterA配置脚本

<RouterA> system-view

[RouterA] interface serial 1/0/0

[RouterA-Serial1/0/0] ip address 192.1.1.1 255.255.255.0

[RouterA-Serial1/0/0] quit

[RouterA] interface serial 1/1/0

[RouterA-Serial1/1/0] ip address 193.1.1.1 255.255.255.0

[RouterA-Serial1/1/0] quit

# 启动MBGP

[RouterA] bgp 100

[RouterA-bgp] ipv4-family multicast

# 指定MBGP要发送的网络。

[RouterA-bgp-af-mul] network 1.0.0.0

[RouterA-bgp-af-mul] network 2.0.0.0

[RouterA-bgp-af-mul] quit

# 配置对等体。

[RouterA-bgp] bgp 100

[RouterA-bgp] group a1 external

[RouterA-bgp] peer 192.1.1.2 group a1 as-number 200

[RouterA-bgp] group a2 external

[RouterA-bgp] peer 193.1.1.2 group a2 as-number 200

[RouterA-bgp] ipv4-family multicast

[RouterA-bgp-af-mul] peer a1 enable

[RouterA-bgp-af-mul] peer 192.1.1.2 group a1

[RouterA-bgp-af-mul] peer a2 enable

[RouterA-bgp-af-mul] peer 193.1.1.2 group a2

[RouterA-bgp-af-mul] quit

# 配置路由器AMED属性。

# 路由器A上增加访问控制列表,允许网络1.0.0.0

[RouterA] acl number 2001

[RouterA-acl-basic-2001] rule permit ip source 1.0.0.0 0.255.255.255

# 定义两个路由策略,一个名为set_med_50,另一个名为set_med_100,第一个路由策略为网络1.0.0.0配置的MED属性为50,第二个的MED属性为100

[RouterA] route-policy set_med_50 permit node 10

[RouterA-route-policy] if-match acl 2001

[RouterA-route-policy] apply cost 50

[RouterA-route-policy] quit

[RouterA] route-policy set_med_100 permit node 10

[RouterA-route-policy] if-match acl 2001

[RouterA-route-policy] apply cost 100

# 应用路由策略set_med_50到路由器C193.1.1.2)出口路由更新上,应用路由策略set_med_100到路由器B192.1.1.2)的出口路由更新上。

[RouterA] bgp 100

[RouterA-bgp] ipv4-family multicast

[RouterA-bgp-af-mul] peer a2 route-policy set_med_50 export

[RouterA-bgp-af-mul] peer a1 route-policy set_med_100 export

RouterB配置脚本

<RouterB> system-view

[RouterB] interface serial 1/0/0

[RouterB-Serial1/0/0] ip address 192.1.1.2 255.255.255.0

[RouterB-Serial1/0/0] quit

[RouterB] interface serial 1/1/0

[RouterB-Serial1/1/0] ip address 194.1.1.2 255.255.255.0

[RouterB-Serial1/1/0] quit

[RouterB] ospf

[RouterB-ospf-1] area 0

[RouterB-ospf-1-area-0.0.0.0] network 194.1.1.0 0.0.0.255

[RouterB-ospf-1-area-0.0.0.0] network 192.1.1.0 0.0.0.255

[RouterB-ospf-1-area-0.0.0.0] quit

[RouterB-ospf-1] quit

[RouterB] bgp 200

[RouterB-bgp] undo synchronization

[RouterB-bgp] group b1 external

[RouterB-bgp] peer 192.1.1.1.1 group b1 as-number 100

[RouterB-bgp] group b2 internal

[RouterB-bgp] peer 194.1.1.1.1 group b1 as-number 200

[RouterB-bgp] peer 195.1.1.1.2 group b1 as-number 200

[RouterB-bgp] ipv4-family multicast

[RouterB-bgp-af-mul] peer b1 enable

[RouterB-bgp-af-mul] peer 192.1.1.1 group b1

[RouterB-bgp-af-mul] peer b2 enable

[RouterB-bgp-af-mul] peer 194.1.1.1 group b2

[RouterB-bgp-af-mul] peer 195.1.1.2 group b2

 

RouterC配置脚本

<RouterC> system-view

[RouterC] interface serial 1/0/0

[RouterC-Serial1/0/0] ip address 193.1.1.2 255.255.255.0

[RouterC-Serial1/0/0] quit

[RouterC] interface serial 1/1/0

[RouterC-Serial1/1/0] ip address 195.1.1.2 255.255.255.0

[RouterC-Serial1/1/0] quit

[RouterC] ospf

[RouterC-ospf-1] area 0

[RouterC-ospf-1-area-0.0.0.0] network 193.1.1.0 0.0.0.255

[RouterC-ospf-1-area-0.0.0.0] network 195.1.1.0 0.0.0.255

[RouterC-ospf-1-area-0.0.0.0] quit

[RouterC-ospf-1] quit

[RouterC] bgp 200

[RouterC-bgp] undo synchronization

[RouterC-bgp] group c1 external

[RouterC-bgp] peer 193.1.1.1 group c1 as-number 100

[RouterC-bgp] group c2 internal

[RouterC-bgp] peer 194.1.1.2 group c2 as-number 200

[RouterC-bgp] peer 195.1.1.1 group c2 as-number 200

[RouterC-bgp] ipv4-family multicast

[RouterC-bgp-af-mul] peer c1 enable

[RouterC-bgp-af-mul] peer 193.1.1.1 group c1

[RouterC-bgp-af-mul] peer c1  next-hop-local

[RouterC-bgp-af-mul] peer c2 enable

[RouterC-bgp-af-mul] peer 194.1.1.2 group c2

[RouterC-bgp-af-mul] peer 195.1.1.1 group c2

[RouterC-bgp-af-mul] peer c2  next-hop-local

# 配置路由器C的本地优先级属性。

# 在路由器C上加上访问列表2001,允许网络1.0.0.0

[RouterC] acl number 2001

[RouterC-acl-basic-2001] rule permit source 1.0.0.0 0.255.255.255

[RouterC-acl-basic-2001] quit

# 定义名为localpref的路由策略,该策略中配置了匹配ACL 2001(访问控制列表2001)的路由的本地优先级为200,不匹配的为100

[RouterC] route-policy localpref permit node 10

[RouterC-route-policy] if-match acl 2001

[RouterC-route-policy] apply local-preference 200

[RouterC-route-policy] quit

[RouterC] route-policy localpref permit node 20

[RouterC-route-policy] apply local-preference 100

# 应用此路由策略到来自BGP邻居193.1.1.2(路由器A)上的入口流量上。

[RouterC] bgp 200

[RouterC-bgp] ipv4-family multicast

[RouterC-bgp-af-mul] peer c1. route-policy localpref import

RouterD配置脚本

<RouterD> system-view

[RouterD] interface serial 1/0/0

[RouterD-Serial1/0/0] ip address 194.1.1.1 255.255.255.0

[RouterD-Serial1/0/0] quit

[RouterD] interface serial 1/1/0

[RouterD-Serial1/1/0] ip address 195.1.1.1 255.255.255.0

[RouterD-Serial1/1/0] quit

[RouterD] ospf

[RouterD-ospf-1] area 0

[RouterD-ospf-1-area-0.0.0.0] network 194.1.1.0 0.0.0.255

[RouterD-ospf-1-area-0.0.0.0] network 195.1.1.0 0.0.0.255

[RouterD-ospf-1-area-0.0.0.0] network 4.0.0.0 0.0.0.255

[RouterD-ospf-1-area-0.0.0.0] quit

[RouterD-ospf-1] quit

[RouterD] bgp 200

[RouterD-bgp] undo synchronization

[RouterD-bgp] group d1 internal

[RouterD-bgp] peer 194.1.1.2 group d1

[RouterD-bgp] peer 194.1.1.2 group d1

[RouterD-bgp] ipv4-family multicast

[RouterD-bgp-af-mul] peer d1 enable

[RouterD-bgp-af-mul] peer 195.1.1.2 group d1

[RouterD-bgp-af-mul] peer 194.1.1.2 group d1

【提示】

为使配置生效,所有的MBGP邻居需要使用reset bgp all命令重设。

0 个评论

该案例暂时没有网友评论

编辑评论

举报

×

侵犯我的权益 >
对根叔知了社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔知了社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明

提出建议

    +

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作