• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 漏洞说明
  • 全部
  • 全部
  • 大数据引擎
  • 知了引擎
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
搜索引擎
匹配模式
高级搜索

AR28/AR46系列路由器OSPF引入自治区域外部路由的典型配置

2006-09-20 发表
  • -1关注 ,146浏览
粉丝: 关注:

AR28/AR46系列路由器OSPF引入自治区域

外部路由的典型配置

【需求】

路由器使用ospf路由协议,同时引入外部路由,使得两台PC实现互连互通。

【组网图】

【配置脚本】

RouterA配置脚本

#

sysname RouterA

#

router id 1.1.1.1      /配置router idloopback0地址一致/

#

radius scheme system

#

domain system

#

interface Ethernet0/0

ip address 10.1.1.1 255.255.255.0

#

interface Serial0/0

link-protocol ppp

ip address 20.1.1.1 255.255.255.252

#

interface NULL0

#

interface LoopBack0

ip address 1.1.1.1 255.255.255.255

#

ospf 1                           /启动ospf路由协议/

area 0.0.0.0                     /创建区域0/

network 1.1.1.1 0.0.0.0          /接口loop 0使能OSPF/

network 10.1.1.0 0.0.0.255       /接口e0/0使能OSPF/

network 20.1.1.0 0.0.0.3         /接口s0/0使能OSPF/

#

user-interface con 0

user-interface vty 0 4

#

return

RouterB配置脚本

#

sysname RouterB

#

router id 1.1.1.2      /配置router idloopback0地址一致/

#

radius scheme system

#

domain system

#

interface Ethernet1/0/0

ip address 30.1.1.1 255.255.255.0

#

interface Serial2/0/0

link-protocol ppp

ip address 20.1.1.2 255.255.255.252

#

interface NULL0

#

interface LoopBack0

ip address 1.1.1.2 255.255.255.255

#

ospf 1                      /启动ospf路由协议/

import-route direct         /引入接口直连路由/

area 0.0.0.0                /创建区域0/

network 1.1.1.2 0.0.0.0     /接口loop 0使能OSPF/

network 20.1.1.0 0.0.0.3    /接口s0/0使能OSPF/

#

user-interface con 0

user-interface vty 0 4

#

return

 

【验证】

RouterARouterB可以通过OSPF学习到对方路由信息,并可以ping通对方网段。

RouterA路由表:

[RouterA]disp ip routing-table

Routing Table: public net

Destination/Mask   Protocol Pre  Cost        Nexthop         Interface

1.1.1.1/32         DIRECT   0    0           127.0.0.1       InLoopBack0

1.1.1.2/32         OSPF     10   1563        20.1.1.2        Serial0/0

10.1.1.0/24        DIRECT   0    0           10.1.1.1        Ethernet0/0

10.1.1.1/32        DIRECT   0    0           127.0.0.1       InLoopBack0

20.1.1.0/30        DIRECT   0    0           20.1.1.1        Serial0/0

20.1.1.1/32        DIRECT   0    0           127.0.0.1       InLoopBack0

20.1.1.2/32        DIRECT   0    0           20.1.1.2        Serial0/0

30.1.1.0/24        O_ASE    150  1            20.1.1.2        Serial0/0

127.0.0.0/8        DIRECT   0    0           127.0.0.1       InLoopBack0

127.0.0.1/32       DIRECT   0    0           127.0.0.1       InLoopBack0

 

【提示】

1、建议将router id 指定和loopback 0接口地址一致。

2network中需要使用反掩码wildcard bits

3、通过引入直连接口的方式来通告路由路由表显示这一网段为自治系统外部路由。

4、关于ospf network-type的配置原则

Quidway路由器的网络类型缺省如下

网络类型

链路层协议

p2p

PPPloopback

NBMA

frx25HDLC

p2mp

broadcast

Ethernet

5、互连的路由器网络类型必须一致。

6、对于接口类型为NBMA的网络,由于无法通过广播Hello报文的形式发现相邻路由器,必须手工为其指定相邻路由器的IP地址:

[Quidway-ospf-1]peer 20.1.1.2

0 个评论

该案例暂时没有网友评论

编辑评论

举报

×

侵犯我的权益 >
对根叔知了社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔知了社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明

提出建议

    +

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作