• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 漏洞说明
  • 全部
  • 全部
  • 大数据引擎
  • 知了引擎
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
搜索引擎
匹配模式
高级搜索

ipsec旁路无法建立sa

2021-08-03提问
  • 0关注
  • 0收藏,184浏览
粉丝:0人 关注:0人

问题描述:


脚本没传上来,重发一遍。

拓扑是这样,ipsec网关旁挂核心交换机,核心到对端感兴趣流的回程路由已经写好了,总部有固定ip,分支是4G,没有固定ip,采用野蛮模式,分支是在边界发起链接,总部的出口是一台天融信的墙,已经把ipsec网关的500和4500两个udp端口映射到公网ip,且让天融信厂家看过,确保NAT映射正确无误。从下午调到现在,两侧连ike sa都无法建议,不知道问题出在哪里,下边是两侧脚本,还请各位老师帮忙看看,急~!

组网及组网描述:

总部:

[IPsec]dis cur

#

 version 5.20, Release 2514P04

#

 sysname IPsec

#

 ike local-name zongbu

#

 domain default enable system

#

 dns proxy enable

#

 telnet server enable

#

 dar p2p signature-file flash:/p2p_default.mtd

#

 ndp enable

#

 ntdp enable

#

 cluster enable

#

 port-security enable

#

 password-recovery enable

#

acl number 3000

acl number 3001

 rule 0 permit ip source 10.173.129.0 0.0.0.255 destination 10.173.130.64 0.0.0.

15

#

vlan 1

#

domain system

 access-limit disable

 state active

 idle-cut disable

 self-service-url disable

#

ike proposal 2

#

ike peer center

 exchange-mode aggressive

 proposal 2

 pre-shared-key cipher $c$3$4KOaQTAjcf0BqGeXiK8JFms/DFOYkYh9kA==

 id-type name

 remote-name branch

 remote-address branch dynamic

 local-address 61.150.106.90

 local-name center

 nat traversal

#

ipsec transform-set center

 encapsulation-mode tunnel

 transform esp

 esp authentication-algorithm md5

 esp encryption-algorithm 3des

#

ipsec policy 1048580 1 isakmp

 connection-name center

 security acl 3001

 ike-peer center

 transform-set center

 sa duration traffic-based 1843200

 sa duration time-based 3600

#

ipsec profile 1

#

user-group system

 group-attribute allow-guest

#

local-user admin

 password cipher $c$3$g6a6AIDd3LJRPAyTYIKyV7DY6nO9imem

 authorization-attribute level 3

 service-type telnet

 service-type web

#

cwmp

 undo cwmp enable

#

interface Cellular0/0

 async mode protocol

 link-protocol ppp

 tcp mss 1024

#

interface NULL0

#

interface Vlan-interface1

#

interface GigabitEthernet0/0

 port link-mode route

 tcp mss 1024

#

interface GigabitEthernet0/4

 port link-mode route

 ip address 10.173.129.53 255.255.255.0

 ipsec no-nat-process enable

 ipsec policy 1048580

#

interface GigabitEthernet0/1

 port link-mode bridge

#

interface GigabitEthernet0/2

 port link-mode bridge

#

interface GigabitEthernet0/3

 port link-mode bridge

#

 ip route-static 0.0.0.0 0.0.0.0 10.173.129.3

#

 dhcp enable

#

 load xml-configuration

#

 load tr069-configuration

#

user-interface con 0

user-interface tty 13

user-interface vty 0 4

 user privilege level 3

 set authentication password cipher $c$3$A4CPpDaEQjlEiKs0j5cWcE5cKKmxa57/

 protocol inbound telnet

#

return

[IPsec]



分支:

#

 version 7.1.064, Release 0615P10

#

 sysname YuLin_JZT

#

 telnet server enable

#

 dialer-group 1 rule ip permit

 dialer-group 28 rule ip permit

 dialer-group 89 rule ip permit

#

 ip load-sharing mode per-flow src-ip global

#

 dhcp enable

 dhcp server always-broadcast

#

 dns proxy enable

#

 password-recovery enable

#

vlan 1

#

dhcp server ip-pool lan1

 gateway-list 10.173.130.65

 network 10.173.130.64 mask 255.255.255.240

 address range 10.173.130.68 10.173.130.78

 dns-list 10.173.130.65

#

apn-profile profile69

 apn static cmnet

#

wlan service-template 1

 ssid YuLin_JZT

 akm mode psk

 preshared-key pass-phrase cipher $c$3$y3nrrQ0Yo3T9p7t3Mlo+TvG68rThWbx6fCB9

 cipher-suite ccmp

 security-ie rsn

 service-template enable

#

controller Cellular0/0

 description Single_Line1-CMCC

 serial-set 0

#

controller Cellular1/0

 eth-channel 0

#

interface Dialer0

#

interface Dialer1

#

interface Dialer2

#

interface Dialer3

#

interface Dialer4

#

interface Dialer5

#

interface Dialer6

#

interface Dialer7

#

interface Dialer8

#

interface Dialer1023

#

interface Serial0/0:0

 ppp ipcp dns admit-any

 ppp ipcp dns request

 dialer circular enable

 dialer-group 28

 dialer timer autodial 5

 dialer number *99# autodial

 ip address ppp-negotiate

 nat outbound 3001

 ipsec apply policy branch

#

interface NULL0

#

interface Vlan-interface1

 ip address 10.173.130.65 255.255.255.240

 tcp mss 1280

#

interface GigabitEthernet0/0

 port link-mode route

#

interface GigabitEthernet0/5

 port link-mode route

#

interface GigabitEthernet0/1

 port link-mode bridge

#

interface GigabitEthernet0/2

 port link-mode bridge

#

interface GigabitEthernet0/3

 port link-mode bridge

#

interface GigabitEthernet0/4

 port link-mode bridge

#

interface WLAN-Radio0/0

 service-template 1

#

interface Eth-channel1/0:0

 dialer circular enable

 dialer-group 1

 dialer timer idle 0

 dialer timer autodial 60

 dialer number #777 autodial

 ip address cellular-alloc

 tcp mss 1280

 nat outbound 3001

 ipsec apply policy branch

#

security-zone name Local

#

security-zone name Trust

#

security-zone name DMZ

#

security-zone name Untrust

#

security-zone name Management

#

 scheduler logfile size 16

#

line class console

 user-role network-admin

#

line class tty

 user-role network-operator

#

line class usb

 user-role network-admin

#

line class vty

 user-role network-operator

#

line con 0

 user-role network-admin

#

line tty 1

 user-role network-operator

 modem enable both

#

line vty 0 63

 authentication-mode scheme

 user-role network-operator

#

 ip route-static 0.0.0.0 0 Eth-channel1/0:0

 ip route-static 0.0.0.0 0 Serial0/0:0

 ip route-static 10.173.129.0 24 Eth-channel1/0:0

#

acl advanced 3000

 rule 0 permit ip source 10.173.130.64 0.0.0.15 destination 10.173.129.0 0.0.0.2

55

#

acl advanced 3001

 rule 0 deny ip source 10.173.130.64 0.0.0.15 destination 10.173.129.0 0.0.0.255

 rule 10000 permit ip

#

 password-control enable

 undo password-control aging enable

 undo password-control history enable

 password-control length 6

 password-control login-attempt 3 exceed lock-time 10

 password-control update-interval 0

 password-control login idle-time 0

 password-control complexity user-name check

#

domain system

#

 domain default enable system

#

role name level-0

 description Predefined level-0 role

#

role name level-1

 description Predefined level-1 role

#

role name level-2

 description Predefined level-2 role

#

role name level-3

 description Predefined level-3 role

#

role name level-4

 description Predefined level-4 role

#

role name level-5

 description Predefined level-5 role

#

role name level-6

 description Predefined level-6 role

#

role name level-7

 description Predefined level-7 role

#

role name level-8

 description Predefined level-8 role

#

role name level-9

 description Predefined level-9 role

#

role name level-10

 description Predefined level-10 role

#

role name level-11

 description Predefined level-11 role

#

role name level-12

 description Predefined level-12 role

#

role name level-13

 description Predefined level-13 role

#

role name level-14

 description Predefined level-14 role

#

user-group system

#

local-user admin class manage

 service-type telnet http

 authorization-attribute user-role network-admin

#

ipsec transform-set branch

 esp encryption-algorithm 3des-cbc

 esp authentication-algorithm md5

#

ipsec policy branch 65535 isakmp

 transform-set branch

 security acl 3000

 remote-address 61.150.106.90

 ike-profile branch

 sa duration time-based 3600

 sa duration traffic-based 1843200

#

ike profile branch

 keychain branch

 exchange-mode aggressive

 local-identity fqdn branch

 match remote identity fqdn center

 proposal 65535

#

ike proposal 65535

#

ike keychain branch

 pre-shared-key hostname center key cipher $c$3$uLkMumxaOiTLb/gxcgFFV2jaMeCo5rlO

GA==

#

 ip http enable

#

wlan global-configuration

#

return

[YuLin_JZT]


最佳答案

已采纳
小茶 五段
粉丝:3人 关注:0人

分部指总部地址也添加进去,然后分部触发

ike profile branch

 keychain branch

 exchange-mode aggressive

 local-identity fqdn branch

 match remote identity fqdn center

match remote identity  address  61.150.106.90

 proposal 65535

#

ike proposal 65535

#

ike keychain branch

 pre-shared-key hostname center key cipher $c$3$uLkMumxaOiTLb/gxcgFFV2jaMeCo5rlO

GA==

pre-shared-key  address 61.150.106.90  key simple  密码

#

你好,请问这个密码是预共享密钥么?如果配了这条,hostname哪条应该可以删了吧

橘子熟了 发表时间:2021-08-03

是的,不用删除,一起配置都可以,不影响

小茶 发表时间:2021-08-03
回复小茶:

感谢!!!加了一条就可以了,以为前边有了 remote-address 指向就可以了呢。

橘子熟了 发表时间:2021-08-03

野蛮模式,使用FQDN分部有时候会找不到总部,加个指向地址就问题不大了

小茶 发表时间:2021-08-03
0 个回答

该问题暂时没有网友解答

编辑答案

你正在编辑答案

如果你要对问题或其他回答进行点评或询问,请使用评论功能。

分享扩散:

提出建议

    +

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作

举报

×

侵犯我的权益 >
对根叔社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明