• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 全部
  • 全部
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
高级搜索

SecPath M9006 与对端ZX设备ipsec建立不成功问题处理经验案例

2018-06-24 发表
  • 0关注
  • 0收藏,958浏览
关萌 五段
粉丝:1人 关注:0人

组网及说明

组网如下图


问题描述


客户使用我司M9000设备与ZX友商设备对接IPSec,对接后发现设备IPSec SA无法正常建立,M9000配置如下

#
 version 7.1.054, Release 9115P14
#
 sysname LQ_DTTE_center_FW
#
context Admin id 1
#
ip vpn-instance DX
 route-distinguisher 1:1
 vpn-target 1:1 import-extcommunity
 vpn-target 1:1 export-extcommunity
#
ip vpn-instance LT
 route-distinguisher 2:2
 vpn-target 2:2 import-extcommunity
 vpn-target 2:2 export-extcommunity
#
ip vpn-instance management
 route-distinguisher 1000000000:1
 vpn-target 1000000000:1 import-extcommunity
 vpn-target 1000000000:1 export-extcommunity
#
 telnet server enable
#             
 security-zone intra-zone default permit
#
 system-working-mode standard
 password-recovery enable
#
vlan 1
#
interface NULL0
#
interface LoopBack0
#
interface LoopBack1
 ip binding vpn-instance DX
 ip address 192.168.2.1 255.255.255.255
#
interface GigabitEthernet3/0/1
 port link-mode route
 ip binding vpn-instance DX
 ip address 192.168.10.1 255.255.255.0
#
interface GigabitEthernet3/0/2
 port link-mode route
#             
interface GigabitEthernet3/0/3
 port link-mode route
#
interface GigabitEthernet3/0/4
 port link-mode route
#
interface GigabitEthernet3/0/5
 port link-mode route
#
interface GigabitEthernet3/0/6
 port link-mode route
#
interface GigabitEthernet3/0/7
 port link-mode route
#
interface GigabitEthernet3/0/8
 port link-mode route
#
interface GigabitEthernet3/0/9
 port link-mode route
#
interface GigabitEthernet3/0/10
 port link-mode route
#
interface GigabitEthernet3/0/11
 port link-mode route
#
interface GigabitEthernet3/0/12
 port link-mode route
#
interface GigabitEthernet3/0/13
 port link-mode route
#
interface GigabitEthernet3/0/14
 port link-mode route
#
interface GigabitEthernet3/0/15
 port link-mode route
#
interface GigabitEthernet3/0/16
 port link-mode route
#
interface GigabitEthernet3/0/17
 port link-mode route
 description to ISP
 combo enable copper
 ip binding vpn-instance DX
 ip address 10.10.10.2 255.255.255.0
 nat outbound 3000 address-group 1 vpn-instance DX
 ipsec apply policy test
#
interface GigabitEthernet3/0/18
 port link-mode route
 combo enable fiber
 ip binding vpn-instance LT
#
interface GigabitEthernet3/0/19
 port link-mode route
 combo enable fiber
#
interface GigabitEthernet3/0/20
 port link-mode route
 combo enable fiber
#
interface GigabitEthernet3/0/21
 port link-mode route
 combo enable fiber
#
interface GigabitEthernet3/0/22
 port link-mode route
 combo enable fiber
#
interface GigabitEthernet3/0/23
 port link-mode route
 combo enable fiber
#
interface GigabitEthernet3/0/24
 port link-mode route
 combo enable fiber
#
interface M-GigabitEthernet0/0/0
 ip binding vpn-instance management
 ip address 192.168.0.1 255.255.255.0
#
interface Ten-GigabitEthernet3/0/25
 port link-mode route
#
interface Ten-GigabitEthernet3/0/26
 port link-mode route
#
interface Blade2/0/1
#             
interface Blade-Aggregation1
#
object-policy ip DMZ-DMZ
 rule 0 pass vrf DX
 rule 1 pass vrf LT
 rule 3 pass vrf management
#
object-policy ip DMZ-Local
 rule 0 pass vrf DX
 rule 1 pass vrf LT
 rule 4 pass vrf management
#
object-policy ip DMZ-Trust
 rule 0 pass vrf DX
 rule 1 pass vrf LT
 rule 4 pass vrf management
#
object-policy ip DMZ-Untrust
 rule 0 pass vrf DX
 rule 1 pass vrf LT
 rule 4 pass vrf management
#
object-policy ip Local-DMZ
 rule 0 pass vrf DX
 rule 1 pass vrf LT
 rule 4 pass vrf management
#
object-policy ip Local-Local
 rule 0 pass vrf DX
 rule 1 pass vrf LT
 rule 4 pass vrf management
#
object-policy ip Local-Management
 rule 0 pass vrf DX
 rule 1 pass vrf LT
 rule 4 pass vrf management
#
object-policy ip Local-Trust
 rule 0 pass vrf DX
 rule 1 pass vrf LT
 rule 4 pass vrf management
#
object-policy ip Local-Untrust
 rule 0 pass vrf DX
 rule 1 pass vrf LT
 rule 4 pass vrf management
#
object-policy ip Trust-DMZ
 rule 0 pass vrf DX
 rule 1 pass vrf LT
 rule 4 pass vrf management
#
object-policy ip Trust-Local
 rule 0 pass vrf DX
 rule 1 pass vrf LT
 rule 4 pass vrf management
#
object-policy ip Trust-Trust
 rule 0 pass vrf DX
 rule 1 pass vrf LT
 rule 4 pass vrf management
#
object-policy ip Trust-Untrust
 rule 0 pass vrf DX
 rule 1 pass vrf LT
 rule 4 pass vrf management
#
object-policy ip Untrust-DMZ
 rule 0 pass vrf DX
 rule 1 pass vrf LT
 rule 4 pass vrf management
#
object-policy ip Untrust-Local
 rule 0 pass vrf DX
 rule 1 pass vrf LT
 rule 4 pass vrf management
#
object-policy ip Untrust-Trust
 rule 0 pass vrf DX
 rule 1 pass vrf LT
 rule 4 pass vrf management
#
object-policy ip Untrust-Untrust
 rule 0 pass vrf DX
 rule 1 pass vrf LT
 rule 4 pass vrf management
#
security-zone name Local
#
security-zone name Trust
 import interface GigabitEthernet3/0/1
 import interface GigabitEthernet3/0/21
 import interface GigabitEthernet3/0/22
 import interface GigabitEthernet3/0/23
 import interface GigabitEthernet3/0/24
 import interface LoopBack1
#
security-zone name DMZ
#
security-zone name Untrust
 import interface GigabitEthernet3/0/17
 import interface GigabitEthernet3/0/18
 import interface GigabitEthernet3/0/19
 import interface GigabitEthernet3/0/20
#
security-zone name Management
 import interface M-GigabitEthernet0/0/0
#
zone-pair security source DMZ destination DMZ
 object-policy apply ip DMZ-DMZ
#
zone-pair security source DMZ destination Local
 object-policy apply ip DMZ-Local
#
zone-pair security source DMZ destination Trust
 object-policy apply ip DMZ-Trust
#
zone-pair security source DMZ destination Untrust
 object-policy apply ip DMZ-Untrust
#
zone-pair security source Local destination DMZ
 object-policy apply ip Local-DMZ
#
zone-pair security source Local destination Local
 object-policy apply ip Local-Local
#
zone-pair security source Local destination Management
 object-policy apply ip Local-Management
#
zone-pair security source Local destination Trust
 object-policy apply ip Local-Trust
#
zone-pair security source Local destination Untrust
 object-policy apply ip Local-Untrust
#
zone-pair security source Trust destination DMZ
 object-policy apply ip Trust-DMZ
#             
zone-pair security source Trust destination Local
 object-policy apply ip Trust-Local
#
zone-pair security source Trust destination Trust
 object-policy apply ip Trust-Trust
#
zone-pair security source Trust destination Untrust
 object-policy apply ip Trust-Untrust
#
zone-pair security source Untrust destination DMZ
 object-policy apply ip Untrust-DMZ
#
zone-pair security source Untrust destination Local
 object-policy apply ip Untrust-Local
#
zone-pair security source Untrust destination Trust
 object-policy apply ip Untrust-Trust
#
zone-pair security source Untrust destination Untrust
 object-policy apply ip Untrust-Untrust
#
 scheduler logfile size 16
#             
line class console
 user-role network-admin
#
line class vty
 user-role network-operator
#
line con 1 2
 authentication-mode scheme
 user-role network-admin
#
line vty 0 63
 authentication-mode scheme
 user-role network-admin
#
 ip route-static vpn-instance DX 0.0.0.0 0 10.10.10.1
#
 ssh server enable
 undo ssh server compatible-ssh1x enable
#
acl number 3000
 rule 6 deny ip vpn-instance DX source 192.168.2.1 0 destination 192.168.1.0 0.0.0.255
 rule 10 permit ip vpn-instance DX
#             
acl number 3001
#
acl number 3010
 description to ipsec
 rule 4 permit ip vpn-instance DX source 192.168.2.1 0 destination 192.168.1.0 0.0.0.255
#
domain system
#
 domain default enable system
#
role name level-0
 description Predefined level-0 role
#
role name level-1
 description Predefined level-1 role
#
role name level-2
 description Predefined level-2 role
#
role name level-3
 description Predefined level-3 role
#
role name level-4
 description Predefined level-4 role
#
role name level-5
 description Predefined level-5 role
#
role name level-6
 description Predefined level-6 role
#
role name level-7
 description Predefined level-7 role
#
role name level-8
 description Predefined level-8 role
#
role name level-9
 description Predefined level-9 role
#
role name level-10
 description Predefined level-10 role
#
role name level-11
 description Predefined level-11 role
#             
role name level-12
 description Predefined level-12 role
#
role name level-13
 description Predefined level-13 role
#
role name level-14
 description Predefined level-14 role
#
user-group system
#
local-user admin class manage
 password hash $h$6$Y6JqR67X2KTtp6pI$3KMTtH9BpM2u10IvA6mRU80+XxxyFOMIF4xRUvISjsuigXzRFVn8nHejGjqMwMXXeZ0Ngy558baeDySxYzLCfw==
 service-type ssh telnet terminal https
 authorization-attribute user-role level-3
 authorization-attribute user-role network-admin
 authorization-attribute user-role network-operator
#
ipsec transform-set test
 esp encryption-algorithm 3des-cbc
 esp authentication-algorithm md5
#
ipsec policy test 1 isakmp
 transform-set test
 security acl 3010
 local-address 10.10.10.2
 remote-address 10.10.10.1
 ike-profile test
#
nat address-group 1
 address 10.10.10.2 10.10.10.2
#
ike profile test
 local-identity address 10.10.10.2
 match remote identity address 10.10.10.1 255.255.255.0 vpn-instance DX
 match local address 10.10.10.2 vpn-instance DX
 proposal 1
#
ike proposal 1
 encryption-algorithm 3des-cbc
 authentication-algorithm md5
#
ike keychain test vpn-instance DX
 pre-shared-key address 10.10.10.1 255.255.255.0 key cipher $c$3$1DdHZtpBBsaTmC6RiozzZaZvhSZW9w==
#
 ip https enable
#
return

过程分析

在M9000上开启调试开关,查看到有如下调试信息打出

*Jun 14 12:47:57:852 2017 LQ_DTTE_center_FW IKE/7/PACKET: -Slot=2.1; Received packet from 10.10.10.1 source port 500 destination port 500.
*Jun 14 12:47:57:852 2017 LQ_DTTE_center_FW IKE/7/PACKET: -Slot=2.1;
  I-COOKIE: e308ec59ad9e32d8
  R-COOKIE: fa03a4ef576d1106
  next payload: HASH
  version: ISAKMP Version 1.0
  exchange mode: Quick
  flags: ENCRYPT
  message ID: 3695893f
  length: 164
*Jun 14 12:47:57:852 2017 LQ_DTTE_center_FW IKE/7/EVENT: -Slot=2.1; IKE thread 366523548320 processes a job.
*Jun 14 12:47:57:852 2017 LQ_DTTE_center_FW IKE/7/EVENT: -Slot=2.1; Set IPsec SA state to IKE_P2_STATE_INIT.
*Jun 14 12:47:57:852 2017 LQ_DTTE_center_FW IKE/7/PACKET: -Slot=2.1; Decrypt the packet.
*Jun 14 12:47:57:852 2017 LQ_DTTE_center_FW IKE/7/PACKET: -Slot=2.1; Received ISAKMP Hash Payload.
*Jun 14 12:47:57:852 2017 LQ_DTTE_center_FW IKE/7/PACKET: -Slot=2.1; Received ISAKMP Security Association Payload.
*Jun 14 12:47:57:852 2017 LQ_DTTE_center_FW IKE/7/PACKET: -Slot=2.1; Received ISAKMP Nonce Payload.
*Jun 14 12:47:57:852 2017 LQ_DTTE_center_FW IKE/7/PACKET: -Slot=2.1; Received ISAKMP Identification Payload (IPsec DOI).
*Jun 14 12:47:57:852 2017 LQ_DTTE_center_FW IKE/7/PACKET: -Slot=2.1; Received ISAKMP Identification Payload (IPsec DOI).
*Jun 14 12:47:57:852 2017 LQ_DTTE_center_FW IKE/7/PACKET: -Slot=2.1; Process HASH payload.
*Jun 14 12:47:57:852 2017 LQ_DTTE_center_FW IKE/7/EVENT: -Slot=2.1; Validated HASH(1) successfully.
*Jun 14 12:47:57:852 2017 LQ_DTTE_center_FW IKE/7/PACKET: -Slot=2.1; Process IPsec ID payload.
*Jun 14 12:47:57:852 2017 LQ_DTTE_center_FW IKE/7/PACKET: -Slot=2.1; Process IPsec ID payload.
*Jun 14 12:47:57:852 2017 LQ_DTTE_center_FW IKE/7/EVENT: -Slot=2.1; IPsec SA state changed from IKE_P2_STATE_INIT to IKE_P2_STATE_GETSP.
*Jun 14 12:47:57:852 2017 LQ_DTTE_center_FW IPSEC/7/EVENT: -Slot=2.1;
The policy's acl or ike profile does not match the flow, Name = test, Seqnum = 1
*Jun 14 12:47:57:852 2017 LQ_DTTE_center_FW IKE/7/ERROR: -Slot=2.1; Failed to get IPsec policy for phase 2 responder. Delete IPsec SA.
*Jun 14 12:47:57:852 2017 LQ_DTTE_center_FW IKE/7/ERROR: -Slot=2.1; Failed to negotiate IPsec SA.
*Jun 14 12:47:57:852 2017 LQ_DTTE_center_FW IKE/7/EVENT: -Slot=2.1; Delete IPsec SA.
*Jun 14 12:47:57:853 2017 LQ_DTTE_center_FW IKE/7/PACKET: -Slot=2.1; Encrypt the packet.
*Jun 14 12:47:57:853 2017 LQ_DTTE_center_FW IKE/7/PACKET: -Slot=2.1; Construct notification packet: INVALID_ID_INFORMATION.
*Jun 14 12:47:57:853 2017 LQ_DTTE_center_FW IKE/7/PACKET: -Slot=2.1; Sending packet to 10.10.10.1 remote port 500, local port 500.
*Jun 14 12:47:57:853 2017 LQ_DTTE_center_FW IKE/7/PACKET: -Slot=2.1;
  I-COOKIE: e308ec59ad9e32d8
  R-COOKIE: fa03a4ef576d1106
  next payload: HASH
  version: ISAKMP Version 1.0
  exchange mode: Info
  flags: ENCRYPT
  message ID: 41d07dea
  length: 68
*Jun 14 12:47:57:853 2017 LQ_DTTE_center_FW IKE/7/PACKET: -Slot=2.1; Sending an IPv4 packet.
*Jun 14 12:47:57:853 2017 LQ_DTTE_center_FW IPSEC/7/packet: -Slot=2.1;
Enter IPsec output process, Flag : 0x80, Data length : 96


根据调试信息分析可以看到,设备提示INVALID_ID_INFORMATION,根据报错,怀疑还是配置参数不匹配,导致IPSec无法正常建立。

*Jun 14 12:47:57:852 2017 LQ_DTTE_center_FW IKE/7/ERROR: -Slot=2.1; Failed to get IPsec policy for phase 2 responder. Delete IPsec SA.
*Jun 14 12:47:57:852 2017 LQ_DTTE_center_FW IKE/7/ERROR: -Slot=2.1; Failed to negotiate IPsec SA.
*Jun 14 12:47:57:852 2017 LQ_DTTE_center_FW IKE/7/EVENT: -Slot=2.1; Delete IPsec SA.
*Jun 14 12:47:57:853 2017 LQ_DTTE_center_FW IKE/7/PACKET: -Slot=2.1; Encrypt the packet.
*Jun 14 12:47:57:853 2017 LQ_DTTE_center_FW IKE/7/PACKET: -Slot=2.1; Construct notification packet: INVALID_ID_INFORMATION.

通过检查设备配置,发现设备配置感兴趣流与对端不匹配

#
acl number 3010
 description to ipsec
 rule 4 permit ip vpn-instance DX source 192.168.2.1 0 destination 192.168.1.0 0.0.0.255
#

ZX侧感性趣流配置如下

$
!</switchvlan>
!<ipv4-acl>
ipv4-access-list 3010
  rule 10 permit ip 192.168.1.0 0.0.0.255 192.168.2.1 0.0.0.0
$

可以看到acl中一端配置了vpn实例,另一端没有配置vpn实例。

解决方法

调整中兴侧配置,将acl配置vpn实例解决。

0 个评论

该案例暂时没有网友评论

编辑评论

举报

×

侵犯我的权益 >
对根叔知了社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔知了社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明

提出建议

    +
<

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作