Print

VXLAN典型组网配置案例2(单个VLAN经过交换机透传)

2020-10-24 发表

组网及说明


本案例采用HCL模拟器来模拟VXLAN典型组网配置案例,为了实现大二层的通信,需要将通过VXLAN使得PC_5和PC_6能互通。

配置步骤

1、将PC划分到相应的VLAN中。

2、R1和R2采用OSPF互通。

3、R1与R2建立VXLAN隧道。

4、配置VXLAN

配置关键点

SW1配置如下:

sysname SW1

vlan 100

quit

interface GigabitEthernet1/0/1

 port link-mode bridge 

 port access vlan 100 

quit


interface GigabitEthernet1/0/2 

 port access vlan 100 

 quit


SW2配置如下:

sysname SW2

vlan 100

quit


interface GigabitEthernet1/0/1

 port link-mode bridge 

 port access vlan 100 

quit


interface GigabitEthernet1/0/2 

 port access vlan 100 

 quit


R1配置如下:

sysname R1

ospf 1 router-id 1.1.1.1 

 area 0.0.0.0 

 network 1.1.1.1 0.0.0.0 

 network 10.0.0.1 0.0.0.0

quit


interface LoopBack0 

 ip address 1.1.1.1 255.255.255.255

quit


interface GigabitEthernet0/0 

 description <connect to R2> 

 ip address 10.0.0.1 255.255.255.252

quit


interface Tunnel0 mode vxlan 

 source 1.1.1.1 

 destination 2.2.2.2

quit


 l2vpn enable 


 vsi vpna 

 vxlan 100 

 tunnel 0

quit


interface GigabitEthernet0/1 

 xconnect vsi vpna access-mode vlan

quit


R2配置如下:

sysname R2

ospf 1 router-id 2.2.2.2 

 area 0.0.0.0 

 network 2.2.2.2 0.0.0.0 

 network 10.0.0.2 0.0.0.0

quit


interface LoopBack0 

 ip address 2.2.2.2 255.255.255.255

quit


interface GigabitEthernet0/0

 ip address 10.0.0.2 255.255.255.252

quit


interface Tunnel0 mode vxlan 

 source 2.2.2.2 

 destination 1.1.1.1

quit


 l2vpn enable 


 vsi vpna

 vxlan 100 

 tunnel 0

quit


interface GigabitEthernet0/1 

 xconnect vsi vpna access-mode vlan

quit



以上是VXLAN的配置关键点,具体的配置文件详情见附件!