Print

MSR路由器MPLS TE自动路由宣告 + Absolute Metric功能的配置

2006-09-08发表

MSR路由器

MPLS TE 自动路由宣告 + Absolute Metric功能的配置

 

关键字:MSR;MPLS;TE;CRLDP;OSPF;IGP Advertise; Absolute Metric

 

一、组网需求

RTARTBRTCRTD通过OSPF发布路由,RTA通过CR-LDP建立一条到RTDTE隧道,RTA通过IGP Advertise方式引入流量

设备清单:MSR路由器4

二、组网图:

三、配置步骤:

适用设备和版本:MSRVersion 5.20, Beta 1105后所有版本。

RTA配置

#

 router id 1.1.1.1

#

mpls lsr-id 1.1.1.1

#

#

mpls

 //全局使能TE

 mpls te

//使能cspf

 mpls te cspf

#

//使能mpls ldp

mpls ldp

#

interface Ethernet0/0

 port link-mode route

 description connects to RTB

 ip address 1.2.0.1 255.255.255.0

mpls

 //接口使能mpls te

 mpls te

 //指定接口的最大链路带宽BC0

 mpls te max-link-bandwidth 100

 //指定接口的最大预留带宽BC1,必须小于BC0

 mpls te max-reservable-bandwidth 50

 //接口使能ldp

 mpls ldp

#

interface LoopBack0

 ip address 1.1.1.1 255.255.255.255

#

interface Tunnel0

 ip address 1.4.0.1 255.255.255.252

 //指定隧道类型

 tunnel-protocol mpls te

 //指定te信令协议为crldp

 mpls te signal-protocol crldp

 //指定隧道目的

 destination 4.4.4.4

 //指定隧道需要预留的bc0带宽

 mpls te bandwidth bc0 20

 //指定使用IGP Advertise,必配

mpls te igp advertise

//指定TunnelMetric

 mpls te igp metric absolute 2

 //执行上述配置

 mpls te commit

#

ospf 1

 //支持type 10 LSA的发送与接收

 opaque-capability enable

 //使能traffic-adjustment advertise,必配

 enable traffic-adjustment advertise

 area 0.0.0.0

  network 1.1.1.1 0.0.0.0

  network 1.2.0.0 0.0.0.255

  //Tunnel口添加到OSPF计算中

  network 1.4.0.0 0.0.0.3

  //使能该区域的te数据采集

  mpls-te enable

#

RTB配置

#

router id 2.2.2.2

#

mpls lsr-id 2.2.2.2

#

mpls

//全局使能TE

 mpls te

//使能cspf

 mpls te cspf

#

//使能mpls ldp

mpls ldp

#

interface Ethernet0/0

 port link-mode route

 description connects to RTA

 ip address 1.2.0.2 255.255.255.0

mpls

 //接口使能mpls te

 mpls te

 //指定接口的最大链路带宽BC0

 mpls te max-link-bandwidth 100

 //指定接口的最大预留带宽BC1,必须小于BC0

 mpls te max-reservable-bandwidth 50

 //接口使能ldp

 mpls ldp

#

interface Ethernet0/1

 port link-mode route

 description connects to RTC

 ip address 2.3.0.2 255.255.255.0

mpls

 //接口使能mpls te

 mpls te

 //指定接口的最大链路带宽BC0

 mpls te max-link-bandwidth 100

 //指定接口的最大预留带宽BC1,必须小于BC0

 mpls te max-reservable-bandwidth 50

 //接口使能ldp

 mpls ldp

#

interface LoopBack0

 ip address 2.2.2.2 255.255.255.255

#

ospf 1

//支持type 10 LSA的发送与接收

 opaque-capability enable

 area 0.0.0.0

  network 2.2.2.2 0.0.0.0

  network 1.2.0.0 0.0.0.255

  network 2.3.0.0 0.0.0.255

  //使能该区域的te数据采集

  mpls-te enable

#

RTC配置

#

router id 3.3.3.3

#

mpls lsr-id 3.3.3.3

#

mpls

//全局使能TE

 mpls te

//使能cspf

 mpls te cspf

#

//使能mpls ldp

mpls ldp

#

interface Ethernet0/0

 port link-mode route

 description connects to RTB

 ip address 2.3.0.3 255.255.255.0

mpls

 //接口使能mpls te

 mpls te

 //指定接口的最大链路带宽BC0

 mpls te max-link-bandwidth 100

 //指定接口的最大预留带宽BC1,必须小于BC0

 mpls te max-reservable-bandwidth 50

 //接口使能ldp

 mpls ldp

#

interface Ethernet0/1

 port link-mode route

 description connects to RTD

 ip address 3.4.0.3 255.255.255.0

mpls

 //接口使能mpls te

 mpls te

 //指定接口的最大链路带宽BC0

 mpls te max-link-bandwidth 100

 //指定接口的最大预留带宽BC1,必须小于BC0

 mpls te max-reservable-bandwidth 50

 //接口使能ldp

 mpls ldp

#

interface LoopBack0

 ip address 3.3.3.3 255.255.255.255

#

ospf 1

//支持type 10 LSA的发送与接收

 opaque-capability enable

 area 0.0.0.0

  network 3.3.3.3 0.0.0.0

  network 2.3.0.0 0.0.0.255

  network 3.4.0.0 0.0.0.255

  //使能该区域的te数据采集

  mpls-te enable

#

RTD配置

#

router id 4.4.4.4

#

mpls lsr-id 4.4.4.4

#

mpls

//全局使能TE

 mpls te

//使能cspf

 mpls te cspf

#

//使能mpls ldp

mpls ldp

#

interface Ethernet0/0

 port link-mode route

 description connects to RTC

 ip address 3.4.0.4 255.255.255.0

mpls

 //接口使能mpls te

 mpls te

 //指定接口的最大链路带宽BC0

 mpls te max-link-bandwidth 100

 //指定接口的最大预留带宽BC1,必须小于BC0

 mpls te max-reservable-bandwidth 50

 //接口使能ldp

 mpls ldp

#

interface LoopBack0

 ip address 4.4.4.4 255.255.255.255

#

interface Tunnel0

 ip address 1.4.0.4 255.255.255.252

 //指定隧道类型

 tunnel-protocol mpls te

 //指定te信令协议为crldp

 mpls te signal-protocol crldp

 //指定隧道目的

 destination 1.1.1.1

 //指定隧道需要预留的bc0带宽

 mpls te bandwidth bc0 20

 //指定使用IGP Advertise必配

mpls te igp advertise

//指定TunnelMetric

 mpls te igp metric absolute 2

 //执行上述配置

 mpls te commit

#

ospf 1

 //支持type 10 LSA的发送与接收

 opaque-capability enable

 //使能traffic-adjustment advertise,必配

 enable traffic-adjustment advertise

 area 0.0.0.0

  network 4.4.4.4 0.0.0.0

  network 3.4.0.0 0.0.0.255

  //Tunnel口添加到OSPF计算中

  network 1.4.0.0 0.0.0.3

  //使能该区域的te数据采集

  mpls-te enable

#

四、配置关键点

1) 在CRLDP + OSPF配置正确的基础上稍作修改;

2) 去掉RTA的静态路由引入方式;

3) RTA的Tunnel口上配置mpls te igp advertise;

4) RTATunnel口上要配置mpls te metric absolute,要比igp计算的metric才可能引入流量

5) RTAOSPF需要使能traffic-adjustment advertise(注意与IGP Shortcut的区别),还需要将Tunnel口加入到OSPF区域中;

6) 要使用IGP Advertise(IGP转发邻接),必须要建立双向TE隧道,RTD必须要建立一条到RTA的Tunnel,只有双方Tunnel都成功建立,才可能IGP Advertise成功。