一台MSR36-40路由,通过2M线接入国家电网调度数据专网。按接入方式要求,只允许从OSPF获取路由,不允许从BGP获取。
我做的配置如下:
#
version 7.1.059, Release 0304P15
#
sysname CQNA-DFSB.R1
#
clock timezone beijing add 08:00:00
#
ip vpn-instance vpn-nrt
route-distinguisher 25513:2
vpn-target 25513:2110 30000:802 20000:200 import-extcommunity
vpn-target 25513:2110 25588:200 export-extcommunity
#
ip vpn-instance vpn-rt
route-distinguisher 25513:1
vpn-target 25513:1110 30000:801 20000:100 import-extcommunity
vpn-target 25513:1110 25588:100 export-extcommunity
#
router id 55.2.42.49
#
ospf 1
area 0.0.0.3
network 55.2.42.49 0.0.0.0
network 55.3.74.192 0.0.0.3
network 55.3.77.192 0.0.0.3
#
mpls lsr-id 55.2.42.49
mpls ttl propagate vpn
#
password-recovery enable
#
vlan 1
#
traffic classifier c_vpn-nrt-in operator and
if-match acl 2001
#
traffic classifier c_vpn-nrt-out operator and
if-match mpls-exp 3
#
traffic classifier c_vpn-rt-in operator and
if-match acl 2001
#
traffic classifier c_vpn-rt-out operator and
if-match mpls-exp 4
#
traffic behavior b_vpn-nrt-in
remark dscp af31
#
traffic behavior b_vpn-nrt-out
queue af bandwidth pct 30
#
traffic behavior b_vpn-rt-in
remark dscp af41
#
traffic behavior b_vpn-rt-out
queue af bandwidth pct 70
#
qos policy p_vpn-nrt-in
classifier c_vpn-nrt-in behavior b_vpn-nrt-in
#
qos policy p_vpn-out
classifier c_vpn-rt-out behavior b_vpn-rt-out
classifier c_vpn-nrt-out behavior b_vpn-nrt-out
#
qos policy p_vpn-rt-in
classifier c_vpn-rt-in behavior b_vpn-rt-in
#
mpls ldp
#
controller Cellular0/0
#
controller Cellular0/1
#
interface Aux0
#
interface Serial3/0
description DD2-DFSB1-2M
fe1 unframed
ip address 55.3.74.194 255.255.255.252
ospf authentication-mode md5 1 cipher $c$3$WMl1Z2MYGKzrg92B0lKzs9TjtchL/gbDGA==
mpls enable
mpls ldp enable
mpls ldp transport-address interface
#
interface Serial3/1
shutdown
#
interface Serial4/0
description BD2-DFSB1-2M
fe1 unframed
ip address 55.3.77.194 255.255.255.252
ospf authentication-mode md5 1 cipher $c$3$SPqUzpH7rwULmfoA0+aGtTRiCntrDuoa4g==
mpls enable
mpls ldp enable
mpls ldp transport-address interface
#
interface Serial4/1
shutdown
#
interface NULL0
#
interface LoopBack0
ip address 55.2.42.49 255.255.255.255
#
interface Ethernet2/0
port link-mode bridge
shutdown
#
interface Ethernet2/1
port link-mode bridge
shutdown
#
interface Ethernet2/2
port link-mode bridge
shutdown
#
interface Ethernet2/3
port link-mode bridge
shutdown
#
interface GigabitEthernet0/0
port link-mode route
description R1-S1
combo enable copper
ip binding vpn-instance vpn-rt
ip address 55.110.32.126 255.255.255.128
#
interface GigabitEthernet0/1
port link-mode route
description R1-S2
combo enable copper
ip binding vpn-instance vpn-nrt
ip address 55.111.32.126 255.255.255.128
#
interface GigabitEthernet0/2
port link-mode route
shutdown
#
bgp 25513
group ibgp-peer internal
peer ibgp-peer connect-interface LoopBack0
peer 55.2.40.2 group ibgp-peer
peer 55.2.40.5 group ibgp-peer
#
address-family ipv4 unicast
import-route direct
peer ibgp-peer enable
#
address-family vpnv4
peer ibgp-peer enable
#
ip vpn-instance vpn-nrt
#
address-family ipv4 unicast
import-route direct
#
ip vpn-instance vpn-rt
#
address-family ipv4 unicast
import-route direct
#
scheduler logfile size 16
#
line class aux
user-role network-admin
#
line class tty
user-role network-operator
#
line class vty
user-role network-operator
#
line aux 0
authentication-mode scheme
user-role level-15
user-role network-admin
idle-timeout 5 0
#
line vty 0 4
authentication-mode scheme
user-role level-15
user-role network-admin
protocol inbound ssh
idle-timeout 5 0
#
line vty 5 63
user-role network-operator
#
info-center loghost 55.254.13.1
#
snmp-agent
snmp-agent local-engineid 800063A280D461FE43CA2900000001
snmp-agent community read CQEP-READ
snmp-agent community write CQEP-WRITE
snmp-agent sys-info version v3
snmp-agent group v3 CQEP privacy read-view CQEP-READ write-view CQEP-WRITE notify-view CQEP-READ
snmp-agent target-host trap address udp-domain 55.254.13.1 params securityname CQEP-READ
snmp-agent mib-view included CQEP-READ iso
snmp-agent mib-view included CQEP-WRITE iso
snmp-agent usm-user v3 cqdl CQEP cipher authentication-mode sha $c$3$zUJ3vlz2/td/QKfBkBlH7tD5YyNV1GTTzikvWCMGN2iTISyS3cw= privacy-mode des56 $c$3$5xdVHLv69qIpcvayjR45JyTa3TcB7YtLUIIxSqEryG0clg==
snmp-agent trap source LoopBack0
#
ssh server enable
ssh user cqdl-ssh service-type stelnet authentication-type password
#
ntp-service unicast-server 55.2.40.2
ntp-service unicast-server 55.2.40.5
#
acl basic 2001
rule 0 permit source 55.254.13.0 0.0.0.255
rule 5 permit source 55.3.0.0 0.0.255.255
#
domain system
#
domain default enable system
#
role name level-0
description Predefined level-0 role
#
role name level-1
description Predefined level-1 role
#
role name level-2
description Predefined level-2 role
#
role name level-3
description Predefined level-3 role
#
role name level-4
description Predefined level-4 role
#
role name level-5
description Predefined level-5 role
#
role name level-6
description Predefined level-6 role
#
role name level-7
description Predefined level-7 role
#
role name level-8
description Predefined level-8 role
#
role name level-9
description Predefined level-9 role
#
role name level-10
description Predefined level-10 role
#
role name level-11
description Predefined level-11 role
#
role name level-12
description Predefined level-12 role
#
role name level-13
description Predefined level-13 role
#
role name level-14
description Predefined level-14 role
#
user-group system
#
local-user cqdl-con class manage
password hash $h$6$spxLOTDn+b99u2k4$bhcSm9KNOfjxbcw5Qwk5BN31nDwXR0W8KQ0S3jDTP1qtctEmG2Dv5iWhCIOBKxtkyRgbmvE0uEiVpGOHbsFaww==
service-type terminal
authorization-attribute user-role level-15
authorization-attribute user-role network-admin
#
local-user cqdl-ssh class manage
password hash $h$6$UvnTyFOktg0s5tvl$yJy5divtM8HQ+lMxC+mqKSO6O4N22ItRByP/3memdCgJFOT+DkeYI8IMgICHHQRk0872PV5tpn6Si9b7pFYYlA==
service-type ssh
authorization-attribute user-role level-15
authorization-attribute user-role network-admin
#
public-key peer 55.110.32.124
public-key-code begin
308201B73082012C06072A8648CE3804013082011F02818100D757262C4584C44C211F18BD
96E5F061C4F0A423F7FE6B6B85B34CEF72CE14A0D3A5222FE08CECE65BE6C265854889DC1E
DBD13EC8B274DA9F75BA26CCB987723602787E922BA84421F22C3C89CB9B06FD60FE01941D
DD77FE6B12893DA76EEBC1D128D97F0678D7722B5341C8506F358214B16A2FAC4B36895038
7811C7DA33021500C773218C737EC8EE993B4F2DED30F48EDACE915F0281810082269009E1
4EC474BAF2932E69D3B1F18517AD9594184CCDFCEAE96EC4D5EF93133E84B47093C52B20CD
35D02492B3959EC6499625BC4FA5082E22C5B374E16DD00132CE71B020217091AC717B6123
91C76C1FB2E88317C1BD8171D41ECB83E210C03CC9B32E810561C21621C73D6DAAC028F4B1
585DA7F42519718CC9B09EEF0381840002818071810E8D5F8C3609D843DA2750E8E9ADAB69
58FDD3D827BBEE75344568A7E730FBD132712F53217F3F1C96B128246CDE826BC284224FA7
42A0E49B0C44645D731F5ADB53F4FA19920FABD1697ED9BC000A936FB23575A6C1F8389615
1954AD65FA22E95E33AE7C9FBEB36346845492266FF905B6B7AFD9F8A4DFD3DBB777DBAF
public-key-code end
peer-public-key end
#
return
目前学到的路由如下:
<CQNA-DFSB.R1>dis ip routing-table
Destinations : 236 Routes : 290
Destination/Mask Proto Pre Cost NextHop Interface
0.0.0.0/32 Direct 0 0 127.0.0.1 InLoop0
3.55.113.0/30 O_INTER 10 49 55.3.74.193 Ser3/0
3.55.113.4/30 O_INTER 10 54 55.3.77.193 Ser4/0
3.254.55.0/24 O_ASE2 150 100 55.3.74.193 Ser3/0
4.55.0.0/16 O_ASE2 150 100 55.3.74.193 Ser3/0
5.55.0.0/16 O_ASE2 150 100 55.3.74.193 Ser3/0
5.55.113.0/30 O_INTER 10 49 55.3.74.193 Ser3/0
5.55.113.4/30 O_INTER 10 54 55.3.77.193 Ser4/0
5.254.55.0/24 O_ASE2 150 100 55.3.74.193 Ser3/0
55.2.40.0/22 BGP 255 0 55.2.40.2 Ser3/0
55.2.40.1/32 O_INTER 10 49 55.3.74.193 Ser3/0
55.2.40.2/32 O_INTER 10 48 55.3.74.193 Ser3/0
55.2.40.5/32 O_INTER 10 48 55.3.77.193 Ser4/0
55.2.41.1/32 O_INTER 10 99 55.3.74.193 Ser3/0
55.2.41.2/32 O_INTER 10 99 55.3.74.193 Ser3/0
55.2.41.3/32 O_INTER 10 99 55.3.74.193 Ser3/0
55.2.41.4/32 O_INTER 10 98 55.3.74.193 Ser3/0
55.2.41.5/32 O_INTER 10 536 55.3.74.193 Ser3/0
55.2.41.6/32 O_INTER 10 98 55.3.74.193 Ser3/0
55.2.41.7/32 O_INTER 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.41.8/32 O_INTER 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.41.9/32 O_INTER 10 292 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.41.10/32 O_INTER 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.41.18/32 O_INTER 10 292 55.3.74.193 Ser3/0
55.2.42.1/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.2/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.3/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.4/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.5/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.6/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.7/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.8/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.9/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.10/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.11/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.12/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.13/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.14/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.15/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.16/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.17/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.18/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.19/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.20/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.21/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.22/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.23/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.24/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.25/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.26/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.27/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.28/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.29/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.30/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.31/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.32/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.33/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.34/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.35/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.36/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.37/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.38/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.39/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.40/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.41/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.42/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.43/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.44/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.45/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.46/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.47/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.48/32 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.42.49/32 Direct 0 0 127.0.0.1 InLoop0
55.2.43.192/32 O_INTER 10 536 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.2.43.194/32 O_INTER 10 536 55.3.77.193 Ser4/0
55.2.43.195/32 O_INTER 10 608 55.3.77.193 Ser4/0
55.2.43.196/32 O_INTER 10 632 55.3.77.193 Ser4/0
55.2.43.197/32 O_INTER 10 632 55.3.77.193 Ser4/0
55.2.43.198/32 O_INTER 10 608 55.3.77.193 Ser4/0
55.2.43.199/32 O_INTER 10 632 55.3.77.193 Ser4/0
55.2.43.200/32 O_INTER 10 608 55.3.77.193 Ser4/0
55.2.43.201/32 O_INTER 10 608 55.3.77.193 Ser4/0
55.2.43.202/32 O_INTER 10 608 55.3.77.193 Ser4/0
55.2.43.203/32 O_INTER 10 608 55.3.77.193 Ser4/0
55.2.43.204/32 O_INTER 10 608 55.3.77.193 Ser4/0
55.3.64.0/20 BGP 255 0 55.2.40.2 Ser3/0
55.3.64.0/30 O_INTER 10 49 55.3.74.193 Ser3/0
55.3.64.4/30 O_INTER 10 50 55.3.74.193 Ser3/0
55.3.64.8/30 O_INTER 10 54 55.3.74.193 Ser3/0
55.3.77.193 Ser4/0
55.3.68.0/25 O_INTER 10 536 55.3.74.193 Ser3/0
55.3.69.0/24 O_INTER 10 536 55.3.77.193 Ser4/0
55.3.70.0/24 O_INTER 10 632 55.3.77.193 Ser4/0
55.3.72.0/30 O_INTER 10 98 55.3.74.193 Ser3/0
55.3.72.4/30 O_INTER 10 98 55.3.74.193 Ser3/0
55.3.72.8/30 O_INTER 10 98 55.3.74.193 Ser3/0
55.3.72.12/30 O_INTER 10 98 55.3.74.193 Ser3/0
55.3.72.16/30 O_INTER 10 536 55.3.74.193 Ser3/0
55.3.72.20/30 O_INTER 10 98 55.3.74.193 Ser3/0
55.3.72.68/30 O_INTER 10 292 55.3.74.193 Ser3/0
55.3.74.0/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.4/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.8/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.12/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.16/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.20/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.24/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.28/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.32/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.36/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.40/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.44/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.48/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.52/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.56/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.60/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.64/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.68/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.72/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.76/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.80/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.84/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.88/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.92/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.96/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.100/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.104/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.108/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.112/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.116/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.120/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.124/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.128/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.132/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.136/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.140/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.144/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.148/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.152/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.156/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.160/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.164/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.168/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.172/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.176/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.180/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.184/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.188/30 O_INTRA 10 536 55.3.74.193 Ser3/0
55.3.74.192/30 Direct 0 0 55.3.74.194 Ser3/0
55.3.74.192/32 Direct 0 0 55.3.74.194 Ser3/0
55.3.74.193/32 Direct 0 0 55.3.74.193 Ser3/0
55.3.74.194/32 Direct 0 0 127.0.0.1 InLoop0
55.3.74.195/32 Direct 0 0 55.3.74.194 Ser3/0
55.3.76.0/25 O_INTER 10 536 55.3.77.193 Ser4/0
55.3.77.0/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.4/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.8/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.12/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.16/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.20/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.24/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.28/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.32/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.36/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.40/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.44/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.48/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.52/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.56/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.60/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.64/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.68/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.72/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.76/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.80/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.84/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.88/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.92/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.96/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.100/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.104/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.108/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.112/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.116/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.120/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.124/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.128/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.132/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.136/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.140/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.144/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.148/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.152/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.156/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.160/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.164/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.168/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.172/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.176/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.180/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.184/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.188/30 O_INTRA 10 536 55.3.77.193 Ser4/0
55.3.77.192/30 Direct 0 0 55.3.77.194 Ser4/0
55.3.77.192/32 Direct 0 0 55.3.77.194 Ser4/0
55.3.77.193/32 Direct 0 0 55.3.77.193 Ser4/0
55.3.77.194/32 Direct 0 0 127.0.0.1 InLoop0
55.3.77.195/32 Direct 0 0 55.3.77.194 Ser4/0
55.4.38.10/32 O_INTER 10 608 55.3.77.193 Ser4/0
55.4.38.14/32 O_INTER 10 608 55.3.77.193 Ser4/0
55.4.38.15/32 O_INTER 10 608 55.3.77.193 Ser4/0
55.4.38.16/32 O_INTER 10 608 55.3.77.193 Ser4/0
55.4.38.17/32 O_INTER 10 608 55.3.77.193 Ser4/0
55.4.38.18/32 O_INTER 10 608 55.3.77.193 Ser4/0
55.4.38.19/32 O_INTER 10 608 55.3.77.193 Ser4/0
55.4.38.20/32 O_INTER 10 608 55.3.77.193 Ser4/0
55.4.38.21/32 O_INTER 10 608 55.3.77.193 Ser4/0
55.4.38.22/32 O_INTER 10 608 55.3.77.193 Ser4/0
55.5.50.0/25 O_INTER 10 73 55.3.74.193 Ser3/0
55.5.50.36/30 O_INTER 10 608 55.3.77.193 Ser4/0
55.5.50.52/30 O_INTER 10 608 55.3.77.193 Ser4/0
55.5.50.56/30 O_INTER 10 608 55.3.77.193 Ser4/0
55.5.50.60/30 O_INTER 10 608 55.3.77.193 Ser4/0
55.5.50.64/30 O_INTER 10 608 55.3.77.193 Ser4/0
55.5.50.68/30 O_INTER 10 608 55.3.77.193 Ser4/0
55.5.50.72/30 O_INTER 10 608 55.3.77.193 Ser4/0
55.5.50.76/30 O_INTER 10 608 55.3.77.193 Ser4/0
55.5.50.80/30 O_INTER 10 608 55.3.77.193 Ser4/0
55.5.50.84/30 O_INTER 10 608 55.3.77.193 Ser4/0
55.254.13.0/24 BGP 255 0 55.2.40.2 Ser3/0
55.254.13.0/25 O_INTER 10 49 55.3.74.193 Ser3/0
127.0.0.0/8 Direct 0 0 127.0.0.1 InLoop0
127.0.0.0/32 Direct 0 0 127.0.0.1 InLoop0
127.0.0.1/32 Direct 0 0 127.0.0.1 InLoop0
127.255.255.255/32 Direct 0 0 127.0.0.1 InLoop0
224.0.0.0/4 Direct 0 0 0.0.0.0 NULL0
224.0.0.0/24 Direct 0 0 0.0.0.0 NULL0
255.255.255.255/32 Direct 0 0 127.0.0.1 InLoop0
<CQNA-DFSB.R1>
从目前学到的路由来看,还是有BGP协议,BGP路由。
现在问题是:
我的OSPF配置和BGP配置是否有误?若有问题,应该如何修改?最终要求是仅使用OSPF获取路由,不允许BGP协议学习路由。
目前配置BGP的目的是保证私网联通。
bgp 25513
group ibgp-peer internal
peer ibgp-peer connect-interface LoopBack0
peer 55.2.40.2 group ibgp-peer
peer 55.2.40.5 group ibgp-peer
#
address-family ipv4 unicast
import-route direct
peer ibgp-peer enable
#
address-family vpnv4
peer ibgp-peer enable
#
ip vpn-instance vpn-nrt
#
address-family ipv4 unicast
import-route direct
#
ip vpn-instance vpn-rt
#
address-family ipv4 unicast
import-route direct
#
这一段是否应该删除IPV4相关的配置?
烦请举例,谢谢!
(0)
最佳答案
这是一个PE设备吧,BGP学习到的几个路由应该是对端在BGP里面import的其他路由或者是network的,这种情况要想不从BGP学,反而从OSPF学习的花,在OSPF里面引入BGP就行了呀,不过还是没理解为什么这样做
(0)
用于业务接入,应该算CE设备。只能从OSFP获取路由,不允许使用BGP,是国家电网提出的强制要求,我也没有理解为什么要这样做,只能无条件服从。 我比较菜,现在的问题是:BGP25513下的配置是为了保证私网联通,那么是否可以不peer IPV4, 只配置VPNV4? 如您所讲,在OSPF里引入BGP是如何配置?直接加一条引入直连路由么?
bgp 25513 group ibgp-peer internal peer ibgp-peer connect-interface LoopBack0 peer 55.2.40.2 group ibgp-peer peer 55.2.40.5 group ibgp-peer # ipv4-family vpnv4 peer 55.2.40.2 enable peer 55.2.40.2 advertise-community peer 55.2.40.2 reflect-client peer 55.2.40.5 enable peer 55.2.40.5 advertise-community peer 55.2.40.5 reflect-client peer ibgp-peer enable peer ibgp-peer reflect-client 这样写是否可以
亲~登录后才可以操作哦!
确定你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作
举报
×
侵犯我的权益
×
侵犯了我企业的权益
×
抄袭了我的内容
×
原文链接或出处
诽谤我
×
对根叔社区有害的内容
×
不规范转载
×
举报说明
bgp 25513 group ibgp-peer internal peer ibgp-peer connect-interface LoopBack0 peer 55.2.40.2 group ibgp-peer peer 55.2.40.5 group ibgp-peer # ipv4-family vpnv4 peer 55.2.40.2 enable peer 55.2.40.2 advertise-community peer 55.2.40.2 reflect-client peer 55.2.40.5 enable peer 55.2.40.5 advertise-community peer 55.2.40.5 reflect-client peer ibgp-peer enable peer ibgp-peer reflect-client 这样写是否可以