• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 漏洞说明
  • 全部
  • 全部
  • 大数据引擎
  • 知了引擎
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
搜索引擎
匹配模式
高级搜索

ICG3000 series如何配置固定IP上网

2023-09-28提问
  • 0关注
  • 0收藏,833浏览
粉丝:0人 关注:0人

问题描述:

ICG3000 series如何配置固定IP上网

最佳答案

粉丝:36人 关注:7人

您好,请知:

以下是配置案例,请参考:


组网说明:本案例是采用H3C HCL模拟器来模拟搭建basic NAT的组网环境,内网和外网均以在网络拓扑图中有了明确的标识,R1是某局点的内网设备,R1为出口设备,某局点申请了202.1.100.3-202.1.100.5范围的公网地址,内网终端需要通过NAT地址转换来访问外网。PC-3为外网的服务器。本案例要求PC-4、PC-5能通过转换为202.1.100.3-202.1.100.5范围内的公网地址来访问PC-3。

配置步骤

1、按照网络拓扑图正确配置IP地址

2、在R1配置NAT,实现地址转换

3、R1配置默认路由指向到外网

4、PC-4、PC-5能通过地址转换后PING通外网服务器PC-3

配置关键点

R1:

<H3C>sys

[H3C]sysname R1

[R1]int LoopBack 0

[R1-LoopBack0]ip address 2.2.2.2 32

[R1-LoopBack0]quit

[R1]router id 2.2.2.2

[R1]vlan 10

[R1-vlan10]quit

[R1]vlan 20

[R1-vlan20]quit

[R1]int vlan 10

[R1-Vlan-interface10]ip address 192.168.10.1 24

[R1-Vlan-interface10]quit

[R1]int vlan 20

[R1-Vlan-interface20]ip address 192.168.20.1 24

[R1-Vlan-interface20]quit

 

[R1]int gi 5/0

[R1-GigabitEthernet5/0]port link-mode bridge

[R1-GigabitEthernet5/0]port link-type access

[R1-GigabitEthernet5/0]port access vlan 10

[R1-GigabitEthernet5/0]quit

[R1]int gi 5/1

[R1-GigabitEthernet5/1]port link-mode bridge

[R1-GigabitEthernet5/1]port link-type access

[R1-GigabitEthernet5/1]port access vlan 20

[R1-GigabitEthernet5/1]quit

 

 

[R1]int gi 0/1

[R1-GigabitEthernet0/1]description <connect to ISP>

[R1-GigabitEthernet0/1]ip address 202.1.100.2 28

[R1-GigabitEthernet0/1]quit

 

 

NAT配置:

[R1]acl basic 2000

[R1-acl-ipv4-basic-2000]rule 0 permit source any

[R1-acl-ipv4-basic-2000]quit

 

[R1]nat address-group 1

[R1-address-group-1]address 202.1.100.3 202.1.100.5

[R1-address-group-1]quit

 

[R1]int gi 0/1

[R1-GigabitEthernet0/1]nat outbound 2000 address-group 1 no-pat

[R1-GigabitEthernet0/1]quit

[R1]ip route-static 0.0.0.0 0.0.0.0 202.1.100.1

 

ISP:

 

<H3C>sys

[H3C]sysname ISP

[ISP]int gi 0/1

[ISP-GigabitEthernet0/1]description <connect to R1>

[ISP-GigabitEthernet0/1]ip address 202.1.100.1 28

[ISP-GigabitEthernet0/1]quit

[ISP]int gi 0/0

[ISP-GigabitEthernet0/0]description <connect to PC-3>

[ISP-GigabitEthernet0/0]ip address 202.103.224.254 24

[ISP-GigabitEthernet0/0]quit

 

测试:

所有PC都填写上IP地址、子网掩码、默认网关







PC-4和PC-5能PING通PC-3





查看NAT的转换情况及会话清单:



至此,basic NAT典型组网配置案例已完成!


暂无评论

1 个回答
粉丝:171人 关注:8人

1.2 配置需求及实现的效果

路由器作为企业网络的出口路由器,要实现WAN口配置静态IP上网。此案例中,运营商给的公网地址为1.1.1.1,网关为1.1.1.2,内网地址段为192.168.0.1/23,运营商的DNS地址为5.5.5.5和6.6.6.6


组网图

 


配置步骤

配置步骤


3.1 配置WAN接口地址

#将运营商给的固定IP设置在WAN口

<H3C>system-view

[H3C]interface GigabitEthernet 0/0

[H3C-GigabitEthernet0/0]ip address 1.1.1.1 28    

[H3C-GigabitEthernet0/0]quit


3.2 配置内网网关

#一般情况下Comware V7平台MSR830-WiNet系列路由器设备默认已经配置内网网关Vlan1地址为192.168.0.1/23,DHCP服务器已经默认开启,如果内网是192.168.0.1/23网段,则不需配置这一步

<H3C>interface Vlan-interface1

[H3C-Vlan-interface1]ip address 192.168.0.1 255.255.254.0

[H3C-Vlan-interface1]quit


3.3 设置DHCP

#缺省情况下,DHCP服务器已经默认开启,设备默认DHCP分配的网段为192.168.0.0/23,默认分配的DNS地址是网关地址192.168.0.1,如果局域网电脑需要自动获取IP地址和DNS地址上网,那就需要根据实际情况设置对应DHCP地址池的参数

<H3C>system-view

#进入系统缺省VLAN1的DHCP地址池

[H3C]dhcp server ip-pool lan1

#配置要分配的地址网段

[H3C-dhcp-pool-lan1] network 192.168.0.0 mask 255.255.254.0

#配置客户端的网关地址

[H3C-dhcp-pool-lan1]gateway-list 192.168.0.1

#修改下发的dns地址,此处填写运营商实际提供的DNS地址,可以设置一个,也可以设置多个

[H3C-dhcp-pool-lan1] dns-list 5.5.5.5 6.6.6.6    

[H3C-dhcp-pool-lan1]quit


3.4 在WAN口配置NAT,实现内网地址上网进行源地址转换

[H3C]interface GigabitEthernet 0/0

[H3C- GigabitEthernet 0/0]nat outbound

[H3C]quit


3.5 配置默认路由

#默认路由下一跳地址配置运营商分配的网关地址

[H3C]ip route-static 0.0.0.0 0.0.0.0 1.1.1.2   

保存配置

[H3C]save force


暂无评论

编辑答案

你正在编辑答案

如果你要对问题或其他回答进行点评或询问,请使用评论功能。

分享扩散:

提出建议

    +

亲~登录后才可以操作哦!

确定

亲~检测到您登陆的账号未在http://hclhub.h3c.com进行注册

注册后可访问此模块

跳转hclhub

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作

举报

×

侵犯我的权益 >
对根叔社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到pub.zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 pub.zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到pub.zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明