• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 漏洞说明
  • 全部
  • 全部
  • 大数据引擎
  • 知了引擎
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
搜索引擎
匹配模式
高级搜索

两台堆叠或者mlag组网的交换机,上行连接路由器跑ospf

2024-01-25提问
  • 0关注
  • 0收藏,246浏览
粉丝:0人 关注:4人

问题描述:

这种情况下,流量是负载分担的吗,如果出去走左边,回来走右边,这样有影响吗?

1 个回答
粉丝:168人 关注:8人

负载分担的,没有影响,上联聚合


1.24.3  M-LAG双活网关场景下通过动态路由接入M-LAG配置举例

1. 组网需求

图1-19所示,用户在服务器上通过三层路由方式接入到M-LAG时,需要满足以下要求:

·     当一条接入链路发生故障时,流量可以快速切换到另一条链路,保证可靠性。

·     用户流量在两条接入链路上负载分担。

2. 组网图

图1-19 M-LAG双活网关场景下通过动态路由接入M-LAG配置组网图

3. 配置限制和指导

配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下配置不冲突。

同级M-LAG设备的m-lag system-mac应配置为相同,不同级M-LAG设备的m-lag system-mac一定要配置为不同。

M-LAG双活网关组网环境下,M-LAG设备的下行VLAN接口不要配置本地代理ARP/ND功能,否则会触发流量环路。有关ARP/ND本地代理功能的详细介绍,请参见“三层技术-IP业务配置指导”中的“代理ARP”和“IPv6邻居发现”。

4. 配置步骤

(1)     配置Device A

# 配置M-LAG系统参数。

<DeviceA> system-view

[DeviceA] m-lag system-mac 2-2-2

[DeviceA] m-lag system-number 1

[DeviceA] m-lag system-priority 123

# 配置Keepalive报文的目的IP地址和源IP地址。

[DeviceA] m-lag keepalive ip destination 21.1.1.2 source 21.1.1.1

# 配置端口Ten-GigabitEthernet1/0/5工作在三层模式,并配置IP地址为Keepalive报文的源IP地址。

[DeviceA] interface ten-gigabitethernet 1/0/5

[DeviceA-Ten-GigabitEthernet1/0/5] port link-mode route

[DeviceA-Ten-GigabitEthernet1/0/5] ip address 21.1.1.1 24

[DeviceA-Ten-GigabitEthernet1/0/5] ipv6 address 21::1 64

[DeviceA-Ten-GigabitEthernet1/0/5] quit

# 配置Keepalive链路接口为M-LAG保留接口。

[DeviceA] m-lag mad exclude interface ten-gigabitethernet 1/0/5

# 创建动态二层聚合接口1。

[DeviceA] interface bridge-aggregation 1

[DeviceA-Bridge-Aggregation1] link-aggregation mode dynamic

[DeviceA-Bridge-Aggregation1] quit

# 分别将端口Ten-GigabitEthernet1/0/3和Ten-GigabitEthernet1/0/4加入到聚合组1中。

[DeviceA] interface ten-gigabitethernet 1/0/3

[DeviceA-Ten-GigabitEthernet1/0/3] port link-aggregation group 1

[DeviceA-Ten-GigabitEthernet1/0/3] quit

[DeviceA] interface ten-gigabitethernet 1/0/4

[DeviceA-Ten-GigabitEthernet1/0/4] port link-aggregation group 1

[DeviceA-Ten-GigabitEthernet1/0/4] quit

# 将二层聚合接口1配置为peer-link接口。

[DeviceA] interface bridge-aggregation 1

[DeviceA-Bridge-Aggregation1] port m-lag peer-link 1

[DeviceA-Bridge-Aggregation1] undo mac-address static source-check enable

[DeviceA-Bridge-Aggregation1] quit

# 创建动态二层聚合接口3,并配置该接口为M-LAG接口1。

[DeviceA] interface bridge-aggregation 3

[DeviceA-Bridge-Aggregation3] link-aggregation mode dynamic

[DeviceA-Bridge-Aggregation3] port m-lag group 1

[DeviceA-Bridge-Aggregation3] quit

# 将端口Ten-GigabitEthernet1/0/1和Ten-GigabitEthernet1/0/2加入到聚合组3中。

[DeviceA] interface ten-gigabitethernet 1/0/1

[DeviceA-Ten-GigabitEthernet1/0/1] port link-aggregation group 3

[DeviceA-Ten-GigabitEthernet1/0/1] quit

[DeviceA] interface ten-gigabitethernet 1/0/2

[DeviceA-Ten-GigabitEthernet1/0/2] port link-aggregation group 3

[DeviceA-Ten-GigabitEthernet1/0/2] quit

# 创建VLAN 102、VLAN 103。

[DeviceA] vlan 102 103

# 配置二层聚合接口3为Trunk端口,并允许VLAN 102和VLAN 103的报文通过。

[DeviceA] interface bridge-aggregation 3

[DeviceA-Bridge-Aggregation3] port link-type trunk

[DeviceA-Bridge-Aggregation3] port trunk permit vlan 102 103

[DeviceA-Bridge-Aggregation3] quit

# 创建接口Vlan-interface102,并配置其IPv4和IPv6地址,作为双活网关。

[DeviceA] interface vlan-interface 102

[DeviceA-Vlan-interface102] ip address 10.102.0.1 255.255.255.0

[DeviceA-Vlan-interface102] ipv6 address 10:102::1 64

# 配置M-LAG虚拟IPv4和IPv6地址,以便和下行设备Device D建立OSPF和OSPFv3邻居关系。

[DeviceA-Vlan-interface102] port m-lag virtual-ip 10.102.0.3 24 active

[DeviceA-Vlan-interface102] port m-lag ipv6 virtual-ip FE80::2 link-local

# 配置接口Vlan-interface102的MAC地址。

[DeviceA-Vlan-interface102] mac-address 3-3-3

[DeviceA-Vlan-interface102] quit

# 配置Vlan-interface102接口为M-LAG保留接口。

[DeviceA] m-lag mad exclude interface vlan-interface 102

# 创建接口Vlan-interface103,并配置其IPv4和IPv6地址,作为双活网关。

[DeviceA] interface vlan-interface 103

[DeviceA-Vlan-interface103] ip address 10.103.0.1 24

[DeviceA-Vlan-interface103] ipv6 address 10:103::1 64

# 配置M-LAG虚拟IPv4和IPv6地址,以便和下行设备Device D建立BGP和BGP4+邻居关系。

[DeviceA-Vlan-interface103] port m-lag virtual-ip 10.103.0.3 24 active

[DeviceA-Vlan-interface103] port m-lag ipv6 virtual-ip 10:103::3 64 active

# 配置接口Vlan-interface103的MAC地址。

[DeviceA-Vlan-interface103] mac-address 4-4-4

[DeviceA-Vlan-interface103] quit

# 配置Vlan-interface103接口为M-LAG保留接口。

[DeviceA] m-lag mad exclude interface vlan-interface 103

# 配置上行口Ten-GigabitEthernet1/0/6的IPv4地址和IPv6地址。

[DeviceA] interface ten-gigabitethernet 1/0/6

[DeviceA-Ten-GigabitEthernet1/0/6] port link-mode route

[DeviceA-Ten-GigabitEthernet1/0/6] ip address 32.1.1.1 24

[DeviceA-Ten-GigabitEthernet1/0/6] ipv6 address 32:1::1 64

[DeviceA-Ten-GigabitEthernet1/0/6] quit

# 配置OSPF。

[DeviceA] ospf 1 router-id 11.1.1.1

[DeviceA-ospf-1] area 0

[DeviceA-ospf-1-area-0.0.0.0] quit

[DeviceA-ospf-1] quit

[DeviceA] interface vlan-interface 102

[DeviceA-Vlan-interface102] ospf 1 area 0

[DeviceA-Vlan-interface102] ospf peer sub-address enable 10.102.0.3

[DeviceA-Vlan-interface102] quit

[DeviceA] interface ten-gigabitethernet 1/0/6

[DeviceA-Ten-GigabitEthernet1/0/6] ospf 1 area 0

[DeviceA-Ten-GigabitEthernet1/0/6] quit

# 配置OSPFv3。

[DeviceA] ospfv3 1

[DeviceA-ospfv3-1] router-id 10.1.1.1

[DeviceA-ospfv3-1] area 0

[DeviceA-ospfv3-1-area-0.0.0.0] quit

[DeviceA-ospfv3-1] quit

[DeviceA] interface vlan-interface 102

[DeviceA-Vlan-interface102] ospfv3 1 area 0

[DeviceA-Vlan-interface102] quit

[DeviceA] interface ten-gigabitethernet 1/0/6

[DeviceA-Ten-GigabitEthernet1/0/6] ospfv3 1 area 0

[DeviceA-Ten-GigabitEthernet1/0/6] quit

# 配置BGP。

[DeviceA] bgp 100

[DeviceA-bgp-default] router-id 12.1.1.1

[DeviceA-bgp-default] peer 32.1.1.2 as-number 100

[DeviceA-bgp-default] peer 10.103.0.2 as-number 100

[DeviceA-bgp-default] peer 10.103.0.2 source-address 10.103.0.3

[DeviceA-bgp-default] address-family ipv4

[DeviceA-bgp-default-ipv4] peer 10.103.0.2 enable

[DeviceA-bgp-default-ipv4] network 10.103.0.0  255.255.255.0

[DeviceA-bgp-default-ipv4] peer 32.1.1.2 enable

[DeviceA-bgp-default-ipv4] network 32.1.1.0 255.255.255.0

[DeviceA-bgp-default-ipv4] quit

# 配置BGP4+。

[DeviceA-bgp-default] peer 32:1::2 as-number 100

[DeviceA-bgp-default] peer 10:103::2 as-number 100

[DeviceA-bgp-default] peer 10:103::2 source-address 10:103::3

[DeviceA-bgp-default] address-family ipv6

[DeviceA-bgp-default-ipv6] peer 10:103::2 enable

[DeviceA-bgp-default-ipv6] network 10:103::2  64

[DeviceA-bgp-default-ipv6] peer 32:1::2 enable

[DeviceA-bgp-default-ipv6] network  32:1::2 64

[DeviceA-bgp-default-ipv6] quit

[DeviceA-bgp-default] quit

(2)     配置Device B

# 配置M-LAG系统参数。

<DeviceB> system-view

[DeviceB] m-lag system-mac 2-2-2

[DeviceB] m-lag system-number 2

[DeviceB] m-lag system-priority 123

# 配置Keepalive报文的目的IP地址和源IP地址。

[DeviceB] m-lag keepalive ip destination 21.1.1.1 source 21.1.1.2

# 配置端口Ten-GigabitEthernet1/0/5工作在三层模式,并配置IP地址为Keepalive报文的源IP地址。

[DeviceB] interface ten-gigabitethernet 1/0/5

[DeviceB-Ten-GigabitEthernet1/0/5] port link-mode route

[DeviceB-Ten-GigabitEthernet1/0/5] ip address 21.1.1.2 255.255.255.0

[DeviceB-Ten-GigabitEthernet1/0/5] ipv6 address 21::2 64

[DeviceB-Ten-GigabitEthernet1/0/5] quit

# 配置Keepalive链路接口为保留接口。

[DeviceB] m-lag mad exclude interface ten-gigabitethernet 1/0/5

# 创建动态二层聚合接口1。

[DeviceB] interface bridge-aggregation 1

[DeviceB-Bridge-Aggregation1] link-aggregation mode dynamic

[DeviceB-Bridge-Aggregation1] quit

# 分别将端口Ten-GigabitEthernet1/0/3和Ten-GigabitEthernet1/0/4加入到聚合组1中。

[DeviceB] interface ten-gigabitethernet 1/0/3

[DeviceB-Ten-GigabitEthernet1/0/3] port link-aggregation group 1

[DeviceB-Ten-GigabitEthernet1/0/3] quit

[DeviceB] interface ten-gigabitethernet 1/0/4

[DeviceB-Ten-GigabitEthernet1/0/4] port link-aggregation group 1

[DeviceB-Ten-GigabitEthernet1/0/4] quit

# 将二层聚合接口1配置为peer-link接口。

[DeviceB] interface bridge-aggregation 1

[DeviceB-Bridge-Aggregation1] port m-lag peer-link 1

[DeviceB-Bridge-Aggregation1] undo mac-address static source-check enable

[DeviceB-Bridge-Aggregation1] quit

# 创建动态二层聚合接口3,并配置该接口为M-LAG接口1。

[DeviceB] interface bridge-aggregation 3

[DeviceB-Bridge-Aggregation3] link-aggregation mode dynamic

[DeviceB-Bridge-Aggregation3] port m-lag group 1

[DeviceB-Bridge-Aggregation3] quit

# 将端口Ten-GigabitEthernet1/0/1和Ten-GigabitEthernet1/0/2加入到聚合组3中。

[DeviceB] interface ten-gigabitethernet 1/0/1

[DeviceB-Ten-GigabitEthernet1/0/1] port link-aggregation group 3

[DeviceB-Ten-GigabitEthernet1/0/1] quit

[DeviceB] interface ten-gigabitethernet 1/0/2

[DeviceB-Ten-GigabitEthernet1/0/2] port link-aggregation group 3

[DeviceB-Ten-GigabitEthernet1/0/2] quit

# 创建VLAN 102、103。

[DeviceB] vlan 102 103

# 配置二层聚合接口3为Trunk端口,并允许VLAN 102和VLAN 103的报文通过。

[DeviceB] interface bridge-aggregation 3

[DeviceB-Bridge-Aggregation3] port link-type trunk

[DeviceB-Bridge-Aggregation3] port trunk permit vlan 102 103

[DeviceB-Bridge-Aggregation3] quit

# 创建接口Vlan-interface102,并配置其IPv4和IPv6地址,作为双活网关。

[DeviceB] interface vlan-interface 102

[DeviceB-Vlan-interface102] ip address 10.102.0.1 24

[DeviceB-Vlan-interface102] ipv6 address 10:102::1 64

# 配置M-LAG虚拟IPv4和IPv6地址,以便和下行设备Device D建立OSPF和OSPFv3邻居关系。

[DeviceB-Vlan-interface102] port m-lag virtual-ip 10.102.0.4 24 active

[DeviceB-Vlan-interface102] port m-lag ipv6 virtual-ip FE80::4 link-local

# 配置接口Vlan-interface102的MAC地址。

[DeviceB-Vlan-interface102] mac-address 3-3-3

[DeviceB-Vlan-interface102] quit

# 配置Vlan-interface102接口为M-LAG保留接口。

[DeviceB] m-lag mad exclude interface vlan-interface 102

# 创建接口Vlan-interface103,并配置其IPv4和IPv6地址,作为双活网关。

[DeviceB] interface vlan-interface 103

[DeviceB-Vlan-interface103] ip address 10.103.0.1 24

[DeviceB-Vlan-interface103] ipv6 address 10:103::1 64

# 配置M-LAG虚拟IPv4和IPv6地址,以便和下行设备Device D建立BGP和BGP4+邻居关系。

[DeviceB-Vlan-interface103] port m-lag virtual-ip 10.103.0.4 24 active

[DeviceB-Vlan-interface103] port m-lag ipv6 virtual-ip 10:103::4 64 active

# 配置接口Vlan-interface103的MAC地址。

[DeviceB-Vlan-interface103] mac-address 4-4-4

[DeviceB-Vlan-interface103] quit

# 配置Vlan-interface103接口为M-LAG保留接口。

[DeviceB] m-lag mad exclude interface vlan-interface 103

# 配置上行口Ten-GigabitEthernet1/0/6的IPv4地址和IPv6地址。

[DeviceB] interface ten-gigabitethernet 1/0/6

[DeviceB-Ten-GigabitEthernet1/0/6] port link-mode route

[DeviceB-Ten-GigabitEthernet1/0/6] ip address 33.1.1.1 24

[DeviceB-Ten-GigabitEthernet1/0/6] ipv6 address 33:1::1 64

[DeviceB-Ten-GigabitEthernet1/0/6] quit

# 配置OSPF。

[DeviceB] ospf 1 router-id 11.1.1.2

[DeviceB-ospf-1] area 0

[DeviceB-ospf-1-area-0.0.0.0] quit

[DeviceB-ospf-1] quit

[DeviceB] interface vlan-interface 102

[DeviceB-Vlan-interface102] ospf 1 area 0

[DeviceB-Vlan-interface102] ospf peer sub-address enable 10.102.0.4

[DeviceB-Vlan-interface102] quit

[DeviceB] interface ten-gigabitethernet 1/0/6

[DeviceB-Ten-GigabitEthernet1/0/6] ospf 1 area 0

[DeviceB-Ten-GigabitEthernet1/0/6] quit

# 配置OSPFv3。

[DeviceB] ospfv3 1

[DeviceB-ospfv3-1] router-id 10.1.1.2

[DeviceB-ospfv3-1] area 0

[DeviceB-ospfv3-1-area-0.0.0.0] quit

[DeviceB-ospfv3-1] quit

[DeviceB] interface vlan-interface 102

[DeviceB-Vlan-interface102] ospfv3 1 area 0

[DeviceB-Vlan-interface102] quit

[DeviceB] interface ten-gigabitethernet 1/0/6

[DeviceB-Ten-GigabitEthernet1/0/6] ospfv3 1 area 0

[DeviceB-Ten-GigabitEthernet1/0/6] quit

# 配置BGP。

[DeviceB] bgp 100

[DeviceB-bgp-default] router-id 12.1.1.2

[DeviceB-bgp-default] peer 33.1.1.2 as-number 100

[DeviceB-bgp-default] peer 10.103.0.2 as-number 100

[DeviceB-bgp-default] peer 10.103.0.2 source-address 10.103.0.4

[DeviceB-bgp-default] address-family ipv4

[DeviceB-bgp-default-ipv4] peer 10.103.0.2 enable

[DeviceB-bgp-default-ipv4] network 10.103.0.0  255.255.255.0

[DeviceB-bgp-default-ipv4] peer 33.1.1.2 enable

[DeviceB-bgp-default-ipv4] network 33.1.1.0 255.255.255.0

[DeviceB-bgp-default-ipv4] quit

# 配置BGP4+。

[DeviceB-bgp-default] peer 33:1::2 as-number 100

[DeviceB-bgp-default] peer 10:103::2 as-number 100

[DeviceB-bgp-default] peer 10:103::2 source-address 10:103::4

[DeviceB-bgp-default] address-family ipv6

[DeviceB-bgp-default-ipv6] peer 10:103::2 enable

[DeviceB-bgp-default-ipv6] network 10:103::2  64

[DeviceB-bgp-default-ipv6] peer 33:1::2 enable

[DeviceB-bgp-default-ipv6] network  33:1::2 64

[DeviceB-bgp-default-ipv6] quit

[DeviceB-bgp-default] quit

(3)     配置Device C

# 配置接口Ten-GigabitEthernet1/0/1和Ten-GigabitEthernet1/0/2的IPv4地址和IPv6地址。

[DeviceC] interface ten-gigabitethernet 1/0/1

[DeviceC-Ten-GigabitEthernet1/0/1] port link-mode route

[DeviceC-Ten-GigabitEthernet1/0/1] ip address 32.1.1.2 24

[DeviceC-Ten-GigabitEthernet1/0/1] ipv6 address 32:1::2 64

[DeviceC-Ten-GigabitEthernet1/0/1] quit

[DeviceC] interface ten-gigabitethernet 1/0/2

[DeviceC-Ten-GigabitEthernet1/0/2] port link-mode route

[DeviceC-Ten-GigabitEthernet1/0/2] ip address 33.1.1.2 24

[DeviceC-Ten-GigabitEthernet1/0/2] ipv6 address 33:1::2 64

[DeviceC-Ten-GigabitEthernet1/0/2] quit

# 配置OSPF。

[DeviceC] ospf 1 router-id 11.1.1.3

[DeviceC-ospf-1] area 0

[DeviceC-ospf-1-area-0.0.0.0] quit

[DeviceC-ospf-1] quit

[DeviceC] interface ten-gigabitethernet 1/0/1

[DeviceC-Ten-GigabitEthernet1/0/1] ospf 1 area 0

[DeviceC-Ten-GigabitEthernet1/0/1] quit

[DeviceC] interface ten-gigabitethernet 1/0/2

[DeviceC-Ten-GigabitEthernet1/0/2] ospf 1 area 0

[DeviceC-Ten-GigabitEthernet1/0/2] quit

# 配置OSPFv3。

[DeviceC] ospfv3 1

[DeviceC-ospfv3-1] router-id 10.1.1.3

[DeviceC-ospfv3-1] area 0

[DeviceC-ospfv3-1-area-0.0.0.0] quit

[DeviceC-ospfv3-1] quit

[DeviceC] interface ten-gigabitethernet 1/0/1

[DeviceC-Ten-GigabitEthernet1/0/1] ospfv3 1 area 0

[DeviceC-Ten-GigabitEthernet1/0/1] quit

[DeviceC] interface ten-gigabitethernet 1/0/2

[DeviceC-Ten-GigabitEthernet1/0/2] ospfv3 1 area 0

[DeviceC-Ten-GigabitEthernet1/0/2] quit

# 配置BGP。

[DeviceC] bgp 100

[DeviceC-bgp-default] router-id 12.1.1.3

[DeviceC-bgp-default] peer 33.1.1.1 as-number 100

[DeviceC-bgp-default] peer 32.1.1.1 as-number 100

[DeviceC-bgp-default] address-family ipv4

[DeviceC-bgp-default-ipv4] peer 33.1.1.1 enable

[DeviceC-bgp-default-ipv4] network 33.1.1.0  255.255.255.0

[DeviceC-bgp-default-ipv4] peer 32.1.1.1 enable

[DeviceC-bgp-default-ipv4] network 32.1.1.0 255.255.255.0

[DeviceC-bgp-default-ipv4] quit

# 配置BGP4+。

[DeviceC-bgp-default] peer 33:1::1 as-number 100

[DeviceC-bgp-default] peer 32:1::1 as-number 100

[DeviceC-bgp-default] address-family ipv6

[DeviceC-bgp-default-ipv6] peer 32:1::1 enable

[DeviceC-bgp-default-ipv6] peer 33:1::1 enable

[DeviceC-bgp-default-ipv6] network 32:1:: 64

[DeviceC-bgp-default-ipv6] network 33:1:: 64

[DeviceC-bgp-default-ipv6] quit

[DeviceC-bgp-default] quit

(4)     配置Device D

# 创建VLAN 102、VLAN 103。

<DeviceD> system-view

[DeviceD] vlan 102 103

# 创建二层聚合接口3,并配置该接口为动态聚合模式。

[DeviceD] interface bridge-aggregation 3

[DeviceD-Bridge-Aggregation3] link-aggregation mode dynamic

[DeviceD-Bridge-Aggregation3] quit

# 将端口Ten-GigabitEthernet1/0/1~Ten-GigabitEthernet1/0/4加入到聚合组3中。

[DeviceD] interface range ten-gigabitethernet 1/0/1 to ten-gigabitethernet 1/0/4

[DeviceD-if-range] port link-aggregation group 3

[DeviceD-if-range] quit

# 配置二层聚合接口3为Trunk端口,并允许VLAN 102和VLAN 103的报文通过。

[DeviceD] interface bridge-aggregation 3

[DeviceD-Bridge-Aggregation3] port link-type trunk

[DeviceD-Bridge-Aggregation3] port trunk permit vlan 102 103

[DeviceD-Bridge-Aggregation3] quit

# 创建接口Vlan-interface102,并配置其IPv4和IPv6地址。

[DeviceD] interface vlan-interface 102

[DeviceD-Vlan-interface102] ip address 10.102.0.2 24

[DeviceD-Vlan-interface102] ipv6 address 10:102::2 64

[DeviceD-Vlan-interface102] quit

# 创建接口Vlan-interface103,并配置其IPv4和IPv6地址。

[DeviceD] interface vlan-interface 103

[DeviceD-Vlan-interface103] ip address 10.103.0.2 24

[DeviceD-Vlan-interface103] ipv6 address 10:103::2 64

[DeviceD-Vlan-interface103] quit

# 配置OSPF。

[DeviceD] ospf 1 router-id 11.1.1.4

[DeviceD-ospf-1] area 0

[DeviceD-ospf-1-area-0.0.0.0] quit

[DeviceD-ospf-1] quit

[DeviceD] interface vlan-interface 102

[DeviceD-Vlan-interface102] ospf 1 area 0

[DeviceD-Vlan-interface102] quit

[DeviceD] interface vlan-interface 103

[DeviceD-Vlan-interface103] ospf 1 area 0

[DeviceD-Vlan-interface103] quit

# 配置OSPFv3。

[DeviceD] ospfv3 1

[DeviceD-ospfv3-1] router-id 10.1.1.4

[DeviceD-ospfv3-1] area 0

[DeviceD-ospfv3-1-area-0.0.0.0] quit

[DeviceD-ospfv3-1] quit

[DeviceD] interface vlan-interface 102

[DeviceD-Vlan-interface102] ospfv3 1 area 0

[DeviceD-Vlan-interface102] quit

[DeviceD] interface vlan-interface 103

[DeviceD-Vlan-interface103] ospfv3 1 area 0

[DeviceD-Vlan-interface103] quit

# 配置BGP。

[DeviceD] bgp 100

[DeviceD-bgp-default] router-id 12.1.1.4

[DeviceD-bgp-default] peer 10.103.0.3 as-number 100

[DeviceD-bgp-default] peer 10.103.0.4 as-number 100

[DeviceD-bgp-default] address-family ipv4

[DeviceD-bgp-default-ipv4] peer 10.103.0.3 enable

[DeviceD-bgp-default-ipv4] peer 10.103.0.4 enable

[DeviceD-bgp-default-ipv4] network 10.103.0.3  255.255.255.0

[DeviceD-bgp-default-ipv4] quit

# 配置BGP4+。

[DeviceD-bgp-default] peer 10:103::3 as-number 100

[DeviceD-bgp-default] peer 10:103::4 as-number 100

[DeviceD-bgp-default] address-family ipv6

[DeviceD-bgp-default-ipv6] peer 10:103::3 enable

[DeviceD-bgp-default-ipv6] peer 10:103::4 enable

[DeviceD-bgp-default-ipv6] network 10:103::3 64

[DeviceD-bgp-default-ipv6] quit

[DeviceD-bgp-default] quit

5. 验证配置

# 查看M-LAG的简要信息和详细信息,可以看到M-LAG系统正常工作,以Device A为例。

[DeviceA] display m-lag summary

Flags: A -- Aggregate interface down, B -- No peer M-LAG interface configured

       C -- Configuration consistency check failed

 

Peer-link interface: BAGG1

Peer-link interface state (cause): UP

Keepalive link state (cause): UP

 

                     M-LAG interface information

M-LAG IF    M-LAG group  Local state (cause)  Peer state  Remaining down time(s)

BAGG3       1            UP                   UP          -

[DeviceA] display m-lag verbose

Flags: A -- Home_Gateway, B -- Neighbor_Gateway, C -- Other_Gateway,

       D -- PeerLink_Activity, E -- DRCP_Timeout, F -- Gateway_Sync,

       G -- Port_Sync, H -- Expired

 

Peer-link interface/Peer-link interface ID: BAGG1/1

State: UP

Cause: -

Local DRCP flags/Peer DRCP flags: ABDFG/ABDFG

Local Selected ports (index): XGE1/0/3 (260), XGE1/0/4 (261)

Peer Selected ports indexes: 260, 261

 

M-LAG interface/M-LAG group ID: BAGG3/1

Local M-LAG interface state: UP

Peer M-LAG interface state: UP

M-LAG group state: UP

Local M-LAG interface down cause: -

Remaining M-LAG DOWN time: -

Local M-LAG interface LACP MAC: COnfig=N/A, Effective=0002-0002-0002

Peer M-LAG interface LACP MAC: COnfig=N/A, Effective=0002-0002-0002

Local M-LAG interface LACP priority: COnfig=32768, Effective=123

Peer M-LAG interface LACP priority: COnfig=32768, Effective=123

Local DRCP flags/Peer DRCP flags: ABDFG/ABDFG

Local Selected ports (index): XGE1/0/1 (258), XGE1/0/2 (259)

Peer Selected ports indexes: 258, 259

# 查看设备上的OSPF邻居信息,可以看到OSPF中各邻居的信息,以Device A为例。

[DeviceA] display ospf peer

 

         OSPF Process 1 with Router ID 11.1.1.1

               Neighbor Brief Information

 

 Area: 0.0.0.0

 Router ID       Address         Pri Dead-Time  State             Interface

 11.1.1.3        32.1.1.2        1   39         Full/BDR          XGE1/0/6

 11.1.1.4        10.102.0.2      1   31         Full/DROther      Vlan102

 11.1.1.2        10.102.0.4      1   37         Full/DR           Vlan102

# 查看设备上的OSPFv3邻居信息,可以看到OSPFv3中各邻居的信息,以Device A为例。

[DeviceA] display ospfv3 peer

 

               OSPFv3 Process 1 with Router ID 10.1.1.1

 

 Area: 0.0.0.0

-------------------------------------------------------------------------

 Router ID       Pri State             Dead-Time InstID Interface

 10.1.1.3        1   Full/BDR          00:00:34  0      XGE1/0/6

 10.1.1.2        1   Full/BDR          00:00:32  0      Vlan102

 10.1.1.4        1   Full/DROther      00:00:39  0      Vlan102

# 查看设备上的BGP邻居信息,可以看到BGP中各邻居的信息,以Device A为例。

[DeviceA] display bgp peer ipv4

 

 BGP local router ID: 12.1.1.1

 Local AS number: 100

 Total number of peers: 2                 Peers in established state: 2

 

  * - Dynamically created peer

  ^ - Peer created through link-local address

  Peer                    AS  MsgRcvd  MsgSent OutQ PrefRcv Up/Down  State

 

  10.103.0.2             100        6        6    0       1 00:01:50 Established

  32.1.1.2               100        5        5    0       2 00:00:01 Established

# 查看设备上的BGP4+邻居信息,可以看到BGP4+中各邻居的信息,以Device A为例。

[DeviceA] display bgp peer ipv6

 

 BGP local router ID: 12.1.1.1

 Local AS number: 100

 Total number of peers: 2                 Peers in established state: 2

 

  * - Dynamically created peer

  ^ - Peer created through link-local address

  Peer                    AS  MsgRcvd  MsgSent OutQ PrefRcv Up/Down  State

 

  10:103::2              100        9        9    0       1 00:04:26 Established

  32:1::2                100        6        6    0       2 00:02:13 Established

暂无评论

编辑答案

你正在编辑答案

如果你要对问题或其他回答进行点评或询问,请使用评论功能。

分享扩散:

提出建议

    +

亲~登录后才可以操作哦!

确定

亲~检测到您登陆的账号未在http://hclhub.h3c.com进行注册

注册后可访问此模块

跳转hclhub

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作

举报

×

侵犯我的权益 >
对根叔社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明