• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 全部
  • 全部
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
高级搜索

L2TP VPN典型组网配置案例3(远程系统通过PPPOE拨号后再进行L2TP VPN拨号)

2020-02-08 发表
  • 0关注
  • 4收藏,461浏览
粉丝:157人 关注:0人

组网及说明


本案例采用H3C HCL模拟器来模拟L2TP VPN远程系统两次拨号来访问LNS私网的组网。内网和外网在网络拓扑图已经有了明确的标识,内网1R1作为本内网的PPPOE拨号服务器,内网1的终端首先需要通过PPPOE宽带拨号来接入网络。内网2R2作为L2TP VPNLNS端点,内网1的终端完成PPPOE拨号后,再作为LAC端进行再次的拨号,才能穿越NAT和公网到达LNS内部。

配置步骤

1、按照网络拓扑图正确配置IP地址

2、R1配置NAT地址转换,并配置默认路由指向外网

3、R1开启PPPOE功能,为内网1终端的接入提供基础

4、R2配置NAT地址转换,并配置默认路由指向外网

5、R2配置L2TP VPN,作为LNS端点,为LAC的接入提供VPN的承载

6、在建立L2TP VPN隧道前,内网1和内网2的终端不能互通。

7、在建立L2TP VPN隧道后,内网1和内网2的终端可以互通。

配置关键点

1、第一阶段调试(基础网络配置):

R1

<H3C>sys

System View: return to User View with Ctrl+Z.

[H3C]sysname R1

[R1]local-user ninglihua class network

New local user added.

[R1-luser-network-ninglihua]password simple ninglihua

[R1-luser-network-ninglihua]service-type ppp

[R1-luser-network-ninglihua]quit

[R1]domain name system

[R1-isp-system]authentication ppp local

[R1-isp-system]quit

[R1]ip pool ninglihua 192.168.10.2 192.168.10.100

[R1]ip pool ninglihua gateway 192.168.10.1

[R1]int Virtual-Template 1

[R1-Virtual-Template1]ip address 192.168.10.1 255.255.255.0

[R1-Virtual-Template1]ppp authentication pap domain system

[R1-Virtual-Template1]remote address pool ninglihua

[R1-Virtual-Template1]quit

[R1]int gi 0/0

[R1-GigabitEthernet0/0]pppoe-server bind virtual-template 1

[R1-GigabitEthernet0/0]quit

 

[R1]int gi 0/1

[R1-GigabitEthernet0/1]des <connect to ISP>

[R1-GigabitEthernet0/1]ip address 202.1.100.2 30

[R1-GigabitEthernet0/1]nat outbound

[R1-GigabitEthernet0/1]quit

[R1]ip route-static 0.0.0.0 0.0.0.0 202.1.100.1

 

ISP

<H3C>sys

System View: return to User View with Ctrl+Z.

[H3C]sysname ISP

[ISP]int gi 0/0

[ISP-GigabitEthernet0/0]des <connect to R1>

[ISP-GigabitEthernet0/0]ip address 202.1.100.1 30

[ISP-GigabitEthernet0/0]quit

[ISP]int gi 0/1

[ISP-GigabitEthernet0/1]des <connect to R2>

[ISP-GigabitEthernet0/1]ip address 202.2.100.1 30

[ISP-GigabitEthernet0/1]quit

 

R2

<H3C>sys

System View: return to User View with Ctrl+Z.

[H3C]sysname R2

[R2]vlan 100

[R2-vlan100]quit

[R2]int vlan 100

[R2-Vlan-interface100]ip address 172.16.100.1 24

[R2-Vlan-interface100]quit

[R2]int gi 0/0

[R2-GigabitEthernet0/0]port link-mode bridge

[R2-GigabitEthernet0/0]port link-type access

[R2-GigabitEthernet0/0]port access vlan 100

[R2-GigabitEthernet0/0]quit

[R2]acl basic 2000

[R2-acl-ipv4-basic-2000]rule 0 permit source any

[R2-acl-ipv4-basic-2000]quit

[R2]int gi 0/1

[R2-GigabitEthernet0/1]des <connect to ISP>

[R2-GigabitEthernet0/1]ip address 202.2.100.2 30

[R2-GigabitEthernet0/1]nat outbound 2000

[R2-GigabitEthernet0/1]quit

[R2]ip route-static 0.0.0.0 0.0.0.0 202.2.100.1

 

第一阶段测试:

内网1终端进行宽带PPPOE拨号:





内网2终端填写IP地址:



内网1终端能PING通内网2的外网地址,PING不同内网2的私网地址:



内网2终端能PING通内网1的外网地址,PING不同内网1的私网地址:



2、第二阶段配置

L2TP VPN LNS关键配置点:

[R2]local-user weijianing class network

New local user added.

[R2-luser-network-weijianing]password simple weijianing

[R2-luser-network-weijianing]service-type ppp

[R2-luser-network-weijianing]quit

[R2]domain name system

[R2-isp-system]authentication ppp local

[R2-isp-system]quit

[R2]ip pool weijianing 172.16.200.2 172.16.200.254

[R2]ip pool weijianing gateway 172.16.200.1

 

[R2]int Virtual-Template 1

[R2-Virtual-Template1]ip address 172.16.200.1 255.255.255.0

[R2-Virtual-Template1]ppp authentication chap domain system

[R2-Virtual-Template1]remote address pool weijianing

[R2-Virtual-Template1]quit

 

[R2]l2tp enable

[R2]l2tp-group 1 mode lns

[R2-l2tp1]tunnel name LNS

[R2-l2tp1]undo tunnel authentication

[R2-l2tp1]allow l2tp virtual-template 1

[R2-l2tp1]quit

 

内网1的终端设置VPN拨号:





输入用户名、密码,点击连接:



VPN拨号连接成功:




内网1终端能PING内网2的终端:




内网2的终端也可以PING通内网1的终端:

由于内网1的终端拨号过来后,LNS为其分配了IP地址,因此内网2终端PING的是分配后的IP地址,根据内网1拨号后获取的IP地址为172.16.200.3,所以内网2的终端PING的是172.16.200.3


当前内网1的终端是经过了PPPOE宽带拨号后再进行L2TP VPN拨号来实现两次拨号来访问L2TP VPN的私网



至此,L2TP典型组网配置3已完成!

0 个评论

该案例暂时没有网友评论

编辑评论

举报

×

侵犯我的权益 >
对根叔知了社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔知了社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明

提出建议

    +
<

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作