• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 全部
  • 全部
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
高级搜索

S5820 IPV6 BGP4+ RR二级路由反射器典型组网配置案例

2020-04-11 发表
  • 0关注
  • 7收藏,195浏览
粉丝:152人 关注:0人

组网及说明


组网说明:

本案例采用H3C HCL模拟器的S5820交换机来模拟ipv6 BGP RR二级路由反射器的典型组网配置。其中SW1SW2SW3属于AS100SW4属于AS200,由于SW1SW2SW4没有互联,同时又想实现业务地址之间的互通,因此需要使用BGP RR二级路由反射器来实现。SW2SW1的一级RR反射,SW3SW2的二级反射。SW1SW2SW2SW3建立IBGP邻居关系,为了SW1SW2SW2SW3建立IBGP邻居关系及RR路由反射,因此SW1SW2SW3之间建立OSPFv3邻居关系来进行承载。最后SW3SW4建立EBGP邻居关系。

 

IP地址规划:

设备名称

VLAN\接口

IP地址

子网掩码/地址前缀

备注

SW1

Loopback 10

8::1

64

模拟业务

GI 1/0/2

1::1

64

 

Loopback 0

1.1.1.1

64

Router-id

Loopback 1

4::1

64

Ipv6 Router-id

SW2

GI 1/0/2

1::2

64

 

GI 1/0/1

2::1

64

 

Loopback 0

2.2.2.2

64

Router-id

Loopback 1

5::1

64

Ipv6 Router-id

SW3

GI 1/0/1

2::2

64

 

GI 1/0/2

3::1

64

 

Loopback 0

3.3.3.3

64

Router-id

Loopback 1

6::1

64

Ipv6 Router-id

SW4

Loopback 100

9::1

64

模拟业务

GI 1/0/2

3::2

64

 

Loopback 0

4.4.4.4

64

Router-id

Loopback 1

7::1

64

Ipv6 Router-id


配置步骤

SW1

sys

System View: return to User View with Ctrl+Z.

[H3C]sysname SW1

[SW1]int loopback 0

[SW1-LoopBack0]ip address 1.1.1.1 32

[SW1-LoopBack0]quit

[SW1]int loopback 1

[SW1-LoopBack1]ipv6 address 4::1 64

[SW1-LoopBack1]quit

[SW1]int loopback 10

[SW1-LoopBack10]ipv6 address 8::1 64

[SW1-LoopBack10]quit

[SW1]int gi 1/0/2

[SW1-GigabitEthernet1/0/2]port link-mode route

[SW1-GigabitEthernet1/0/2]des

[SW1-GigabitEthernet1/0/2]ipv6 address 1::1 64

[SW1-GigabitEthernet1/0/2]quit

[SW1]ospfv3 1

[SW1-ospfv3-1]router-id 1.1.1.1

[SW1-ospfv3-1]quit

[SW1]int gi 1/0/2

[SW1-GigabitEthernet1/0/2]ospfv3 1 area 0

[SW1-GigabitEthernet1/0/2]quit

[SW1]int loopback 1

[SW1-LoopBack1]ospfv3 1 area 0

[SW1-LoopBack1]quit

[SW1]bgp 100

[SW1-bgp-default]router-id 1.1.1.1

[SW1-bgp-default]peer 5::1 as-number 100

[SW1-bgp-default]peer 5::1 connect-interface LoopBack 1

[SW1-bgp-default]address-family ipv6 unicast

[SW1-bgp-default-ipv6]peer 5::1 enable

[SW1-bgp-default-ipv6]network 8:: 64

[SW1-bgp-default-ipv6]quit

[SW1-bgp-default]quit

 

SW2

sys

System View: return to User View with Ctrl+Z.

[H3C]sysname SW2

[SW2]int loopback 0

[SW2-LoopBack0]ip address 2.2.2.2 32

[SW2-LoopBack0]quit

[SW2]int loopback 1

[SW2-LoopBack1]ipv6 address 5::1 64

[SW2-LoopBack1]quit

[SW2]int gi 1/0/2

[SW2-GigabitEthernet1/0/2]port link-mode route

[SW2-GigabitEthernet1/0/2]des

[SW2-GigabitEthernet1/0/2]ipv6 address 1::2 64

[SW2-GigabitEthernet1/0/2]quit

[SW2]int gi 1/0/1

[SW2-GigabitEthernet1/0/1]port link-mode route

[SW2-GigabitEthernet1/0/1]des

[SW2-GigabitEthernet1/0/1]ipv6 address 2::1 64

[SW2-GigabitEthernet1/0/1]quit

[SW2]ospfv3 1

[SW2-ospfv3-1]router-id 2.2.2.2

[SW2-ospfv3-1]quit

[SW2]int loopback 1

[SW2-LoopBack1]ospfv3 1 area 0

[SW2-LoopBack1]quit

[SW2]int gi 1/0/1

[SW2-GigabitEthernet1/0/1]ospfv3 1 area 0

[SW2-GigabitEthernet1/0/1]quit

[SW2]int gi 1/0/2

[SW2-GigabitEthernet1/0/2]ospfv3 1 area 0

[SW2-GigabitEthernet1/0/2]quit

[SW2]bgp 100

[SW2-bgp-default]router-id 2.2.2.2

[SW2-bgp-default]peer 6::1 as-number 100

[SW2-bgp-default]peer 4::1 as-number 100

[SW2-bgp-default]peer 6::1 connect-interface LoopBack 1

[SW2-bgp-default]peer 4::1 connect-interface LoopBack 1

[SW2-bgp-default]address-family ipv6 unicast

[SW2-bgp-default-ipv6]peer 6::1 enable

[SW2-bgp-default-ipv6]peer 4::1 enable

[SW2-bgp-default-ipv6]peer 4::1 reflect-client  //指向4::1RR反射器的客户端

[SW2-bgp-default-ipv6]quit

[SW2-bgp-default]quit

 

SW3

sys

System View: return to User View with Ctrl+Z.

[H3C]sysname SW3

[SW3]int loopback 0

[SW3-LoopBack0]ip address 3.3.3.3 32

[SW3-LoopBack0]quit

[SW3]int loopback 1

[SW3-LoopBack1]ipv6 address 6::1 64

[SW3-LoopBack1]quit

[SW3]int gi 1/0/1

[SW3-GigabitEthernet1/0/1]port link-mode route

[SW3-GigabitEthernet1/0/1]des

[SW3-GigabitEthernet1/0/1]ipv6 address 2::2 64

[SW3-GigabitEthernet1/0/1]quit

[SW3]int gi 1/0/2

[SW3-GigabitEthernet1/0/2]port link-mode route

[SW3-GigabitEthernet1/0/2]des

[SW3-GigabitEthernet1/0/2]ipv6 address 3::1 64

[SW3-GigabitEthernet1/0/2]quit

[SW3]ospfv3 1

[SW3-ospfv3-1]router-id 3.3.3.3

[SW3-ospfv3-1]quit

[SW3]int loopback 1

[SW3-LoopBack1]ospfv3 1 area 0

[SW3-LoopBack1]quit

[SW3]int gi 1/0/2

[SW3-GigabitEthernet1/0/2]ospfv3 1 area 0

[SW3-GigabitEthernet1/0/2]quit

[SW3]int gi 1/0/1

[SW3-GigabitEthernet1/0/1]ospfv3 1 area 0

[SW3-GigabitEthernet1/0/1]quit

[SW3]bgp 100

[SW3-bgp-default]router-id 3.3.3.3

[SW3-bgp-default]peer 5::1 as-number 100

[SW3-bgp-default]peer 5::1 connect-interface LoopBack 1

[SW3-bgp-default]peer 3::2 as-number 200

[SW3-bgp-default]address-family ipv6 unicast

[SW3-bgp-default-ipv6]peer 3::2 enable

[SW3-bgp-default-ipv6]peer 5::1 enable

[SW3-bgp-default-ipv6]peer 5::1 reflect-client  //指向5::1RR路由反射器的客户端

[SW3-bgp-default-ipv6]quit

[SW3-bgp-default]quit

 

 

SW4

sys

System View: return to User View with Ctrl+Z.

[H3C]sysname SW4

[SW4]int loopback 0

[SW4-LoopBack0]ip address 4.4.4.4 32

[SW4-LoopBack0]quit

[SW4]int loopback 1

[SW4-LoopBack1]ipv6 address 7::1 64

[SW4-LoopBack1]quit

[SW4]int loopback 100

[SW4-LoopBack100]ipv6 address 9::1 64

[SW4-LoopBack100]quit

[SW4]int gi 1/0/2

[SW4-GigabitEthernet1/0/2]port link-mode route

[SW4-GigabitEthernet1/0/2]des

[SW4-GigabitEthernet1/0/2]ipv6 address 3::2 64

[SW4-GigabitEthernet1/0/2]quit

[SW4]bgp 200

[SW4-bgp-default]router-id 4.4.4.4

[SW4-bgp-default]peer 3::1 as-number 100

[SW4-bgp-default]address-family ipv6 unicast

[SW4-bgp-default-ipv6]peer 3::1 enable

[SW4-bgp-default-ipv6]network 9:: 64

[SW4-bgp-default-ipv6]quit

[SW4-bgp-default]quit

 

测试:

SW1loopback 10能与SW4loopback 100互通:





分别查看SW1SW2SW3OSPFV3邻居信息:







分别查看SW1SW2SW3SW4BGP4+邻居信息:









分别查看SW1SW2SW3SW4IPV6路由表:

[SW1]dis ipv6 routing-table

 

Destinations : 14       Routes : 14

 

Destination: ::1/128                                     Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 1::/64                                      Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : GE1/0/2                                     Cost      : 0

 

Destination: 1::1/128                                    Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 2::/64                                      Protocol  : O_INTRA

NextHop    : FE80::2ADE:8EFF:FE3C:307                    Preference: 10

Interface  : GE1/0/2                                     Cost      : 2

 

Destination: 3::/64                                      Protocol  : O_INTRA

NextHop    : FE80::2ADE:8EFF:FE3C:307                    Preference: 10

Interface  : GE1/0/2                                     Cost      : 3

 

Destination: 4::/64                                      Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : Loop1                                       Cost      : 0

 

Destination: 4::1/128                                    Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 5::1/128                                    Protocol  : O_INTRA

NextHop    : FE80::2ADE:8EFF:FE3C:307                    Preference: 10

Interface  : GE1/0/2                                     Cost      : 1

 

Destination: 6::1/128                                    Protocol  : O_INTRA

NextHop    : FE80::2ADE:8EFF:FE3C:307                    Preference: 10

Interface  : GE1/0/2                                     Cost      : 2

 

Destination: 8::/64                                      Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : Loop10                                      Cost      : 0

 

Destination: 8::1/128                                    Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 9::/64                                      Protocol  : BGP4+

NextHop    : 3::2                                        Preference: 255

Interface  : GE1/0/2                                     Cost      : 0

 

Destination: FE80::/10                                   Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: FF00::/8                                    Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : NULL0                                       Cost      : 0

[SW1]

 

[SW2]dis ipv6 routing-table

 

Destinations : 14       Routes : 14

 

Destination: ::1/128                                     Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 1::/64                                      Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : GE1/0/2                                     Cost      : 0

 

Destination: 1::2/128                                    Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 2::/64                                      Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : GE1/0/1                                     Cost      : 0

 

Destination: 2::1/128                                    Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 3::/64                                      Protocol  : O_INTRA

NextHop    : FE80::2ADE:87FF:FE8D:206                    Preference: 10

Interface  : GE1/0/1                                     Cost      : 2

 

Destination: 4::1/128                                    Protocol  : O_INTRA

NextHop    : FE80::2ADE:92FF:FED6:407                    Preference: 10

Interface  : GE1/0/2                                     Cost      : 1

 

Destination: 5::/64                                      Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : Loop1                                       Cost      : 0

 

Destination: 5::1/128                                    Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 6::1/128                                    Protocol  : O_INTRA

NextHop    : FE80::2ADE:87FF:FE8D:206                    Preference: 10

Interface  : GE1/0/1                                     Cost      : 1

 

Destination: 8::/64                                      Protocol  : BGP4+

NextHop    : 4::1                                        Preference: 255

Interface  : GE1/0/2                                     Cost      : 0

 

Destination: 9::/64                                      Protocol  : BGP4+

NextHop    : 3::2                                        Preference: 255

Interface  : GE1/0/1                                     Cost      : 0

 

Destination: FE80::/10                                   Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: FF00::/8                                    Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : NULL0                                       Cost      : 0

[SW2]

 

[SW3]dis ipv6 routing-table

 

Destinations : 14       Routes : 14

 

Destination: ::1/128                                     Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 1::/64                                      Protocol  : O_INTRA

NextHop    : FE80::2ADE:8EFF:FE3C:306                    Preference: 10

Interface  : GE1/0/1                                     Cost      : 2

 

Destination: 2::/64                                      Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : GE1/0/1                                     Cost      : 0

 

Destination: 2::2/128                                    Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 3::/64                                      Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : GE1/0/2                                     Cost      : 0

 

Destination: 3::1/128                                    Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 4::1/128                                    Protocol  : O_INTRA

NextHop    : FE80::2ADE:8EFF:FE3C:306                    Preference: 10

Interface  : GE1/0/1                                     Cost      : 2

 

Destination: 5::1/128                                    Protocol  : O_INTRA

NextHop    : FE80::2ADE:8EFF:FE3C:306                    Preference: 10

Interface  : GE1/0/1                                     Cost      : 1

 

Destination: 6::/64                                      Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : Loop1                                       Cost      : 0

 

Destination: 6::1/128                                    Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 8::/64                                      Protocol  : BGP4+

NextHop    : 4::1                                        Preference: 255

Interface  : GE1/0/1                                     Cost      : 0

 

Destination: 9::/64                                      Protocol  : BGP4+

NextHop    : 3::2                                        Preference: 255

Interface  : GE1/0/2                                     Cost      : 0

 

Destination: FE80::/10                                   Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: FF00::/8                                    Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : NULL0                                       Cost      : 0

[SW3]

 

[SW4]dis ipv6 routing-table

 

Destinations : 10       Routes : 10

 

Destination: ::1/128                                     Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 3::/64                                      Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : GE1/0/2                                     Cost      : 0

 

Destination: 3::2/128                                    Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 7::/64                                      Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : Loop1                                       Cost      : 0

 

Destination: 7::1/128                                    Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 8::/64                                      Protocol  : BGP4+

NextHop    : 3::1                                        Preference: 255

Interface  : GE1/0/2                                     Cost      : 0

 

Destination: 9::/64                                      Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : Loop100                                     Cost      : 0

 

Destination: 9::1/128                                    Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: FE80::/10                                   Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: FF00::/8                                    Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : NULL0                                       Cost      : 0

[SW4]

 

至此,S5820 IPV6 BGP4+ RR二级路由反射器典型组网配置案例已完成!




配置关键点


0 个评论

该案例暂时没有网友评论

编辑评论

举报

×

侵犯我的权益 >
对根叔知了社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔知了社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明

提出建议

    +
<

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作