• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 漏洞说明
  • 全部
  • 全部
  • 大数据引擎
  • 知了引擎
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
搜索引擎
匹配模式
高级搜索

S5820 IPV6 MPLS VPN OPTION-A典型组网配置案例

2020-04-05 发表
  • 0关注
  • 0收藏 717浏览
粉丝:79人 关注:0人

组网及说明


组网说明:

本案例采用H3C HCL模拟器的S5820交换机来模拟IPV6 MPLS VPN OPTION-A典型组网配置。为了实现业务的相互隔离,需要将不同的业务绑定到不同的VPN实例中进行业务的互通,因此在本案例引入多实例VPN,将相关的业务进行捆绑。SW1SW2的互联使用trunk,允许VLAN 400 VLAN 500通过,其中SW1属于AS100,SW2属于AS200,最终建立多VPN实例EBGP邻居关系,宣告业务网段,使得相同VPN实例的业务能互通,不同VPN实例的业务不能互通。

 

VPN实例规划如下:

VPN实例名称

RD

RT

业务类型

备注

vpn-rt

100:1

100:1

实时业务

 

vpn-nrt

200:1

200:1

非实时业务

 

 

 

 

 

 

 

IP地址规划如下:

设备名称

接口/VLAN

IPV4/IPV6地址

IPV4/IPV6地址位数

所属VPN实例

备注

SW1

VLAN 400

1::1

64

vpn-rt

互联

VLAN 500

1::1

64

vpn-nrt

互联

Loopback 10

2::1

64

vpn-rt

模拟业务

Loopback 20

3::1

64

vpn-nrt

模拟业务

Loopback 0

1.1.1.1

32

vpn-rt

作为vpn-rt router-id

Loopback 1

2.2.2.2

32

vpn-nrt

作为vpn-nrt router-id

SW2

VLAN 400

1::2

64

vpn-rt

互联

VLAN 500

1::2

64

vpn-nrt

互联

Loopback 10

4::1

64

vpn-rt

模拟业务

Loopback 20

5::1

64

vpn-nrt

模拟业务

Loopback 0

3.3.3.3

32

vpn-rt

作为vpn-rt router-id

Loopback 1

4.4.4.4

32

vpn-nrt

作为vpn-nrt router-id


配置步骤

SW1

sys

System View: return to User View with Ctrl+Z.

[H3C]sysname SW1

#创建VPN实例,指定RD值、RT

[SW1]ip vpn-instance vpn-rt

[SW1-vpn-instance-vpn-rt]route-distinguisher 100:1

[SW1-vpn-instance-vpn-rt]vpn-target 100:1

[SW1-vpn-instance-vpn-rt]quit

[SW1]ip vpn-instance vpn-nrt

[SW1-vpn-instance-vpn-nrt]route-distinguisher 200:1

[SW1-vpn-instance-vpn-nrt]vpn-target 200:1

[SW1-vpn-instance-vpn-nrt]quit

[SW1]vlan 400

[SW1-vlan400]quit

[SW1]vlan 500

[SW1-vlan500]quit

[SW1]int vlan 400

[SW1-Vlan-interface400]ip binding vpn-instance vpn-rt //VLAN绑定到VPN实例

Some configurations on the interface are removed.

[SW1-Vlan-interface400]des

[SW1-Vlan-interface400]ipv6 address 1::1 64

[SW1-Vlan-interface400]quit

[SW1]int vlan 500

[SW1-Vlan-interface500]ip binding vpn-instance vpn-nrt

Some configurations on the interface are removed.

[SW1-Vlan-interface500]des

[SW1-Vlan-interface500]ipv6 address 1::1 64

[SW1-Vlan-interface500]quit

[SW1]int gi 1/0/1

[SW1-GigabitEthernet1/0/1]des

[SW1-GigabitEthernet1/0/1]port link-type trunk

[SW1-GigabitEthernet1/0/1]undo port trunk permit vlan 1

[SW1-GigabitEthernet1/0/1]port trunk permit vlan 400 500

[SW1-GigabitEthernet1/0/1]quit

[SW1]int loopback 10

[SW1-LoopBack10]ip binding vpn-instance vpn-rt

Some configurations on the interface are removed.

[SW1-LoopBack10]ipv6 address 2::1 64

[SW1-LoopBack10]quit

[SW1]int loopback 20

[SW1-LoopBack20]ip binding vpn-instance vpn-nrt

Some configurations on the interface are removed.

[SW1-LoopBack20]ipv6 address 3::1 64

[SW1-LoopBack20]quit

[SW1]int loopback 0

[SW1-LoopBack0]ip binding vpn-instance vpn-rt

Some configurations on the interface are removed.

[SW1-LoopBack0]ip address 1.1.1.1 32

[SW1-LoopBack0]quit

[SW1]int loopback 1

[SW1-LoopBack1]ip binding vpn-instance vpn-nrt

Some configurations on the interface are removed.

[SW1-LoopBack1]ip address 2.2.2.2 32

[SW1-LoopBack1]quit

[SW1]bgp 100

[SW1-bgp-default]router-id 1.1.1.1

[SW1-bgp-default]ip vpn-instance vpn-rt //BGP内绑定VPN实例

[SW1-bgp-default-vpn-rt]peer 1::2 as-number 200

[SW1-bgp-default-vpn-rt]address-family ipv6 unicast

[SW1-bgp-default-ipv6-vpn-rt]peer 1::2 enable

[SW1-bgp-default-ipv6-vpn-rt]network 2:: 64

[SW1-bgp-default-ipv6-vpn-rt]quit

[SW1-bgp-default-vpn-rt]quit

[SW1-bgp-default]ip vpn-instance vpn-nrt

[SW1-bgp-default-vpn-nrt]peer 1::2 as-number 200

[SW1-bgp-default-vpn-nrt]address-family ipv6 unicast

[SW1-bgp-default-ipv6-vpn-nrt]peer 1::2 enable

[SW1-bgp-default-ipv6-vpn-nrt]network 3:: 64

[SW1-bgp-default-ipv6-vpn-nrt]quit

[SW1-bgp-default-vpn-nrt]quit

[SW1-bgp-default]quit

 

 

sys

System View: return to User View with Ctrl+Z.

[H3C]sysname SW2

[SW2]ip vpn-instance vpn-rt

[SW2-vpn-instance-vpn-rt]route-distinguisher 100:1

[SW2-vpn-instance-vpn-rt]vpn-target 100:1

[SW2-vpn-instance-vpn-rt]quit

[SW2]ip vpn-instance vpn-nrt

[SW2-vpn-instance-vpn-nrt]route-distinguisher 200:1

[SW2-vpn-instance-vpn-nrt]vpn-target 200:1

[SW2-vpn-instance-vpn-nrt]quit

[SW2]vlan 400

[SW2-vlan400]quit

[SW2]vlan 500

[SW2-vlan500]quit

[SW2]int vlan 400

[SW2-Vlan-interface400]ip binding vpn-instance vpn-rt

Some configurations on the interface are removed.

[SW2-Vlan-interface400]des

[SW2-Vlan-interface400]ipv6 address 1::2 64

[SW2-Vlan-interface400]quit

[SW2]int vlan 500

[SW2-Vlan-interface500]ip binding vpn-instance vpn-nrt

Some configurations on the interface are removed.

[SW2-Vlan-interface500]des

[SW2-Vlan-interface500]ipv6 address 1::2 64

[SW2-Vlan-interface500]quit

[SW2]int LoopBack 10

[SW2-LoopBack10]ip binding vpn-instance vpn-rt

Some configurations on the interface are removed.

[SW2-LoopBack10]ipv6 address 4::1 64

[SW2-LoopBack10]quit

[SW2]int loopback 20

[SW2-LoopBack20]ip binding vpn-instance vpn-nrt

Some configurations on the interface are removed.

[SW2-LoopBack20]ipv6 address 5::1 64

[SW2-LoopBack20]quit

[SW2]int loopback 0

[SW2-LoopBack0]ip binding vpn-instance vpn-rt

Some configurations on the interface are removed.

[SW2-LoopBack0]ip address 3.3.3.3 32

[SW2-LoopBack0]quit

[SW2]int loopback 1

[SW2-LoopBack1]ip binding vpn-instance vpn-nrt

Some configurations on the interface are removed.

[SW2-LoopBack1]ip address 4.4.4.4 32

[SW2-LoopBack1]quit

[SW2]int gi 1/0/1

[SW2-GigabitEthernet1/0/1]port link-mode bridge

[SW2-GigabitEthernet1/0/1]des

[SW2-GigabitEthernet1/0/1]port link-type trunk

[SW2-GigabitEthernet1/0/1]undo port trunk permit vlan 1

[SW2-GigabitEthernet1/0/1]port trunk permit vlan 400 500

[SW2-GigabitEthernet1/0/1]quit

[SW2]bgp 200

[SW2-bgp-default]router-id 2.2.2.2

[SW2-bgp-default]ip vpn-instance vpn-rt

[SW2-bgp-default-vpn-rt]peer 1::1 as-number 100

[SW2-bgp-default-vpn-rt]address-family ipv6 unicast

[SW2-bgp-default-ipv6-vpn-rt]peer 1::1 enable

[SW2-bgp-default-ipv6-vpn-rt]network 4:: 64

[SW2-bgp-default-ipv6-vpn-rt]quit

[SW2-bgp-default-vpn-rt]quit

[SW2-bgp-default]ip vpn-instance vpn-nrt

[SW2-bgp-default-vpn-nrt]peer 1::1 as-number 100

[SW2-bgp-default-vpn-nrt]address-family ipv6 unicast

[SW2-bgp-default-ipv6-vpn-nrt]peer 1::1 enable

[SW2-bgp-default-ipv6-vpn-nrt]network 5:: 64

[SW2-bgp-default-ipv6-vpn-nrt]quit

[SW2-bgp-default-vpn-nrt]quit

[SW2-bgp-default]quit

 

测试:

SW1使用loopback 10作为源,带VPNPINGFW2loopback 10PING不通FW2loopback 20





SW1使用loopback 20作为源,带VPNPINGFW2loopback20PING不通FW2loopback 10





 

SW2使用loopback 10作为源,带VPNPINGFW1loopback 10PING不通FW1loopback 20





 

SW2使用loopback 20作为源,带VPNPINGFW1loopback20PING不通FW1loopback 10





根据测试结果得知,相同VPN实例内的业务可以互通,不同VPN实例内的业务不能互通,达到了隔离的效果。

 

查看SW1BGP邻居信息:



查看SW2BGP邻居信息:



查看SW1 IPV6 VPN的路由表:





 

查看SW2 IPV6 VPN的路由表:





 

至此,S5820 IPV6 MPLS VPN OPTION-A典型组网配置案例已完成!

 

 

 

配置关键点


该案例对您是否有帮助:

您的评价:1

若您有关于案例的建议,请反馈:

0 个评论

该案例暂时没有网友评论

编辑评论

举报

×

侵犯我的权益 >
对根叔知了社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔知了社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明

提出建议

    +

亲~登录后才可以操作哦!

确定

亲~检测到您登陆的账号未在http://hclhub.h3c.com进行注册

注册后可访问此模块

跳转hclhub

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作