• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 全部
  • 全部
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
高级搜索

IPV6之VRRP典型组网配置案例

2020-02-23发表
  • 4关注
  • 9收藏,183浏览
粉丝:102人 关注:0人

组网及说明



组网说明:

本案例采用H3C HCL模拟器来模拟IPV6 VRRP典型组网配置。为了确保网络的冗余,将SW2SW3开启VRRP作为网关冗余。SW2为主设备,SW3为备用设备。SW2SW3R1的互联采用ospfv3路由协议互通。当断开SW2GI1/0/2上联口是,物理机能走SW3方向去往R1


配置步骤

1、按照网络拓扑图正确配置IP地址和VLAN划分

2、SW2SW3配置VRRP

3、SW2配置track,方便VRRP的检测与切换

4、SW2SW3R1运行OSPFv3路由协议

配置关键点

SW1

<H3C>sys

System View: return to User View with Ctrl+Z.

[H3C]sysname SW1

[SW1]vlan 10

[SW1-vlan10]quit

[SW1]int gi 1/0/3

[SW1-GigabitEthernet1/0/3]port link-type access

[SW1-GigabitEthernet1/0/3]port access vlan 10

[SW1-GigabitEthernet1/0/3]quit

[SW1]int range gi 1/0/1 to gi 1/0/2

[SW1-if-range]port link-type trunk

[SW1-if-range]undo port trunk permit vlan 1

[SW1-if-range]port trunk permit vlan 10

[SW1-if-range]quit

[SW1]ip unreachables enable

[SW1]ip ttl-expires enable

[SW1]ipv6 unreachables enable

 

 

SW2

<H3C>sys

System View: return to User View with Ctrl+Z.

[H3C]sysname SW2

[SW2]vlan 10

[SW2-vlan10]quit

[SW2]int range gi 1/0/1 gi 1/0/3

[SW2-if-range]port link-type trunk

[SW2-if-range]undo port trunk permit vlan 1

[SW2-if-range]port trunk permit vlan 10

[SW2-if-range]quit

[SW2]int vlan 10

[SW2-Vlan-interface10]ipv6 address fe80::2 link-local

[SW2-Vlan-interface10]vrrp ipv6 vrid 1 virtual-ip fe80::1 link-local

[SW2-Vlan-interface10]vrrp ipv6 vrid 1 priority 120

[SW2-Vlan-interface10]vrrp ipv6 vrid 1 track 1 priority reduced 30

[SW2-Vlan-interface10]ipv6 address 3::1 64

[SW2-Vlan-interface10]ospfv3 1 area 0

[SW2-Vlan-interface10]quit

[SW2]track 1 interface GigabitEthernet 1/0/2

[SW2-track-1]quit

[SW2]int LoopBack 0

[SW2-LoopBack0]ip address 1.1.1.1 32

[SW2-LoopBack0]quit

[SW2]ospfv3 1

[SW2-ospfv3-1]import-route direct

[SW2-ospfv3-1]router-id 1.1.1.1

[SW2-ospfv3-1]silent-interface Vlan-interface 10

[SW2-ospfv3-1]quit

[SW2]int gi 1/0/2

[SW2-GigabitEthernet1/0/2]port link-mode route

[SW2-GigabitEthernet1/0/2]des <connect to R1>

[SW2-GigabitEthernet1/0/2]ipv6 address 1::1 64

[SW2-GigabitEthernet1/0/2]ospfv3 1 area 0

[SW2-GigabitEthernet1/0/2]quit

[SW2]ip unreachables enable

[SW2]ip ttl-expires enable

[SW2]ipv6 unreachables enable

 

SW3

<H3C>sys

System View: return to User View with Ctrl+Z.

[H3C]sysname SW3

[SW3]int loopback 0

[SW3-LoopBack0]ip address 2.2.2.2 32

[SW3-LoopBack0]quit

[SW3]vlan 10

[SW3-vlan10]quit

[SW3]int range gi 1/0/1 gi 1/0/3

[SW3-if-range]port link-type trunk

[SW3-if-range]undo port trunk permit vlan 1

[SW3-if-range]port trunk permit vlan 10

[SW3-if-range]quit

[SW3]int vlan 10

[SW3-Vlan-interface10]ipv6 address fe80::3 link-local

[SW3-Vlan-interface10]vrrp ipv6 vrid 1 virtual-ip fe80::1 link-local

[SW3-Vlan-interface10]ipv6 address 3::2 64

[SW3-Vlan-interface10]ospfv3 1 area 0

[SW3-GigabitEthernet1/0/2]ospfv3 cost 200

[SW3-Vlan-interface10]quit

[SW3]ospfv3 1

[SW3-ospfv3-1]silent-interface Vlan-interface 10

[SW3-ospfv3-1]import-route direct

[SW3-ospfv3-1]router-id 2.2.2.2

[SW3-ospfv3-1]quit

[SW3]int gi 1/0/2

[SW3-GigabitEthernet1/0/2]port link-mode route

[SW3-GigabitEthernet1/0/2]des <connect to R1>

[SW3-GigabitEthernet1/0/2]ipv6 address 2::1 64

[SW3-GigabitEthernet1/0/2]ospfv3 1 area 0

[SW3-GigabitEthernet1/0/2]quit

[SW3]ip unreachables enable

[SW3]ip ttl-expires enable

[SW3]ipv6 unreachables enable

 

 

R1

<H3C>sys

System View: return to User View with Ctrl+Z.

[H3C]sysname R1

[R1]int loopback 0

[R1-LoopBack0]ip address 3.3.3.3 32

[R1-LoopBack0]quit

[R1]int loopback 1

[R1-LoopBack1]ipv6 address 4::1 64

[R1-LoopBack1]ospfv3 1 area 0

[R1-LoopBack1]quit

[R1]ospfv3 1

[R1-ospfv3-1]router-id 3.3.3.3

[R1-ospfv3-1]import-route direct

[R1-ospfv3-1]quit

[R1]int gi 0/0

[R1-GigabitEthernet0/0]des <connect to SW2>

[R1-GigabitEthernet0/0]ipv6 address 1::2 64

[R1-GigabitEthernet0/0]ospfv3 1 area 0

[R1-GigabitEthernet0/0]quit

[R1]int gi 0/1

[R1-GigabitEthernet0/1]des <connect to SW3>

[R1-GigabitEthernet0/1]ipv6 address 2::2 64

[R1-GigabitEthernet0/1]ospfv3 1 area 0

[R1-GigabitEthernet0/1]quit

[R1]ip unreachables enable

[R1]ip ttl-expires enable

[R1]ipv6 unreachables enable

 

查看SW2VRRP显示信息为master



查看SW3VRRP显示信息为backup



查看SW2OSPF邻居信息:



查看SW3OSPF邻居信息:


查看R1OSPF邻居信息:


查看SW2的路由表:

[SW2]dis ipv6 routing-table

 

Destinations : 10       Routes : 10

 

Destination: ::1/128                                     Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 1::/64                                      Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : GE1/0/2                                     Cost      : 0

 

Destination: 1::1/128                                    Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 2::/64                                      Protocol  : O_INTRA

NextHop    : FE80::867D:FF:FE9A:405                      Preference: 10

Interface  : GE1/0/2                                     Cost      : 2

 

Destination: 3::/64                                      Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : Vlan10                                      Cost      : 0

 

Destination: 3::1/128                                    Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 4::/64                                      Protocol  : O_ASE2

NextHop    : FE80::867D:FF:FE9A:405                      Preference: 150

Interface  : GE1/0/2                                     Cost      : 1

 

Destination: 4::1/128                                    Protocol  : O_INTRA

NextHop    : FE80::867D:FF:FE9A:405                      Preference: 10

Interface  : GE1/0/2                                     Cost      : 1

 

Destination: FE80::/10                                   Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: FF00::/8                                    Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : NULL0                                       Cost      : 0

[SW2]

 

查看SW3的路由表:

[SW3]dis ipv6 routing-table

 

Destinations : 10       Routes : 10

 

Destination: ::1/128                                     Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 1::/64                                      Protocol  : O_INTRA

NextHop    : FE80::867D:FF:FE9A:406                      Preference: 10

Interface  : GE1/0/2                                     Cost      : 201

 

Destination: 2::/64                                      Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : GE1/0/2                                     Cost      : 0

 

Destination: 2::1/128                                    Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 3::/64                                      Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : Vlan10                                      Cost      : 0

 

Destination: 3::2/128                                    Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 4::/64                                      Protocol  : O_ASE2

NextHop    : FE80::867D:FF:FE9A:406                      Preference: 150

Interface  : GE1/0/2                                     Cost      : 1

 

Destination: 4::1/128                                    Protocol  : O_INTRA

NextHop    : FE80::867D:FF:FE9A:406                      Preference: 10

Interface  : GE1/0/2                                     Cost      : 200

 

Destination: FE80::/10                                   Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: FF00::/8                                    Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : NULL0                                       Cost      : 0

[SW3]

 

查看R1的路由表:

[R1]dis ipv6 routing-table

 

Destinations : 10       Routes : 11

 

Destination: ::1/128                                     Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 1::/64                                      Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : GE0/0                                       Cost      : 0

 

Destination: 1::2/128                                    Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 2::/64                                      Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : GE0/1                                       Cost      : 0

 

Destination: 2::2/128                                    Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: 3::/64                                      Protocol  : O_INTRA

NextHop    : FE80::867C:9AFF:FE0A:207                    Preference: 10

Interface  : GE0/0                                       Cost      : 2

 

Destination: 3::/64                                      Protocol  : O_INTRA

NextHop    : FE80::867C:9FFF:FEF2:307                    Preference: 10

Interface  : GE0/1                                       Cost      : 2

 

Destination: 4::/64                                      Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : Loop1                                       Cost      : 0

 

Destination: 4::1/128                                    Protocol  : Direct

NextHop    : ::1                                         Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: FE80::/10                                   Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : InLoop0                                     Cost      : 0

 

Destination: FF00::/8                                    Protocol  : Direct

NextHop    : ::                                          Preference: 0

Interface  : NULL0                                       Cost      : 0

[R1]

 

物理机设置IPV6地址:



物理机能PING4::1



路由追踪,走SW2方向去往4::1



关闭SW2GI 1/0/2端口:

[SW2]int gi 1/0/2

[SW2-GigabitEthernet1/0/2]shutdown

 

查看SW2SW3VRRP状态:

SW2VRRP状态为backup



SW3VRRP状态为main



此时物理机依然可以PING4::1



使用trecert -d 4::1,物理机去往4::1已经走SW3方向:



由以上测试结果得知,VRRP可以正常切换,同时在切换后,VLAN10的流量可以正常走SW3方向去往R1。


至此,IPV6VRRP典型组网配置案例已完成!


0 个评论

该案例暂时没有网友评论

编辑评论

举报

×

侵犯我的权益 >
对根叔知了社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔知了社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明

提出建议

    +
<

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作