• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 全部
  • 全部
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
高级搜索

IPV6之IPV4 over IPV6隧道over SSL VPN WEB接入(缺省证书)双臂(旁路)典型组网配置案例

2020-02-25 发表
  • 5关注
  • 9收藏,459浏览
粉丝:152人 关注:0人

组网及说明


组网说明:

本案例采用H3C HCL模拟器来模拟IPV4 over IPV6 over ssl vpn典型组网配置。内网和外网已经有了明确的标识。内网1和内网2都是采用IPV4作为基础网络的搭建。外网采用IPV6来实现内网1和内网2的互联。为了实现内网1和内网2的互通,要求在R1与R2之间建立隧道,采用IPV6 over IPV6的方式。内网2的FW1使用F1060防火墙做成SSL VPN网关,内网1的终端到达内网2之后,首先要进行SSL VPN的认证过后,方能访问SW1。因此需要在R2做策略路由,实现流量的引流。由于模拟器的局限性,因此使用SW1采用S5820交换机开启WEB功能来模拟WEB服务器。最后SSL VPN的接入的方式为WEB接入(缺省证书)双臂(旁路)的架构,提供WEB服务并将内网2的WEB服务器进行发布。



配置步骤

1、按照网络拓扑图正确配置IP地址

2、R1R2建立隧道

3、FW1开启SSL VPN功能

4、SW1开启WEB功能,并创建相应的账户和分配权限

5、R2配置策略路由,当IPV4 over IPV6隧道建立后,必须先登陆SSL VPN网关,才可访问SW1的WEB服务。


配置关键点

SW1

sys

System View: return to User View with Ctrl+Z.

[H3C]sysname SW1

[SW1]int gi 1/0/1

[SW1-GigabitEthernet1/0/1]port link-mode route

[SW1-GigabitEthernet1/0/1]des

[SW1-GigabitEthernet1/0/1]ip address 10.0.0.5 30

[SW1-GigabitEthernet1/0/1]quit

[SW1]ip route-static 0.0.0.0 0.0.0.0 10.0.0.6

[SW1]ip http enable

[SW1]ip https enable

[SW1]local-user admin

New local user added.

[SW1-luser-manage-admin]password simple admin

[SW1-luser-manage-admin]service-type http https

[SW1-luser-manage-admin]authorization-attribute user-role network-admin

[SW1-luser-manage-admin]quit

 

ISP

sys

System View: return to User View with Ctrl+Z.

[H3C]sysname ISP

[ISP]int gi 0/2

[ISP-GigabitEthernet0/2]des

[ISP-GigabitEthernet0/2]ipv6 address 1::2 64

[ISP-GigabitEthernet0/2]quit

[ISP]int gi 0/0

[ISP-GigabitEthernet0/0]des

[ISP-GigabitEthernet0/0]ipv6 address 2::2 64

[ISP-GigabitEthernet0/0]quit

[ISP]

 

R1

sys

System View: return to User View with Ctrl+Z.

[H3C]sysname R1

[R1]int gi 0/0

[R1-GigabitEthernet0/0]ip address 192.168.1.1 24

[R1-GigabitEthernet0/0]quit

[R1]int gi 0/2

[R1-GigabitEthernet0/2]des

[R1-GigabitEthernet0/2]ipv6 address 1::1 64

[R1-GigabitEthernet0/2]quit

[R1]ipv6 route-static :: 0 1::2

R1 IPV4 over IPV6隧道关键配置点:

[R1]int tunnel 0 mode ipv6

[R1-Tunnel0]ip address 123.0.0.1 30

[R1-Tunnel0]source 1::1

[R1-Tunnel0]destination 2::1

[R1-Tunnel0]undo shutdown

[R1-Tunnel0]quit

[R1]ip route-static 10.0.0.0 255.255.255.0 123.0.0.2

[R1]

 

R2

sys

System View: return to User View with Ctrl+Z.

[H3C]sysname R2

[R2]int gi 0/1

[R2-GigabitEthernet0/1]des

[R2-GigabitEthernet0/1]ip address 10.0.0.6 30

[R2-GigabitEthernet0/1]quit

[R2]int gi 0/2

[R2-GigabitEthernet0/2]des

[R2-GigabitEthernet0/2]ip address 10.0.0.2 30

[R2-GigabitEthernet0/2]quit

[R2]int gi 0/0

[R2-GigabitEthernet0/0]des

[R2-GigabitEthernet0/0]ipv6 address 2::1 64

[R2-GigabitEthernet0/0]quit

[R2]ipv6 route-static :: 0 2::2

 

R2 策略路由及IPV4 over IPV6隧道配置关键点:

[R2]acl basic 2000

[R2-acl-ipv4-basic-2000]rule 0 permit source 192.168.1.0 0.0.0.255

[R2-acl-ipv4-basic-2000]quit

[R2]policy-based-route james permit node 1

[R2-pbr-james-1]if-match acl 2000

[R2-pbr-james-1]apply next-hop 10.0.0.1

[R2-pbr-james-1]quit

[R2]int Tunnel 0 mode ipv6

[R2-Tunnel0]ip address 123.0.0.2 30

[R2-Tunnel0]source 2::1

[R2-Tunnel0]destination 1::1

[R2-Tunnel0]ip policy-based-route james

[R2-Tunnel0]undo shutdown

[R2-Tunnel0]quit

[R2]ip route-static 192.168.1.0 255.255.255.0 123.0.0.1

 

FW1

sys

System View: return to User View with Ctrl+Z.

[H3C]sysname FW1

[FW1]int gi 1/0/2

[FW1-GigabitEthernet1/0/2]des

[FW1-GigabitEthernet1/0/2]ip address 10.0.0.1 30

[FW1-GigabitEthernet1/0/2]quit

[FW1]ip route-static 0.0.0.0 0.0.0.0 10.0.0.2

[FW1]security-zone name trust

[FW1-security-zone-Trust]import interface GigabitEthernet 1/0/2

[FW1-security-zone-Trust]quit

[FW1]acl basic 2001

[FW1-acl-ipv4-basic-2001]rule 0 permit source any

[FW1-acl-ipv4-basic-2001]quit

[FW1]

[FW1]zone-pair security source trust destination untrust

[FW1-zone-pair-security-Trust-Untrust]packet-filter 2001

[FW1-zone-pair-security-Trust-Untrust]quit

[FW1]

[FW1]zone-pair security source untrust destination trust

[FW1-zone-pair-security-Untrust-Trust]packet-filter 2001

[FW1-zone-pair-security-Untrust-Trust]quit

[FW1]

[FW1]zone-pair security source trust destination local

[FW1-zone-pair-security-Trust-Local]packet-filter 2001

[FW1-zone-pair-security-Trust-Local]quit

[FW1]

[FW1]zone-pair security source local destination trust

[FW1-zone-pair-security-Local-Trust]packet-filter 2001

[FW1-zone-pair-security-Local-Trust]quit

[FW1]

[FW1]zone-pair security source untrust destination local

[FW1-zone-pair-security-Untrust-Local]packet-filter 2001

[FW1-zone-pair-security-Untrust-Local]quit

[FW1]

[FW1]zone-pair security source local destination untrust

[FW1-zone-pair-security-Local-Untrust]packet-filter 2001

[FW1-zone-pair-security-Local-Untrust]quit

 

FW1 SSL VPN关键配置点:

 

[FW1]acl advanced 3000

[FW1-acl-ipv4-adv-3000]rule 0 permit tcp source any destination any

[FW1-acl-ipv4-adv-3000]quit

[FW1]sslvpn gateway james

[FW1-sslvpn-gateway-james] ip address 10.0.0.1

[FW1-sslvpn-gateway-james]service enable

[FW1-sslvpn-gateway-james]quit

[FW1]sslvpn context james

[FW1-sslvpn-context-james]gateway james domain james

[FW1-sslvpn-context-james]url-list  S5820

[FW1-sslvpn-context-james-url-list-S5820] heading web

[FW1-sslvpn-context-james-url-list-S5820]url S5820-https url-value https://10.0.0.5

[FW1-sslvpn-context-james-url-list-S5820]url S5820-http url-value http://10.0.0.5

[FW1-sslvpn-context-james-url-list-S5820]quit

[FW1-sslvpn-context-james] policy-group url

[FW1-sslvpn-context-james-policy-group-url]resources url-list S5820

[FW1-sslvpn-context-james-policy-group-url]filter web-access acl 3000

[FW1-sslvpn-context-james-policy-group-url]service enable

[FW1-sslvpn-context-james]quit

[FW1]local-user james class network

New local user added.

[FW1-luser-network-james]password simple james

[FW1-luser-network-james]service-type sslvpn

[FW1-luser-network-james]authorization-attribute user-role network-operator

[FW1-luser-network-james]authorization-attribute sslvpn-policy-group url

[FW1-luser-network-james]quit

 

测试:

物理机填写IP地址:



物理机能PINGFW1


打开浏览器,输入网址:https://10.0.0.5 ,发现无法访问,是因为必须要先登录SSL VPN网关,在SSL VPN网关内的资源才可访问:


打开浏览器,输入网址:https://10.0.0.1 ,回车,点击“james”


输入用户名、密码,点击“登陆”:


登陆SSL VPN网关成功:


点击“S5820-https”:


可以正常打开网页:


输入用户名、密码,点击登录:


登陆成功:



查看R1的路由表,可看到隧道的路由:



查看R2的路由表,可看到隧道的路由:



查看R1的隧道状态:



查看R2的隧道状态:



查看R1的隧道配置信息:


查看R2的隧道配置信息:


查看FW1SSL VPN显示信息:







至此,IPV6IPV4 over IPV6 over ssl vpn(双臂旁路WEB接入)典型组网配置案例已完成!

 



0 个评论

该案例暂时没有网友评论

编辑评论

举报

×

侵犯我的权益 >
对根叔知了社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔知了社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明

提出建议

    +
<

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作