• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 全部
  • 全部
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
高级搜索

F1060 BGP RR一级路由反射器典型组网配置案例

2020-04-11 发表
  • 1关注
  • 9收藏,174浏览
粉丝:161人 关注:0人

组网及说明


组网说明:

本案例使用H3C HCL模拟器的F1060防火墙来模拟BGP一级RR路由反射器的典型组网配置。FW1FW2属于AS100FW3属于AS200.由于FW1FW3没有互联,又想实现PC的互通,因此需要采用RR路由反射器技术,FW2FW1RR路由反射器,FW1FW2RR路由反射器的客户端。为了使得FW1FW2之间能够建立IBGP邻居关系及达到路由反射的效果,因此FW1FW2之间同时运行OSPF路由协议,为IBGP邻居的建立及路由反射提供承载。最后FW2FW3之间建立IBGP邻居关系。

 

IP地址规划如下:

 

设备名称

接口/VLAN

IP地址

子网掩码位数

备注

FW1

Gi 1/0/3

10.0.0.1

30

 

VLAN 10

192.168.10.1

24

 

Loopback 0

1.1.1.1

32

Router-id

FW2

GI 1/0/3

10.0.0.2

30

 

GI 1/0/4

10.0.0.5

30

 

Loopback 0

3.3.3.3

32

Router-id

FW3

GI 1/0/4

10.0.0.6

30

 

VLAN 100

172.16.10.1

24

 

Loopback 0

2.2.2.2

32

Router-id

配置步骤

FW1

<H3C>sys

System View: return to User View with Ctrl+Z.

[H3C]sysname FW1

[FW1]int loopback 0

[FW1-LoopBack0]ip address 1.1.1.1 32

[FW1-LoopBack0]quit

[FW1]acl basic 2000

[FW1-acl-ipv4-basic-2000]rule 0 permit source any

[FW1-acl-ipv4-basic-2000]quit

[FW1]zone-pair security source trust destination untrust

[FW1-zone-pair-security-Trust-Untrust]packet-filter 2000

[FW1-zone-pair-security-Trust-Untrust]quit

[FW1]zone-pair security source untrust destination trust

[FW1-zone-pair-security-Untrust-Trust]packet-filter 2000

[FW1-zone-pair-security-Untrust-Trust]quit

[FW1]zone-pair security source trust destination local

[FW1-zone-pair-security-Trust-Local]packet-filter 2000

[FW1-zone-pair-security-Trust-Local]quit

[FW1]zone-pair security source local destination trust

[FW1-zone-pair-security-Local-Trust]packet-filter 2000

[FW1-zone-pair-security-Local-Trust]quit

[FW1]zone-pair security source untrust destination local

[FW1-zone-pair-security-Untrust-Local]packet-filter 2000

[FW1-zone-pair-security-Untrust-Local]quit

[FW1]zone-pair security source local destination untrust

[FW1-zone-pair-security-Local-Untrust]packet-filter 2000

[FW1-zone-pair-security-Local-Untrust]quit

[FW1]zone-pair security source trust destination trust

[FW1-zone-pair-security-Trust-Trust]packet-filter 2000

[FW1-zone-pair-security-Trust-Trust]quit

[FW1]zone-pair security source untrust destination untrust

[FW1-zone-pair-security-Untrust-Untrust]packet-filter 2000

[FW1-zone-pair-security-Untrust-Untrust]quit

[FW1]vlan 10

[FW1-vlan10]quit

[FW1]int vlan 10

[FW1-Vlan-interface10]ip address 192.168.10.1 24

[FW1-Vlan-interface10]quit

[FW1]int gi 1/0/2

[FW1-GigabitEthernet1/0/2]port link-mode bridge

[FW1-GigabitEthernet1/0/2]port link-type access

[FW1-GigabitEthernet1/0/2]port access vlan 10

[FW1-GigabitEthernet1/0/2]quit

[FW1]int gi 1/0/3

[FW1-GigabitEthernet1/0/3]des <connect to FW2>

[FW1-GigabitEthernet1/0/3]ip address 10.0.0.1 30

[FW1-GigabitEthernet1/0/3]quit

[FW1]ospf 1 router-id 1.1.1.1

[FW1-ospf-1]area 0.0.0.0

[FW1-ospf-1-area-0.0.0.0]network 10.0.0.1 0.0.0.0

[FW1-ospf-1-area-0.0.0.0]network 1.1.1.1 0.0.0.0

[FW1-ospf-1-area-0.0.0.0]quit

[FW1-ospf-1]quit

[FW1]bgp 100

[FW1-bgp-default]router-id 1.1.1.1

[FW1-bgp-default]peer 3.3.3.3 as-number 100

[FW1-bgp-default]peer 3.3.3.3 connect-interface LoopBack 0

[FW1-bgp-default]address-family ipv4 unicast

[FW1-bgp-default-ipv4]peer 3.3.3.3 enable

[FW1-bgp-default-ipv4]network 192.168.10.0 255.255.255.0

[FW1-bgp-default-ipv4]network 192.168.20.0 255.255.255.0

[FW1-bgp-default-ipv4]quit

[FW1-bgp-default]quit

[FW1]security-zone name Untrust

[FW1-security-zone-Untrust]import interface GigabitEthernet 1/0/3

[FW1-security-zone-Untrust]import interface LoopBack 0

[FW1-security-zone-Untrust]quit

[FW1]security-zone name Trust

[FW1-security-zone-Trust]import interface vlan 10

[FW1-security-zone-Trust]import interface GigabitEthernet 1/0/2 vlan 10

[FW1-security-zone-Trust]quit

 

FW2

[H3C]sysname FW2

[FW2]acl basic 2000

[FW2-acl-ipv4-basic-2000]rule 0 permit source any

[FW2-acl-ipv4-basic-2000]quit

[FW2]zone-pair security source trust destination untrust

[FW2-zone-pair-security-Trust-Untrust]packet-filter 2000

[FW2-zone-pair-security-Trust-Untrust]quit

[FW2]zone-pair security source untrust destination trust

[FW2-zone-pair-security-Untrust-Trust]packet-filter 2000

[FW2-zone-pair-security-Untrust-Trust]quit

[FW2]zone-pair security source trust destination local

[FW2-zone-pair-security-Trust-Local]packet-filter 2000

[FW2-zone-pair-security-Trust-Local]quit

[FW2]zone-pair security source local destination trust

[FW2-zone-pair-security-Local-Trust]packet-filter 2000

[FW2-zone-pair-security-Local-Trust]quit

[FW2]zone-pair security source untrust destination local

[FW2-zone-pair-security-Untrust-Local]packet-filter 2000

[FW2-zone-pair-security-Untrust-Local]quit

[FW2]zone-pair security source local destination untrust

[FW2-zone-pair-security-Local-Untrust]packet-filter 2000

[FW2-zone-pair-security-Local-Untrust]quit

[FW2]zone-pair security source trust destination trust

[FW2-zone-pair-security-Trust-Trust]packet-filter 2000

[FW2-zone-pair-security-Trust-Trust]quit

[FW2]zone-pair security source untrust destination untrust

[FW2-zone-pair-security-Untrust-Untrust]packet-filter 2000

[FW2-zone-pair-security-Untrust-Untrust]quit

[FW2]int loopback 0

[FW2-LoopBack0]ip address 3.3.3.3 32

[FW2-LoopBack0]quit

[FW2]int gi 1/0/3

[FW2-GigabitEthernet1/0/3]port link-mode route

[FW2-GigabitEthernet1/0/3]des <connect to FW1>

[FW2-GigabitEthernet1/0/3]ip address 10.0.0.2 30

[FW2-GigabitEthernet1/0/3]quit

[FW2]int gi 1/0/4

[FW2-GigabitEthernet1/0/4]ip address 10.0.0.5 30

[FW2-GigabitEthernet1/0/4]des <connect to FW3>

[FW2-GigabitEthernet1/0/4]quit

[FW2]ospf 1 router-id 3.3.3.3

[FW2-ospf-1]area 0.0.0.0

[FW2-ospf-1-area-0.0.0.0]network 10.0.0.2 0.0.0.0

[FW2-ospf-1-area-0.0.0.0]network 3.3.3.3 0.0.0.0

[FW2-ospf-1-area-0.0.0.0]quit

[FW2-ospf-1]quit

[FW2]bgp 100

[FW2-bgp-default]router-id 3.3.3.3

[FW2-bgp-default]peer 1.1.1.1 as-number 100

[FW2-bgp-default]peer 1.1.1.1 connect-interface LoopBack 0

[FW2-bgp-default]peer 10.0.0.6 as-number 200

[FW2-bgp-default]address-family ipv4 unicast

[FW2-bgp-default-ipv4]import-route direct

[FW2-bgp-default-ipv4]peer 1.1.1.1 enable

[FW2-bgp-default-ipv4]peer 1.1.1.1 reflect-client //指定1.1.1.1RR反射器的客户端

[FW2-bgp-default-ipv4]peer 10.0.0.6 enable

[FW2-bgp-default-ipv4]quit

[FW2-bgp-default]quit

[FW2]security-zone name Untrust

[FW2-security-zone-Untrust]import interface GigabitEthernet 1/0/4

[FW2-security-zone-Untrust]quit

[FW2]security-zone name Trust

[FW2-security-zone-Trust]import interface GigabitEthernet 1/0/3

[FW2-security-zone-Trust]import interface LoopBack 0

[FW2-security-zone-Trust]quit

 

FW3

<H3C>sys

System View: return to User View with Ctrl+Z.

[H3C]sysname FW3

[FW3]acl basic 2000

[FW3-acl-ipv4-basic-2000]rule 0 permit source any

[FW3-acl-ipv4-basic-2000]quit

[FW3]zone-pair security source trust destination untrust

[FW3-zone-pair-security-Trust-Untrust]packet-filter 2000

[FW3-zone-pair-security-Trust-Untrust]quit

[FW3]zone-pair security source untrust destination trust

[FW3-zone-pair-security-Untrust-Trust]packet-filter 2000

[FW3-zone-pair-security-Untrust-Trust]quit

[FW3]zone-pair security source trust destination local

[FW3-zone-pair-security-Trust-Local]packet-filter 2000

[FW3-zone-pair-security-Trust-Local]quit

[FW3]zone-pair security source local destination trust

[FW3-zone-pair-security-Local-Trust]packet-filter 2000

[FW3-zone-pair-security-Local-Trust]quit

[FW3]zone-pair security source untrust destination local

[FW3-zone-pair-security-Untrust-Local]packet-filter 2000

[FW3-zone-pair-security-Untrust-Local]quit

[FW3]zone-pair security source local destination untrust

[FW3-zone-pair-security-Local-Untrust]packet-filter 2000

[FW3-zone-pair-security-Local-Untrust]quit

[FW3]zone-pair security source trust destination trust

[FW3-zone-pair-security-Trust-Trust]packet-filter 2000

[FW3-zone-pair-security-Trust-Trust]quit

[FW3]zone-pair security source untrust destination untrust

[FW3-zone-pair-security-Untrust-Untrust]packet-filter 2000

[FW3-zone-pair-security-Untrust-Untrust]quit

[FW3]int loopback 0

[FW3-LoopBack0]ip address 2.2.2.2 32

[FW3-LoopBack0]quit

[FW3]vlan 100

[FW3-vlan100]quit

[FW3]int vlan 100

[FW3-Vlan-interface100]ip address 172.16.10.1 24

[FW3-Vlan-interface100]quit

[FW3]int gi 1/0/2

[FW3-GigabitEthernet1/0/2]port link-mode bridge

[FW3-GigabitEthernet1/0/2]port link-type access

[FW3-GigabitEthernet1/0/2]port access vlan 100

[FW3-GigabitEthernet1/0/2]quit

[FW3]int gi 1/0/4

[FW3-GigabitEthernet1/0/4]des <connect to FW2>

[FW3-GigabitEthernet1/0/4]ip address 10.0.0.6 30

[FW3-GigabitEthernet1/0/4]quit

[FW3]bgp 200

[FW3-bgp-default]router-id 2.2.2.2

[FW3-bgp-default]peer 10.0.0.5 as-number 100

[FW3-bgp-default]address-family ipv4 unicast

[FW3-bgp-default-ipv4]peer 10.0.0.5 enable

[FW3-bgp-default-ipv4]import-route direct

[FW3-bgp-default-ipv4]network 172.16.10.0 255.255.255.0

[FW3-bgp-default-ipv4]network 172.16.20.0 255.255.255.0

[FW3-bgp-default-ipv4]quit

[FW3-bgp-default]quit

[FW3]security-zone name Untrust

[FW3-security-zone-Untrust]import interface GigabitEthernet 1/0/4

[FW3-security-zone-Untrust]quit

[FW3]security-zone name Trust

[FW3-security-zone-Trust]import interface vlan 100

[FW3-security-zone-Trust]import interface GigabitEthernet 1/0/2 vlan 100

[FW3-security-zone-Trust]import interface LoopBack 0

[FW3-security-zone-Trust]quit

 

 

PC都填写IP地址:





PC之间可以相互PING通:





分别查看FW1FW2FW3BGP邻居信息:







分别查看FW1FW2OSPF邻居信息:





分别查看FW1FW2FW3的路由表:







至此,F1060 BGP RR一级路由反射器典型组网配置案例已完成!

 

 

配置关键点


0 个评论

该案例暂时没有网友评论

编辑评论

举报

×

侵犯我的权益 >
对根叔知了社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔知了社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明

提出建议

    +
<

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作