• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 漏洞说明
  • 全部
  • 全部
  • 大数据引擎
  • 知了引擎
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
搜索引擎
匹配模式
高级搜索

F1060 BGP联盟典型组网配置案例

2020-04-11 发表
  • 0关注 ,496浏览
粉丝: 关注:

组网及说明


组网说明:

本案例采用H3C HCL模拟器的F1060来模拟 BGP联盟的典型组网配置。在网络拓扑图中FW1FW2没有直连到FW4,同时又属于不同的AS,为了实现FW1FW2能与FW4互通,因此使用BGP联盟来达到互通的效果。

 

BGP联盟规划:

设备名称

AS

联盟ID

备注

FW1

65001

100

 

FW2

65002

100

 

FW3

65003

100

 

FW4

200

 

非联盟设备

 

IP地址规划:

设备名称

VLAN\接口

IP地址

子网掩码/地址前缀

备注

FW1

Loopback 0

1.1.1.1

32

Router-id

VLAN 10

192.168.10.1

24

模拟业务

GI 1/0/1

10.0.0.1

30

 

FW2

Loopback 0

2.2.2.2

32

Router-id

VLAN 20

192.168.20.1

24

模拟业务

GI 1/0/3

10.0.0.5

30

 

FW3

Loopback 0

3.3.3.3

32

Router-id

GI 1/0/1

10.0.0.2

30

 

GI 1/0/3

10.0.0.6

30

 

GI 1/0/2

10.0.0.9

64

 

FW4

Loopback 0

4.4.4.4

32

Router-id

VLAN 100

172.16.100.1

24

模拟业务

GI 1/0/2

10.0.0.10

30

配置步骤

FW1:

<H3C>sys

System View: return to User View with Ctrl+Z.

[H3C]sysname FW1

[FW1]acl basic 2000

[FW1-acl-ipv4-basic-2000]rule 0 permit source any

[FW1-acl-ipv4-basic-2000]quit

[FW1]zone-pair security source trust destination untrust

[FW1-zone-pair-security-Trust-Untrust]packet-filter 2000

[FW1-zone-pair-security-Trust-Untrust]quit

[FW1]zone-pair security source untrust destination trust

[FW1-zone-pair-security-Untrust-Trust]packet-filter 2000

[FW1-zone-pair-security-Untrust-Trust]quit

[FW1]zone-pair security source trust destination local

[FW1-zone-pair-security-Trust-Local]packet-filter 2000

[FW1-zone-pair-security-Trust-Local]quit

[FW1]zone-pair security source local destination trust

[FW1-zone-pair-security-Local-Trust]packet-filter 2000

[FW1-zone-pair-security-Local-Trust]quit

[FW1]zone-pair security source untrust destination local

[FW1-zone-pair-security-Untrust-Local]packet-filter 2000

[FW1-zone-pair-security-Untrust-Local]quit

[FW1]zone-pair security source local destination untrust

[FW1-zone-pair-security-Local-Untrust]packet-filter 2000

[FW1-zone-pair-security-Local-Untrust]quit

[FW1]zone-pair security source trust destination trust

[FW1-zone-pair-security-Trust-Trust]packet-filter 2000

[FW1-zone-pair-security-Trust-Trust]quit

[FW1]zone-pair security source untrust destination untrust

[FW1-zone-pair-security-Untrust-Untrust]packet-filter 2000

[FW1-zone-pair-security-Untrust-Untrust]quit

[FW1]int loopback 0

[FW1-LoopBack0]ip address 1.1.1.1 32

[FW1-LoopBack0]quit

[FW1]vlan 10

[FW1-vlan10]quit

[FW1]int vlan 10

[FW1-Vlan-interface10]ip address 192.168.10.1 24

[FW1-Vlan-interface10]quit

[FW1]int gi 1/0/5

[FW1-GigabitEthernet1/0/5]port link-mode bridge

[FW1-GigabitEthernet1/0/5]port link-type access

[FW1-GigabitEthernet1/0/5]port access vlan 10

[FW1-GigabitEthernet1/0/5]quit

[FW1]int gi 1/0/3

[FW1-GigabitEthernet1/0/3]port link-mode route

[FW1-GigabitEthernet1/0/3]des <connect to FW3>

[FW1-GigabitEthernet1/0/3]ip address 10.0.0.1 30

[FW1-GigabitEthernet1/0/3]quit

[FW1]bgp 65001

[FW1-bgp-default]router-id 1.1.1.1

[FW1-bgp-default]confederation id 100  //指定联盟ID

[FW1-bgp-default]confederation peer-as 65002 65003  //指定联盟成员

[FW1-bgp-default]peer 10.0.0.2 as-number 65003

[FW1-bgp-default]address-family ipv4 unicast

[FW1-bgp-default-ipv4]peer 10.0.0.2 enable

[FW1-bgp-default-ipv4]network 192.168.10.0 255.255.255.0

[FW1-bgp-default-ipv4]quit

[FW1-bgp-default]quit

[FW1]security-zone name Untrust

[FW1-security-zone-Untrust]import interface GigabitEthernet 1/0/3

[FW1-security-zone-Untrust]quit

[FW1]security-zone name Trust

[FW1-security-zone-Trust]import interface vlan 10

[FW1-security-zone-Trust]import interface LoopBack 0

[FW1-security-zone-Trust]import interface GigabitEthernet 1/0/5 vlan 10

[FW1-security-zone-Trust]quit

[FW1]

 

FW2:

<H3C>sys

System View: return to User View with Ctrl+Z.

[H3C]sysname FW2

[FW2]acl basic 2000

[FW2-acl-ipv4-basic-2000]rule 0 permit source any

[FW2-acl-ipv4-basic-2000]quit

[FW2]zone-pair security source trust destination untrust

[FW2-zone-pair-security-Trust-Untrust]packet-filter 2000

[FW2-zone-pair-security-Trust-Untrust]quit

[FW2]zone-pair security source untrust destination trust

[FW2-zone-pair-security-Untrust-Trust]packet-filter 2000

[FW2-zone-pair-security-Untrust-Trust]quit

[FW2]zone-pair security source trust destination local

[FW2-zone-pair-security-Trust-Local]packet-filter 2000

[FW2-zone-pair-security-Trust-Local]quit

[FW2]zone-pair security source local destination trust

[FW2-zone-pair-security-Local-Trust]packet-filter 2000

[FW2-zone-pair-security-Local-Trust]quit

[FW2]zone-pair security source untrust destination local

[FW2-zone-pair-security-Untrust-Local]packet-filter 2000

[FW2-zone-pair-security-Untrust-Local]quit

[FW2]zone-pair security source local destination untrust

[FW2-zone-pair-security-Local-Untrust]packet-filter 2000

[FW2-zone-pair-security-Local-Untrust]quit

[FW2]zone-pair security source trust destination trust

[FW2-zone-pair-security-Trust-Trust]packet-filter 2000

[FW2-zone-pair-security-Trust-Trust]quit

[FW2]zone-pair security source untrust destination untrust

[FW2-zone-pair-security-Untrust-Untrust]packet-filter 2000

[FW2-zone-pair-security-Untrust-Untrust]quit

[FW2]int loopback 0

[FW2-LoopBack0]ip address 2.2.2.2 32

[FW2-LoopBack0]quit

[FW2]vlan 20

[FW2-vlan20]quit

[FW2]int vlan 20

[FW2-Vlan-interface20]ip address 192.168.20.1 24

[FW2-Vlan-interface20]quit

[FW2]int gi 1/0/5

[FW2-GigabitEthernet1/0/5]port link-mode bridge

[FW2-GigabitEthernet1/0/5]port link-type access

[FW2-GigabitEthernet1/0/5]port access vlan 20

[FW2-GigabitEthernet1/0/5]quit

[FW2]int gi 1/0/2

[FW2-GigabitEthernet1/0/2]port link-mode route

[FW2-GigabitEthernet1/0/2]des <connect to FW3>

[FW2-GigabitEthernet1/0/2]ip address 10.0.0.5 30

[FW2-GigabitEthernet1/0/2]quit

[FW2]bgp 65002

[FW2-bgp-default]router-id 2.2.2.2

[FW2-bgp-default]confederation id 100

[FW2-bgp-default]confederation peer-as 65001 65003

[FW2-bgp-default]peer 10.0.0.6 as-number 65003

[FW2-bgp-default]address-family ipv4 unicast

[FW2-bgp-default-ipv4]peer 10.0.0.6 enable

[FW2-bgp-default-ipv4]network 192.168.20.0 255.255.255.0

[FW2-bgp-default-ipv4]quit

[FW2-bgp-default]quit

[FW2]security-zone name Untrust

[FW2-security-zone-Untrust]import interface GigabitEthernet 1/0/2

[FW2-security-zone-Untrust]quit

[FW2]security-zone name Trust

[FW2-security-zone-Trust]import interface vlan 20

[FW2-security-zone-Trust]import interface LoopBack 0

[FW2-security-zone-Trust]import interface GigabitEthernet 1/0/5 vlan 20

[FW2-security-zone-Trust]quit

[FW2]

 

FW3:

<H3C>sys

System View: return to User View with Ctrl+Z.

[H3C]sysname FW3

[FW3]acl basic 2000

[FW3-acl-ipv4-basic-2000]rule 0 permit source any

[FW3-acl-ipv4-basic-2000]quit

[FW3]zone-pair security source trust destination untrust

[FW3-zone-pair-security-Trust-Untrust]packet-filter 2000

[FW3-zone-pair-security-Trust-Untrust]quit

[FW3]zone-pair security source untrust destination trust

[FW3-zone-pair-security-Untrust-Trust]packet-filter 2000

[FW3-zone-pair-security-Untrust-Trust]quit

[FW3]zone-pair security source trust destination local

[FW3-zone-pair-security-Trust-Local]packet-filter 2000

[FW3-zone-pair-security-Trust-Local]quit

[FW3]zone-pair security source local destination trust

[FW3-zone-pair-security-Local-Trust]packet-filter 2000

[FW3-zone-pair-security-Local-Trust]quit

[FW3]zone-pair security source untrust destination local

[FW3-zone-pair-security-Untrust-Local]packet-filter 2000

[FW3-zone-pair-security-Untrust-Local]quit

[FW3]zone-pair security source local destination untrust

[FW3-zone-pair-security-Local-Untrust]packet-filter 2000

[FW3-zone-pair-security-Local-Untrust]quit

[FW3]zone-pair security source trust destination trust

[FW3-zone-pair-security-Trust-Trust]packet-filter 2000

[FW3-zone-pair-security-Trust-Trust]quit

[FW3]zone-pair security source untrust destination untrust

[FW3-zone-pair-security-Untrust-Untrust]packet-filter 2000

[FW3-zone-pair-security-Untrust-Untrust]quit

[FW3]int loopback 0

[FW3-LoopBack0]ip address 3.3.3.3 32

[FW3-LoopBack0]quit

[FW3]int gi 1/0/3

[FW3-GigabitEthernet1/0/3]port link-mode route

[FW3-GigabitEthernet1/0/3]des <connect to FW1>

[FW3-GigabitEthernet1/0/3]ip address 10.0.0.2 30

[FW3-GigabitEthernet1/0/3]quit

[FW3]int gi 1/0/2

[FW3-GigabitEthernet1/0/2]port link-mode route

[FW3-GigabitEthernet1/0/2]des <connect to FW2>

[FW3-GigabitEthernet1/0/2]ip address 10.0.0.6 30

[FW3-GigabitEthernet1/0/2]quit

[FW3]int gi 1/0/4

[FW3-GigabitEthernet1/0/4]port link-mode route

[FW3-GigabitEthernet1/0/4]des <connect to FW4>

[FW3-GigabitEthernet1/0/4]ip address 10.0.0.9 30

[FW3-GigabitEthernet1/0/4]quit

[FW3]bgp 65003

[FW3-bgp-default]router-id 3.3.3.3

[FW3-bgp-default]confederation id 100

[FW3-bgp-default]confederation peer-as 65001 65002

[FW3-bgp-default]peer 10.0.0.1 as-number 65001

[FW3-bgp-default]peer 10.0.0.5 as-number 65002

[FW3-bgp-default]peer 10.0.0.10 as-number 200

[FW3-bgp-default]address-family ipv4 unicast

[FW3-bgp-default-ipv4]peer 10.0.0.1 enable

[FW3-bgp-default-ipv4]peer 10.0.0.5 enable

[FW3-bgp-default-ipv4]peer 10.0.0.10 enable

[FW3-bgp-default-ipv4]import-route direct

[FW3-bgp-default-ipv4]quit

[FW3-bgp-default]quit

[FW3]security-zone name Untrust

[FW3-security-zone-Untrust]import interface GigabitEthernet 1/0/4

[FW3-security-zone-Untrust]quit

[FW3]security-zone name Trust

[FW3-security-zone-Trust]import interface GigabitEthernet 1/0/2

[FW3-security-zone-Trust]import interface GigabitEthernet 1/0/3

[FW3-security-zone-Trust]import interface LoopBack 0

[FW3-security-zone-Trust]quit

[FW3]

 

FW4:

 

<H3C>sys

System View: return to User View with Ctrl+Z.

[H3C]sysname FW4

[FW4]acl basic 2000

[FW4-acl-ipv4-basic-2000]rule 0 permit source any

[FW4-acl-ipv4-basic-2000]quit

[FW4]zone-pair security source trust destination untrust

[FW4-zone-pair-security-Trust-Untrust]packet-filter 2000

[FW4-zone-pair-security-Trust-Untrust]quit

[FW4]zone-pair security source untrust destination trust

[FW4-zone-pair-security-Untrust-Trust]packet-filter 2000

[FW4-zone-pair-security-Untrust-Trust]quit

[FW4]zone-pair security source trust destination local

[FW4-zone-pair-security-Trust-Local]packet-filter 2000

[FW4-zone-pair-security-Trust-Local]quit

[FW4]zone-pair security source local destination trust

[FW4-zone-pair-security-Local-Trust]packet-filter 2000

[FW4-zone-pair-security-Local-Trust]quit

[FW4]zone-pair security source untrust destination local

[FW4-zone-pair-security-Untrust-Local]packet-filter 2000

[FW4-zone-pair-security-Untrust-Local]quit

[FW4]zone-pair security source local destination untrust

[FW4-zone-pair-security-Local-Untrust]packet-filter 2000

[FW4-zone-pair-security-Local-Untrust]quit

[FW4]zone-pair security source trust destination trust

[FW4-zone-pair-security-Trust-Trust]packet-filter 2000

[FW4-zone-pair-security-Trust-Trust]quit

[FW4]zone-pair security source untrust destination untrust

[FW4-zone-pair-security-Untrust-Untrust]packet-filter 2000

[FW4-zone-pair-security-Untrust-Untrust]quit

[FW4]int loopback 0

[FW4-LoopBack0]ip address 4.4.4.4 32

[FW4-LoopBack0]quit

[FW4]vlan 100

[FW4-vlan100]quit

[FW4]int vlan 100

[FW4-Vlan-interface100]ip address 172.16.100.1 24

[FW4-Vlan-interface100]quit

[FW4]int gi 1/0/5

[FW4-GigabitEthernet1/0/5]port link-mode bridge

[FW4-GigabitEthernet1/0/5]port link-type access

[FW4-GigabitEthernet1/0/5]port access vlan 100

[FW4-GigabitEthernet1/0/5]quit

[FW4]int gi 1/0/4

[FW4-GigabitEthernet1/0/4]port link-mode route

[FW4-GigabitEthernet1/0/4]des <connect to FW3>

[FW4-GigabitEthernet1/0/4]ip address 10.0.0.10 30

[FW4-GigabitEthernet1/0/4]quit

[FW4]bgp 200

[FW4-bgp-default]router-id 4.4.4.4

[FW4-bgp-default]peer 10.0.0.9 as-number 100

[FW4-bgp-default]address-family ipv4 unicast

[FW4-bgp-default-ipv4]peer 10.0.0.9 en

[FW4-bgp-default-ipv4]peer 10.0.0.9 enable

[FW4-bgp-default-ipv4]network 172.16.100.0 255.255.255.0

[FW4-bgp-default-ipv4]quit

[FW4-bgp-default]quit

[FW4]security-zone name Untrust

[FW4-security-zone-Untrust]import interface GigabitEthernet 1/0/4

[FW4-security-zone-Untrust]quit

[FW4]security-zone name Trust

[FW4-security-zone-Trust]import interface vlan 100

[FW4-security-zone-Trust]import interface LoopBack 0

[FW4-security-zone-Trust]import interface GigabitEthernet 1/0/5 vlan 100

[FW4-security-zone-Trust]quit

[FW4]

 

测试:

所有PC都填写IP地址:







所有PC都能相互PING通:







分别查看FW1FW2FW3FW4BGP邻居信息:









分别查看FW1FW2FW3FW4的路由表:









 

至此,F1060 BGP联盟典型组网配置案例已完成!

 

配置关键点

1、非联盟设备指向联盟边界设备建立EBGP邻居关系时,指向联盟ID即可,不用指向联盟边界设备的BGP进程号。

2、联盟内部的邻居建立均是EBGP邻居关系。

0 个评论

该案例暂时没有网友评论

编辑评论

举报

×

侵犯我的权益 >
对根叔知了社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔知了社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明

提出建议

    +

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作