• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 全部
  • 全部
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
高级搜索

5130/5150系列交换机Voice Vlan自动模式配置方法(命令行版)

2020-08-25 发表
  • 0关注
  • 0收藏,266浏览
闫宁 九段
粉丝:17人 关注:0人

组网及说明

1 配置需求或说明

1.1  适用产品系列

本案例适用于如S5120V2-52P-LIS5120V2-28P-SIS5130-52S-EIS5130S-28S-EIS5150X-16ST-EIS5120V2S5130S5150系列的交换机。

1.2  配置需求及实现的效果

 为了保障语音数据能够优先转发,需要将语音电话和PC地址区分开,将语音电话地址设置成192.168.2网段划分到VLAN2,将PC地址设置成192.168.10网段划分到VLAN10,路由器器作为DHCP服务器给语音电话和PC下发IP地址。

 

2 组网图

 


配置步骤

3 配置步骤

3.1  配置交换机

#开启POE,为话机供电

system-view

[H3C]interface GigabitEthernet1/0/1

[H3C-GigabitEthernet1/0/1]poe enable

[H3C-GigabitEthernet1/0/1]quit

#创建话机所属VLAN2以及PC所属VLAN10

[H3C]vlan 2

[H3C-vlan2]quit

[H3C]vlan 10

[H3C-vlan10]quit

#设置允许通过的OUI地址为MAC地址前缀为6ca8-4900-0000,即当报文的前缀为6ca8-4900-0000时,设备会把它当成语音报文来处理

[H3C]voice-vlan mac-address 6ca8-4900-0000 mask ffff-ff00-0000 description avaya

#将端口GigabitEthernet1/0/1设定为Hybrid端口,开启使能端口Voice VLAN功能

[H3C]interface GigabitEthernet 1/0/1

[H3C-GigabitEthernet1/0/1]port link-type hybrid

[H3C-GigabitEthernet1/0/1]voice-vlan 2 enable

#设置PC所属vlanvlan10

[H3C-GigabitEthernet1/0/1]port hybrid pvid vlan 10

[H3C-GigabitEthernet1/0/1]port hybrid vlan 10 untagged

[H3C-GigabitEthernet1/0/1]quit

#设备连接dhcp服务器的接口1/0/17,允许VLAN2VLAN10通过

[H3C]interface GigabitEthernet 1/0/17

[H3C-GigabitEthernet1/0/17]port link-type trunk

[H3C-GigabitEthernet1/0/17]port trunk permit vlan 2 10

[H3C-GigabitEthernet1/0/17]quit

#保存配置

[H3C]save force

3.2  配置DHCP服务器

#创建VLAN2VLAN10及其对应的VLAN接口,为该虚接口配置IP地址

system-view

[H3C]vlan 2

[H3C-vlan2]quit

[H3C]vlan 10

[H3C-vlan10]quit

[H3C] interface Vlan-interface 2

[H3C-Vlan-interface2]ip address 192.168.2.1 255.255.255.0

[H3C-Vlan-interface2]quit

[H3C] interface Vlan-interface 10

[H3C-Vlan-interface10]ip address 192.168.10.1 255.255.255.0

[H3C-Vlan-interface2]quit

#设备连接交换机的接口1/0/7,允许VLAN2VLAN10通过

[H3C]interface GigabitEthernet 1/0/7

[H3C-GigabitEthernet1/0/7]port link-type trunk

[H3C-GigabitEthernet1/0/7]port trunk permit vlan 2 10

[H3C-GigabitEthernet1/0/7]quit

#设置话机VLAN2DHCP地址池

[H3C]dhcp server ip-pool vlan2

[H3C-dhcp-pool-vlan2]network 192.168.2.0 mask 255.255.255.0

[H3C-dhcp-pool-vlan2]gateway-list 192.168.2.1

[H3C-dhcp-pool-vlan2]quit

#设置PCVLAN10DHCP地址池

[H3C]dhcp server ip-pool vlan10

[H3C-dhcp-pool-vlan10]network 192.168.10.0 mask 255.255.255.0

[H3C-dhcp-pool-vlan10]gateway-list 192.168.10.1

[H3C-dhcp-pool-vlan10]dns-list 114.114.114.114

[H3C-dhcp-pool-vlan10]quit

#保存配置

[H3C]save force

4 实验结果验证

#交换机上查验证结果,查看话机是否加入到VLAN2

dis mac-address

MAC Address        VLAN ID  STATE       Port/Nickname           AGING

3897-d630-676b  10       Learned        GE1/0/17                 Y

3897-d630-676b  2        Learned         GE1/0/17                Y

6ca8-4986-6d59  2        Learned         GE1/0/1                  Y

0068-eb95-3683  10       Learned         GE1/0/1                  Y

 

#查看voice vlan 配置是否生效

dis voice-vlan mac-address

Oui Address     Mask            Description

0003-6b00-0000  ffff-ff00-0000  Cisco phone

00e0-7500-0000  ffff-ff00-0000  Polycom phone

6ca8-4900-0000  ffff-ff00-0000  avaya

 

#默认voice vlan默认为auto(自动模式)

dis voice-vlan state

Current Voice VLANs: 1

 Voice VLAN security mode: Security

 Voice VLAN aging time: 1440 minutes

 Voice VLAN enabled port and its mode:

 PORT                        VLAN        MODE        COS        DSCP

 --------------------------------------------------------------------

 GE1/0/1         2           AUTO        6          46

 

#DHCP服务器上查看话机和PC获取的动作

%Jan  1 09:19:59:333 2019 DHCP DHCPS/5/DHCPS_ALLOCATE_IP: DHCP server information: Server IP = 192.168.2.1, DHCP client IP = 192.168.2.2, DHCP client hardware address = 6ca8-4986-6d59, DHCP client lease = 86400.

dis dhcp server ip-in-use all

Pool utilization: 0.59%

 IP address       Client-identifier/    Lease expiration          Type

                  Hardware address

 192.168.2.2      6ca8-4986-6d59        Jan  9 2013 09:19:59      Auto:COMMITTED

 192.168.10.4     0068-eb95-3683        Jan  9 2013 09:19:42      Auto:COMMITTED

              

配置关键点

0 个评论

该案例暂时没有网友评论

编辑评论

举报

×

侵犯我的权益 >
对根叔知了社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔知了社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明

提出建议

    +
<

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作