• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 全部
  • 全部
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
高级搜索

S5500/S5800/S5830系列交换机三层组播配置方法(命令行版)

2020-10-10 发表
  • 0关注
  • 0收藏,96浏览
闫宁 九段
粉丝:20人 关注:0人

组网及说明

1 配置需求或说明

1.1  适用产品系列

交换机产品分类平台适用产品型号

本案例适用于如SS5500-20TP-SIS5500-52C-EIS5500-52C-PWR-EIS5500-34C-HIS5800-32C-EI5800-32FS5800-60C-PWRS5830-106SS5500S5800S5830系列的交换机。

1.1 配置需求

公司内部部署了一台组播源,为保证终端能正常接收组播源传输的业务,需在所经交换机上开启组播功能。




2 组网图




配置步骤

3 配置步骤

3.1  配置SW1IP地址和互联路由

<H3C>system–view

#新建互联VLAN10

[H3C]vlan 10

#10口加入到VLAN10

[H3C]interface Ethernet1/0/10

[H3C-Ethernet1/0/10]port access vlan 10

[H3C-Ethernet1/0/10]quit

#配置交换机间互联地址

[H3C]interface Vlan-interface10

[H3C-Vlan-interface10]ip address 172.16.10.1 255.255.255.0

[H3C-Vlan-interface10]quit

#配置与组播源互联地址

[H3C]interface Vlan-interface1

[H3C-Vlan-interface1]ip address 192.168.1.1 255.255.255.0

[H3C-Vlan-interface1]quit

#配置组播源与组播客户端互联路由

[H3C]ip route-static 192.168.2.0 255.255.255.0 172.16.10.2

 

3.2  SW1上开启组播路由功能,接口下使能PIM DM

#开启组播路由功能

[H3C]multicast routing-enable

#设备互联接口使能PIM-DM功能

[H3C]interface Vlan-interface10

[H3C-Vlan-interface10]pim dm

[H3C-Vlan-interface10]quit

#连接组播源接口使能PIM功能

[H3C]interface Vlan-interface1

[H3C-Vlan-interface1]pim dm

[H3C-Vlan-interface1]quit

[H3C]save

配置SW2IP地址和互联路由

<H3C>system–view

#新建互联VLAN10

[H3C]vlan 10

#10口加入到VLAN10

[H3C]interface GigabitEthernet 1/0/10

[H3C-GigabitEthernet1/0/10]port access vlan 10

[H3C-GigabitEthernet1/0/10]quit

#配置交换机间互联地址

[H3C]interface Vlan-interface10

[H3C-Vlan-interface10]ip address 172.16.10.2 255.255.255.0

[H3C-Vlan-interface10]quit

#配置与组播客户端互联地址

[H3C]interface Vlan-interface1

[H3C-Vlan-interface1]ip address 192.168.2.1 255.255.255.0

[H3C-Vlan-interface1]quit

#配置组播源与组播客户端互联路由

[H3C]ip route-static 192.168.1.0 255.255.255.0 172.16.10.1

 

3.3  SW2上开启组播路由功能,设备互联接口使能PIM-DM,组播接受者接口使能IGMP

#开启组播路由功能

[H3C]multicast routing-enable

#互联接口接口使能PIM-DM功能

[H3C]interface Vlan-interface10

[H3C-Vlan-interface10]pim dm

[H3C-Vlan-interface10]quit

#连接组播客户端接口使能IGMP功能

[H3C]interface Vlan-interface1

[H3C-Vlan-interface1]igmp enable

[H3C-Vlan-interface1]quit

[H3C]save

 

3.4  检查配置结果

 

组播源:


通过使用display pim  routing-table命令查看SW1 PIM路由表信息。

dis  pim routing-table

 VPN-Instance: public net

 Total 0 (*, G) entry; 1 (S, G) entry

 

 (192.168.1.100, 225.0.0.1)

     Protocol: pim-dm, Flag: LOC ACT

     UpTime: 00:00:17

     Upstream interface: Vlan-interface1

         Upstream neighbor: NULL

         RPF prime neighbor: NULL

     Downstream interface(s) information:

     Total number of downstreams: 1

         1: Vlan-interface10

             Protocol: pim-dm, UpTime: 00:00:07, Expires: never

 

 

 

组播客户端:


通过使用display pim  routing-table命令查看SW2 PIM路由表信息

<H3C>dis  pim  routing-table

 VPN-Instance: public net

 Total 2 (*, G) entries; 1 (S, G) entry

 

 (*, 225.0.0.1)

     Protocol: pim-dm, Flag: WC EXT

     UpTime: 00:05:45

     Upstream interface: NULL

         Upstream neighbor: NULL

         RPF prime neighbor: NULL

     Downstream interface(s) information: None

 

 (192.168.1.100, 225.0.0.1)

     Protocol: pim-dm, Flag: EXT ACT

     UpTime: 00:08:12

     Upstream interface: Vlan-interface10

         Upstream neighbor: 172.16.10.1

         RPF prime neighbor: 172.16.10.1

     Downstream interface(s) information: None

 

 (*, 239.255.255.250)

     Protocol: pim-dm, Flag: WC EXT

     UpTime: 00:05:42

     Upstream interface: NULL

         Upstream neighbor: NULL

         RPF prime neighbor: NULL

     Downstream interface(s) information: None

配置关键点

0 个评论

该案例暂时没有网友评论

编辑评论

举报

×

侵犯我的权益 >
对根叔知了社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔知了社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明

提出建议

    +
<

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作