• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 全部
  • 全部
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
高级搜索

★ H3C to Cisco IPsec configuration(Main mode)

2020-12-25 Published
  • 0关注
  • 0收藏,98浏览
粉丝:0人 关注:0人

Network Topology


AS

Configuration Steps

H3C:

#

dhcp server ip-pool lan1

 gateway-list 192.168.100.1

 network 192.168.100.0 mask 255.255.255.0

 address range 192.168.100.50 192.168.100.254

 dns-list 8.8.8.8

#

interface Vlan-interface1

 ip address 192.168.100.1 255.255.255.0

#

interface GigabitEthernet0/0

 port link-mode route

 description Single_Line1

 ip address 168.168.168.1 255.255.255.252

 packet-filter name GigabitEthernet0/0 inbound

 nat outbound 3005

 ipsec apply policy map1

#

#

line vty 0 63 

 authentication-mode scheme

 user-role network-operator

#

 ip route-static 192.168.200.0 24 168.168.168.2

#

acl advanced 3005

 rule 0 deny ip source 192.168.100.0 0.0.0.255 destination 192.168.200.0 0.0.0.255 ////Use NAT to reject ipsec interested flow

#

acl advanced 3101

 rule 0 permit ip source 192.168.100.0 0.0.0.255 destination 192.168.200.0 0.0.0.255//IPSEC interested flow

#

#

domain system

#

ipsec transform-set tran1

 esp encryption-algorithm 3des-cbc  

 esp authentication-algorithm md5   

#

ipsec policy map1 10 isakmp

 transform-set tran1

 security acl 3101  

 Local-address 168.168.168.1

 remote-address 168.168.168.2

 ike-profile profile1

#

ike profile profile1

 keychain keychain1

 local-identity address 168.168.168.1

 match remote identity address 168.168.168.2 255.255.255.252

 proposal 1  

#

ike proposal 1

 encryption-algorithm 3des-cbc 

 authentication-algorithm md5  

 sa duration 3600 

#

ike keychain keychain1

 pre-shared-key address 168.168.168.2 255.255.255.252 key simple 12345678

#


CISCO:


ip dhcp pool LAN

   network 192.168.200.0 255.255.255.0

   default-router 192.168.200.1 //dhcp 网关

   dns-server 8.8.8.8

!

!

!

crypto isakmp policy 20

 encr 3des

 hash md5 

 authentication pre-share

 lifetime 3600

crypto isakmp key cisco123 address 168.168.168.1

!

!

crypto ipsec transform-set mysetto esp-3des esp-md5-hmac 

!

crypto map mymap 20 ipsec-isakmp

 set peer 168.168.168.1

 set transform-set mysetto

 match address 100 

!

!

!

interface FastEthernet0/0

 ip address 168.168.168.2 255.255.255.252

 duplex auto

 speed auto

 crypto map mymap

!

interface FastEthernet0/1

 ip address 192.168.200.1 255.255.255.0

 duplex auto

 speed auto

!        

ip classless

ip route 192.168.100.0 255.255.255.0 168.168.168.1

!

access-list 100 permit ip 192.168.200.0 0.0.0.255 192.168.100.0 0.0.0.255 //acl 

!

!

Key Configuration

1.The encryption and authentication algorithms configured on both sides must be consistent

2.ACL source and destination address is the subnet address

0 comments

No comments

Add Comments:

举报

×

侵犯我的权益 >
对根叔知了社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔知了社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明

提出建议

    +
<

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作