• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 漏洞说明
  • 全部
  • 全部
  • 大数据引擎
  • 知了引擎
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
搜索引擎
匹配模式
高级搜索

S3600v2系列交换机多SmartLink组负载分担功能典型配置

  • 0关注
  • 0收藏 1327浏览
粉丝: 关注:

S3600v2系列交换机多SmartLink组负载分担功能

典型配置

一、  组网需求:

在下图所示的组网中,SWDSmart Link设备,SW ASWBSWC为相关设备。SWDVLAN 1020的流量经过SWBSWA转发,SWDVLAN 21~30的流量经过SWC SWA转发。

二、  组网图:

HOSTA HOSTB 都处在VLAN10分别连接在SWASWD上,通过配置多SmartLink组实现不同VLAN的流量分担到不同的上行链路。

HOSTA: 192.168.0.1/24 网关: 192.168.0.254/24

HOSTB: 192.168.0.2/24 网关: 192.168.0.254/24

SWA: Interface VLAN 10  192.168.0.254/24

三、  配置步骤:

1、配置SWD

# 创建VLAN 130,将VLAN1~20映射到MSTI 1上、VLAN21~30映射到MSTI 2,并激活MST域的配置。

system-view

[SWD] vlan 1 to 30

[SWD] stp region-configuration

[SWD-mst-region] instance 1 vlan 1 to 20

[SWD-mst-region] instance 2 vlan 21 to 30

[SWD-mst-region] active region-configuration

[SWD-mst-region] quit

# 分别关闭端口Ethernet1/0/1Ethernet1/0/2,在这两个端口上分别关闭生成树协议,并将端口配置为Trunk端口且允许VLAN 130通过。

[SWD] interface ethernet 1/0/1

[SWD-Ethernet1/0/1] shutdown

[SWD-Ethernet1/0/1] undo stp enable

[SWD-Ethernet1/0/1] port link-type trunk

[SWD-Ethernet1/0/1] port trunk permit vlan 1 to 30

[SWD-Ethernet1/0/1] quit

[SWD] interface ethernet 1/0/2

[SWD-Ethernet1/0/2] shutdown

[SWD-Ethernet1/0/2] undo stp enable

[SWD-Ethernet1/0/2] port link-type trunk

[SWD-Ethernet1/0/2] port trunk permit vlan 1 to 30

[SWD-Ethernet1/0/2] quit

# 创建Smart Link1,并配置其保护VLANMSTI 1所映射的VLAN

[SWD] smart-link group 1

[SWD-smlk-group1] protected-vlan reference-instance 1

# 配置Smart Link1的主端口为Ethernet1/0/1,从端口为Ethernet1/0/2

[SWD-smlk-group1] port ethernet 1/0/1 master

[SWD-smlk-group1] port ethernet 1/0/2 slave

# Smart Link1中配置抢占模式为角色抢占模式并使能发送Flush报文的功能,并指定发送Flush报文的控制VLANVLAN 20

[SWD-smlk-group1] preemption mode role

[SWD-smlk-group1]flush enable control-vlan 20

[SWD-smlk-group1] quit

# 创建Smart Link2,并配置其保护VLANMSTI 2所映射的VLAN

[SWD] smart-link group 2

[SWD-smlk-group2] protected-vlan reference-instance 2

# 配置Smart Link2的主端口为Ethernet1/0/2,从端口为Ethernet1/0/1

[SWD-smlk-group2] port ethernet 1/0/2 master

[SWD-smlk-group2] port ethernet 1/0/1 slave

# Smart Link2中配置抢占模式为角色抢占模式并使能发送Flush报文的功能,并指定发送Flush报文的控制VLANVLAN 30

[SWD-smlk-group2]preemption mode role

[SWD-smlk-group2] flush enable control-vlan 30

[SWD-smlk-group2] quit

# 重新开启端口Ethernet1/0/1Ethernet1/0/2

[SWD] interface ethernet 1/0/1

[SWD-Ethernet1/0/1] undo shutdown

[SWD-Ethernet1/0/1] quit

[SWD] interface ethernet 1/0/2

[SWD-Ethernet1/0/2] undo shutdown

[SWD-Ethernet1/0/2] quit

# 把端口Ethernet1/0/3加入VLAN 10

[SWD] interface ethernet 1/0/3

[SWD-Ethernet1/0/3] port access vlan 10

[SWD-Ethernet1/0/3] quit

2、配置SWB

# 创建VLAN 130

system-view

[SWB] vlan 1 to 30

# 将端口Ethernet1/0/1配置为Trunk端口且允许VLAN 130通过,在该端口上使能接收Flush报文的功能,并指定接收Flush报文的控制VLANVLAN 2030

[SWB] interface ethernet 1/0/1

[SWB-Ethernet1/0/1] port link-type trunk

[SWB-Ethernet1/0/1] port trunk permit vlan 1 to 30

[SWB-Ethernet1/0/1] smart-link flush enable control-vlan 20 30

[SWB-Ethernet1/0/1] quit

# 将端口Ethernet1/0/2配置为Trunk端口且允许VLAN 130通过,在该端口上关闭生成树协议,使能接收Flush报文的功能,并指定接收Flush报文的控制VLANVLAN 2030

[SWB] interface ethernet 1/0/2

[SWB-Ethernet1/0/2] port link-type trunk

[SWB-Ethernet1/0/2] port trunk permit vlan 1 to 30

[SWB-Ethernet1/0/2] undo stp enable

[SWB-Ethernet1/0/2] smart-link flush enable control-vlan 20 30

[SWB-Ethernet1/0/2] quit

3、配置SWC

# 创建VLAN 130

system-view

[SWC] vlan 1 to 30

# 将端口Ethernet1/0/1配置为Trunk端口且允许VLAN 130通过,在该端口上使能接收Flush报文的功能,并指定接收Flush报文的控制VLANVLAN 2030

[SWC] interface ethernet 1/0/1

[SWC-Ethernet1/0/1] port link-type trunk

[SWC-Ethernet1/0/1] port trunk permit vlan 1 to 30

[SWC-Ethernet1/0/1] smart-link flush enable control-vlan 20 30

[SWC-Ethernet1/0/1] quit

# 将端口Ethernet1/0/2配置为Trunk端口且允许VLAN 130通过,在该端口上关闭生成树协议,使能接收Flush报文的功能,并指定接收Flush报文的控制VLANVLAN 2030

[SWC] interface ethernet 1/0/2

[SWC-Ethernet1/0/2] port link-type trunk

[SWC-Ethernet1/0/2] port trunk permit vlan 1 to 30

[SWC-Ethernet1/0/2] undo stp enable

[SWC-Ethernet1/0/2] smart-link flush enable control-vlan 20 30

[SWC-Ethernet1/0/2] quit

4、配置SWA

# 创建VLAN 130

system-view

[SWA] vlan 1 to 30

# 将端口Ethernet1/0/1配置为Trunk端口且允许VLAN 130通过,在该端口上使能接收Flush报文的功能,并指定接收Flush报文的控制VLANVLAN 2030

[SWA] interface ethernet 1/0/1

[SWA-Ethernet1/0/1] port link-type trunk

[SWA-Ethernet1/0/1] port trunk permit vlan 1 to 30

[SWA-Ethernet1/0/1] smart-link flush enable control-vlan 20 30

[SWA-Ethernet1/0/1] quit

# 将端口Ethernet1/0/2配置为Trunk端口且允许VLAN 130通过,在该端口上关闭生成树协议,使能接收Flush报文的功能,并指定接收Flush报文的控制VLANVLAN 2030

[SWA] interface ethernet 1/0/2

[SWA-Ethernet1/0/2] port link-type trunk

[SWA-Ethernet1/0/2] port trunk permit vlan 1 to 30

[SWA-Ethernet1/0/2] undo stp enable

[SWA-Ethernet1/0/2] smart-link flush enable control-vlan 20 30

[SWA-Ethernet1/0/2] quit

# 把端口Ethernet1/0/3加入VLAN 10并配置interface VLAN 10

[SWD] interface ethernet 1/0/3

[SWD-Ethernet1/0/3] port access vlan 10

[SWD-Ethernet1/0/3] quit

interface Vlan-interface10

[SWD-Vlan-interface10]ip address 192.168.0.254 24

5 验证配置结果

# 通过使用display smart-link group命令可以查看设备上Smart Link组的信息。

# 查看SWDSmart Link组的信息。

[SWD]display smart-link group all

 Smart link group 1 information:

 Device ID: c4ca-d9db-8aff

 Preemption mode: ROLE

 Preemption delay: 1(s)

 Control VLAN: 20

 Protected VLAN: Reference Instance 1

 Member    Role    State    Flush-count Last-flush-time

 -----------------------------------------------------------------------------

 Ethernet1/0/1    MASTER  ACTIVE   2           03:21:45 2010/01/01

 Ethernet1/0/2    SLAVE   STANDBY  1           02:34:35 2010/01/01

 Smart link group 2 information:

 Device ID: c4ca-d9db-8aff

 Preemption mode: ROLE

 Preemption delay: 1(s)

 Control VLAN: 30

 Protected VLAN: Reference Instance 2

 Member     Role    State    Flush-count Last-flush-time

 -----------------------------------------------------------------------------

 Ethernet1/0/2    MASTER  ACTIVE   1           02:48:40 2010/01/01

 Ethernet1/0/1    SLAVE   STANDBY  0           NA

#通过使用display smart-link flush命令可以查看设备上收到的Flush报文信息。

# 查看SWB上收到的Flush报文信息(注意只有发生切换时才会产生Flush报文)

[SWB]display smart-link flush

 Received flush packets                       : 1

 Receiving interface of the last flush packet : Ethernet1/0/1

 Receiving time of the last flush packet      : 02:34:34 2010/01/01

 Device ID of the last flush packet           : c4ca-d9db-8aff

 Control VLAN of the last flush packet        : 20

四、  配置关键点:

1、如果欲配置某端口为Smart Link组的成员端口(主端口或从端口):

需先手工关闭该端口,并待Smart Link组配置完成后再开启该端口,以避免形成环路,导致广播风暴;

需先关闭该端口的生成树协议和RRPP功能,并确保该端口不是聚合成员端口或业务环回组成员端口。

2、需要为不同的Smart Link组配置不同的控制VLAN

3 用户需要配置保证控制VLAN存在,且Smart Link组的端口允许控制VLAN的报文通过。

4 Smart Link组的控制VLAN应同时为该Smart Link组的保护VLAN,且不要将已配置为控制VLANVLAN删除,否则会影响Flush报文的发送。


若您有关于案例的建议,请反馈:

作者在2019-06-12对此案例进行了修订
0 个评论

该案例暂时没有网友评论

编辑评论

举报

×

侵犯我的权益 >
对根叔知了社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到pub.zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 pub.zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到pub.zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔知了社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明

提出建议

    +

亲~登录后才可以操作哦!

确定

亲~检测到您登陆的账号未在http://hclhub.h3c.com进行注册

注册后可访问此模块

跳转hclhub

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作