• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 全部
  • 全部
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
高级搜索

7506E与CISCO交换机MSTP协议对接配置

2011-10-27发表
  • 5关注
  • 3收藏,3811浏览
粉丝: 关注:

7506ECISCO交换机MSTP协议对接配置

 

一、 组网需求:

安徽某客户要求我司75E交换机与CISCO交换机MSTP协议对接,并具备防环和链路备份功能。

二、 组网图:

客户网络架构如下图,两台75E各配置一块安全插卡,所有PC网关设置在FW插卡上,安全插卡划分子接口方式。两台75E作为网络核心交换机,通过vlan-interface Vlan100三层接口与3750互联。通过trunk方式与接入层2960交换机互联。目前275EFW插卡没有开启STP协议,3CISCO交换机运行PVST协议。

三、 配置步骤:

75E-1设备:

//开启STP协议,并将STP配置为mstp模式

stp enable

stp mode mstp

 

//配置MSTP实例,在这台交换机上将instance 0 设置为主

stp region-configuration

region-name h3c

revision-level 1

instance 0 vlan 1 to 4094

active region-configuration

#

stp instance 0 root primary

 

 

//配置与CISCO设备对接时需要修改的参数

stp bpdu-protection

stp pathcost-standard dot1t

stp timer-factor 1

stp no-agreement-check

 

#

stp config-digest-snooping

#

//接口基本配置,并开启摘要侦听功能

interface GigabitEthernet5/0/1

 port link-mode bridge

port access vlan 100

stp config-digest-snooping

#

interface GigabitEthernet5/0/4

 port link-mode bridge

 port link-type trunk

 port trunk permit vlan all

stp config-digest-snooping

 

#

interface GigabitEthernet5/0/5

 port link-mode bridge

 port link-type trunk

 port trunk permit vlan all

 speed 1000

 duplex full

stp config-digest-snooping

 

75E-2设备:

//开启STP协议,并将STP配置为mstp模式

stp enable

stp mode mstp

 

//配置MSTP实例,在这台交换机上将instance 0 设置为备

stp region-configuration

region-name h3c

revision-level 1

instance 0 vlan 1 to 4094

active region-configuration

#

stp instance 0 root secondary

 

 

//配置与CISCO设备对接时需要修改的参数

stp bpdu-protection

stp pathcost-standard dot1t

stp timer-factor 1

stp no-agreement-check

 

#

stp config-digest-snooping

#

//接口基本配置,并开启摘要侦听功能

interface GigabitEthernet5/0/1

 port link-mode bridge

port access vlan 100

stp config-digest-snooping

#

interface GigabitEthernet5/0/4

 port link-mode bridge

 port link-type trunk

 port trunk permit vlan all

stp config-digest-snooping

 

#

interface GigabitEthernet5/0/5

 port link-mode bridge

 port link-type trunk

 port trunk permit vlan all

 speed 1000

 duplex full

stp config-digest-snooping

 

安全插卡:

     因为安全插卡运行在三层模式,所以不需要开启STP协议。

3750配置:

//STP配置mst模式,并将pathcost配置long

spanning-tree mode mst

spanning-treee pathcost method long

 

//配置mst实例

spanning-tree mst configuration

name h3c

revision 1

instance 0 vlan 1-4094

 

 

//接口基本配置,并配置MST开销值为20000

interface g1/0/27

switchport access vlan 100

switchport mode access

spanning-tree mst 0 cost 20000

#

interface g1/0/28

switchport access vlan 100

switchport mode access

spanning-tree mst 0 cost 20000

 

2960-1配置:

//STP配置mst模式,并将pathcost配置long

spanning-tree mode mst

spanning-treee pathcost method long

 

//配置mst实例

spanning-tree mst configuration

name h3c

revision 1

instance 0 vlan 1-4094

 

 

//接口基本配置,并配置MST开销值为20000

interface g1/0/49

switchport trunk allowed vlan 2,10

switchport mode trunk

spanning-tree mst 0 cost 20000

#

interface g1/0/51

switchport access vlan 100

switchport mode access

spanning-tree mst 0 cost 20000

 

      

2960-2配置:

//STP配置mst模式,并将pathcost配置long

spanning-tree mode mst

spanning-treee pathcost method long

 

//配置mst实例

spanning-tree mst configuration

name h3c

revision 1

instance 0 vlan 1-4094

 

 

//接口基本配置,并配置MST开销值为20000

interface g1/0/49

switchport trunk allowed vlan 2,10

switchport mode trunk

spanning-tree mst 0 cost 20000

#

interface g1/0/51

switchport access vlan 100

switchport mode access

spanning-tree mst 0 cost 20000

         

四、 配置关键点:

配置3750交换机为MST模式后,G1/0/27端口转发数据,G1/0/28端口处于阻塞状态,MSTP协议运行正常。当配置2960-1交换机为MST模式后,2960-1交换机上联到75E的两个端口都会处于阻塞状态。拔掉其中一根网线后,剩余一个端口还是处于阻塞状态。将2960-2交换机配置为mst模式或者关闭stp协议,2960-1两端口状态就正常了,一个转发数据,一个处于阻塞状态。当网络中有多台cisco交换机,并且都是通过trunk方式说核心互联时,要先将运行PVSTcisco设备隔离或者关闭STP协议,然后逐一配置为mst模式。因为CISCO交找机运行mst模式时收到pvst BPDU报文时会将收到此报文的端口置于阻塞状态。此案例中375075E是三层互联,3750收不到PVST BPDU报文,所以3750不会被2960交换机PVST报文影响。

 

 

0 个评论

该案例暂时没有网友评论

编辑评论

举报

×

侵犯我的权益 >
对根叔知了社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔知了社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明

提出建议

    +
<

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作