• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 漏洞说明
  • 全部
  • 全部
  • 大数据引擎
  • 知了引擎
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
搜索引擎
匹配模式
高级搜索

S3X00V2/S3110系列交换机本地认证用户授权命令配置方法

  • 0关注
  • 0收藏 1187浏览
闫宁 九段
粉丝:32人 关注:0人

组网及说明

1 配置需求或说明

1.1适用产品系列

本案例适用于如S3100V2-26TP-SIS3100V2-26TP-EIS3600V2-28TP-EIS3600V2-28TP-SIS3110-26TP-PWRS3100V2S3600V23110系列的交换机。

1.2配置需求

Switch管理VLANVLAN2,开启了Telnet功能。Telnet用户主机与Switch相连,需要实现Switch对不同的Telnet用户进行分权管理。其中,admin用户拥有最高管理权限,user1用户只有修改、删除vlan虚接口地址的权限。

2 组网图



配置步骤

配置步骤

3.1 Switch配置

#设置交换机系统名称为Switch

system-view

[H3C]sysname Switch

# 创建管理VLAN

[Switch] vlan 2

[Switch-vlan2]quit

# 设置交换机管理地址。

[Switch]interface Vlan-interface 2

[Switch-Vlan-interface2]ip address 1.1.1.1 255.255.255.0

[Switch-Vlan-interface2]quit

# 设置交换机连接Router的接口加入VLAN2

[Switch]interface g1/0/1

[Switch-GigabitEthernet1/0/1]port link-type access

[Switch-GigabitEthernet1/0/1]port access vlan 2

[Switch-GigabitEthernet1/0/1]quit

# 开启telnet功能。

[Switch]telnet server enable

# 配置使用帐号+密码方式进行telnet认证。

[Switch] user-interface vty 0 4

[Switch-ui-vty0-4]authentication-mode scheme

[Switch-ui-vty0-4]quit

# 创建admin帐号。

[Switch]local-user admin

# 配置帐号的服务类型为telnet

[Switch-luser-admin]service-type telnet

# 配置帐号的密码为admin

[Switch-luser-admin]password simple admin

#赋予帐号最高权限。

[Switch-luser-admin] authorization-attribute level 3

[Switch-luser-admin]quit

# 配置level 0级别只能使用pingtracertdisplay interface相关命令

[Switch]command-privilege level 0 view shell system-view

[Switch]command-privilege level 0 view system interface vlan-interface 2     //这里的数字2一定要写,随意写一个数字就行。否则vlan-interface 后无法跟其他的参数

[Switch]command-privilege level 0 view vlan-interface ip address 1.1.1.1 255.255.255.0    //这里的地址和掩码一定要写,随意写一个就行。否则ip address 后无法跟其他的参数

[Switch]command-privilege level 0 view vlan-interface undo ip address

[Switch]command-privilege level 0 view vlan-interface quit

[Switch]command-privilege level 0 view system quit

[Switch]command-privilege level 0 view shell save force

# 创建账号user1

[Switch]local-user user1

# 配置帐号的服务类型为telnet                                        

[Switch-luser-user1]service-type telnet

# 配置帐号的密码为user1

[Switch-luser-user1]password simple user1

#赋予帐号拥有level0的权限。

[Switch-luser-user1]authorization-attribute level 0

[Switch-luser-user1]quit

#保存配置

[Switch]save force

3.5 Router配置

#设置交换机系统名称为Router

[H3C]sysname Router

#Router配置接口地址,保证能和Switch互通

[Router]interface GigabitEthernet 0/0

[Router-GigabitEthernet0/0]ip address 1.1.1.2 255.255.255.0

[Router-GigabitEthernet0/0]quit

#保存配置

[Router]save force

 

配置关键点

该案例对您是否有帮助:

您的评价:1

若您有关于案例的建议,请反馈:

0 个评论

该案例暂时没有网友评论

编辑评论

举报

×

侵犯我的权益 >
对根叔知了社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到pub.zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 pub.zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到pub.zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔知了社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明

提出建议

    +

亲~登录后才可以操作哦!

确定

亲~检测到您登陆的账号未在http://hclhub.h3c.com进行注册

注册后可访问此模块

跳转hclhub

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作