• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 全部
  • 全部
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
高级搜索

WAC360、361系列产品本地MAC认证配置案例(命令行版)

2019-08-20 发表
  • 0关注
  • 0收藏,370浏览
骆翔 九段
粉丝:6人 关注:0人

组网及说明

1.1  适用产品系列

本案例适用于WAC360WAC361系列的AC

1.2  配置需求及实现的效果

无线电脑连接SSIDservice后,无线电脑终端通过在小贝产品上进行的MAC认证配置,获取到网关vlan200ip地址:192.168.200.0 /24,实现对无线用户的统一管理和认证功能。现使用WAC361作为无线网络的网关设备。通过对终端设备的MAC进行认证,达到对用户访问进行控制的目的。

2 组网图


配置步骤

3.1  在无线控制器上配置相关VLAN及对应虚接口的地址

提示:ap注册和无线配置详细步骤参考:2.2.05 WAC361系列产品AP二层注册、无线加密配置方法(命令行版)》

H3C上配置相关VLAN及对应虚接口的地址,并放通对应接口。

#创建VLAN100及其对应的VLAN接口,为该接口配置IP地址192.168.100./24。开启dhcp服务,AP使用该VLAN进行上线。

<H3C> system-view

[H3C] vlan 100

[H3C-vlan100] quit

[H3C] interface Vlan-interface 100

[H3C-Vlan-interface100] ip address 192.168.100.1 24

[H3C-Vlan-interface100] quit

#创建VLAN200及其对应的VLAN接口,为该接口配置IP地址192.168.200.1/24。开启dhcp服务,终端使用该VLAN接入无线网络。

[H3C] vlan 200

[H3C-vlan200]quit

[H3C] interface Vlan-interface 200

[H3C-Vlan-interface200] ip address 192.168.200.1 24

[H3C-Vlan-interface200] quit

配置ACSwitch相连的接口GigabitEthernet1/0/1Trunk类型,禁止VLAN 1报文通过,允许VLAN 100VLAN 200通过,设置当前Trunk口的PVID100

[H3C] interface gigabitethernet1/0/1

[H3C -GigabitEthernet1/0/1] port link-type trunk

[H3C -GigabitEthernet1/0/1] undo port trunk permit vlan 1

[H3C -GigabitEthernet1/0/1] port trunk permit vlan 100 200

[H3C -GigabitEthernet1/0/1] port trunk pvid vlan 100

[H3C -GigabitEthernet1/0/1]quit

#开启DHCP服务器功能

[H3C]dhcp enable

#配置地址池vlan100,为AP分配192.168.100.0/24网段

[H3C]dhcp server ip-pool vlan100

[H3C-dhcp-pool-1] network 192.168.100.0 mask 255.255.255.0

#分配网关和DNS服务器地址,网关是192.168.100.1DNS服务器是114.114.114.114

[H3C-dhcp-pool-1] gateway-list 192.168.100.1

[H3C-dhcp-pool-1] dns-list 114.114.114.114

[H3C-dhcp-pool-1] quit

#配置地址池vlan200,为终端分配192.168.200.0/20网段

[H3C]dhcp server ip-pool vlan200

[H3C-dhcp-pool-1] network 192.168.200.0 mask 255.255.255.0

#分配网关和DNS服务器地址,网关是192.168.200.1DNS服务器是114.114.114.114

[H3C-dhcp-pool-1]gateway-list 192.168.200.1

[H3C-dhcp-pool-1]dns-list 114.114.114.114

[H3C-dhcp-pool-1]quit

3.1  配置本地认证域

#创建一个名称为local-mac的认证域,为lan-access用户配置认证方法为local

[H3C] domain local-mac

[H3C-isp-local-mac] authentication lan-access local

#配置用户闲置切断时间为15分钟,闲置切断时间内产生的流量为1024字节。

[H3C-isp-local-mac] authorization-attribute idle-cut 15 1024

[H3C-isp-local-mac] quit

3.2  配置WLAN-ESS接口

#创建一个WLAN-ESS的接口,配置为终端提供的vlan200,配置认证的方式为MAC认证,指定认证域为local-mac

[H3C] interface WLAN-ESS1

[H3C-WLAN-ESS1] port link-type hybrid

[H3C-WLAN-ESS1] undo port hybrid vlan 1

[H3C-WLAN-ESS1] port hybrid vlan 200 untagged

[H3C-WLAN-ESS1] port hybrid pvid vlan 200

[H3C-WLAN-ESS1] port-security port-mode mac-authentication

[H3C-WLAN-ESS1]mac-authentication domain local-mac

[H3C-WLAN-ESS1] quit

3.3  配置本地用户

配置一个网络接入类的本地用户,名称为客户端的MAC地址b0eb57595cea,密码为明文密码b0eb57595cea(同账号),并指定用户可以使用lan-access服务。

[H3C] local-user b0eb57595cea

[H3C-luser-network-b0eb57595cea] password simple b0eb57595cea

[H3C-luser-network-b0eb57595cea] service-type lan-access

[H3C-luser-network-b0eb57595cea] quit

3.4  配置本地MAC地址认证的用户名格式

#配置MAC地址认证的用户名格式为小写不带横杠(该配置为缺省配置)。

[H3C] mac-authentication user-name-format mac-address without-hyphen lowercase

3.5  配置无线服务

#创建无线服务模板1,并进入无线服务模板视图。

[H3C] wlan service-template 1 clear

#配置SSIDservice

[H3C-wlan-st-1] ssid service

#绑定WLAN-ESS接口,并开启服务模板。

[H3C-wlan-st-1] bind WLAN-ESS 1

[H3C-wlan-st-1] service-template enable

[H3C-wlan-st-1] quit

#创建AP,配置AP名称为officeap,型号名称选择WAP722S,并配置序列号

2…………………1。提示:此处根据实际的AP序列号来填写。

[H3C] wlan ap officeap model WAP722S

[H3C-wlan-ap-officeap] serial-id 2…………………1

#进入Radio 2视图,绑定服务模板1

[H3C-wlan-ap-office] radio 2

#将无线服务模板1绑定到radio 2,并开启射频。

[H3C-wlan-ap-officeap-radio-2] service-template 1

[H3C-wlan-ap-officeap-radio-2] radio enable

[H3C-wlan-ap-officeap-radio-2] quit

 

3.6  配置Switch

#创建VLAN 100,其中VLAN 100用于转发ACAPCAPWAP隧道内的流量,VLAN 200用于转发Client无线报文。

<H3C> system-view

[H3C] vlan 100

[H3C-vlan100] quit

#配置SwitchWAC361相连的GigabitEthernet1/0/1接口的属性为Trunk,禁止VLAN 1报文通过,允许VLAN 100通过,配置当前Trunk口的PVID100

[H3C] interface gigabitethernet1/0/1

[H3C-GigabitEthernet1/0/1] port link-type trunk

[H3C-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[H3C-GigabitEthernet1/0/1] port trunk permit vlan 100

[H3C-GigabitEthernet1/0/1] port trunk pvid vlan 100

[H3C-GigabitEthernet1/0/1] quit

#配置SwitchAP相连的GigabitEthernet1/0/2接口属性为Access,并允许VLAN 100通过

[H3C] interface gigabitethernet1/0/2

[H3C-GigabitEthernet1/0/2] port link-type access

[H3C-GigabitEthernet1/0/2] port access vlan 100

#开启PoE接口远程供电功能

[H3C-GigabitEthernet1/0/2] poe enable

[H3C-GigabitEthernet1/0/2] quit

3.7  实验结果验证

#无线用户Client通过连接到WLAN网络并进行本地MAC认证,用户在通过认证后。

通过执行以下显示命令查看WAC上生成的无线在线用户信息。

<H3C>dis wlan client

 Total Number of Clients: 1

                              Client Information

 SSID: service

--------------------------------------------------------------------------------

MAC Address    User Name            APID/RID IP Address      IPv6 Address   VLAN

--------------------------------------------------------------------------------

b0eb-5759-5cea b0eb57595cea         1   /1   192.168.200.2   -NA-           200

--------------------------------------------------------------------------------

#未通过认证的设备不能不能进行接入。


配置关键点

0 个评论

该案例暂时没有网友评论

编辑评论

举报

×

侵犯我的权益 >
对根叔知了社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔知了社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明

提出建议

    +
<

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作