• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 全部
  • 全部
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
高级搜索

H3C 无线控制器三层注册典型配置举例(V7)

2016-06-21 发表
  • 1关注
  • 6收藏,3887浏览
粉丝:9人 关注:3人

本文档介绍APAC间通过三层网络完成注册的配置举例。

本文档适用于使用Comware V7软件版本的无线控制器和接入点产品,不严格与具体硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解WLAN接入相关特性。

1所示,集中式转发架构下,无线客户端Client、有线客户端Host通过L3 switchAC相连,L3 switchDHCP serverAPClientHost分配IP地址。需要实现无线客户端Client通过AP连接到AC上,并能与有线客户端Host互相访问,具体要求如下:

·              无线客户端Client通过VLAN 200接入网络,有线客户端Host通过VLAN 300接入网络;

·              AC属于VLAN 100AP属于VLAN 400ACAP之间跨三层网络建立连接。

1.1  配置思路

·              L3 switch上开启DHCP server功能,AP、无线客户端Client和有线客户端Host都能通过DHCP server自动获取IP地址。

·              L3 switchAC上配置到达对端网段的静态路由。

·              AC上配置无线服务,确保Client可以通过配置的无线服务接入网络,并访问Host

1.2  配置步骤

1.2.1  配置AC

(1)      配置AC接口

# 创建VLAN 100及其对应的VLAN接口,并为该接口配置IP地址。AP将获取该IP地址与AC建立CAPWAP隧道。

system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface100

[AC-Vlan-interface100] ip address 192.168.10.1 255.255.255.0

[AC-Vlan-interface100] quit

# 创建VLAN 200AC需要使用该VLAN转发无线客户端数据报文。

[AC] vlan 200

[AC-vlan200] quit

# 配置ACL3 switch相连的接口GigabitEthernet1/0/1Trunk类型,禁止VLAN 1报文通过,允许VLAN 100VLAN 200通过。

[AC] interface gigabitethernet 1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

[AC-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[AC-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[AC-GigabitEthernet1/0/1] quit

(2)      配置三层路由

# 配置AC192.168.40.0网段的静态路由,指定下一跳的IP地址为192.168.10.83

[AC] ip route-static 192.168.40.0 24 192.168.10.83

(3)      配置无线服务

# 创建无线服务模板1,并进入无线服务模板视图。

[AC] wlan service-template 1

# 配置SSIDservice

[AC-wlan-st-1] ssid service

# 使能服务模板。

[AC-wlan-st-1] service-template enable

[AC-wlan-st-1] quit

(4)      配置AP

# 创建手工AP,名称为officeap,型号名称为WA4320i-ACN

[AC] wlan ap officeap model WA4320i-ACN

# 设置AP的序列号为210235A1GQB147031200

[AC-wlan-ap-officeap] serial-id 210235A1GQB147031200

# 进入APRadio 1视图,并将无线服务模板1绑定到Radio 1上,并指定客户端上线的VLANVLAN 200

[AC-wlan-ap-officeap] radio 1

[AC-wlan-ap-officeap-radio-1] service-template 1 vlan 200

# 开启Radio 1射频功能

[AC-wlan-ap-officeap-radio-1] radio enable

[AC-wlan-ap-officeap-radio-1] return

1.2.2  配置L3 switch

(1)      配置L3 switch的接口

# 创建VLAN 400VLAN 100,并配置IP地址,用于转发ACAP间的CAPWAP隧道内的流量。

system-view

[L3 switch] vlan 100

[L3 switch-vlan100] quit

[L3 switch] interface vlan-interface 100

[L3 switch-Vlan-interface100] ip address 192.168.10.83 255.255.255.0 

[L3 switch-Vlan-interface100] quit

[L3 switch] vlan 400

[L3 switch-vlan400] quit

[L3 switch] interface vlan-interface 400

[L3 switch-Vlan-interface400] ip address 192.168.40.1 255.255.255.0 

[L3 switch-Vlan-interface400] quit

# 创建VLAN 200,并为该接口配置IP地址。Client使用该VLAN接入无线网络

[L3 switch] vlan 200

[L3 switch-vlan200] quit

[L3 switch] interface vlan-interface 200

[L3 switch-Vlan-interface200] ip address 192.168.20.1 255.255.255.0 

[L3 switch-Vlan-interface200] quit

# 创建VLAN 300,并为该接口配置IP地址。Host使用VLANAC建立连接。

[L3 switch] vlan 300

[L3 switch-vlan300] quit

[L3 switch] interface vlan-interface 300

[L3 switch-Vlan-interface300] ip address 192.168.30.1 255.255.255.0 

[L3 switch-Vlan-interface300] quit

# 配置L3 switchAC相连的接口GigabitEthernet1/0/1Trunk类型,允许VLAN100VLAN 200通过。

[L3 switch] interface gigabitEthernet 1/0/1

[L3 switch-GigabitEthernet1/0/1] port link-type trunk

[L3 switch-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[L3 switch-GigabitEthernet1/0/1] quit

# 配置L3 switchAP相连的接口GigabitEthernet1/0/2Trunk类型,禁止VLAN 1报文通过,允许VLAN 400VLAN 100通过,当前Trunk口的PVID400

[L3 switch] interfac gigabitEthernet 1/0/2

[L3 switch-GigabitEthernet1/0/2] port link-type trunk 

[L3 switch-GigabitEthernet1/0/2] undo port trunk permit vlan 1

[L3 switch-GigabitEthernet1/0/2] port trunk permit vlan 200 400

[L3 switch-GigabitEthernet1/0/2] port trunk pvid vlan 400

[L3 switch-GigabitEthernet1/0/2] quit

# 配置L3 switchHost相连的接口GigabitEthernet1/0/3Access类型,允许VLAN 300通过。

[L3 switch] interfac gigabitEthernet 1/0/3

[L3 switch-GigabitEthernet1/0/3] port access vlan 300

[L3 switch-GigabitEthernet1/0/3] quit

(2)      配置DHCP server

# 开启DHCP server功能。

[L3 switch] dhcp enable

# 配置DHCP地址池1AP分配地址范围为192.168.40.0/24,网关地址为192.168.40.1

[L3 switch] dhcp server ip-pool 1

[L3 switch-dhcp-pool-1] network 192.168.40.0 mask 255.255.255.0

[L3 switch-dhcp-pool-1] gateway-list 192.168.40.1

# 配置DHCP Option43的内容AC的十六进制IP地址。

[L3 switch-dhcp-pool-1] option 43 hex 8007000001c0a80a01

[L3 switch-dhcp-pool-1] quit

# 配置DHCP地址池2Client分配地址范围为192.168.20.0/24,网关地址为192.168.20.1

[L3 switch] dhcp server ip-pool 2

[L3 switch-dhcp-pool-2] network 192.168.20.0 mask 255.255.255.0 

[L3 switch-dhcp-pool-2] gateway-list 192.168.20.1

[L3 switch-dhcp-pool-2] quit

# 配置DHCP地址池3Host分配地址范围为192.168.30.0 /24,网关地址为192.168.30.1

[L3 switch] dhcp server ip-pool 3

[L3 switch-dhcp-pool-3] network 192.168.30.0 mask 255.255.255.0

[L3 switch-dhcp-pool-3] gateway-list 192.168.30.1 

[L3 switch-dhcp-pool-3] quit

1.3  验证配置

(1)      AC上查看到AP注册信息

# AC上使用命令display wlan ap all查看AP,可以看到AP的状态是R/M,表明AP已经成功注册到AC

display wlan ap all                             

Total number of APs: 1                                                         

Total number of connected APs: 1                                               

Total number of connected manual APs: 1                                         

Total number of connected auto APs: 0                                          

Total number of connected anchor APs: 0                                        

Maximum supported APs: 3072                                                     

Remaining APs: 3071                                                            

Fit APs activated by license: 512                                              

Remaining fit APs: 511                                                          

WTUs activated by license: 2500                                                

Remaining WTUs: 2500                                                           

                                                                               

                                 AP information                                

 State : I = Idle,      J  = Join,       JA = JoinAck,    IL = ImageLoad       

         C = Config,    DC = DataCheck,  R  = Run,   M = Master,  B = Backup   

                                                                                

AP name                AP ID   State   Model             Serial ID             

-----------------------------------------------------------------------

officeap               1        R/M     WA4320i-ACN      210235A1GQB147031200 

(2)      AC上查看Client信息

# AC上使用命令display wlan client查看在线Client,可以看到Client已经连接到APradio1

display wlan client

Total number of clients: 1

                                                                                

MAC address    Username             APID/RID  IP address                 VLAN ID

90b9-311a-bef6 N/A                     1/1     192.168.20.3               200

(3)      HostClient可以相互ping

# Client通过DHCP server获取到IP地址192.168.20.3,在Hostping ClientIP地址可以ping通。同理,在Clientping HostIP地址也能ping通,不再赘述。

C:\Users\system32>ping 192.168.20.3 -t

 

Pinging 192.168.20.3 with 32 bytes of data:

Reply from 192.168.20.3: bytes=32 time=2470ms TTL=63

Reply from 192.168.20.3: bytes=32 time=2ms TTL=63

Reply from 192.168.20.3: bytes=32 time=1427ms TTL=63

Reply from 192.168.20.3: bytes=32 time=2ms TTL=63

Reply from 192.168.20.3: bytes=32 time=86ms TTL=63

Reply from 192.168.20.3: bytes=32 time=142ms TTL=63

Reply from 192.168.20.3: bytes=32 time=561ms TTL=63

Reply from 192.168.20.3: bytes=32 time=84ms TTL=63

Reply from 192.168.20.3: bytes=32 time=465ms TTL=63

Reply from 192.168.20.3: bytes=32 time=114ms TTL=63

Reply from 192.168.20.3: bytes=32 time=124ms TTL=63

Reply from 192.168.20.3: bytes=32 time=446ms TTL=63

 

Ping statistics for 192.168.20.3:

    Packets: Sent = 12, Received = 12, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

    Minimum = 2ms, Maximum = 2470ms, Average = 495ms

Control-C

^C

C:\Users\system32>

1.4  配置文件

·              AC

#                                                                              

vlan 100                                                                       

# 

vlan 200  

#

interface Vlan-interface100                                                     

 ip address 192.168.10.1 255.255.255.0                                         

#                                                                                 

wlan service-template 1                                                        

 ssid service                                                                  

 service-template enable                                                       

#                                                                              

interface GigabitEthernet1/0/1                                                 

 port link-type trunk                                                          

 port trunk permit vlan 100 200                                                

#                                                                               

ip route-static 192.168.40.0 24 192.168.10.83                                 

#                                                                              

wlan ap officeap model WA4320i-ACN                                              

 serial-id 210235A1GQB147031200                                                

 vlan 1                                                                        

 radio 1                                                                       

  radio enable                                                                 

  service-template 1 vlan 200                                                  

 radio 2                                                                        

#                                                                              

·              L3 switch

#                                                                              

 dhcp enable                                                                    

#                                                                              

vlan 100                                                                       

#                                                                               

vlan 200                                                                       

#                                                                              

vlan 300                                                                        

#                                                                              

vlan 400                                                                       

#                                                                               

dhcp server ip-pool 1                                                          

 gateway-list 192.168.40.1                                                     

 network 192.168.40.0 mask 255.255.255.0                                        

 option 43 hex 8007000001c0a80a01                                              

#                                                                              

dhcp server ip-pool 2                                                          

 gateway-list 192.168.20.1                                                     

 network 192.168.20.0 mask 255.255.255.0                                       

#                                                                              

dhcp server ip-pool 3                                                          

 gateway-list 192.168.30.1                                                     

 network 192.168.30.0 mask 255.255.255.0                                       

#                                                                               

interface Vlan-interface100                                                    

 ip address 192.168.10.83 255.255.255.0                                        

#                                                                               

interface Vlan-interface200                                                    

 ip address 192.168.20.1 255.255.255.0                                         

#                                                                               

interface Vlan-interface300                                                    

 ip address 192.168.30.1 255.255.255.0                                         

#                                                                               

interface Vlan-interface400                                                    

 ip address 192.168.40.1 255.255.255.0                                         

#                                                                               

interface GigabitEthernet1/0/1                                                 

 port link-type trunk                                                          

 undo port trunk permit vlan 1                                                 

 port trunk permit vlan 100 200                                                

#                                                                              

interface GigabitEthernet1/0/2                                                 

port link-type trunk                                                           

 undo port trunk permit vlan 1                                                 

 port trunk permit vlan 200 400                                                

 port trunk pvid vlan 400   

#                                                                               

interface GigabitEthernet1/0/3                                                 

 port access vlan 300                                                          

#                                                                              

·              配置AP的序列号时请确保该序列号与AP唯一对应,AP的序列号可以通过AP设备背面的标签获取。

·              配置L3 switchAP相连的接口禁止VLAN 1报文通过,以防止VLAN 1内报文过多

1 个评论
Relyon 三段
粉丝:0人 关注:0人

option 43 hex8007000001XXXXXXXX

8007000001这是干什么的?

如果我有两个AC呢,option 43 应该怎么写?

编辑评论

举报

×

侵犯我的权益 >
对根叔知了社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔知了社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明

提出建议

    +
<

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作