• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 全部
  • 全部
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
高级搜索

H3C无线控制器WLAN本地转发典型配置举例(V7)

2016-06-21 发表
  • -1关注 ,10909浏览
粉丝:9人 关注:3人

本文档介绍了WLAN本地转发典型配置举例。

本文档适用于使用Comware V7软件版本的无线控制器和接入点产品,不严格与具体硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解本地转发相关特性。

1所示,Switch作为DHCP服务器为APClient分配IP地址。现要求:在AC上配置本地转发功能,使Client的数据流量不经过AC,直接由AP转发。

1.1  配置思路

为了将APGigabitEthernet1/0/1接口加入本地转发的VLAN 200,需要AC下发map-configuration文件。

1.2  配置步骤

1. apcfg.txt的配置

apcfg.txt的内容,要求为文本文件,按照命令行配置的顺序编写文本文件上传至AC即可,ACAP关联后,通过map-configuration命令下发至AP生效。从而完成对AP的配置。

 

# apcfg.txt配置文件为:

system-view

vlan 200

quit

interface GigabitEthernet 1/0/1

port link-type trunk

port trunk permit vlan 200

2. 配置AC

(1)      配置AC的接口

# 创建VLAN 100及其对应的VLAN接口,并为该接口配置IP地址。AP将获取该IP地址与AC建立CAPWAP隧道。

system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 192.1.1.1 16

[AC-Vlan-interface100] quit

(2)      配置无线服务

# 创建无线服务模板1,并进入无线服务模板视图。

[AC] wlan service-template 1

# 配置SSIDservice

[AC-wlan-st-1] ssid service

# 配置本地转发模式,开启VLAN 200的本地转发功能。

[AC-wlan-st-1] client forwarding-location ap vlan 200

# 开启无线服务模板。

[AC-wlan-st-1] service-template enable

[AC-wlan-st-1] quit

(3)      配置AP

# 创建手工AP,名称为officeap,型号名称为WA4320i-ACN

[AC] wlan ap officeap model WA4320i-ACN

# 设置AP序列号为219801A0T78159E09083

[AC-wlan-ap-officeap] serial-id 219801A0T78159E09083

# 进入APRadio 2视图,并将无线服务模板1绑定到Radio 2上。

[AC-wlan-ap-officeap] radio 2

[AC-wlan-ap-officeap-radio-2] service-template 1 vlan 200

# 开启Radio 2的射频功能。

[AC-wlan-ap-officeap-radio-2] radio enable

[AC-wlan-ap-officeap-radio-2] quit

(4)      配置AP的配置文件

# AC上将配置文件apcfg.txt下发到AP

[AC-wlan-ap-officeap] map-configuration apcfg.txt

[AC-wlan-ap-officeap] quit

3. Switch的配置

(1)      配置Switch的接口

# 创建VLAN 100VLAN 200及其对应接口,并为该接口配置IP地址,其中VLAN 100用于转发ACAPCAPWAP隧道内的流量,VLAN 200用于转发Client无线报文。

system-view

[Switch] vlan 100

[Switch-vlan100] quit

[Switch] interface vlan-interface 100

[Switch-Vlan-interface100] ip address 192.1.1.2 16

[Switch-Vlan-interface100] quit

[Switch] vlan 200

[Switch-vlan200] quit

[Switch] interface vlan-interface 200

[Switch-Vlan-interface200] ip address 192.2.1.2 24

[Switch-Vlan-interface200] quit

# 配置SwitchAC相连的接口GigabitEthernet1/0/1Trunk类型,禁止VLAN 1报文通过,当前Trunk口的PVID100

[Switch] interface GigabitEthernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[Switch-GigabitEthernet1/0/1] port trunk pvid vlan 100

[Switch-GigabitEthernet1/0/1] quit

# 配置SwitchAP相连的接口GigabitEthernet1/0/2Trunk类型,禁止VLAN 1报文通过,允许VLAN 100VLAN 200通过,当前Trunk口的PVID100

[Switch] interface GigabitEthernet 1/0/2

[Switch-GigabitEthernet1/0/2] port link-type trunk

[Switch-GigabitEthernet1/0/2] undo port trunk permit vlan 1

[Switch-GigabitEthernet1/0/2] port trunk permit vlan 100 200

[Switch-GigabitEthernet1/0/2] port trunk pvid vlan 100

# 开启SwitchAP相连的接口GigabitEthernet1/0/2PoE供电功能。

[Switch-GigabitEthernet1/0/2] poe enable

[Switch-GigabitEthernet1/0/2] quit

(2)      配置DHCP服务

# 开启DHCP功能。

[Switch] dhcp enable

# 创建名为vlan100DHCP地址池,配置地址池动态分配的网段为192.1.0.0/16,网关地址为192.1.1.2,为AP分配IP地址。

[Switch] dhcp server ip-pool vlan100

[Switch-dhcp-pool-vlan100] network 192.1.0.0 mask 255.255.0.0

[Switch-dhcp-pool-vlan100] forbidden-ip 192.1.1.1

[Switch-dhcp-pool-vlan100] gateway-list 192.1.1.2

[Switch-dhcp-pool-vlan100] quit

# 创建名为vlan200DHCP地址池,配置地址池动态分配的网段为192.2.1.0/24,网关地址为192.2.1.2,为Client分配IP地址。

[Switch] dhcp server ip-pool vlan200

[Switch-dhcp-pool-vlan200] network 192.2.1.0 mask 255.255.255.0

[Switch-dhcp-pool-vlan200] forbidden-ip 192.2.1.1

[Switch-dhcp-pool-vlan200] gateway-list 192.2.1.2

[Switch-dhcp-pool-vlan200] quit

1.3  验证配置

# Client1Client2上线获取到地址分别是192.2.1.3192.2.1.4,通过抓包可以发现ICMP报文不需要经过ACAP间的隧道封装,直接转发。

图1 本地转发ICMP报文

 

1.4  配置文件

·              AC

#

Vlan 100

#

vlan 200

#

wlan service-template 1

 ssid service

 client forwarding-location ap vlan 200

 service-template enable

#

interface Vlan-interface100

 ip address 192.1.1.1 255.255.0.0

#

wlan ap officeap model WA4320i-ACN

 map-configuration flash:/apcfg.txt

 serial-id 219801A0T78159E09083

 radio 1

 radio 2

  radio enable

  service-template 1 vlan 200

#

·              Switch

#

 dhcp enable

#

vlan 100

#

vlan 200

#

dhcp server ip-pool vlan100

 gateway-list 192.1.1.2

 network 192.1.0.0 mask 255.255.0.0

 forbidden-ip 192.1.1.1

#

dhcp server ip-pool vlan200

gateway-list 192.2.1.2

 network 192.2.1.0 mask 255.255.255.0

 forbidden-ip 192.2.1.1

#

interface Vlan-interface100

 ip address 192.1.1.2 255.255.0.0

#

interface Vlan-interface200

 ip address 192.2.1.2 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-mode bridge

port link-type trunk

undo port trunk permit vlan 1

port trunk pvid vlan 100

#

interface GigabitEthernet1/0/2

 port link-mode bridge

port link-type trunk

undo port trunk permit vlan 1

 port trunk permit vlan 100 200

 port trunk pvid vlan 100

#

·              map-configuration文件的命令行后面不要出现Tab键或者空格,否则会出现该行配置不成功的情况。

·              AP的配置需要根据具体AP的型号和序列号进行配置。

1 个评论
粉丝:1人 关注:0人

DHCP 在交换机上,那么AC和switch相连接的口还用配置pvid 为100么?

编辑评论

举报

×

侵犯我的权益 >
对根叔知了社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔知了社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明

提出建议

    +

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作