• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 全部
  • 全部
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
高级搜索

MSR路由器BGP路由协议基础功能的配置

2006-09-08 发表
  • 0关注 ,175浏览
粉丝: 关注:

MSR路由器

BGP路由协议基础配置

 

关键字:MSR;BGP;基础配置

 

一、组网需求

RouterARouterB之间运行IBGPRouter BRouter C之间运行EBGP

设备清单:PC两台、MSR路由器3

二、组网图:

三、配置步骤:

选用设备和版本:MSRVersion 5.20, Beta 1105

Router A 配置

//配置router idloopback 0 接口地址一样

#

router-id 1.1.1.1

#

//配置loopback0接口地址

interface GigabitEthernet0/0

ip address 20.2.2.1 255.255.255.252

#

interface GigabitEthernet0/1

 ip address 10.1.1.1 255.255.255.0

#

interface Loopback0

 ip address 1.1.1.1 255.255.255.255

#

//启动BGPAS100

bgp 100

undo synchronization

//将路由表中10.1.1.0/24网段路由发布出去

network 10.1.1.0 255.255.255.0

//配置组“in”,类型为internal

 group in internal

//指定IBGP邻居

 peer 2.2.2.2 group in

 //使用loopback0建立IBGP连接

 peer in connect-interface LoopBack0

#

 //静态路由保证内部各网段地址互通,可以使用OSPF/ISIS/RIPIGP替代

 ip route-static 2.2.2.2 255.255.255.255 20.2.2.2

#

Router B 配置

#

router-id 2.2.2.2

#

interface GigabitEthernet0/0

 ip address 20.2.2.2 255.255.255.252

#

interface GigabitEthernet0/1

 ip address 30.3.3.1 255.255.255.252

#

interface Loopback0

 ip address 2.2.2.2 255.255.255.255

#

//启动BGPAS100

bgp 100

 undo synchronization

//配置组“in”,类型为internal

 group in internal

 //指定IBGP邻居

 peer 1.1.1.1 group in

//EBGP学到路由向IBGP扩散时将下一跳改成自己的地址

 peer in next-hop-local

 //使用loopback0建立IBGP连接

 peer in connect-interface LoopBack0

//配置组“ex”,类型为external

 group ex external

 //指定EBGP邻居

peer 30.3.3.2 group ex as-number 200

#

 //静态路由保证内部各网段地址互通,可以使用OSPF/ISIS/RIPIGP替代

 ip route-static 1.1.1.1 255.255.255.255 20.2.2.1

#

Router C 配置

#

router-id 3.3.3.3

#

interface GigabitEthernet0/0

 ip address 30.3.3.2 255.255.255.252

#

interface GigabitEthernet0/1

 ip address 40.4.4.1 255.255.255.0

#

interface Loopback0

 ip address 3.3.3.3 255.255.255.255

#

//启动BGPAS200

bgp 200

undo synchronization

//发布路由表中40.4.4.0/24网段路由

network 40.4.4.0 255.255.255.0

//配置组“ex”,类型为external

 group ex external

//指定EBGP邻居

 peer 30.3.3.1 group ex as-number 100

#

四、配置关键点

1Router id 最好配置成和loopback接口地址相同。若没有手工指定router id ,路由器会从当前接口的IP地址中自动选择一个。

2)配置BGP邻居时候要注意是IBGP邻居还是EBGP邻居。

3)此例仅演示IBGPEBGP最简配置,实际组网中,路由器间可以正常建立TCP连接就可以建立IBGP邻居关系,EBGP缺省必须是逐跳之间建立连接,即使用同一链路上的地址建立连接。

 

0 个评论

该案例暂时没有网友评论

编辑评论

举报

×

侵犯我的权益 >
对根叔知了社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔知了社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明

提出建议

    +

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作