• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 漏洞说明
  • 全部
  • 全部
  • 大数据引擎
  • 知了引擎
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
搜索引擎
匹配模式
高级搜索

AR28/AR46系列路由器MSDP的典型配置

2006-09-12 发表
  • 0关注 ,106浏览
粉丝: 关注:

AR28/AR46系列路由器MSDP的典型配置

【需求】

PIM-SM域内配置Anycast RP。RTA和RTB之间建立MSDP对等体,在RTA和RTB上配置向外发送SA消息时使用Loopback0地址;配置RTA和RTB的Loopback10接口为BSR/RP,并配置Anycast RP地址,以达到当有组播组成员加入时,与主机直接相连的路由器能够向拓扑距离最近的RP发起加入的目的。

配置Anycast RP。

【组网图】

【配置脚本】

RouterA配置脚本

# 启动组播

[RTA] multicast routing-enable

# 配置接口Loopback0IP地址。

[RTA] interface loopback0

[RTA-LoopBack0] ip address 10.21.1.1 255.255.255.255

[RTA-LoopBack0] quit

# 配置接口Loopback10IP地址,启动PIM-SM

[RTA] interface loopback10

[RTA-LoopBack10] ip address 10.1.1.1 255.255.255.255

[RTA-LoopBack10] pim sm

[RTA-LoopBack10] quit

# 配置接口Serial1/0/0IP地址,启动PIM-SM

[RTA] interface serial 1/0/0

[RTA-Serial1/0/0] ip address 10.21.2.1 255.255.255.0

[RTA-Serial1/0/0] pim sm

[RTA-Serial1/0/0] undo shutdown

[RTA-Serial1/0/0] quit

# 配置接口Serial1/1/0IP地址启动PIM-SM

[RTA] interface serial 1/1/0

[RTA-Serial1/1/0] ip address 10.21.3.1 255.255.255.0

[RTA-Serial1/1/0] pim sm

[RTA-Serial1/1/0] undo shutdown

[RTA-Serial1/1/0] quit

# 配置OSPF路由。

[RTA] ospf

[RTA-ospf-1] area 0

[RTA-ospf-1-area-0.0.0.0] network 10.21.2.0 0.255.255.255

[RTA-ospf-1-area-0.0.0.0] network 10.21.3.0 0.255.255.255

[RTA-ospf-1-area-0.0.0.0] network 10.1.1.1 0.0.0.0

[RTA-ospf-1-area-0.0.0.0] network 10.21.1.1 0.0.0.0

[RTA-ospf-1-area-0.0.0.0] quit

[RTA-ospf-1] quit

# 配置RTB为其MSDP对等体。

[RTA] msdp

[RTA-msdp] peer 10.10.1.1 connect-interface loopback 0

# 配置Originating RP

[RTA-msdp] originating-rp loopback0

[RTA-msdp] quit

# 配置候选RPBSR

[RTA] pim

[RTA-pim] c-rp loopback 10

[RTA-pim] c-bsr loopback 10 30

RouterB配置脚本

# 启动组播。

<RTB> system-view

[RTB] multicast routing-enable

# 配置接口Loopback0IP地址。

[RTB] interface loopback0

[RTB-LoopBack0] ip address 10.10.1.1 255.255.255.255

[RTB-LoopBack0] quit

# 配置接口Loopback10IP地址,启动PIM-SM

[RTB] interface loopback10

[RTB-LoopBack10] ip address 10.1.1.1 255.255.255.255

[RTB-LoopBack10] pim sm

[RTB-LoopBack10] quit

# 配置接口Serial1/1/0IP地址,启动PIM-SM

[RTB] interface serial 1/1/0

[RTB-Serial1/1/0] ip address 10.10.2.1 255.255.255.0

[RTB-Serial1/1/0] pim sm

[RTB-Serial1/1/0] undo shutdown

[RTB-Serial1/1/0] quit

# 配置接口Serial1/0/0IP地址,启动PIM-SM

[RTB] interface serial 1/0/0

[RTB-Serial1/0/0] ip address 10.10.3.1 255.255.255.0

[RTB-Serial1/0/0] pim sm

[RTB-Serial1/0/0] undo shutdown

[RTB-Serial1/0/0] quit

# 配置OSPF

[RTB] ospf

[RTB-ospf-1] area 0

[RTB-ospf-1-area-0.0.0.0] network 10.10.2.0 0.255.255.255

[RTB-ospf-1-area-0.0.0.0] network 10.10.3.0 0.255.255.255

[RTB-ospf-1-area-0.0.0.0] network 10.1.1.1 0.0.0.0

[RTB-ospf-1-area-0.0.0.0] network 10.10.1.1 0.0.0.0

[RTB-ospf-1-area-0.0.0.0] quit

[RTB-ospf-1] quit

# 配置RTA为其MSDP对等体。

[RTB] msdp

[RTB-msdp] peer 10.21.1.1 connect-interface loopback 0

# 配置Originating RP

[RTB-msdp] originating-rp loopback0

[RTB-msdp] quit

# 配置候选RPBSR

[RTB] pim

[RTB-pim] c-rp loopback 10

[RTB-pim] c-bsr loopback 10 30

【提示】

本例主要进行RTARTB的配置,由于RTERTDRTC上的配置主要是启动组播和在各个接口上启动PIM-SM协议,本举例将省略此部分内容。

0 个评论

该案例暂时没有网友评论

编辑评论

举报

×

侵犯我的权益 >
对根叔知了社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔知了社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明

提出建议

    +

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作