• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 漏洞说明
  • 全部
  • 全部
  • 大数据引擎
  • 知了引擎
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
搜索引擎
匹配模式
高级搜索

SecPath防火墙作为LAC时PC拨号接入私网LNS的配置

2006-09-15 发表
  • 0关注 ,147浏览
粉丝: 关注:

一、组网需求

    L2TPLACLNS端均采用SecPath防火墙设备,PC通过windows自带的拨号软件接入到私网的LNS后,就可以访问其内网资源了。

二、组网图

    如图所示,使用SecPath防火墙作为L2TPLACLNS,客户端软件是windows自带的拨号软件。其中,1.1.0.0/12为公网地址,10.0.0.1/24为私网地址。

    软件版本如下:

    SecPath1000FVRP 3.40 ESS 1604

    客户端软件:windows XP自带的拨号软件。

三、配置步骤

3.1 LAC端的配置:

[LAC]dis ver                                                   //系统的软件版本        

 Copyright Notice:                                                              

 All rights reserved (Aug  2 2006).                                             

 Without the owner's prior written consent, no decompiling                     

 nor reverse-engineering shall be allowed.                                     

 Huawei Versatile Routing Platform Software                                     

 VRP software, Version 3.40, ESS 1604                                          

 Copyright (c) 1998-2006 Huawei Tech. Co., Ltd. All rights reserved.           

 Quidway SecPath 500F uptime is 0 week, 0 day, 0 hour, 22 minutes              

  CPU type: Mips IDT RC32438 266MHz                                            

  256M bytes DDR SDRAM Memory                                                  

  16M bytes Flash Memory                                                       

  Pcb Version:3.0                                                         

  Logic Version:1.0                                                         

  BootROM Version:1.19                                                        

  [SLOT 0] 4FE      (Hardware)3.0, (Driver)2.0, (Cpld)1.0                      

  [SLOT 1] 3FE      (Hardware)3.0, (Driver)2.0, (Cpld)1.0                      

[LAC]dis cu                                                                

sysname LAC                                                                

l2tp enable                                                       //开启l2tp功能    

firewall packet-filter enable                                                 

 firewall packet-filter default permit                                         

 firewall statistic system enable                                              

radius scheme system                                                           

domain system                                                                  

local-user hujun                                                //配置ppp协商的用户名和密码

 password simple 123                                                            

 service-type ppp                                                              

interface Virtual-Template1                                //配置虚拟接口模板及其验证方式    

 ppp authentication-mode pap                                                    

interface Aux0                                                                 

 async mode flow 

interface GigabitEthernet1/0                                                   

interface GigabitEthernet1/1                                                               

interface GigabitEthernet1/0                                                   

ip address 10.0.0.2 255.255.255.0                

interface GigabitEthernet1/1                                                   

 pppoe-server bind Virtual-Template 1                 //在接口上配置pppoe-server,并且绑定到虚拟接口模板1

 interface Encrypt2/0                                                           

interface NULL0                                                                

firewall zone local                                                            

 set priority 100                                                              

firewall zone trust                                                            

 add interface GigabitEthernet1/0                                              

 add interface GigabitEthernet1/1                                              

add interface Virtual-Template1                         //将虚拟接口模板添加进入安全域                               

 set priority 85                                                               

firewall zone untrust                                                          

 set priority 5                                                                 

firewall zone DMZ                                                              

 set priority 50                                                               

firewall interzone local trust                                                  

firewall interzone local untrust                                               

firewall interzone local DMZ                                                   

firewall interzone trust untrust                                                

firewall interzone trust DMZ                                                   

firewall interzone DMZ untrust                         

l2tp-group 1                                                    //配置l2tp                    

 undo tunnel authentication                               //取消隧道验证                  

 start l2tp ip 1.1.2.1 fullusername hujun             //配置使用名字的方式发起l2tp连接,

1.1.2.1NAT Server外网接口ip地址

ip route-static 0.0.0.0 0.0.0.0 1.1.1.2 preference 60   //配置一条静态默认路由

user-interface con 0                                                            

user-interface aux 0                                                           

user-interface vty 0 4                                                         

return                                                                          

3.2 LNS端的配置:

[LNS]dis cu                                                                    

sysname LNS                                                                   

l2tp enable                                                       //开启l2tp功能    

firewall packet-filter enable                                                 

 firewall packet-filter default permit                                         

undo connection-limit enable                                                  

 connection-limit default deny                                                  

 connection-limit default amount upper-limit 50 lower-limit 20                 

firewall statistic system enable                                              

radius scheme system                                                            

domain system                                                                  

 ip pool 1 3.0.0.2 3.0.0.10                                  //配置接入用户使用的地址池 

local-user hujun                                                //配子用户名和密码                                 

 password simple 123                                                           

 service-type ppp                                                              

interface Virtual-Template1                                //配置虚拟接口模板及其验证方式

 ppp authentication-mode pap                                                   

ip address 3.0.0.1 255.255.255.0                                              

interface Aux0                                                                 

 async mode flow  

interface GigabitEthernet0/0                                                   

interface GigabitEthernet0/1                                                            

interface GigabitEthernet1/0                                                   

interface GigabitEthernet1/1                                                   

ip address 10.0.0.1 255.255.255.0                                             

interface Encrypt2/0                                                           

interface NULL0                                                                 

firewall zone local                                                            

 set priority 100                                                              

firewall zone trust                                                             

add interface GigabitEthernet1/1                                              

 add interface Virtual-Template1                          //把虚拟接口模板添加进入安全域

 set priority 85                                                                

firewall zone untrust                                                          

 set priority 5                                                                

firewall zone DMZ                                                              

 set priority 50                                                               

firewall interzone local trust                                                 

firewall interzone local untrust                                               

firewall interzone local DMZ                                                   

firewall interzone trust untrust                                               

firewall interzone trust DMZ                                                   

firewall interzone DMZ untrust                                                  

l2tp-group 1                                                    //取消隧道验证

 undo tunnel authentication                               //配置使用名字的方式发起l2tp连接,

 allow l2tp virtual-template 1                             //使用虚拟接口1来接收隧道连接请求

ip route-static 0.0.0.0 0.0.0.0 10.0.0.2 preference 60   //配置静态默认路由                      

user-interface con 0                                                           

user-interface aux 0                                                           

user-interface vty 0 4                                                         

 authentication-mode none                                                       

 user privilege level 3                                                        

return   

3.2 NAT Server的配置:

[Quidway]dis cu                                                                

sysname Quidway                                                               

firewall packet-filter enable                                                 

 firewall packet-filter default permit                                         

insulate                                                                      

undo connection-limit enable                                                  

 connection-limit default deny                                                 

 connection-limit default amount upper-limit 50 lower-limit 20                 

firewall statistic system enable                                              

radius scheme system                                                            

domain system                                                                  

interface Aux0                                                                 

 async mode flow                                                                

interface Ethernet0/0                                                          

interface Ethernet0/1                                                          

interface Ethernet0/2                                                           

interface Ethernet0/3                                                          

interface Ethernet1/0                                                          

 ip address 1.1.2.1 255.255.255.0                                               

 nat server protocol udp global 1.1.2.1 any inside 10.0.0.1 any     //配置NAT服务器,指向内网LNSIP地址            

interface Ethernet1/1                                                          

interface Ethernet1/2                                                           

 ip address 10.0.0.2 255.255.255.0                                             

interface Encrypt2/0                                                           

interface NULL0                                                                

firewall zone local                                                            

 set priority 100                                                              

firewall zone trust                                                            

 add interface Ethernet1/0                                                     

 add interface Ethernet1/2                                                     

 set priority 85                                                               

firewall zone untrust                                                           

 set priority 5                                                                

firewall zone DMZ                                                              

 set priority 50                                                                

firewall interzone local trust                                                 

firewall interzone local untrust                                               

firewall interzone local DMZ                                                    

firewall interzone trust untrust                                               

firewall interzone trust DMZ                                                   

firewall interzone DMZ untrust                                                  

ip route-static 0.0.0.0 0.0.0.0 1.1.2.2 preference 60                         

user-interface con 0                                                           

user-interface aux 0                                                            

user-interface vty 0 4                                                         

 authentication-mode none                                                      

 user privilege level 3                                                        

return                                                                          

四、配置关键点

    请见配置里面的蓝色斜体字和红色标记的位子。

0 个评论

该案例暂时没有网友评论

编辑评论

举报

×

侵犯我的权益 >
对根叔知了社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔知了社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明

提出建议

    +

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作