• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 漏洞说明
  • 全部
  • 全部
  • 大数据引擎
  • 知了引擎
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
搜索引擎
匹配模式
高级搜索

Typical Configuration of DVPN on AR Series Routers

2007-09-14 发表
  • 0关注
  • 0收藏 565浏览
粉丝: 关注:

Typical Configuration of DVPN on AR Series Routers

 

[Requirements]

Configure the DVPN to implement intercommunications between Client 1/2 and the Server and between Client 1 and Client 2.

[Networking diagram]

 

[Configuration script]

Configuration script on Server

#

sysname Server

#

radius scheme system

#

domain system

#

local-user admin

password cipher .]@USE=B,53Q=^Q`MAF4<1!!

service-type telnet terminal

level 3

service-type ftp

#

dvpn policy 1                                     /Create dvpn-policy view 1/

#

interface Aux0

async mode flow

#

interface Ethernet0/0

ip address 202.1.1.1 255.255.255.0

#

interface Ethernet0/1

ip address dhcp-alloc

#

interface Serial1/0

clock DTECLK1

link-protocol ppp

ip address ppp-negotiate

#

interface Serial1/1

clock DTECLK1

link-protocol ppp

ip address ppp-negotiate

#

interface Tunnel0                                    /Create Tunnel 0/

ip address 10.0.0.1 255.255.255.0

tunnel-protocol udp dvpn                             /Encapsulation format of Tunnel interface/

source Ethernet0/0

dvpn interface-type server                           /Set the type of Tunnel interface to server/

dvpn dvpn-id 1                                       /Configure DVPN domain 1 for Tunnel interface/

dvpn policy 1                                        /Quote dvpn-policy view 1/

#

interface NULL0

#

interface LoopBack0

ip address 172.16.1.1 255.255.255.0

#

FTP server enable

#

dvpn service enable                                   /Enable the DVPN/

dvpn server pre-shared-key 12345                      /Configure pre-shared-key for the Server/

#

ip route-static 172.16.2.0 255.255.255.0 10.0.0.2 preference 60    /Configure routing information/

ip route-static 172.16.3.0 255.255.255.0 10.0.0.3 preference 60

#

user-interface con 0

user-interface aux 0

user-interface vty 0 4

authentication-mode scheme

#

return

Configuration script on Client 1

#

sysname Client1

#

radius scheme system

#

domain system

#

local-user admin

password cipher .]@USE=B,53Q=^Q`MAF4<1!!

service-type telnet terminal

level 3

service-type ftp

#

dvpn class test                              /Configure DVPN class for Tunnel interface/

public-ip 202.1.1.1

authentication-server method pre-share

pre-shared-key 12345

#

interface Aux0

async mode flow

#

interface Ethernet0/0

ip address 202.1.1.2 255.255.255.0

#

interface Tunnel0                             /Create Tunnel 0/

ip address 10.0.0.2 255.255.255.0

tunnel-protocol udp dvpn                      /Encapsulation format of Tunnel interface/

source Ethernet0/0

dvpn interface-type client                    /Set the type of Tunnel interface to client/

dvpn dvpn-id 1                                /Configure DVPN domain 1 for Tunnel interface/

dvpn server test                              /Quote the configured DVPN class/

#

interface NULL0

#

interface LoopBack0

ip address 172.16.2.1 255.255.255.0

#

FTP server enable

#

dvpn service enable                           /Enable the DVPN/

#

ip route-static 172.16.1.0 255.255.255.0 10.0.0.1 preference 60  /Configure routing information/

ip route-static 172.16.3.0 255.255.255.0 10.0.0.3 preference 60

#

user-interface con 0

user-interface aux 0

user-interface vty 0 4

authentication-mode scheme

#

return

Configuration script on Client 2

#

sysname Client2

#

radius scheme system

#

domain system

#

local-user admin

password cipher .]@USE=B,53Q=^Q`MAF4<1!!

service-type telnet terminal

level 3

service-type ftp

#

dvpn class test                                /Configure DVPN class for Tunnel interface/

public-ip 202.1.1.1

authentication-server method pre-share

pre-shared-key 12345

#

interface Aux0

async mode flow

#

interface Ethernet0/0

ip address 202.1.1.3 255.255.255.0

#

interface Ethernet0/1

ip address dhcp-alloc

#

interface Tunnel0                                /Create Tunnel 0/

ip address 10.0.0.3 255.255.255.0

tunnel-protocol udp dvpn                         /Encapsulation format of Tunnel interface/

source Ethernet0/0

dvpn interface-type client                       /Set the type of Tunnel interface to client/

dvpn dvpn-id 1                                   /Configure DVPN domain 1 for Tunnel interface/

dvpn server test                                 /Quote the configured DVPN class/

#

interface NULL0

#

interface LoopBack0

ip address 172.16.3.1 255.255.255.0

#

FTP server enable

#

dvpn service enable                               /Enable the DVPN/

#

ip route-static 172.16.1.0 255.255.255.0 10.0.0.1 preference 60   /Configure routing information/

ip route-static 172.16.2.0 255.255.255.0 10.0.0.2 preference 60

#

user-interface con 0

user-interface aux 0

user-interface vty 0 4

authentication-mode scheme

#

return

 

[Verification]

Any two of the Server, Client 1 and Client 2 can implement intercommunications.

Map information and session information on the Server:

[Server]dis dvpn map all

vpn-id   private-ip       public-ip   port    state    type   client-id

------------------------------------------------------------------------------

1         10.0.0.3        202.1.1.3   40959  FINISHED  S->C     88383300

1         10.0.0.2        202.1.1.2   40959  FINISHED  S->C     91175268

 

[Server]display dvpn session all

vpn-id   private-ip       public-ip    port     state  type

-----------------------------------------------------------------

1         10.0.0.2        202.1.1.2   40959   SUCCESS  S->C

1         10.0.0.3        202.1.1.3   40959   SUCCESS  S->C

 

Map information and session information on Client 1:

[Client1]dis dvpn map all

vpn-id    private-ip      public-ip    port     state  type   client-id

------------------------------------------------------------------------------

1         10.0.0.1        202.1.1.1   40959   SUCCESS  C->S     91175268

 

[Client1]dis dvpn se all

vpn-id    private-ip      public-ip    port     state  type

-----------------------------------------------------------------

1         10.0.0.1        202.1.1.1   40959   SUCCESS  C->S

1         10.0.0.3        202.1.1.3   40959   SUCCESS  C->C

 

Map information and session information on Client 2:

[Client2]dis dvpn map all

vpn-id    private-ip      public-ip    port     state  type   client-id

------------------------------------------------------------------------------

1         10.0.0.1        202.1.1.1   40959   SUCCESS  C->S     88383300

 

[Client2]dis dvpn se all

vpn-id    private-ip      public-ip    port     state  type

-----------------------------------------------------------------

1         10.0.0.1        202.1.1.1   40959   SUCCESS  C->S

1         10.0.0.2        202.1.1.2   40959   SUCCESS  C->C

 

[Tip]

1.        During the DVPN data transmission, the system performs IPSec encryption for all data by default. Therefore, you do not need to configure it.

2.        For ID authentication through the pre-shared-key, the Client needs to specify an identical pre-shared-key with that of the Server to be accessed.

3.        Up to one dvpn-policy can be applied to an interface. To apply a new dvpn-policy, delete the existing dvpn-policy first. One dvpn-policy can be used by several interfaces at the same time.

4.        Encapsulate the UDP DVPN on the Tunnel interface before configuring other DVPN parameters.

若您有关于案例的建议,请反馈:

作者在2007-09-30对此案例进行了修订
0 个评论

该案例暂时没有网友评论

编辑评论

举报

×

侵犯我的权益 >
对根叔知了社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到pub.zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 pub.zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到pub.zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔知了社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明

提出建议

    +

亲~登录后才可以操作哦!

确定

亲~检测到您登陆的账号未在http://hclhub.h3c.com进行注册

注册后可访问此模块

跳转hclhub

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作