• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 漏洞说明
  • 全部
  • 全部
  • 大数据引擎
  • 知了引擎
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
搜索引擎
匹配模式
高级搜索

Typical HoPE Configuration

2007-09-18 发表
  • 0关注
  • 0收藏 590浏览
粉丝: 关注:

Typical HoPE Configuration

[Requirements]

RT2 is the SPE, and RT3 is the UPE. The SPE only needs to advertise one default route to the UPE.

[Networking diagram]

[Configuration script]

Configuration script (RT1)

#

 sysname RT1

#

 router id 1.1.1.1

#

 mpls lsr-id 1.1.1.1

#

radius scheme system

#

mpls

#

 mpls ldp

#

ip vpn-instance vpna

 route-distinguisher 100:1

 vpn-target 100:1 export-extcommunity

 vpn-target 100:1 import-extcommunity

#

ip vpn-instance vpnb

 route-distinguisher 200:1

 vpn-target 200:1 export-extcommunity

 vpn-target 200:1 import-extcommunity

#

domain system

#                                        

interface Serial2/0/0                    

 link-protocol ppp

 ip address 10.0.0.1 255.255.255.252

 mpls

 mpls ldp enable

#

interface NULL0

#

interface LoopBack0

 ip address 1.1.1.1 255.255.255.255

#

interface LoopBack11

 ip binding vpn-instance vpna

 ip address 192.168.11.1 255.255.255.0

#

interface LoopBack21

 ip binding vpn-instance vpnb

 ip address 192.168.21.1 255.255.255.0

#

bgp 100

 undo synchronization

 group inter internal

 peer 2.2.2.2 group inter

 peer 2.2.2.2 connect-interface LoopBack0

 #                                        

 ipv4-family vpn-instance vpna           

  import-route direct                    

  undo synchronization

 #

 ipv4-family vpn-instance vpnb

  import-route direct

  undo synchronization

 #

 ipv4-family vpnv4

  peer inter enable

  peer 2.2.2.2 group inter

#

ospf 1

 area 0.0.0.0

  network 1.1.1.1 0.0.0.0

  network 10.0.0.0 0.0.0.3

#

return

 

Configuration script (RT2)

#

sysname RT2

#

router id 2.2.2.2

#

mpls lsr-id 2.2.2.2

#

radius scheme system

#

mpls

#

mpls ldp

#

ip vpn-instance vpna

route-distinguisher 100:1

vpn-target 100:1 export-extcommunity

vpn-target 100:1 import-extcommunity

#

ip vpn-instance vpnb

route-distinguisher 200:1

vpn-target 200:1 export-extcommunity

#

domain system

#

interface Serial2/0/0

link-protocol ppp

ip address 10.0.0.2 255.255.255.252

mpls

mpls ldp enable

#

interface Serial2/0/1

link-protocol ppp

ip address 10.0.0.5 255.255.255.252

mpls

mpls ldp enable

#

interface NULL0

#

interface LoopBack0

ip address 2.2.2.2 255.255.255.255

#

interface LoopBack12

ip binding vpn-instance vpna

ip address 192.168.12.1 255.255.255.0

#

interface LoopBack22

ip binding vpn-instance vpnb

ip address 192.168.22.1 255.255.255.0

#

bgp 100

undo synchronization

group inter internal

peer 1.1.1.1 group inter

peer 1.1.1.1 connect-interface LoopBack0

peer 3.3.3.3 group inter

peer 3.3.3.3 connect-interface LoopBack0

#

ipv4-family vpn-instance vpna

import-route direct

undo synchronization

#

ipv4-family vpn-instance vpnb

import-route direct

undo synchronization

#

ipv4-family vpnv4

peer inter enable

peer 1.1.1.1 group inter

peer 3.3.3.3 group inter

peer 3.3.3.3 upe                          /Configure 3.3.3.3 as the UPE of HoPE/

peer 3.3.3.3 default-route-advertise vpn-instance vpna

/Advertise the default route to vpna of the UPE/

peer 3.3.3.3 default-route-advertise vpn-instance vpnb

/ Advertise the default route to vpnb of the UPE/

#

ospf 1

area 0.0.0.0

network 2.2.2.2 0.0.0.0

network 10.0.0.0 0.0.0.3

network 10.0.0.4 0.0.0.3

#

return

Configuration script (RT3)

#

 sysname RT3

#

 router id 3.3.3.3

#

 mpls lsr-id 3.3.3.3

#

radius scheme system

#

mpls

#

 mpls ldp

#

ip vpn-instance vpna

 route-distinguisher 100:1

 vpn-target 100:1 export-extcommunity

 vpn-target 100:1 import-extcommunity

#

ip vpn-instance vpnb

 route-distinguisher 200:1

 vpn-target 200:1 export-extcommunity

 vpn-target 200:1 import-extcommunity

#

domain system

#                                         

interface Serial2/0/0                    

 link-protocol ppp

 ip address 10.0.0.6 255.255.255.252

 mpls

 mpls ldp enable

#

interface NULL0

#

interface LoopBack0

 ip address 3.3.3.3 255.255.255.255

#

interface LoopBack13

 ip binding vpn-instance vpna

 ip address 192.168.13.1 255.255.255.0

#

interface LoopBack23

 ip binding vpn-instance vpnb

 ip address 192.168.23.1 255.255.255.0

#

bgp 100

 undo synchronization

 group inter internal

 peer 2.2.2.2 group inter

 peer 2.2.2.2 connect-interface LoopBack0

 #                                        

 ipv4-family vpn-instance vpna           

  import-route direct                    

  undo synchronization

 #

 ipv4-family vpn-instance vpnb

  import-route direct

  undo synchronization

 #

 ipv4-family vpnv4

  peer inter enable

  peer 2.2.2.2 group inter

#

ospf 1

 area 0.0.0.0

  network 3.3.3.3 0.0.0.0

  network 10.0.0.4 0.0.0.3

#

return

 

[Verification]

Private route table of vpna on RT3:

disp ip routing vpn vpna

  vpna   Route Information

 Routing Table:  vpna   Route-Distinguisher:   100:1

Destination/Mask   Protocol Pre  Cost        Nexthop         Interface

0.0.0.0/0          BGP      256  0           2.2.2.2         InLoopBack0

192.168.13.0/24    DIRECT   0    0           192.168.13.1    LoopBack13

192.168.13.1/32    DIRECT   0    0           127.0.0.1       InLoopBack0

 

There is only one default route advertised by RT2.

[Tip]

1. The configuration of HoPE is similar to that of MPLS except the SPE part (in red).

  peer 3.3.3.3 upe        /Configure 3.3.3.3 as the UPE of HoPE/

peer 3.3.3.3 default-route-advertise vpn-instance vpna              /Advertise the default route to vpna of the UPE/

peer 3.3.3.3 default-route-advertise vpn-instance vpnb              /Advertise the default route to vpnb of the UPE/

 

2. The configuration on the UPE is completely the same as the common MPLS configuration.

3. The SPE is featured by large-capacity route table, powerful forwarding performance, but limited interface resources; the route capacity and forwarding performance of the UPE are inferior to those of the SPE, but it is of strong access capability.

 

若您有关于案例的建议,请反馈:

作者在2007-09-27对此案例进行了修订
0 个评论

该案例暂时没有网友评论

编辑评论

举报

×

侵犯我的权益 >
对根叔知了社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到pub.zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 pub.zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到pub.zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔知了社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明

提出建议

    +

亲~登录后才可以操作哦!

确定

亲~检测到您登陆的账号未在http://hclhub.h3c.com进行注册

注册后可访问此模块

跳转hclhub

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作