• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 漏洞说明
  • 全部
  • 全部
  • 大数据引擎
  • 知了引擎
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
搜索引擎
匹配模式
高级搜索

H3C S3500-EA QinQ功能的典型配置

  • 0关注
  • 0收藏 803浏览
粉丝: 关注:

H3C S3500-EA QinQ功能的典型配置

 

一、  组网需求:

网络环境描述如下:

Provider AProvider B作为运营商网络接入设备。

Customer ACustomer BCustomer C为用户网络接入设备。

Provider AProvider B之间通过Trunk端口连接,Provider A属于运营商网络的VLAN1000Provider B属于运营商网络的VLAN2000

Provider AProvider B之间,运营商采用其他厂商的设备,TPID值为0x8200

希望配置完成后达到下列要求:

Customer AVLAN10的报文可以和Customer BVLAN10的报文经过运营商网络的VLAN1000转发后互通;Customer AVLAN20的报文可以和Customer CVLAN20的报文经过运营商网络的VLAN2000转发后互通

二、  组网图:

 

三、  配置步骤:

(1)    配置Provider A

# 进入系统视图。

<ProviderA> system-view

Ethernet1/0/1端口的配置

# 配置端口为Hybrid端口,且允许VLAN10VLAN20VLAN1000VLAN2000的报文通过,并且在发送时去掉外层Tag

[ProviderA] interface ethernet 1/0/1

[ProviderA-Ethernet1/0/1] port link-type hybrid

[ProviderA-Ethernet1/0/1] port hybrid vlan 10 20 1000 2000 untagged

# 将来自VLAN10的报文封装VLAN ID1000的外层Tag

[ProviderA-Ethernet1/0/1] qinq vid 1000

[ProviderA-Ethernet1/0/1-vid-1000] raw-vlan-id inbound 10

[ProviderA-Ethernet1/0/1-vid-1000] quit

# 将来自VLAN20的报文封装VLAN ID2000的外层Tag

[ProviderA-Ethernet1/0/1] qinq vid 2000

[ProviderA-Ethernet1/0/1-vid-2000] raw-vlan-id inbound 20

[ProviderA-Ethernet1/0/1-vid-2000] quit

[ProviderA-Ethernet1/0/1] quit

Ethernet1/0/2端口的配置

# 配置端口的缺省VLANVLAN1000

[ProviderA] interface ethernet 1/0/2

[ProviderA-Ethernet1/0/2] port access vlan 1000

# 配置端口的基本QinQ功能,将来自VLAN10的报文封装VLAN ID1000的外层Tag

[ProviderA-Ethernet1/0/2] qinq enable

[ProviderA-Ethernet1/0/2] quit

Ethernet1/0/3端口的配置

# 配置端口为Trunk端口,且允许VLAN1000VLAN2000的报文通过。

[ProviderA] interface ethernet 1/0/3

[ProviderA-Ethernet1/0/3] port link-type trunk

[ProviderA-Ethernet1/0/3] port trunk permit vlan 1000 2000

# 为与公共网络中的设备进行互通,配置端口添加外层Tag时采用的TPID值为0x8200

[ProviderA-Ethernet1/0/3] qinq ethernet-type 8200

(2)    配置Provider B

Ethernet1/0/1端口的配置

# 配置端口为Trunk端口,且允许VLAN1000VLAN2000的报文通过。

<ProviderB> system-view

[ProviderB] interface ethernet 1/0/1

[ProviderB-Ethernet1/0/1] port link-type trunk

[ProviderB-Ethernet1/0/1] port trunk permit vlan 1000 2000

# 为与公共网络中的设备进行互通,配置端口添加外层Tag时采用的TPID值为0x8200

[ProviderB-Ethernet1/0/1] qinq ethernet-type 8200

[ProviderB-Ethernet1/0/1] quit

Ethernet1/0/2端口的配置

# 配置端口的缺省VLANVLAN2000

[ProviderB] interface ethernet 1/0/2

[ProviderB-Ethernet1/0/2] port access vlan 2000

# 配置端口的基本QinQ功能,将来自VLAN20的报文封装VLAN ID2000的外层Tag

[ProviderB-Ethernet1/0/2] qinq enable

(3)    公共网络设备的配置

由于Provider AProvider B之间使用的公共网络设备可能来自于其他厂商,这里只介绍基本原理:配置公共网络中与Provider AEthernet1/0/3端口和Provider BEthernet1/0/1端口连接的设备,使其相应的端口允许VLAN1000VLAN2000的报文携带VLAN Tag进行发送即可

四、  配置关键点:

若您有关于案例的建议,请反馈:

作者在2009-01-04对此案例进行了修订
0 个评论

该案例暂时没有网友评论

编辑评论

举报

×

侵犯我的权益 >
对根叔知了社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到pub.zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 pub.zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到pub.zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔知了社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明

提出建议

    +

亲~登录后才可以操作哦!

确定

亲~检测到您登陆的账号未在http://hclhub.h3c.com进行注册

注册后可访问此模块

跳转hclhub

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作