• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 漏洞说明
  • 全部
  • 全部
  • 大数据引擎
  • 知了引擎
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
搜索引擎
匹配模式
高级搜索

S5820 多vpn-instance实例之静态路由典型组网配置案例

2020-04-01 发表
  • 0关注 ,2904浏览
粉丝: 关注:

组网及说明

组网说明:

本案例采用H3C HCL模拟器来模拟多vpn-instance实例静态路由典型组网配置,为了实现不同VLAN之间通过不同的vpn实例进行隔离,因此采用多vpn实例捆绑到相应的VLAN。

VLAN 400与用于在SW1 、SW2的vpn-rt互联使用,VLAN 500用于SW1、SW2的vpn-nrt互联使用。由于VLAN 400与VLAN 500绑定到了不同的VPN实例,因此可以共同使用10.0.0.0/30作为互联地址。  

业务地址、互联地址、Loopback地址如拓扑图所示。其中VLAN 10VLAN 100属于vpn-rt中,VLAN 20VLAN 200属于vpn-nrt实例中,另外SW1SW2之间的互联采用trunk,互联的VLAN使用VLAN 400(绑定到vpn-rt)和VLAN 500(绑定到vpn-nrt),全网采用多VPN实例静态路由互联互通,不通VPN实例的业务地址不能互通。

vpn-rt规划如下:

RD:100:1

RT:100:1

vpn-nrt规划如下:

RD:200:1

RT:200:1


配置步骤

1、分别在SW1SW2创建VPN实例

2、根据组网说明将各业务地址、互联地址、loopback绑定到vpn实例

3、使用多VPN实例静态路由实现互通

4、SW1SW2之间的互联采用trunk,仅允许互联的VLAN互通。

配置关键点

SW1

sys

[H3C]sysname SW1

#创建vpn-rt实例,并配置RD值和RT

[SW1]ip vpn-instance vpn-rt

[SW1-vpn-instance-vpn-rt]route-distinguisher 100:1

[SW1-vpn-instance-vpn-rt]vpn-target 100:1

[SW1-vpn-instance-vpn-rt]quit

#创建vpn-nrt实例,并配置RD值和RT

[SW1]ip vpn-instance vpn-nrt

[SW1-vpn-instance-vpn-nrt]route-distinguisher 200:1

[SW1-vpn-instance-vpn-nrt]vpn-target 200:1

[SW1-vpn-instance-vpn-nrt]quit

[SW1]int LoopBack 0

[SW1-LoopBack0]ip binding vpn-instance vpn-rt  //Loopback0绑定到vpn-rt

Some configurations on the interface are removed.

[SW1-LoopBack0]ip address 1.1.1.1 32

[SW1-LoopBack0]quit

[SW1]int LoopBack 1 

[SW1-LoopBack1]ip binding vpn-instance vpn-nrt //Loopback1绑定到vpn-nrt

Some configurations on the interface are removed.

[SW1-LoopBack1]ip address 1.1.1.1 32

[SW1-LoopBack1]quit

[SW1]vlan 10

[SW1-vlan10]quit

[SW1]vlan 20

[SW1-vlan20]quit

[SW1]vlan 400

[SW1-vlan400]quit

[SW1]vlan 500

[SW1-vlan500]quit

 

[SW1]int vlan 10

[SW1-Vlan-interface10]ip binding vpn-instance vpn-rt  //VLAN 10绑定到vpn-rt

Some configurations on the interface are removed.

[SW1-Vlan-interface10]ip address 192.168.10.1 24

[SW1-Vlan-interface10]quit

[SW1]int vlan 20

[SW1-Vlan-interface20]ip binding vpn-instance vpn-nrt //VLAN 20绑定到vpn-nrt

Some configurations on the interface are removed.

[SW1-Vlan-interface20]ip address 192.168.20.1 24

[SW1-Vlan-interface20]quit

[SW1]int vlan 400

[SW1-Vlan-interface400]ip binding vpn-instance vpn-rt //VLAN400绑定到vpn-rt

Some configurations on the interface are removed.

[SW1-Vlan-interface400]description

[SW1-Vlan-interface400]ip address 10.0.0.1 30

[SW1-Vlan-interface400]quit

[SW1]int vlan 500

[SW1-Vlan-interface500]ip binding vpn-instance vpn-nrt //VLAN 500绑定到vpn-nrt

Some configurations on the interface are removed.

[SW1-Vlan-interface500]description

[SW1-Vlan-interface500]ip address 10.0.0.1 30

[SW1-Vlan-interface500]quit

[SW1]

 

[SW1]int gi 1/0/2

[SW1-GigabitEthernet1/0/2]port link-type access

[SW1-GigabitEthernet1/0/2]port access vlan 10

[SW1-GigabitEthernet1/0/2]quit

[SW1]int gi 1/0/3

[SW1-GigabitEthernet1/0/3]port link-type access

[SW1-GigabitEthernet1/0/3]port access vlan 20

[SW1-GigabitEthernet1/0/3]quit

[SW1]

 

[SW1]int gi 1/0/1

[SW1-GigabitEthernet1/0/1]description

[SW1-GigabitEthernet1/0/1]port link-type trunk

[SW1-GigabitEthernet1/0/1]undo port trunk permit vlan 1

[SW1-GigabitEthernet1/0/1]port trunk permit vlan 400 500

[SW1-GigabitEthernet1/0/1]quit

 

配置静态路由指向,并绑定到相应的VPN实例中

[SW1]ip route-static vpn-instance vpn-rt 2.2.2.2 255.255.255.255 10.0.0.2  

[SW1]ip route-static vpn-instance vpn-rt 172.16.20.0 255.255.255.0 10.0.0.2

[SW1]ip route-static vpn-instance vpn-nrt 2.2.2.2 255.255.255.255 10.0.0.2

[SW1]ip route-static vpn-instance vpn-nrt 172.16.10.0 255.255.255.0 10.0.0.2

 

 

SW2

sys

[H3C]sysname SW2

[SW2]ip vpn-instance vpn-rt

[SW2-vpn-instance-vpn-rt]route-distinguisher 100:1

[SW2-vpn-instance-vpn-rt]vpn-target 100:1

[SW2-vpn-instance-vpn-rt]quit

[SW2]ip vpn-instance vpn-nrt

[SW2-vpn-instance-vpn-nrt]route-distinguisher 200:1

[SW2-vpn-instance-vpn-nrt]vpn-target 200:1

[SW2-vpn-instance-vpn-nrt]quit

[SW2]int LoopBack 0

[SW2-LoopBack0]ip binding vpn-instance vpn-rt

Some configurations on the interface are removed.

[SW2-LoopBack0]ip address 2.2.2.2 32

[SW2-LoopBack0]quit

[SW2]int LoopBack 1

[SW2-LoopBack1]ip binding vpn-instance vpn-nrt

Some configurations on the interface are removed.

[SW2-LoopBack1]ip address 2.2.2.2 32

[SW2-LoopBack1]quit

[SW2]vlan 100

[SW2-vlan100]quit

[SW2]vlan 200

[SW2-vlan200]quit

[SW2]vlan 400

[SW2-vlan400]quit

[SW2]vlan 500

[SW2-vlan500]quit

[SW2]int vlan 100

[SW2-Vlan-interface100]ip binding vpn-instance vpn-rt

Some configurations on the interface are removed.

[SW2-Vlan-interface100]ip address 172.16.20.1 24

[SW2-Vlan-interface100]quit

[SW2]int vlan 200

[SW2-Vlan-interface200]ip binding vpn-instance vpn-nrt

Some configurations on the interface are removed.

[SW2-Vlan-interface200]ip address 172.16.10.1 24

[SW2-Vlan-interface200]quit

[SW2]int vlan 400

[SW2-Vlan-interface400]ip binding vpn-instance vpn-rt

Some configurations on the interface are removed.

[SW2-Vlan-interface400]description

[SW2-Vlan-interface400]ip address 10.0.0.2 30

[SW2-Vlan-interface400]quit

[SW2]int vlan 500

[SW2-Vlan-interface500]ip binding vpn-instance vpn-nrt

Some configurations on the interface are removed.

[SW2-Vlan-interface500]description

[SW2-Vlan-interface500]ip address 10.0.0.2 30

[SW2-Vlan-interface500]quit

[SW2]int gi 1/0/2

[SW2-GigabitEthernet1/0/2]port link-type access

[SW2-GigabitEthernet1/0/2]port access vlan 100

[SW2-GigabitEthernet1/0/2]quit

[SW2]int gi 1/0/3

[SW2-GigabitEthernet1/0/3]port link-type access

[SW2-GigabitEthernet1/0/3]port access vlan 200

[SW2-GigabitEthernet1/0/3]quit

[SW2]int gi 1/0/1

[SW2-GigabitEthernet1/0/1]description

[SW2-GigabitEthernet1/0/1]port link-type trunk

[SW2-GigabitEthernet1/0/1]undo port trunk permit vlan 1

[SW2-GigabitEthernet1/0/1]port trunk permit vlan 400 500

[SW2-GigabitEthernet1/0/1]quit

 

配置静态路由,并绑定到VPN实例中

[SW2]ip route-static vpn-instance vpn-rt 1.1.1.1 255.255.255.255 10.0.0.1

[SW2]ip route-static vpn-instance vpn-rt 192.168.10.0 255.255.255.0 10.0.0.1

[SW2]ip route-static vpn-instance vpn-nrt 1.1.1.1 255.255.255.0 10.0.0.1

[SW2]ip route-static vpn-instance vpn-nrt 192.168.20.0 255.255.255.0 10.0.0.1

 

查看各VPN路由表确认VPN路由已学习到

[SW1]dis ip routing-table vpn-instance vpn-rt

 

Destinations : 19       Routes : 19

 

Destination/Mask   Proto   Pre Cost        NextHop         Interface

0.0.0.0/32         Direct  0   0           127.0.0.1       InLoop0

1.1.1.1/32         Direct  0   0           127.0.0.1       InLoop0

2.2.2.2/32         Static  60  0           10.0.0.2        Vlan400

10.0.0.0/30        Direct  0   0           10.0.0.1        Vlan400

10.0.0.0/32        Direct  0   0           10.0.0.1        Vlan400

10.0.0.1/32        Direct  0   0           127.0.0.1       InLoop0

10.0.0.3/32        Direct  0   0           10.0.0.1        Vlan400

127.0.0.0/8        Direct  0   0           127.0.0.1       InLoop0

127.0.0.0/32       Direct  0   0           127.0.0.1       InLoop0

127.0.0.1/32       Direct  0   0           127.0.0.1       InLoop0

127.255.255.255/32 Direct  0   0           127.0.0.1       InLoop0

172.16.20.0/24     Static  60  0           10.0.0.2        Vlan400

192.168.10.0/24    Direct  0   0           192.168.10.1    Vlan10

192.168.10.0/32    Direct  0   0           192.168.10.1    Vlan10

192.168.10.1/32    Direct  0   0           127.0.0.1       InLoop0

192.168.10.255/32  Direct  0   0           192.168.10.1    Vlan10

224.0.0.0/4        Direct  0   0           0.0.0.0         NULL0

224.0.0.0/24       Direct  0   0           0.0.0.0         NULL0

255.255.255.255/32 Direct  0   0           127.0.0.1       InLoop0

[SW1]

 

[SW1]dis ip routing-table vpn-instance vpn-nrt

 

Destinations : 19       Routes : 19

 

Destination/Mask   Proto   Pre Cost        NextHop         Interface

0.0.0.0/32         Direct  0   0           127.0.0.1       InLoop0

1.1.1.1/32         Direct  0   0           127.0.0.1       InLoop0

2.2.2.2/32         Static  60  0           10.0.0.2        Vlan500

10.0.0.0/30        Direct  0   0           10.0.0.1        Vlan500

10.0.0.0/32        Direct  0   0           10.0.0.1        Vlan500

10.0.0.1/32        Direct  0   0           127.0.0.1       InLoop0

10.0.0.3/32        Direct  0   0           10.0.0.1        Vlan500

127.0.0.0/8        Direct  0   0           127.0.0.1       InLoop0

127.0.0.0/32       Direct  0   0           127.0.0.1       InLoop0

127.0.0.1/32       Direct  0   0           127.0.0.1       InLoop0

127.255.255.255/32 Direct  0   0           127.0.0.1       InLoop0

172.16.10.0/24     Static  60  0           10.0.0.2        Vlan500

192.168.20.0/24    Direct  0   0           192.168.20.1    Vlan20

192.168.20.0/32    Direct  0   0           192.168.20.1    Vlan20

192.168.20.1/32    Direct  0   0           127.0.0.1       InLoop0

192.168.20.255/32  Direct  0   0           192.168.20.1    Vlan20

224.0.0.0/4        Direct  0   0           0.0.0.0         NULL0

224.0.0.0/24       Direct  0   0           0.0.0.0         NULL0

255.255.255.255/32 Direct  0   0           127.0.0.1       InLoop0

[SW1]

 

[SW2]dis ip routing-table vpn-instance vpn-rt

 

Destinations : 19       Routes : 19

 

Destination/Mask   Proto   Pre Cost        NextHop         Interface

0.0.0.0/32         Direct  0   0           127.0.0.1       InLoop0

1.1.1.1/32         Static  60  0           10.0.0.1        Vlan400

2.2.2.2/32         Direct  0   0           127.0.0.1       InLoop0

10.0.0.0/30        Direct  0   0           10.0.0.2        Vlan400

10.0.0.0/32        Direct  0   0           10.0.0.2        Vlan400

10.0.0.2/32        Direct  0   0           127.0.0.1       InLoop0

10.0.0.3/32        Direct  0   0           10.0.0.2        Vlan400

127.0.0.0/8        Direct  0   0           127.0.0.1       InLoop0

127.0.0.0/32       Direct  0   0           127.0.0.1       InLoop0

127.0.0.1/32       Direct  0   0           127.0.0.1       InLoop0

127.255.255.255/32 Direct  0   0           127.0.0.1       InLoop0

172.16.20.0/24     Direct  0   0           172.16.20.1     Vlan100

172.16.20.0/32     Direct  0   0           172.16.20.1     Vlan100

172.16.20.1/32     Direct  0   0           127.0.0.1       InLoop0

172.16.20.255/32   Direct  0   0           172.16.20.1     Vlan100

192.168.10.0/24    Static  60  0           10.0.0.1        Vlan400

224.0.0.0/4        Direct  0   0           0.0.0.0         NULL0

224.0.0.0/24       Direct  0   0           0.0.0.0         NULL0

255.255.255.255/32 Direct  0   0           127.0.0.1       InLoop0

[SW2]

 

[SW2]dis ip routing-table vpn-instance vpn-nrt

 

Destinations : 19       Routes : 19

 

Destination/Mask   Proto   Pre Cost        NextHop         Interface

0.0.0.0/32         Direct  0   0           127.0.0.1       InLoop0

1.1.1.0/24         Static  60  0           10.0.0.1        Vlan500

2.2.2.2/32         Direct  0   0           127.0.0.1       InLoop0

10.0.0.0/30        Direct  0   0           10.0.0.2        Vlan500

10.0.0.0/32        Direct  0   0           10.0.0.2        Vlan500

10.0.0.2/32        Direct  0   0           127.0.0.1       InLoop0

10.0.0.3/32        Direct  0   0           10.0.0.2        Vlan500

127.0.0.0/8        Direct  0   0           127.0.0.1       InLoop0

127.0.0.0/32       Direct  0   0           127.0.0.1       InLoop0

127.0.0.1/32       Direct  0   0           127.0.0.1       InLoop0

127.255.255.255/32 Direct  0   0           127.0.0.1       InLoop0

172.16.10.0/24     Direct  0   0           172.16.10.1     Vlan200

172.16.10.0/32     Direct  0   0           172.16.10.1     Vlan200

172.16.10.1/32     Direct  0   0           127.0.0.1       InLoop0

172.16.10.255/32   Direct  0   0           172.16.10.1     Vlan200

192.168.20.0/24    Static  60  0           10.0.0.1        Vlan500

224.0.0.0/4        Direct  0   0           0.0.0.0         NULL0

224.0.0.0/24       Direct  0   0           0.0.0.0         NULL0

255.255.255.255/32 Direct  0   0           127.0.0.1       InLoop0

[SW2]

 

 

PC填写相应的IP地址,同VPN实例的能PING通,不同VPN实例的不能PING





VPN实例能互通,不同VPN实例不能PING



至此,多VPN实例静态路由典型组网配置案例已完成!


0 个评论

该案例暂时没有网友评论

编辑评论

举报

×

侵犯我的权益 >
对根叔知了社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔知了社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明

提出建议

    +

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作