• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 全部
  • 全部
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
高级搜索

S3110

2021-03-16提问
  • 0关注
  • 1收藏,100浏览
粉丝:0人 关注:0人

问题描述:

请问S3110支持mac-vlan吗?

求一份S3110配置文档。

谢谢

组网及组网描述:


最佳答案

粉丝:19人 关注:3人

https://www.h3c.com/cn/d_201810/1118821_30005_0.htm#_Toc527629502

1.5.3  基于MAC的VLAN典型配置举例

1. 组网需求

·     如图1-6所示,Device A和Device C的Ethernet1/0/1端口分别连接到两个会议室,Laptop1和Laptop2是会议用笔记本电脑,会在两个会议室间移动使用。

·     Laptop1和Laptop2分别属于两个部门,两个部门间使用VLAN 100和VLAN 200进行隔离。现要求这两台笔记本电脑无论在哪个会议室使用,均只能访问自己部门的服务器,即Server1和Server2。

·     Laptop1和Laptop2的MAC地址分别为000d-88F8-4E71和0014-222C-AA69。

2. 组网图

图1-6 基于MAC的VLAN组网图

 

3. 配置思路

·     创建VLAN 100、VLAN 200。

·     配置Device A和Device C的上行端口为Trunk端口,并允许VLAN 100和VLAN 200的报文通过。

·     配置 Device B 的下行端口为Trunk端口,并允许VLAN 100和VLAN 200的报文通过;上行端口分别加入VLAN 100、VLAN 200。

·     Laptop1和Laptop2的MAC地址分别与VLAN 100、VLAN 200关联。

4. 配置步骤

(1)     Device A的配置

# 创建VLAN 100和VLAN 200。

<DeviceA> system-view

[DeviceA] vlan 100

[DeviceA-vlan100] quit

[DeviceA] vlan 200

[DeviceA-vlan200] quit

# Laptop1MAC地址与VLAN 100关联,Laptop2MAC地址与VLAN 200关联。

[DeviceA] mac-vlan mac-address 000d-88f8-4e71 vlan 100

[DeviceA] mac-vlan mac-address 0014-222c-aa69 vlan 200

# 配置终端的接入端口:Laptop1和Laptop2均可能从Ethernet1/0/1接入,将Ethernet1/0/1的端口类型配置为Hybrid,并使其在发送VLAN 100和VLAN 200的报文时去掉VLAN Tag;开启Ethernet1/0/1端口的MAC-VLAN功能。

[DeviceA] interface ethernet 1/0/1

[DeviceA-Ethernet1/0/1] port link-type hybrid

[DeviceA-Ethernet1/0/1] port hybrid vlan 100 200 untagged

 Please wait... Done.

[DeviceA-Ethernet1/0/1] mac-vlan enable

[DeviceA-Ethernet1/0/1] quit

# 为了终端能够访问Server1和Server2,需要将上行端口Ethernet1/0/2的端口类型配置为Trunk,并允许VLAN 100和VLAN 200的报文通过。

[DeviceA] interface ethernet 1/0/2

[DeviceA-Ethernet1/0/2] port link-type trunk

[DeviceA-Ethernet1/0/2] port trunk permit vlan 100 200

[DeviceA-Ethernet1/0/2] quit

(2)     Device B的配置

# 创建VLAN 100和VLAN 200,并将Ethernet1/0/13加入VLAN 100,Ethernet 1/0/14加入VLAN 200。

<DeviceB> system-view

[DeviceB] vlan 100

[DeviceB-vlan100] port ethernet 1/0/13

[DeviceB-vlan100] quit

[DeviceB] vlan 200

[DeviceB-vlan200] port ethernet 1/0/14

[DeviceB-vlan200] quit

# 配置Ethernet1/0/3Ethernet1/0/4端口为Trunk端口,均允许VLAN 100VLAN 200的报文通过。

[DeviceB] interface ethernet 1/0/3

[DeviceB-Ethernet1/0/3] port link-type trunk

[DeviceB-Ethernet1/0/3] port trunk permit vlan 100 200

[DeviceB-Ethernet1/0/3] quit

[DeviceB] interface ethernet 1/0/4

[DeviceB-Ethernet1/0/4] port link-type trunk

[DeviceB-Ethernet1/0/4] port trunk permit vlan 100 200

[DeviceB-Ethernet1/0/4] quit

(3)     Device C的配置

Device C的配置与Device A完全一致,这里不再赘述。

5. 显示与验证

(1)     Laptop1只能访问Server1,不能访问Server2;Laptop2只能访问Server2,不能访问Server1。

(2)     在Device A和Device C上可以查看到Laptop1和VLAN 100、Laptop2和VLAN 200的静态MAC VLAN地址表项已经生成。

[DeviceA] display mac-vlan all

  The following MAC VLAN addresses exist:

  S:Static  D:Dynamic

  MAC ADDR         MASK             VLAN ID   PRIO   STATE

  --------------------------------------------------------

  000d-88f8-4e71   ffff-ffff-ffff   100       0      S

  0014-222c-aa69   ffff-ffff-ffff   200       0      S

 

  Total MAC VLAN address count:2

6. 配置注意事项

·     基于MAC的VLAN只能在Hybrid端口上配置。

·     基于MAC的VLAN的配置主要用于在用户的接入设备的下行端口上进行配置,因此不能与聚合功能同时使用

暂无评论

1 个回答
粉丝:32人 关注:0人

您好,参考以下链接

https://www.h3c.com/cn/Service/Document_Software/Document_Center/Switches/Catalog/S3110/S3110/?CHID=176319

暂无评论

编辑答案

你正在编辑答案

如果你要对问题或其他回答进行点评或询问,请使用评论功能。

分享扩散:

提出建议

    +

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作

举报

×

侵犯我的权益 >
对根叔社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明