• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 漏洞说明
  • 全部
  • 全部
  • 大数据引擎
  • 知了引擎
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
搜索引擎
匹配模式
高级搜索

(十万火急)无法把AC的WEB网管映射出来

2021-06-05提问
  • 0关注
  • 1收藏,229浏览
粉丝:0人 关注:2人

问题描述:




详细配置如下:

一、AC配置

ip http port 80 

ip http secure-port 4430 

enable service web-server all 

enable service web-server http 

enable service web-server https 

interface GigabitEthernet 0/1 

 no switchport 

 no ip unreachables 

 no ip redirects 

 no ip mask-reply 

ip address 192.168.200.2 255.255.255.0 

ip route 172.16.1.0 255.255.255.0 192.168.200.1 

ip route 172.230.0.0 255.255.0.0 192.168.200.1


二、交换机配置如下:

vlan batch 10 100 200 

#

 interface Vlanif100 

 ip address 172.16.1.2 255.255.255.0 

 # 

 interface Vlanif200 

 ip address 192.168.200.1 255.255.255.0 

 # 

 interface GigabitEthernet0/0/15 

 port default vlan 200 

 # 

 interface GigabitEthernet0/0/48 

 port default vlan 100 

 # 

 ip route-static 0.0.0.0 0.0.0.0 172.16.1.1


三、路由器配置如下

 vlan 1 

 # 

 interface Vlan-interface1 

 ip address 172.16.1.1 255.255.255.0 

 interface GigabitEthernet0/1

 port link-mode route 

 nat outbound 

 nat server 63 protocol tcp global current-interface 2020 inside 192.168.200.2 www 

 nat server 64 protocol tcp global current-interface 2021 inside 192.168.200.2 4430 

 ip address X.X.X.X 255.255.255.128 

 dns server 221.7.34.10 

 dns server 221.7.34.11 

 interface GigabitEthernet0/2 

 port link-mode bridge 

ip route-static 0.0.0.0 0.0.0.0 GigabitEthernet0/1 X.X.X.X(公网地址) 

ip route-static 192.168.200.0 255.255.255.0 172.16.1.2 

#                

路由器验证结果:



交换机验证结果:



AC验证结果:



组网及组网描述:

设置列表

  • 有序列表
  • 无序列表




详细配置如下:

一、AC配置

ip http port 80 

ip http secure-port 4430 

enable service web-server all 

enable service web-server http 

enable service web-server https 

interface GigabitEthernet 0/1 

 no switchport 

 no ip unreachables 

 no ip redirects 

 no ip mask-reply 

ip address 192.168.200.2 255.255.255.0 

ip route 172.16.1.0 255.255.255.0 192.168.200.1 

ip route 172.230.0.0 255.255.0.0 192.168.200.1


二、交换机配置如下:

vlan batch 10 100 200 

#

 interface Vlanif100 

 ip address 172.16.1.2 255.255.255.0 

 # 

 interface Vlanif200 

 ip address 192.168.200.1 255.255.255.0 

 # 

 interface GigabitEthernet0/0/15 

 port default vlan 200 

 # 

 interface GigabitEthernet0/0/48 

 port default vlan 100 

 # 

 ip route-static 0.0.0.0 0.0.0.0 172.16.1.1


三、路由器配置如下

 vlan 1 

 # 

 interface Vlan-interface1 

 ip address 172.16.1.1 255.255.255.0 

 interface GigabitEthernet0/1

 port link-mode route 

 nat outbound 

 nat server 63 protocol tcp global current-interface 2020 inside 192.168.200.2 www 

 nat server 64 protocol tcp global current-interface 2021 inside 192.168.200.2 4430 

 ip address X.X.X.X 255.255.255.128 

 dns server 221.7.34.10 

 dns server 221.7.34.11 

 interface GigabitEthernet0/2 

 port link-mode bridge 

ip route-static 0.0.0.0 0.0.0.0 GigabitEthernet0/1 X.X.X.X(公网地址) 

ip route-static 192.168.200.0 255.255.255.0 172.16.1.2 

#                

路由器验证结果:



交换机验证结果:



AC验证结果:



最佳答案

已采纳
粉丝:12人 关注:0人

ac添加默认路由

为什么加默认路由就可以了呢

zhiliao_Pactt 发表时间:2021-06-05
3 个回答
yyu 五段
粉丝:3人 关注:0人

您好:

路由器上的端口映射的global地址的端口建议配置成10000-65535之间,10000以下的端口很容易被运营商禁用

 nat server 63 protocol tcp global current-interface 2020 inside 192.168.200.2 www 

 nat server 64 protocol tcp global current-interface 2021 inside 192.168.200.2 4430

改了还是不行?

zhiliao_Pactt 发表时间:2021-06-05
粉丝: 关注:

您好,请知:

可尝试在外网是否能直接访问,如果不能,以下是排查要点,请参考:

1、检查AC的路由是否可达到出口设备。

2、可尝试使用非常规端口重新映射看下,常规端口端口可能在运营商侧被拦截。

3、由于是非固定IP的映射,可尝试使用DDNS来进行映射。

如果是内网终端无法使用外网地址访问内网AC,需要在内网口开启NAT回流功能,以下是参考命令:

int gi 1/0/1

nat hairpin enable

quit


出口地址是固定ip呀

zhiliao_Pactt 发表时间:2021-06-05
zhiliao_Pactt 知了小白
粉丝:0人 关注:2人

ip route 0.0.0.0 0.0.0.0 192.168.200.1

谢谢,已经搞定

zhiliao_Pactt 发表时间:2021-06-05

编辑答案

你正在编辑答案

如果你要对问题或其他回答进行点评或询问,请使用评论功能。

分享扩散:

提出建议

    +

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作

举报

×

侵犯我的权益 >
对根叔社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明