• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 漏洞说明
  • 全部
  • 全部
  • 大数据引擎
  • 知了引擎
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
搜索引擎
匹配模式
高级搜索

防火墙端口映射,急!!!

2021-06-17提问
  • 0关注
  • 1收藏,200浏览
粉丝:0人 关注:1人

问题描述:

设置列表

  • 有序列表
  • 无序列表

把内网192.168.1.200这台服务器通过3306映射到公网,使外网任意电脑可以通过公网访问这台服务器


组网及组网描述:

对齐方式

  • 靠左
  • 居中
  • 靠右


最佳答案

粉丝:0人 关注:1人

debug看看吧,安全策略放通没,nat转没转,会话有没有等等

4 个回答
zhiliao_H5rPy 知了小白
粉丝:0人 关注:1人

现在的配置如下 ,但是不通


#
version 7.1.064, Release 9510P06
#
sysname F100-C-G2
#
context Admin id 1
#
telnet server enable
#
irf mac-address persistent timer
irf auto-update enable
undo irf link-delay
irf member 1 priority 1
#
dialer-group 1 rule ip permit
#
dhcp enable
dhcp server forbidden-ip 192.168.100.1
dhcp server forbidden-ip 192.168.100.2
#
password-recovery enable
#
vlan 1
#
object-group ip address 47.99.126.94
0 network host address 47.99.126.94
#
object-group ip address fuwuqi
0 network host address 192.168.1.234
#
object-group ip address xinzengFWQ
0 network host address 192.168.1.200
#
object-group ip address 网络用户
0 network subnet 172.16.1.0 255.255.255.0
10 network subnet 172.16.2.0 255.255.255.0
20 network subnet 172.16.3.0 255.255.255.0
#
object-group service 10000
#
object-group service 10000duankou
0 service tcp destination eq 10000
#
object-group service 3306
0 service tcp destination eq 3306
#
dhcp server ip-pool 1
gateway-list 192.168.100.1
network 192.168.100.0 mask 255.255.255.0
dns-list 222.172.200.68 61.166.150.123
expired day 0 hour 9
#
interface Dialer1
ppp chap password cipher $c$3$2kwYJ2CJCTO4/3d0pA6x5+skIAYTv6yY0g==
ppp chap user 2927A104@sidy.yn
ppp ipcp dns admit-any
ppp ipcp dns request
ppp pap local-user 2927A104@sidy.yn password cipher $c$3$FIWy5xXlnMeym8EqJ1MB06IkM8gl3oCCPw==
dialer bundle enable
dialer-group 1
dialer timer idle 0
ip address ppp-negotiate
tcp mss 1024
nat outbound
#
interface NULL0
#
interface GigabitEthernet1/0/0
port link-mode route
combo enable copper
#
interface GigabitEthernet1/0/1
port link-mode route
combo enable fiber
#
interface GigabitEthernet1/0/2
port link-mode route
#
interface GigabitEthernet1/0/3
port link-mode route
ip address 218.*.*.18 255.255.255.128
ip last-hop hold
nat outbound
nat server protocol tcp global 218.*.*.18 3306 inside 192.168.1.200 3306
nat server protocol tcp global 218.*.*.18 10000 inside 192.168.1.234 10000
#
interface GigabitEthernet1/0/4
port link-mode route
ip last-hop hold
pppoe-client dial-bundle-number 1
#
interface GigabitEthernet1/0/5
port link-mode route
ip address 192.168.100.1 255.255.255.0
#
interface GigabitEthernet1/0/6
port link-mode route
#
interface GigabitEthernet1/0/7
port link-mode route
#
interface GigabitEthernet1/0/8
port link-mode route
#
interface GigabitEthernet1/0/9
port link-mode route
#
interface GigabitEthernet1/0/10
port link-mode route
#
interface GigabitEthernet1/0/11
port link-mode route
#
object-policy ip fuwuqi
rule 0 pass source-ip 47.99.126.94 destination-ip fuwuqi service 10000duankou
rule 1 pass destination-ip xinzengFWQ service 3306
#
object-policy ip pass
rule 0 pass
#
security-zone name Local
#
security-zone name Trust
import interface GigabitEthernet1/0/5
#
security-zone name DMZ
#
security-zone name Untrust
import interface Dialer1
import interface GigabitEthernet1/0/3
import interface GigabitEthernet1/0/4
#
security-zone name Management
import interface GigabitEthernet1/0/0
import interface GigabitEthernet1/0/2
#
zone-pair security source Local destination Trust
object-policy apply ip pass
#
zone-pair security source Local destination Untrust
object-policy apply ip pass
#
zone-pair security source Trust destination Local
object-policy apply ip pass
#
zone-pair security source Trust destination Untrust
object-policy apply ip pass
#
zone-pair security source Untrust destination Local
object-policy apply ip pass
#
zone-pair security source Untrust destination Trust
object-policy apply ip fuwuqi
#
scheduler logfile size 16
#
line class aux
user-role network-operator
#
line class console
user-role network-admin
#
line class vty
user-role network-operator
#
line aux 0
user-role network-admin
#
line con 0
authentication-mode scheme
user-role network-admin
#
line vty 0 63
authentication-mode scheme
user-role network-admin
#
ip route-static 0.0.0.0 0 218.*.*.1
ip route-static 10.176.17.0 24 1.1.1.1
ip route-static 10.182.0.0 16 1.1.1.1
ip route-static 172.16.1.0 24 192.168.100.2
ip route-static 172.16.2.0 24 192.168.100.2
ip route-static 172.16.3.0 24 192.168.100.2
ip route-static 172.16.4.0 24 192.168.100.2
ip route-static 192.168.1.0 24 192.168.100.2
#
ssh server enable
#
domain system
#
aaa session-limit ftp 16
aaa session-limit telnet 16
aaa session-limit ssh 16
domain default enable system
#
role name level-0
description Predefined level-0 role
#
role name level-1
description Predefined level-1 role
#
role name level-2
description Predefined level-2 role
#
role name level-3
description Predefined level-3 role
#
role name level-4
description Predefined level-4 role
#
role name level-5
description Predefined level-5 role
#
role name level-6
description Predefined level-6 role
#
role name level-7
description Predefined level-7 role
#
role name level-8
description Predefined level-8 role
#
role name level-9
description Predefined level-9 role
#
role name level-10
description Predefined level-10 role
#
role name level-11
description Predefined level-11 role
#
role name level-12
description Predefined level-12 role
#
role name level-13
description Predefined level-13 role
#
role name level-14
description Predefined level-14 role
#
user-group system
#
local-user admin class manage
password hash $h$6$TI0U2bmroWUhdrtp$gUF2+SP18ghVVrrXplRswIrWYNUkzCkl79ofhuTYvkAg8UG9bGNeuJ7BGR+tLjoaPdMaQEhiZChClX3E86y1Uw==
service-type ssh telnet terminal https
authorization-attribute user-role level-3
authorization-attribute user-role network-admin
authorization-attribute user-role network-operator
#
ip https enable
#
traffic-policy
rule name 限速1
disable
action qos profile 限速1
source-address address-set 网络用户
source-zone Trust
destination-zone Untrust
profile name 限速1
bandwidth upstream maximum per-ip 2000
bandwidth downstream maximum per-ip 2000
#
return

粉丝: 关注:

您好,请知:

防火墙映射内部服务器不生效,以下是排查要点,请参考:

1、检查内部服务器到防火墙的路由是否可达。

2、检查防火墙的安全策略或域间策略是否已放通。

3、检查防火墙映射的端口是否准确。

4、可尝试使用非常规端口映射看下,不排除运营商侧拦截了常规端口。


粉丝:8人 关注:1人

192.168.1.0/24上网正常不?

正常的

zhiliao_H5rPy 发表时间:2021-06-17
回复zhiliao_H5rPy:

暂时只留interface GigabitEthernet1/0/3对外试一下呢?

落啦耳朵 发表时间:2021-06-17
粉丝:0人 关注:0人

公网的3306可能是被禁用的


编辑答案

你正在编辑答案

如果你要对问题或其他回答进行点评或询问,请使用评论功能。

分享扩散:

提出建议

    +

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作

举报

×

侵犯我的权益 >
对根叔社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明