大佬麻烦看一下ipsec为啥没起来
R1:
interface LoopBack0
ip address 172.16.1.1 255.255.255.255
#
interface LoopBack1
ip address 192.168.1.1 255.255.255.0
#
ip route-static 192.168.2.0 24 Tunnel0
# interface GigabitEthernet0/1
ip address 1.1.1.1 255.255.255.0
ipsec apply policy h3c
#
interface Tunnel0 mode gre
ip address 10.1.1.1 255.255.255.0
source LoopBack0
destination 172.16.1.2
keepalive 3 3
#
acl advanced 3000
rule 0 permit ip source 172.16.1.1 0 destination 172.16.1.2 0
# ipsec transform-set 1
esp encryption-algorithm des-cbc
esp authentication-algorithm md5
#
ipsec policy h3c 10 isakmp
transform-set 1
security acl 3000
remote-address 2.2.2.1
ike-profile 1
#
ike identity user-fqdn
#
ike profile 1
keychain 1
exchange-mode aggressive
local-identity user-fqdn r1
match remote identity user-fqdn r3
#
ike keychain 1
pre-shared-key address 2.2.2.1 255.255.255.255 key simple h3c
_________________________________
R3:
interface LoopBack0
ip address 172.16.1.2 255.255.255.255
#
interface LoopBack1
ip address 192.168.2.1 255.255.255.0
#
interface GigabitEthernet0/1
ip address 2.2.2.1 255.255.255.0
ipsec apply policy h3c
#
interface Tunnel0 mode gre
ip address 10.1.1.2 255.255.255.0
source LoopBack0
destination 172.16.1.1
keepalive 3 3
#
ip route-static 0.0.0.0 0 2.2.2.2
ip route-static 192.168.1.0 24 Tunnel0
#
ipsec transform-set 1
esp encryption-algorithm des-cbc
esp authentication-algorithm md5
#
ipsec policy-template r1 1
transform-set 1
ike-profile 1
#
ipsec policy h3c 10 isakmp template r1
#
ike identity user-fqdn
#
ike profile 1
keychain 1
exchange-mode aggressive
local-identity user-fqdn r3
match remote identity user-fqdn r1
#
ike keychain 1 pre-shared-key hostname r1 key simple h3c
(0)
最佳答案
您好,请知:
IPSEC VPN故障排查:
1、检查公网地址的连通性
2、检查ipsec acl是否配置正确(两端ACL以互为镜像的方式配置)
3、检查ike keychain/ike profile 协商参数配置是否正确(工作模式、keychain、identity、本端/对端隧道地址或隧道名称、NAT穿越功能v7自适应)
4、检查ipsec proposal(v5平台) /ipsec transform-set(v7平台)参数两端是否一致(封装模式、安全协议、验证算法、加密算法)
5、检查设备是否创建ipsec策略,并加载协商参数(acl、ike profile 、ipsec transform-set、对端隧道IP)
6、检查ipsec策略是否应用在正确的接口上
IPSEC排查命令:
1、disp ipsec policy
2、disp acl
3、dis cu conf ike-profile
4、dis cu conf ike-keychain
5、display ike proposal
6、display ipsec transform-set
7、disp ike sa (verbose)
8、disp ipsec sa
9、reset ipsec sa
10、reset ike sa
(0)
亲~登录后才可以操作哦!
确定你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作
举报
×
侵犯我的权益
×
侵犯了我企业的权益
×
抄袭了我的内容
×
原文链接或出处
诽谤我
×
对根叔社区有害的内容
×
不规范转载
×
举报说明
暂无评论