• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 漏洞说明
  • 全部
  • 全部
  • 大数据引擎
  • 知了引擎
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
搜索引擎
匹配模式
高级搜索

什么是ccc l2vpn?

2021-07-08提问
  • 0关注
  • 1收藏,1363浏览
粉丝:0人 关注:0人

问题描述:

什么是ccc vpn,是否有相关资料?

组网及组网描述:

最佳答案

粉丝:144人 关注:0人

您好,参考

1.13.7  CCC远程连接配置举例

1. 组网需求

用户网络有若干个站点,希望通过在骨干网上建立CCC远程连接,实现站点1与站点2互联,站点1和站点2通过以太网接口的方式接入PE 1和PE 2。

2. 组网图

图1-15 CCC远程连接配置组网图

设备

接口

IP地址

设备

接口

IP地址

CE 1

GE1/0/1

100.1.1.1/24

P

Loop0

192.4.4.4/32

PE 1

Loop0

192.2.2.2/32

GE1/0/1

10.1.1.2/24

GE1/0/1

-

GE1/0/2

10.2.2.2/24

GE1/0/2

10.1.1.1/24

PE 2

Loop0

192.3.3.3/32

CE 2

GE1/0/1

100.1.1.2/24

GE1/0/1

-

GE1/0/2

10.2.2.1/24

 

3. 配置步骤

(1)      配置CE 1

<CE1> system-view

[CE1] interface gigabitethernet 1/0/1

[CE1-GigabitEthernet1/0/1] ip address 100.1.1.1 24

[CE1-GigabitEthernet1/0/1] quit

(2)     配置PE 1

# 配置LSR ID。

<PE1> system-view

[PE1] interface loopback 0

[PE1-LoopBack0] ip address 192.2.2.2 32

[PE1-LoopBack0] quit

[PE1] mpls lsr-id 192.2.2.2

# 开启L2VPN功能。

[PE1] l2vpn enable

# 配置连接P的接口GigabitEthernet1/0/2,在此接口上使能MPLS。

[PE1] interface gigabitethernet 1/0/2

[PE1-GigabitEthernet1/0/2] ip address 10.1.1.1 24

[PE1-GigabitEthernet1/0/2] mpls enable

[PE1-GigabitEthernet1/0/2] quit

# 在PE 1上运行OSPF,用于发布路由。

[PE1] ospf

[PE1-ospf-1] area 0

[PE1-ospf-1-area-0.0.0.0] network 10.1.1.1 0.0.0.255

[PE1-ospf-1-area-0.0.0.0] network 192.2.2.2 0.0.0.0

[PE1-ospf-1-area-0.0.0.0] quit

[PE1-ospf-1] quit

# 创建交叉连接组ccc,在该交叉连接组内创建CCC远程连接(入标签为101、出标签为201、下一跳地址为10.1.1.2),并将接口GigabitEthernet1/0/1与此CCC远程连接关联。

[PE1] xconnect-group ccc

[PE1-xcg-ccc] connection ccc

[PE1-xcg-ccc-ccc] ccc in-label 101 out-label 201 nexthop 10.1.1.2

[PE1-xcg-ccc-ccc] ac interface gigabitethernet 1/0/1

[PE1-xcg-ccc-ccc] quit

[PE1-xcg-ccc] quit

(3)     配置P

# 配置LSR ID。

<P> system-view

[P] interface loopback 0

[P-LoopBack0] ip address 192.4.4.4 32

[P-LoopBack0] quit

[P] mpls lsr-id 192.4.4.4

# 配置连接PE 1的接口GigabitEthernet1/0/1,在此接口上使能MPLS。

[P] interface gigabitethernet 1/0/1

[P-GigabitEthernet1/0/1] ip address 10.1.1.2 24

[P-GigabitEthernet1/0/1] mpls enable

[P-GigabitEthernet1/0/1] quit

# 配置连接PE 2的接口GigabitEthernet1/0/2,在此接口上使能MPLS。

[P] interface gigabitethernet 1/0/2

[P-GigabitEthernet1/0/2] ip address 10.2.2.2 24

[P-GigabitEthernet1/0/2] mpls enable

[P-GigabitEthernet1/0/2] quit

# 配置一条静态LSP用于转发由PE 1去往PE 2的报文。

[P] static-lsp transit pe1-pe2 in-label 201 nexthop 10.2.2.1 out-label 202

# 配置另一条静态LSP用于转发由PE 2去往PE 1的报文。

[P] static-lsp transit pe2-pe1 in-label 102 nexthop 10.1.1.1 out-label 101

# 在P上运行OSPF,用于发布路由。

[P] ospf

[P-ospf-1] area 0

[P-ospf-1-area-0.0.0.0] network 10.1.1.2 0.0.0.255

[P-ospf-1-area-0.0.0.0] network 10.2.2.2 0.0.0.255

[P-ospf-1-area-0.0.0.0] network 192.4.4.4 0.0.0.0

[P-ospf-1-area-0.0.0.0] quit

[P-ospf-1] quit

(4)     配置PE 2

# 配置LSR ID。

<PE2> system-view

[PE2] interface loopback 0

[PE2-LoopBack0] ip address 192.3.3.3 32

[PE2-LoopBack0] quit

[PE2] mpls lsr-id 192.3.3.3

# 开启L2VPN功能。

[PE2] l2vpn enable

# 配置连接P的接口GigabitEthernet1/0/2,在此接口上使能MPLS。

[PE2] interface gigabitethernet 1/0/2

[PE2-GigabitEthernet1/0/2] ip address 10.2.2.1 24

[PE2-GigabitEthernet1/0/2] mpls enable

[PE2-GigabitEthernet1/0/2] quit

# 在PE 2上运行OSPF,用于发布路由。

[PE2] ospf

[PE2-ospf-1] area 0

[PE2-ospf-1-area-0.0.0.0] network 10.2.2.0 0.0.0.255

[PE2-ospf-1-area-0.0.0.0] network 192.3.3.3 0.0.0.0

[PE2-ospf-1-area-0.0.0.0] quit

[PE2-ospf-1] quit

# 创建交叉连接组ccc,在该交叉连接组内创建CCC远程连接(入标签为202、出标签为102、下一跳地址为10.2.2.2),并将接口GigabitEthernet1/0/1与此CCC远程连接关联。

[PE2] xconnect-group ccc

[PE2-xcg-ccc] connection ccc

[PE2-xcg-ccc-ccc] ccc in-label 202 out-label 102 nexthop 10.2.2.2

[PE2-xcg-ccc-ccc] ac interface gigabitethernet 1/0/1

[PE2-xcg-ccc-ccc] quit

[PE2-xcg-ccc] quit

(5)     配置CE 2

<CE2> system-view

[CE2] interface gigabitethernet 1/0/1

[CE2-GigabitEthernet1/0/1] ip address 100.1.1.2 24

[CE2-GigabitEthernet1/0/1] quit

4. 验证配置

# 在PE 1上查看PW信息,可以看到建立了一条PW连接。PW ID/Rmt Site字段为“-”,Protoc字段为“Static”,表示该PW连接为CCC远程连接。

[PE1] display l2vpn pw

Flags: M - main, B - backup, BY - bypass, H - hub link, S - spoke link, N - no split horizon

Total number of PWs: 1

1 up, 0 blocked, 0 down, 0 defect, 0 idle, 0 duplicate

 

Xconnect-group Name: ccc

Peer            PW ID/Rmt Site    In/Out Label    Proto   Flag  Link ID  State

10.1.1.2        -                 101/201         Static  M     0        Up

# 在PE 2上也可以看到PW信息。

[PE2] display l2vpn pw

Flags: M - main, B - backup, BY - bypass, H - hub link, S - spoke link, N - no split horizon

Total number of PWs: 1

1 up, 0 blocked, 0 down, 0 defect, 0 idle, 0 duplicate

 

Xconnect-group Name: ccc

Peer            PW ID/Rmt Site    In/Out Label    Proto   Flag  Link ID  State

10.2.2.2        -                 202/102         Static  M     0        Up

# CE 1与CE 2之间能够ping通。


暂无评论

3 个回答
粉丝:124人 关注:6人

您好,请知:

以下是L2VPN的用户手册链接,请参考:

https://www.h3c.com/cn/d_201708/1023153_30005_0.htm 

 

暂无评论

粉丝:12人 关注:1人

1.13.7  CCC远程连接配置举例

1. 组网需求

用户网络有若干个站点,希望通过在骨干网上建立CCC远程连接,实现站点1与站点2互联,站点1和站点2通过以太网接口的方式接入PE 1和PE 2。

2. 组网图

图1-15 CCC远程连接配置组网图

设备

接口

IP地址

设备

接口

IP地址

CE 1

GE1/0/1

100.1.1.1/24

P

Loop0

192.4.4.4/32

PE 1

Loop0

192.2.2.2/32

GE1/0/1

10.1.1.2/24

GE1/0/1

-

GE1/0/2

10.2.2.2/24

GE1/0/2

10.1.1.1/24

PE 2

Loop0

192.3.3.3/32

CE 2

GE1/0/1

100.1.1.2/24

GE1/0/1

-

GE1/0/2

10.2.2.1/24

 

3. 配置步骤

(1)      配置CE 1

<CE1> system-view

[CE1] interface gigabitethernet 1/0/1

[CE1-GigabitEthernet1/0/1] ip address 100.1.1.1 24

[CE1-GigabitEthernet1/0/1] quit

(2)     配置PE 1

# 配置LSR ID。

<PE1> system-view

[PE1] interface loopback 0

[PE1-LoopBack0] ip address 192.2.2.2 32

[PE1-LoopBack0] quit

[PE1] mpls lsr-id 192.2.2.2

# 开启L2VPN功能。

[PE1] l2vpn enable

# 配置连接P的接口GigabitEthernet1/0/2,在此接口上使能MPLS。

[PE1] interface gigabitethernet 1/0/2

[PE1-GigabitEthernet1/0/2] ip address 10.1.1.1 24

[PE1-GigabitEthernet1/0/2] mpls enable

[PE1-GigabitEthernet1/0/2] quit

# 在PE 1上运行OSPF,用于发布路由。

[PE1] ospf

[PE1-ospf-1] area 0

[PE1-ospf-1-area-0.0.0.0] network 10.1.1.1 0.0.0.255

[PE1-ospf-1-area-0.0.0.0] network 192.2.2.2 0.0.0.0

[PE1-ospf-1-area-0.0.0.0] quit

[PE1-ospf-1] quit

# 创建交叉连接组ccc,在该交叉连接组内创建CCC远程连接(入标签为101、出标签为201、下一跳地址为10.1.1.2),并将接口GigabitEthernet1/0/1与此CCC远程连接关联。

[PE1] xconnect-group ccc

[PE1-xcg-ccc] connection ccc

[PE1-xcg-ccc-ccc] ccc in-label 101 out-label 201 nexthop 10.1.1.2

[PE1-xcg-ccc-ccc] ac interface gigabitethernet 1/0/1

[PE1-xcg-ccc-ccc] quit

[PE1-xcg-ccc] quit

(3)     配置P

# 配置LSR ID。

<P> system-view

[P] interface loopback 0

[P-LoopBack0] ip address 192.4.4.4 32

[P-LoopBack0] quit

[P] mpls lsr-id 192.4.4.4

# 配置连接PE 1的接口GigabitEthernet1/0/1,在此接口上使能MPLS。

[P] interface gigabitethernet 1/0/1

[P-GigabitEthernet1/0/1] ip address 10.1.1.2 24

[P-GigabitEthernet1/0/1] mpls enable

[P-GigabitEthernet1/0/1] quit

# 配置连接PE 2的接口GigabitEthernet1/0/2,在此接口上使能MPLS。

[P] interface gigabitethernet 1/0/2

[P-GigabitEthernet1/0/2] ip address 10.2.2.2 24

[P-GigabitEthernet1/0/2] mpls enable

[P-GigabitEthernet1/0/2] quit

# 配置一条静态LSP用于转发由PE 1去往PE 2的报文。

[P] static-lsp transit pe1-pe2 in-label 201 nexthop 10.2.2.1 out-label 202

# 配置另一条静态LSP用于转发由PE 2去往PE 1的报文。

[P] static-lsp transit pe2-pe1 in-label 102 nexthop 10.1.1.1 out-label 101

# 在P上运行OSPF,用于发布路由。

[P] ospf

[P-ospf-1] area 0

[P-ospf-1-area-0.0.0.0] network 10.1.1.2 0.0.0.255

[P-ospf-1-area-0.0.0.0] network 10.2.2.2 0.0.0.255

[P-ospf-1-area-0.0.0.0] network 192.4.4.4 0.0.0.0

[P-ospf-1-area-0.0.0.0] quit

[P-ospf-1] quit

(4)     配置PE 2

# 配置LSR ID。

<PE2> system-view

[PE2] interface loopback 0

[PE2-LoopBack0] ip address 192.3.3.3 32

[PE2-LoopBack0] quit

[PE2] mpls lsr-id 192.3.3.3

# 开启L2VPN功能。

[PE2] l2vpn enable

# 配置连接P的接口GigabitEthernet1/0/2,在此接口上使能MPLS。

[PE2] interface gigabitethernet 1/0/2

[PE2-GigabitEthernet1/0/2] ip address 10.2.2.1 24

[PE2-GigabitEthernet1/0/2] mpls enable

[PE2-GigabitEthernet1/0/2] quit

# 在PE 2上运行OSPF,用于发布路由。

[PE2] ospf

[PE2-ospf-1] area 0

[PE2-ospf-1-area-0.0.0.0] network 10.2.2.0 0.0.0.255

[PE2-ospf-1-area-0.0.0.0] network 192.3.3.3 0.0.0.0

[PE2-ospf-1-area-0.0.0.0] quit

[PE2-ospf-1] quit

# 创建交叉连接组ccc,在该交叉连接组内创建CCC远程连接(入标签为202、出标签为102、下一跳地址为10.2.2.2),并将接口GigabitEthernet1/0/1与此CCC远程连接关联。

[PE2] xconnect-group ccc

[PE2-xcg-ccc] connection ccc

[PE2-xcg-ccc-ccc] ccc in-label 202 out-label 102 nexthop 10.2.2.2

[PE2-xcg-ccc-ccc] ac interface gigabitethernet 1/0/1

[PE2-xcg-ccc-ccc] quit

[PE2-xcg-ccc] quit

(5)     配置CE 2

<CE2> system-view

[CE2] interface gigabitethernet 1/0/1

[CE2-GigabitEthernet1/0/1] ip address 100.1.1.2 24

[CE2-GigabitEthernet1/0/1] quit

4. 验证配置

# 在PE 1上查看PW信息,可以看到建立了一条PW连接。PW ID/Rmt Site字段为“-”,Protoc字段为“Static”,表示该PW连接为CCC远程连接。

[PE1] display l2vpn pw

Flags: M - main, B - backup, BY - bypass, H - hub link, S - spoke link, N - no split horizon

Total number of PWs: 1

1 up, 0 blocked, 0 down, 0 defect, 0 idle, 0 duplicate

 

Xconnect-group Name: ccc

Peer            PW ID/Rmt Site    In/Out Label    Proto   Flag  Link ID  State

10.1.1.2        -                 101/201         Static  M     0        Up

# 在PE 2上也可以看到PW信息。

[PE2] display l2vpn pw

Flags: M - main, B - backup, BY - bypass, H - hub link, S - spoke link, N - no split horizon

Total number of PWs: 1

1 up, 0 blocked, 0 down, 0 defect, 0 idle, 0 duplicate

 

Xconnect-group Name: ccc

Peer            PW ID/Rmt Site    In/Out Label    Proto   Flag  Link ID  State

10.2.2.2        -                 202/102         Static  M     0        Up

# CE 1与CE 2之间能够ping通。

暂无评论

粉丝:143人 关注:1人

CC方式MPLS VLL?是这个?

暂无评论

编辑答案

你正在编辑答案

如果你要对问题或其他回答进行点评或询问,请使用评论功能。

分享扩散:

提出建议

    +

亲~登录后才可以操作哦!

确定

亲~检测到您登陆的账号未在http://hclhub.h3c.com进行注册

注册后可访问此模块

跳转hclhub

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作

举报

×

侵犯我的权益 >
对根叔社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到pub.zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 pub.zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到pub.zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明