• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 漏洞说明
  • 全部
  • 全部
  • 大数据引擎
  • 知了引擎
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
搜索引擎
匹配模式
高级搜索

大神们MSR3610-x1 V7版本,PPPoE拨号获取ipv6怎么配置,谢谢

2021-08-03提问
  • 0关注
  • 0收藏,100浏览
粉丝:0人 关注:0人

问题描述:

大神们MSR3610-x1  V7版本,PPPoE拨号获取ipv6怎么配置,谢谢

组网及组网描述:

大神们MSR3610-x1  V7版本,PPPoE拨号获取ipv6怎么配置,谢谢

最佳答案

粉丝:10人 关注:1人

参考我之前写的两个案例:

https://zhiliao.h3c.com/theme/details/100732

https://zhiliao.h3c.com/theme/details/127269

#

dialer-group 1 rule ip permit

#
interface Dialer0
mtu 1492
ppp chap password cipher 111111111111111111==
ppp chap user 11111111
ppp ipcp dns admit-any
ppp ipcp dns request
ppp pap local-user 1111111111 password cipher $c$3$4r11111111111111rz2Fw==
dialer bundle enable
dialer-group 1
dialer timer idle 0
dialer timer autodial 5
ip address ppp-negotiate
tcp mss 1452
ip last-hop hold
nat outbound
#ipv6 address dhcp-alloc
ipv6 address auto
ipv6 dhcp client pd 1
#

#
interface GigabitEthernet0/0
pppoe-client dial-bundle-number 1
#
interface Vlan-interface1
ip address 192.168.0.1 255.255.255.0
ipv6 address 1 ::1/64
undo ipv6 nd ra halt
#
ip route-static 0.0.0.0 0 Dialer0
ipv6 route-static :: 0 Dialer0
#

暂无评论

2 个回答
粉丝:20人 关注:3人

以下是配置举例,请参考:

3.7.4  PPPoE Server通过ND协议、IPv6CP协商生成信息用于用户生成IPv6地址配置举例

1. 组网需求

Host和Router之间通过以太网接口相连,Host通过PPPoE接入Router,Router作为PPPoE Server通过ND协议为Host分配IPv6地址。

在该场景下,Host通过ND协议中的RA报文获得IPv6地址前缀,通过IPv6CP协商获取IPv6接口标识,二者组合生成IPv6全球单播地址。

2. 组网图

图3-6 配置PPPoE Server通过ND协议、IPv6CP协商生成信息用于用户生成IPv6地址组网图

3. 配置步骤

# 配置虚拟模板接口1的参数,采用PAP认证对端,配置本端IPv6地址,关闭对RA消息发布的抑制。

<Router> system-view

[Router] interface virtual-template 1

[Router-Virtual-Template1] ppp authentication-mode pap domain system

[Router-Virtual-Template1] ipv6 address 2001::1 64

[Router-Virtual-Template1] undo ipv6 nd ra halt

[Router-Virtual-Template1] quit

# 在GigabitEthernet1/0/1接口上启用PPPoE Server协议,将该以太网接口与虚拟模板接口1绑定。

[Router] interface gigabitethernet 1/0/1

[Router-GigabitEthernet1/0/1] pppoe-server bind virtual-template 1

[Router-GigabitEthernet1/0/1] quit

# 配置PPPoE用户。

[Router] local-user user1 class network

[Router-luser-network-user1] password simple 123456TESTplat&!

[Router-luser-network-user1] service-type ppp

[Router-luser-network-user1] quit

# 在ISP域下配置为用户授权IPv6前缀属性。

[Router] domain system

[Router-isp-system] authorization-attribute ipv6-prefix 2003:: 64

[Router-isp-system] quit

4. 验证配置

配置完成后,当Host使用用户名user1、密码pass1,通过PPPoE接入Router后,通过授权的IPv6前缀和IPv6CP协商获取的IPv6接口标识就自动生成一个IPv6全球单播地址。

[Router] display ppp access-user interface gigabitethernet 1/0/1

Interface  Username   MAC address     IP address  IPv6 address           IPv6 PDPrefix

VA0        user1      0000-5e08-9d00  -           2003::9CBC:3898:0:605  -

3.7.5  PPPoE Server通过DHCPv6协议为用户分配IPv6地址配置举例

1. 组网需求

Host和Router之间通过以太网接口相连,Host通过PPPoE接入Router,Router作为PPPoE Server通过DHCPv6协议为Host分配IPv6地址。

2. 组网图

图3-7 配置PPPoE Server通过DHCPv6协议为用户分配IPv6地址组网图

3. 配置步骤

# 配置虚拟模板接口1的参数,采用PAP认证对端,配置本端IPv6地址,关闭对RA消息发布的抑制,配置主机通过DHCPv6协议获取IPv6地址。

<Router> system-view

[Router] interface virtual-template 1

[Router-Virtual-Template1] ppp authentication-mode pap domain system

[Router-Virtual-Template1] ipv6 address 3001::1 64

[Router-Virtual-Template1] undo ipv6 nd ra halt

[Router-Virtual-Template1] ipv6 nd autoconfig managed-address-flag

# 开启DHCPv6 Server功能。

[Router-Virtual-Template1] ipv6 dhcp select server

[Router-Virtual-Template1] quit

# 在GigabitEthernet1/0/1接口上启用PPPoE Server协议,将该以太网接口与虚拟模板接口1绑定。

[Router] interface gigabitethernet 1/0/1

[Router-GigabitEthernet1/0/1] pppoe-server bind virtual-template 1

[Router-GigabitEthernet1/0/1] quit

# 创建名称为pool1的DHCPv6地址池,配置DHCPv6地址池动态分配的地址网段为3001::/32,分配的DNS服务器地址为2001:2::3。

[Router] ipv6 dhcp pool pool1

[Router-dhcp6-pool-pool1] network 3001::/32

[Router-dhcp6-pool-pool1] dns-server 2001:2::3

[Router-dhcp6-pool-pool1] quit

# 配置PPPoE用户。

[Router] local-user user1 class network

[Router-luser-network-user1] password simple 123456TESTplat&!

[Router-luser-network-user1] service-type ppp

[Router-luser-network-user1] quit

# 在ISP域下配置为用户授权地址池属性。

[Router] domain system

[Router-isp-system] authorization-attribute ipv6-pool pool1

[Router-isp-system] quit

4. 验证配置

配置完成后,当Host使用用户名user1、密码pass1,通过PPPoE接入Router后,Router通过DHCPv6协议为Host分配一个IPv6全球单播地址。

[Router] display ppp access-user interface gigabitethernet 1/0/1

Interface  Username   MAC address     IP address  IPv6 address   IPv6 PDPrefix

VA0        user1      0000-5e08-9d00  -           3001::2        -

3.7.6  PPPoE Server通过DHCPv6协议分配代理前缀用于用户生成IPv6地址配置举例

1. 组网需求

Router A和Router B之间通过以太网接口相连,Router A通过PPPoE接入Router B,Router B作为PPPoE Server通过DHCPv6协议给Router A分配代理前缀,Router A再通过代理前缀给下面的主机分配IPv6地址。

2. 组网图

图3-8 配置PPPoE Server通过DHCPv6协议分配代理前缀用于用户生成IPv6地址组网图

3. 配置步骤

(1)     配置Router B(PPPoE Server)

# 配置虚拟模板接口1的参数,采用PAP认证对端,配置本端IPv6地址,关闭对RA消息发布的抑制。

<RouterB> system-view

[RouterB] interface virtual-template 1

[RouterB-Virtual-Template1] ppp authentication-mode pap domain system

[RouterB-Virtual-Template1] ipv6 address 2001::1 64

[RouterB-Virtual-Template1] undo ipv6 nd ra halt

# 开启DHCPv6 Server功能。

[RouterB-Virtual-Template1] ipv6 dhcp select server

[RouterB-Virtual-Template1] quit

# 在GigabitEthernet1/0/1接口上启用PPPoE Server协议,将该以太网接口与虚拟模板接口1绑定。

[RouterB] interface gigabitethernet 1/0/1

[RouterB-GigabitEthernet1/0/1] pppoe-server bind virtual-template 1

[RouterB-GigabitEthernet1/0/1] quit

# 配置DHCPv6前缀池6,包含的前缀为4001::/32,分配的前缀长度为42。

[RouterB] ipv6 dhcp prefix-pool 6 prefix 4001::/32 assign-len 42

# 创建名称为pool1的DHCPv6地址池,在地址池下引用前缀池6。

[RouterB] ipv6 dhcp pool pool1

[RouterB-dhcp6-pool-pool1] prefix-pool 6

[Router-dhcp6-pool-pool1] quit

# 配置PPPoE用户。

[RouterB] local-user user1 class network

[RouterB-luser-network-user1] password simple 123456TESTplat&!

[RouterB-luser-network-user1] service-type ppp

[RouterB-luser-network-user1] quit

# 在ISP域下配置为用户授权地址池属性。

[RouterB] domain system

[RouterB-isp-system] authorization-attribute ipv6-pool pool1

(2)     配置Router A(PPPoE Client)

# 在Dialer1接口上开启共享DDR。

<RouterA> system-view

[RouterA] interface dialer 1

[RouterA-Dialer1] dialer bundle enable

# 配置Router A被Router B以PAP方式认证时Router A发送的PAP用户名和密码。

[RouterA-Dialer1] ppp pap local-user user1 password simple 123456TESTplat&!

# 配置PPPoE Client工作在永久在线模式。

[RouterA-Dialer1] dialer timer idle 0

# 配置DDR自动拨号的间隔时间为60秒。

[RouterA-Dialer1] dialer timer autodial 60

# 配置Dialer1接口作为DHCPv6客户端,通过DHCPv6方式获取IPv6地址和其他网络配置参数。

[RouterA-Dialer1] ipv6 address dhcp-alloc

# 配置Dialer1接口作为DHCPv6客户端,通过DHCPv6方式获取IPv6前缀和其他网络配置参数;指定获取到IPv6前缀后,创建编号为1的IPv6前缀,该前缀编号1对应的IPv6前缀为DHCPv6客户端获取到的前缀。

[RouterA-Dialer1] ipv6 dhcp client pd 1

[RouterA-Dialer1] quit

# 配置一个PPPoE会话,该会话对应Dialer bundle 1(Dialer bundle 1对应Dialer1接口)。

[RouterA] interface gigabitethernet 1/0/2

[RouterA-GigabitEthernet1/0/2] pppoe-client dial-bundle-number 1

[RouterA-GigabitEthernet1/0/2] quit

# 配置缺省路由。

[RouterA] ipv6 route-static :: 0 dialer 1

# 接口GigabitEthernet1/0/1上取消对RA消息发布的抑制。

[RouterA] interface gigabitethernet 1/0/1

[RouterA-GigabitEthernet1/0/1] undo ipv6 nd ra halt

# 在接口GigabitEthernet1/0/1上配置动态获取IPv6前缀的编号为1,即该接口将使用编号为1的前缀生成IPv6地址,并将编号为1的IPv6前缀通过RA报文分配给终端设备。

[RouterA-GigabitEthernet1/0/1] ipv6 address 1 123::123:1:1/64

[RouterA-GigabitEthernet1/0/1] quit

4. 验证配置

配置完成后,当Router A使用用户名user1、密码pass1,通过PPPoE接入Router B后,Router B通过DHCPv6协议为Router A分配一个代理前缀。

# 显示Router A上创建的IPv6前缀信息。

[RouterA] display ipv6 prefix

Number   Prefix                                     Type

1        4001::/42                                  Dynamic

以上信息表示,Router A从Router B获取到代理前缀后,已根据ipv6 dhcp client pd 1配置创建了编号为1的IPv6前缀。

Router A把分配到的代理前缀4001::/42再分配给Host,Host用来生成IPv6全球单播地址。

暂无评论

编辑答案

你正在编辑答案

如果你要对问题或其他回答进行点评或询问,请使用评论功能。

分享扩散:

提出建议

    +

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作

举报

×

侵犯我的权益 >
对根叔社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明