• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 漏洞说明
  • 全部
  • 全部
  • 大数据引擎
  • 知了引擎
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
搜索引擎
匹配模式
高级搜索

三层交换机作为网关,下联pc ping不同路由器

2021-11-07提问
  • 0关注
  • 1收藏,175浏览
wee 零段
粉丝:0人 关注:0人

问题描述:

1. 配置需求或说明

1.1适用产品系列

本案例适用于Comware V软件平台MSR WiNet系列路由器,如MSR830-10BEI-WiNet 、MSR830-6EI-WiNet 、MSR830-5BEI-WiNet 、MSR830-6BHI-WiNet 、MSR830-10BHI-WiNet等。

1.2配置需求及实现效果

交换机作为下面两个网段,192.168.2.0/24网段和192.168.3.0/24网段的网关在交换机上创建两个vlan虚地址,并添加缺省路由指向路由器的网关,路由添加两条明细的回程路由,交换机的G1/0/2接PC1G1/0/3接PC2,要求PC1和PC2可以访问互联网(访问路由器的网关)。

2. 组网图

3. 配置步骤

3.1路由器端配置

#配置虚接口地址

<H3C>system-view

[H3C]interface  Vlan-interface 1

[H3C-Vlan-interface1]ip address 192.168.1.1 24

[H3C-Vlan-interface1]quit

#添加两条静态路由

[H3C]ip route-static 192.168.2.0 24 192.168.1.254

[H3C]ip route-static 192.168.3.0 24 192.168.1.254

#保存配置

[H3C]save force

3.2交换机端的配置

#创建vlan

<H3C>system-view

[H3C]vlan 2 to 3

#创建虚接口地址,vlan2vlan3地址分别作为PC1和PC2的网关

[H3C]interface vlan 1

[H3C-Vlan-interface1]ip address 192.168.1.254 24

[H3C]interface vlan 2

[H3C-Vlan-interface2]ip address 192.168.2.1 24

[H3C]interface vlan 3

[H3C-Vlan-interface3]ip address 192.168.3.1 24

#连接PC1PC2口划分到相应的vlan中

[H3C]interface GigabitEthernet 1/0/2

[H3C-GigabitEthernet1/0/2] port access vlan 2

[H3C-GigabitEthernet1/0/2]interface GigabitEthernet 1/0/3

[H3C-GigabitEthernet1/0/3] port access vlan 3

#添加静态路由,指向路由器的网关

[H3C]ip route-static 0.0.0.0 0 192.168.1.1

#保存配置

[H3C]save force

组网及组网描述:

在HCL模拟器里测试,PC只能ping通192.168.1.254,到192.168.1.1不通,是什么问题?

最佳答案

粉丝:7人 关注:1人

你有没有测直连的通不通  有时候模拟器有bug.接口起不来  重启或者开关接口试试

暂无评论

1 个回答
靓仔 九段
粉丝:156人 关注:1人

检查路由器和交换机互联口是不是都是vlan1


或者你可以在交换机上ping路由器接口地址试试

暂无评论

编辑答案

你正在编辑答案

如果你要对问题或其他回答进行点评或询问,请使用评论功能。

分享扩散:

提出建议

    +

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作

举报

×

侵犯我的权益 >
对根叔社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明