现在防火墙,当路由用,核心做hdcp服务器,划分vlan。怎么配置核心与防火墙的通讯
(0)
最佳答案
配置VLAN
core-switch# configure terminal
core-switch(config)# vlan 10
core-switch(config-vlan)# name Users
core-switch(config-vlan)# exit
core-switch(config)# vlan 20
core-switch(config-vlan)# name Guests
core-switch(config-vlan)# exit
配置Trunk接口
! 假设防火墙的接口名称是 `GigabitEthernet0/0`
firewall(config)# interface gigabitEthernet 0/0
firewall(config-if)# no shutdown
firewall(config-if)# exit
! 创建子接口以支持不同VLAN
firewall(config)# interface gigabitEthernet 0/0.10
firewall(config-subif)# vlan 10
firewall(config-subif)# nameif USERS
firewall(config-subif)# security-level 100
firewall(config-subif)# ip address 192.168.10.254 255.255.255.0
firewall(config-subif)# exit
firewall(config)# interface gigabitEthernet 0/0.20
firewall(config-subif)# vlan 20
firewall(config-subif)# nameif GUESTS
firewall(config-subif)# security-level 50
firewall(config-subif)# ip address 192.168.20.254 255.255.255.0
firewall(config-subif)# exit
配置VLAN接口(SVI)并分配IP地址
core-switch(config)# interface vlan 10
core-switch(config-if)# ip address 192.168.10.1 255.255.255.0
core-switch(config-if)# exit
core-switch(config)# interface vlan 20
core-switch(config-if)# ip address 192.168.20.1 255.255.255.0
core-switch(config-if)# exit
配置DHCP服务器
core-switch(config)# ip dhcp pool VLAN10
core-switch(dhcp-config)# network 192.168.10.0 255.255.255.0
core-switch(dhcp-config)# default-router 192.168.10.1
core-switch(dhcp-config)# dns-server 8.8.8.8
core-switch(dhcp-config)# exit
core-switch(config)# ip dhcp pool VLAN20
core-switch(dhcp-config)# network 192.168.20.0 255.255.255.0
core-switch(dhcp-config)# default-router 192.168.20.1
core-switch(dhcp-config)# dns-server 8.8.8.8
core-switch(dhcp-config)# exit
配置Trunk连接到防火墙
core-switch(config)# interface gigabitEthernet 0/1
core-switch(config-if)# switchport mode trunk
core-switch(config-if)# switchport trunk allowed vlan 10,20
core-switch(config-if)# exit
配置静态路由或默认路由
firewall(config)# route USERS 192.168.10.0 255.255.255.0 192.168.10.1
firewall(config)# route GUESTS 192.168.20.0 255.255.255.0 192.168.20.1
配置NAT/PAT规则
firewall(config)# object network NETWORK_10
firewall(config-network-object)# subnet 192.168.10.0 255.255.255.0
firewall(config-network-object)# nat (USERS,outside) dynamic interface
firewall(config)# object network NETWORK_20
firewall(config-network-object)# subnet 192.168.20.0 255.255.255.0
firewall(config-network-object)# nat (GUESTS,outside) dynamic interface
配置防火墙规则
firewall(config)# access-list INSIDE_ACL extended permit ip 192.168.10.0 255.255.255.0 any
firewall(config)# access-list INSIDE_ACL extended permit ip 192.168.20.0 255.255.255.0 any
firewall(config)# access-group INSIDE_ACL in interface USERS
firewall(config)# access-group INSIDE_ACL in interface GUESTS
(0)
亲~登录后才可以操作哦!
确定你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作
举报
×
侵犯我的权益
×
侵犯了我企业的权益
×
抄袭了我的内容
×
原文链接或出处
诽谤我
×
对根叔社区有害的内容
×
不规范转载
×
举报说明
暂无评论