• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 全部
  • 全部
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
高级搜索

单出口多ip做策略路由问题

2020-07-07提问
  • 0关注
  • 0收藏,124浏览
粉丝:1人 关注:1人

问题描述:

运营商给了几个个固定ip  
分别是10.1   10.2  10.3       对端是10.10 
出口上指了个默认路由到10.10以后 
让现有的三个业务vlan10  20  30网关为1.1  2.1  3.1分别从10.1  10.2  10.3出去  怎么做策略路由...求大佬说的详细些,没做过策略路由

组网及组网描述:

运营商-出口-核心     

最佳答案

粉丝:12人 关注:0人

V7交换机策略路由配置案例(命令行版)

目录

V7交换机策略路由配置案例(命令行版)... 1

1 配置需求或说明... 1

1.1适用产品系列... 1

1.2配置需求及实现的效果... 1

2 组网图... 1

3 配置步骤... 1

4 验证配置... 2

 

 

1 配置需求或说明

1.1适用产品系列

本案例适用于如S7000ES7500E等的V7交换机,V5V7交换机具体分类及型号可以参考“1.1 Comware V5V7平台交换机分类说明”。

1.2配置需求及实现的效果

交换机SW1上配置一条静态路由,使终端访问114.114.114.114的时候通过R2,其中192.168.2.0这个网段,访问114.114.114.114 的时候匹配策略路由从R3去访问。

2 组网图

3 配置步骤

一.交换机和路由器上ip地址基本配置

#SW1上进图系统视图

<H3C>system-view

System View: return to User View with Ctrl+Z.

#创建vlan 1-4

[H3C]vlan 1 to 4

#配置vlan 1-vlan 4虚接口IP地址

[H3C]interface Vlan-interface 1

[H3C-Vlan-interface1] ip address 192.168.1.1 255.255.255.0

[H3C-Vlan-interface1]quit

[H3C]interface Vlan-interface 2

[H3C-Vlan-interface2] ip address 192.168.2.1 255.255.255.0

[H3C-Vlan-interface2]quit

[H3C]interface Vlan-interface 3

[H3C-Vlan-interface3] ip address 10.10.10.1 255.255.255.0

[H3C-Vlan-interface3]quit

[H3C]interface Vlan-interface 4

[H3C-Vlan-interface4] ip address 20.20.20.1 255.255.255.0

[H3C-Vlan-interface4]quit

#将端口分别划分到所属vlan,端口1属于vlan 3,端口4属于vlan 4,端口5属于默人vlan 1,端口6属于vlan 2

[H3C]interface GigabitEthernet 1/0/1

[H3C-GigabitEthernet1/0/1] port access vlan 3

[H3C-GigabitEthernet1/0/1]quit

[H3C]interface GigabitEthernet 1/0/4

[H3C-GigabitEthernet1/0/4] port access vlan 4

[H3C-GigabitEthernet1/0/4]quit

[H3C]interface GigabitEthernet 1/0/6

[H3C-GigabitEthernet1/0/6] port access vlan 2

[H3C-GigabitEthernet1/0/6]quit

#配置到114.114.114.0网段的静态路由

[H3C] ip route-static 114.114.114.0 24 10.10.10.2

[H3C]save force

 

#R1上进图系统视图

<H3C>system-view

System View: return to User View with Ctrl+Z.

#创建环回接口LoopBack 0用来模拟主机,地址是114.114.114.114/24

[H3C]interface LoopBack 0

[H3C-LoopBack0]ip address 114.114.114.114 255.255.255.0

[H3C-LoopBack0]quit

#为路由器1口和2口分别配置IP地址。

[H3C]int GigabitEthernet 0/1

[H3C-GigabitEthernet0/1] ip address 30.30.30.1 255.255.255.0

[H3C]int GigabitEthernet 0/2

[H3C-GigabitEthernet0/2] ip address 40.40.40.1 255.255.255.0

[H3C-GigabitEthernet0/2]quit

#配置到192.168.1.0网段的静态路由

[H3C]ip route-static 192.168.1.0 24 30.30.30.2

#配置到114.114.114.0网段的静态路由

[H3C]ip route-static 192.168.2.0 24 40.40.40.2

#开启设备的ICMP目的不可达报文的发送功能

[H3C]ip unreachables enable

#开启ICMP超时报文发送功能

[H3C]ip ttl-expires enable

[H3C]save force

 

#R2上进图系统视图

<H3C>system-view

System View: return to User View with Ctrl+Z.

#为路由器1口和2口分别配置IP地址。

[H3C]int GigabitEthernet 0/0

[H3C-GigabitEthernet0/0] ip address 30.30.30.2 255.255.255.0

[H3C]int GigabitEthernet 0/1

[H3C-GigabitEthernet0/1] ip address 10.10.10.2 255.255.255.0

#配置到114.114.114.0网段的静态路由

[H3C] ip route-static 114.114.114.0 24 30.30.30.1

#配置到192.168.1.0网段的静态路由

[H3C] ip route-static 192.168.1.0 24 10.10.10.1

#配置到114.114.114.0网段的静态路由

[H3C] ip route-static 192.168.2.0 24 10.10.10.1

#开启设备的ICMP目的不可达报文的发送功能

[H3C]ip unreachables enable

#开启ICMP超时报文发送功能

[H3C]ip ttl-expires enable

[H3C]save force

 

#R3上进图系统视图

<H3C>system-view

System View: return to User View with Ctrl+Z.

#为路由器1口和2口分别配置IP地址。

[H3C]int GigabitEthernet 0/0

[H3C-GigabitEthernet0/0] ip address 40.40.40.2 255.255.255.0

[H3C]int GigabitEthernet 0/1

[H3C-GigabitEthernet0/1] ip address 20.20.20.2 255.255.255.0

#配置到114.114.114.0网段的静态路由

[H3C] ip route-static 114.114.114.0 24 40.40.40.1

#配置到192.168.1.0网段的静态路由

[H3C] ip route-static 192.168.1.0 24 10.10.10.2

#配置到114.114.114.0网段的静态路由

[H3C] ip route-static 192.168.2.0 24 10.10.10.

#开启设备的ICMP目的不可达报文的发送功能

[H3C]ip unreachables enable

#开启ICMP超时报文发送功能

[H3C]ip ttl-expires enable

[H3C]save force

 

二.交换机策略路由配置

<H3C>system-view

System View: return to User View with Ctrl+Z.

#定义访问控制列表3000,用来匹配内网源地址为192.168.2.0/24网段的数据流

[H3C]acl advanced 3000

[H3C-acl-ipv4-adv-3000]rule permit ip source 192.168.2.0 0.0.0.255

[H3C-acl-ipv4-adv-3000]quit

# 定义访问控制列表3001,用来匹配内网192.168.2.0/24网段去访问内网192.168.1.0/24网段的数据流。

[H3C]acl advanced 3001

[H3C-acl-adv-3001]rule permit ip source 192.168.2.0 0.0.0.255 destination 192.168.1.0 0.0.0.255

[H3C-acl-adv-3001]quit

# 创建策略路由,名称为aaa,节点为10,匹配acl 3001的数据流,不设置apply动作(如果不设置动作,则匹配到的数据转发时根据路由表来进行转,且不再匹配下一节点,配置这个节点的作用是实现内网不同网段之间互访的流量不匹配策略路由,达到可以互访的目的。备注:默认情况下,网关在路由器上的不同网段是可以互相访问的)。

[H3C]policy-based-route aaa permit node 10

[H3C-pbr-aaa-10]if-match acl 3001

[H3C-pbr-aaa-10]quit

#创建策略路由aaa的节点20,匹配acl 3000的数据流,设置apply动作,指定数据的下一跳为20.20.20.2

 [H3C]policy-based-route aaa permit node 20

[H3C-pbr-aaa-20]if-match acl 3000

[H3C-pbr-aaa-20]apply next-hop 20.20.20.2

[H3C-pbr-aaa-20]quit

#在内网VLAN虚接口(网关)上应用策略路由

[H3C]interface vlan 2

[H3C-Vlan-interface2]ip policy-based-route aaa

[H3C-Vlan-interface2]quit

[H3C]save force

4 验证配置

# 交换机上没有配置策略路由的时候,在两台终端上tracert路径的结果如下:

 

192.168.1.2

192.168.2.2

 

# 配置了策略路由以后

192.168.1.2

192.168.2.2

 

 

....看不到拓扑

zhiliao_GknuR 发表时间:2020-07-07

然后我这边是单出口,就是一个接口上多个ip ..

zhiliao_GknuR 发表时间:2020-07-07
1 个回答
Xcheng 九段
粉丝:17人 关注:1人

根据描述
可用acl加nat address-group方案即可

由于未提供具体设备型号和软件版本
请参考以下举例
sys
acl a 3001
ru 100 permit ip sou 192.168.1.0 0.0.0.255
acl a 3002
ru 100 permit ip sou 192.168.2.0 0.0.0.255
acl a 3001
ru 100 permit ip sou 192.168.3.0 0.0.0.255
acl a 3004
ru 100 permit ip
nat address-group 1
address 10.10.10.1 10.10.10.1
nat address-group 2
address 10.10.10.2 10.10.10.2
nat address-group 3
address 10.10.10.3 10.10.10.3
int g 0/0
ip add 10.10.10.4 24
nat out 3001 address-group 1
nat out 3002 address-group 2
nat out 3003 address-group 3
nat out 3004
sa f

或参加msr56 00系列NAT配置手册
https://www.h3c.com/cn/d_202005/1295892_30005_0.htm

是3600系列,然后是单接口底下10.1 10.2sub 10.3sub

zhiliao_GknuR 发表时间:2020-07-07

编辑答案

你正在编辑答案

如果你要对问题或其他回答进行点评或询问,请使用评论功能。

分享扩散:

提出建议

    +
<

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作

举报

×

侵犯我的权益 >
对根叔社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明