• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 全部
  • 全部
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
高级搜索

v7控制器ladp认证

2020-07-31提问
  • 0关注
  • 0收藏,172浏览
粉丝:0人 关注:0人

问题描述:

ladp认证 JPEG_20200731_124008.jpg
只给了这些怎么做

组网及组网描述:

认证

最佳答案

粉丝:55人 关注:1人

配置举例

  组网需求

图1所示组网,AP和Client通过DHCP服务器获取IP地址,要求:配置AC对无线用户进行本地Portal认证,并采用LDAP服务器对用户进行远程AAA认证。

图1 本地Portal服务器与LDAP服务器组合认证组网图

 

 配置注意事项

·              配置AP的序列号时请确保该序列号与AP唯一对应,AP的序列号可以通过AP设备背面的标签获取。

·              如果本地Portal Web服务器提供的缺省认证页面文件需要更新,需要undo default-logon-page后重新配置,否则新页面不会生效。

·              配置路由,保证启动Portal之前各设备之间的路由可达。

·              请提前编辑好认证页面,保存为abc.zip,并上传到AC存储介质的根目录

 配置步骤

  配置AC

(1)      配置AC接口

# 创建VLAN 100及其对应的VLAN接口,并为该接口配置IP地址。AP将获取该IP地址与AC建立CAPWAP隧道。

<AC> system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 2.2.1.1 24

[AC-Vlan-interface100] quit

# 创建VLAN 200及其对应的VLAN接口,并为该接口配置IP地址。Client将使用该VLAN接入无线网络。

[AC] vlan 200

[AC-vlan200] quit

[AC] interface vlan-interface 200

[AC-Vlan-interface200] ip address 2.2.2.1 24

[AC-Vlan-interface200] quit

# 配置AC与Switch相连的GigabitEthernet1/0/1接口的属性为Trunk,允许VLAN 100、VLAN 200通过。

[AC] interface gigabitethernet 1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

[AC-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[AC-GigabitEthernet1/0/1] quit

(2)      配置LDAP方案

 # 创建LDAP服务器ldap,并进入LDAP服务器视图。

[AC] ldap server ldap

# 配置具有管理员权限的用户DN。

[AC-ldap-server-ldap] login-dn cn=administrator,cn=users,dc=myias,dc=com

# 配置查询用户的起始目录。

[AC-ldap-server-ldap] search-base-dn dc=myias,dc=com

# 配置LDAP认证服务器的IP地址。

[AC-ldap-server-ldap] ip 192.168.0.112

# 配置具有管理员权限的用户密码。

[AC-ldap-server-ldap] login-password simple 123456

[AC-ldap-server-ldap] quit

# 创建LDAP方案ldap,并进入LDAP方案视图。

[AC] ldap scheme ldap

# 配置LDAP认证服务器。

[AC-ldap-ldap] authentication-server ldap

[AC-ldap-ldap] quit

# 创建ISP域ldap,并进入ISP域视图。

[AC] domain ldap

# 为Portal用户配置AAA认证方法为LDAP认证、不授权、不计费。

[AC-isp-ldap]authentication portal ldap-scheme ldap

[AC-isp-ldap] authorization portal none

[AC-isp-ldap] accounting portal none

# 指定ISP域ldap下的用户闲置切断时间为15分钟,闲置切断时间内产生的流量为1024字节。

[AC-isp-ldap] authorization-attribute idle-cut 15 1024

[AC-isp-ldap] quit

(3)      配置Portal认证

# 配置Portal Web服务器的URL为http://2.2.2.1 /portal。

[AC] portal web-server newpt

[AC-portal-websvr-newpt] url http://2.2.2.1/portal

[AC-portal-websvr-newpt] quit

# 创建本地Portal Web 服务器,进入本地Portal Web服务器视图,并指定使用HTTP协议和客户端交互认证信息。

[AC] portal local-web-server http

# 配置本地Portal Web服务器提供的缺省认证页面文件为abc.zip(设备的存储介质的根目录下必须已存在该认证页面文件,否则功能不生效)。

[AC–portal-local-websvr-http] default-logon-page abc.zip

[AC–portal-local-websvr-http] quit

(4)      配置无线服务

# 创建无线服务模板st1,并进入无线服务模板视图。

[AC] wlan service-template st1

# 配置SSID为service。

[AC-wlan-st-st1] ssid service

# 配置无线服务模板VLAN为200。

[AC-wlan-st-st1] vlan 200

# 使能直接方式的Portal认证。

[AC-wlan-st-st1] portal enable method direct

# 配置接入的Portal用户使用认证域为ldap

[AC-wlan-st-st1] portal domain ldap

# 在服务模板上引用名称为newpt的Portal Web服务器作为用户认证时使用的Web服务器。

[AC-wlan-st-st1] portal apply web-server newpt

# 使能无线服务模板。

[AC-wlan-st-st1] service-template enable

[AC-wlan-st-st1] quit

# 创建AP,配置AP名称为officeap,型号名称选择WA2620E-AGN,并配置其序列号。

[AC] wlan ap officeap model WA2620E-AGN

[AC-wlan-ap-officeap] serial-id 21023529G007C000020

# 进入radio 2射频视图。

[AC-wlan-ap-officeap] radio 2

# 将无线服务模板st1绑定到AP的radio 2,并开启射频。

[AC-wlan-ap-officeap-radio-2] service-template st1

[AC-wlan-ap-officeap-radio-2] radio enable

[AC-wlan-ap-officeap-radio-2] quit

[AC-wlan-ap-officeap] quit

Switch的配置

# 创建VLAN 100,用于转发AC和AP间CAPWAP隧道内的流量。

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

# 创建VLAN 200,用于转发Client无线报文。

[Switch] vlan 200

[Switch-vlan200] quit

# 配置Switch与AC相连的GigabitEthernet1/0/1接口的属性为Trunk,允许VLAN 100和VLAN 200通过。

[Switch] interface gigabitethernet1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[Switch-GigabitEthernet1/0/1] quit

# 配置Switch与AP相连的GigabitEthernet1/0/2接口属性为Access,并允许VLAN 100通过。

[Switch] interface gigabitethernet1/0/2

[Switch-GigabitEthernet1/0/2] port link-type access

[Switch-GigabitEthernet1/0/2] port access vlan 100

# 使能PoE功能。

[Switch-GigabitEthernet1/0/2] poe enable

[Switch-GigabitEthernet1/0/2] quit

  配置LDAP服务器

说明

本文以Microsoft Windows 2003 Server的Active Directory为例,说明该例中LDAP服务器的基本配置。

 

(1)      添加用户aa

# 在LDAP服务器上,选择[开始/管理工具]中的[Active Directory用户和计算机],打开Active Directory用户管理界面。

图2 打开Active Directory用户管理界面

 

# 在Active Directory用户管理界面的左侧导航树中,点击myias.com节点下的<Users>按钮。

图3 添加用户

 

# 右键单击“Users”,选择[新建/用户],打开“新建对象-用户”对话框。

图4 新建用户

 

# 在对话框中输入用户信息和用户登录名aa,并单击<下一步>按钮。

图5 新建用户aa

 

# 在弹出的对话框内输入密码,并确认密码,然后单击<下一步>按钮。

图6 设置用户密码

 

# 完成新建用户。

图7 完成新建用户

 

(2)      将用户aa加入Users组

# 在Active Directory用户管理界面的左侧导航树中,单击myias.com节点下的“Users”按钮。

图8 将用户加入组

 

# 在右侧的Users信息框中右键单击用户aa,选择“属性”项。

图9 选择用户

 

# 选择“隶属于”页签,并单击<添加(D)...>按钮。

图10 修改用户属性

 

# 在弹出的[选择组]对话框中的可编辑区域框中输入对象名称“Users”,单击<确定>,完成用户aa添加到Users组。

图11 添加用户aa到用户组Users

 

# 完成用户aa的添加之后,还需要配置管理员用户administrator的密码。

·              在右侧的Users信息框中右键单击管理员用户administrator,选择“设置密码(S)...”项;

·              在弹出的密码添加对话框中设置管理员密码。

 验证配置

# 打开无线客户端上的IE浏览器,输入任意的IP地址,按回车,网页会自动跳转到Portal认证页面,输入用户名:aa,密码:123456,单击logon按钮,认证成功。

# 用户通过认证后,在AC上使用命令display portal user all可以查看到有Portal用户在线。

<AC> display portal user all

 Index:17

 State:ONLINE

 SubState:NONE

 ACL:3777

 Work-mode:stand-alone

 MAC              IP                Vlan   Interface

 ----------------------------------------------------------------------------

 2477-0341-f118   2.2.2.2           200      Vlan-interface200

 Total 1 user(s) matched, 1 listed.

 配置文件

·              AC:

#

vlan 100

#

vlan 200

#

wlan service-template st1

 ssid service

 vlan 200

 portal enable method direct

 portal domain ldap

 portal apply web-server newpt

 service-template enable

#

interface Vlan-interface100

 ip address 2.2.1.1 255.255.255.0

#

interface Vlan-interface200

 ip address 2.2.2.1 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 100 200

#

ldap server ldap

 login-dn cn=administrator,cn=users,dc=myias,dc=com

 search-base-dn dc=myias,dc=com

 ip 192.168.0.112

 login-password cipher $c$3$CEz2vKCnA2/51D8rFc/+nTNtOx8Gan+81Q==

#

ldap scheme ldap

 authentication-server ldap

#

domain ldap

 authorization-attribute idle-cut 15 1024

 authentication portal ldap-scheme ldap

 authorization portal none

 accounting portal none

#

portal web-server newpt

 url http://2.2.2.1/portal

#

portal local-web-server http

 default-logon-page abc.zip

#

wlan ap officeap model WA2620E-AGN

 serial-id 21023529G007C000020

 radio 2

  radio enable

  service-template st1

#

·              Switch:

#

vlan 100

#

vlan 200

#

interface GigabitEthernet1/0/1

 port link-mode bridge

 port link-type trunk

 port trunk permit vlan 100 200

#

interface GigabitEthernet1/0/2

 port link-mode bridge

 port access vlan 100

 poe enable

#


1 个回答
粉丝:17人 关注:3人

可参考案例集:http://www.h3c.com/cn/d_202006/1308055_30005_0.htm

domain id写在哪

zhiliao_5xsG1 发表时间:2020-07-31

编辑答案

你正在编辑答案

如果你要对问题或其他回答进行点评或询问,请使用评论功能。

分享扩散:

提出建议

    +
<

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作

举报

×

侵犯我的权益 >
对根叔社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明