• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 漏洞说明
  • 全部
  • 全部
  • 大数据引擎
  • 知了引擎
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
搜索引擎
匹配模式
高级搜索

HCL模拟器S5820交换机DHCP配置案例

2019-12-09 发表
  • -1关注 ,1656浏览
粉丝: 关注:

组网及说明

现有一台S5820交换机,连接两个不同的局域网,现要求两个不同的局域网通过DHCP自动获取IP地址后实现互联互通。

网络拓扑图如下:


配置步骤

(1)、将交换机的名字修改为SW1

(2)、在交换机分别创建VLAN 10VLAN 20

(3)VLAN 10IP设置为:192.168.10.1 255.255.255.0

(4)VLAN 20IP设置为:192.168.20.1 255.255.255.0

(5)、将F0/1端口划分到VLAN 10

(6)、将F0/2端口划分到VLAN 20

(7)、开启DHCP功能

(8)、分别创建两个地址池,分配子网、默认网关、DNS

(9)PC_2PC_3都能通过DHCP自动获取IP地址


配置关键点

将交换机的名字修改为SW1

system-view

[H3C]sysname SW1

 

在交换机分别创建VLAN 10VLAN 20

[SW1]vlan 10

[SW1-vlan10]quit

[SW1]vlan 20

[SW1-vlan20]quit

 

VLAN 10IP设置为:192.168.10.1 255.255.255.0

 

 

[SW1]int vlan 10

[SW1-Vlan-interface10]ip address 192.168.10.1 24

[SW1-Vlan-interface10]quit

 

VLAN 20IP设置为:192.168.20.1 255.255.255.0

[SW1]int vlan 20

[SW1-Vlan-interface20]ip address 192.168.20.1 24

[SW1-Vlan-interface20]quit

 

GI1/0/1端口划分到VLAN 10

[SW1]int gi 1/0/1

[SW1-GigabitEthernet1/0/1]port link-type access

[SW1-GigabitEthernet1/0/1]port access vlan 10

[SW1-GigabitEthernet1/0/1]quit

 

GI1/0/2端口划分到VLAN 20

[SW1]int gi 1/0/2

[SW1-GigabitEthernet1/0/2]port link-type access

[SW1-GigabitEthernet1/0/2]port access vlan 20

[SW1-GigabitEthernet1/0/2]quit

 

开启DHCP功能:

 

[SW1]dhcp enable

 

创建DHCP地址池,命名为VLAN10,分配网段、子网掩码、默认网关、DNS

[SW1]dhcp server ip-pool vlan10

[SW1-dhcp-pool-vlan10]network 192.168.10.0 mask 255.255.255.0

[SW1-dhcp-pool-vlan10]gateway-list 192.168.10.1

[SW1-dhcp-pool-vlan10]dns-list 114.114.114.114

[SW1-dhcp-pool-vlan10]quit

[SW1]

 

创建DHCP地址池,命名为VLAN20,分配网段、子网掩码、默认网关、DNS

[SW1]dhcp server ip-pool vlan20

[SW1-dhcp-pool-vlan20]network 192.168.20.0 mask 255.255.255.0

[SW1-dhcp-pool-vlan20]gateway-list 192.168.20.1

[SW1-dhcp-pool-vlan20]dns-list 114.114.114.114

[SW1-dhcp-pool-vlan20]quit

 

 

PC0PC1都能通过DHCP自动获取IP地址:



在交换机查看DHCP分配的情况:

[SW1]dis dhcp server ip-in-use

IP address       Client identifier/    Lease expiration      Type

                 Hardware address

192.168.10.2     0033-3661-612e-3339-  Dec 10 21:35:46 2019  Auto(C)

                 3463-2e30-3230-362d-

                 4745-302f-302f-31

192.168.20.2     0033-3661-612e-3430-  Dec 10 21:35:55 2019  Auto(C)

                 3135-2e30-3330-362d-

                 4745-302f-302f-31

[SW1]


1 个评论
曹帅 知了小白
粉丝:0人 关注:0人



[SW1]dhcp server ip-pool vlan10

命令打进去以后没有用啊 这是什么情况?

小丑是我自己啊,命令都打错

曹帅 发表时间:2021-09-03

编辑评论

举报

×

侵犯我的权益 >
对根叔知了社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔知了社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明

提出建议

    +

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作