• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 全部
  • 全部
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
高级搜索

GRE over ipsec

2018-05-14 发表
  • 5关注
  • 8收藏,1792浏览
粉丝:2人 关注:0人

组网及说明

多分支接入的情况下,如果设备支持点到多点GRE隧道,则总部只需要配置一个GRE Tunnle,但是设备不支持此特性的话,只能在总部为每个分支建立一个GRE Tunnle。

总部:

公网地址:100.0.0.1

私网地址:192.168.0.0/24

GRE tunnel 0:去往分支1

地址:21.0.0.1

封装源地址:20.0.0.1 目的地址:20.0.0.2

GRE tunnel 1:去往分支2

地址:11.0.0.1

封装源地址:10.0.0.1 目的地址:10.0.0.2

 

分支一:

公网地址:100.0.0.2

私网地址:192.168.1.0/24

GRE tunnel 0:去往总部

地址:21.0.0.2

封装源地址:20.0.0.2 目的地址:20.0.0.1

 

分支二:

公网地址:100.0.0.2

私网地址:192.168.1.0/24

GRE tunnel 0:去往总部

地址:11.0.0.2

封装源地址:10.0.0.2 目的地址:10.0.0.1

 



配置步骤

配置基本的IP地址以及域间策略

总部:

interface GigabitEthernet1/0/1

ip address 192.168.0.1 255.255.255.0

#

interface GigabitEthernet1/0/2  #公网口

 ip address 100.0.0.1 255.255.255.0

 

interface LoopBack0  #GRE封装时的源地址

 description GRE

 ip address 20.0.0.1 255.255.255.255

#

interface LoopBack1 # #GRE封装时的源地址

 description GRE

 ip address 10.0.0.1 255.255.255.255

 

 

interface Tunnel0 mode gre

 description ToFenZhi_1

 ip address 21.0.0.1 255.255.255.0

 source 20.0.0.1

 destination 20.0.0.2

#

interface Tunnel1 mode gre

 description ToFenZhi_2

 ip address 11.0.0.1 255.255.255.0

 source 10.0.0.1

      destination 10.0.0.2

 

#域间策略

security-zone name Trust

 import interface GigabitEthernet1/0/1

#

security-zone name Untrust

 import interface GigabitEthernet1/0/2

 import interface Tunnel0

 import interface Tunnel1

 

zone-pair security source Any destination Any

 packet-filter 3010

 

acl advanced 3010

 description yujiancelue

 rule 0 permit ip

 

分支一:

 

interface GigabitEthernet1/0/1

ip address 192.168.1.1 255.255.255.0

#

interface GigabitEthernet1/0/2

ip address 100.0.0.2 255.255.255.0

 

 

interface LoopBack0

 description GRE

 ip address 20.0.0.2 255.255.255.255

 

 

interface Tunnel0 mode gre  #这里封装的地址源目和总部反过来

 ip address 21.0.0.2 255.255.254.0

 source  20.0.0.2

 destination 20.0.0.1

 

security-zone name Trust

 import interface GigabitEthernet1/0/1

#

security-zone name Untrust

 import interface GigabitEthernet1/0/2

 import interface Tunnel0

 

acl advanced 3010

 description yujiancelue

 rule 0 permit ip

 

zone-pair security source Local destination Any

 packet-filter 3010

 

分支二:

 

interface GigabitEthernet1/0/1

ip address 192.168.2.1 255.255.255.0

#

interface GigabitEthernet1/0/2

ip address 100.0.0.3 255.255.255.0

 

 

interface LoopBack0

 description GRE

 ip address 10.0.0.2 255.255.255.255

 

 

 

interface Tunnel0 mode gre

 ip address 11.0.0.2 255.255.255.0

 source 10.0.0.2

 destination 10.0.0.1

 

security-zone name Trust

 import interface GigabitEthernet1/0/1#

security-zone name Untrust

 import interface GigabitEthernet1/0/2

 import interface Tunnel0

#

acl advanced 3010

 description yujiancelue

 rule 0 permit ip

#

zone-pair security source Any destination Any

 packet-filter 3010

 

 

IPsec的配置

总部

#总部使用模板方式建立ipsec,只需要写一个策略,不需要安全acl

ike keychain 1

 pre-shared-key address 0.0.0.0 0.0.0.0 key  simple  123  #0.0.0.0代表接受任何地址建立ipsec

 

ike profile 1

 keychain 1

 local-identity address 100.0.0.1

 match remote identity address 0.0.0.0 0.0.0.0

#

ipsec transform-set 1

 esp encryption-algorithm 3des-cbc

 esp authentication-algorithm md5

#

ipsec policy-template 1 1

 transform-set 1

 local-address 100.0.0.1

 ike-profile 1

#

ipsec policy 1 1 isakmp template 1

 

#接口下调用ipsec

interface GigabitEthernet1/0/2

ip address 100.0.0.1 255.255.255.0

 ipsec apply policy 1

 

最重要的一步:

 

ip route-static 192.168.1.0 24 Tunnel0         #192.168.1.0是分支一的私网地址,将其下一跳指向Tunnle 0,即去往分支一的GRE隧道。

 ip route-static 192.168.2.0 24 Tunnel1        #192.168.1.0是分支二的私网地址,将其下一跳指向Tunnle 0,即去往分支一的GRE隧道。

 

分支一:

ike profile 1

 keychain 1

 match remote identity address 100.0.0.1 255.255.255.255

#

ike keychain 1

 pre-shared-key address 100.0.0.1 255.255.255.255 key simple 123

 

ipsec transform-set 1

 esp encryption-algorithm 3des-cbc

 esp authentication-algorithm md5

#

ipsec policy 1 1 isakmp

 transform-set 1

 security acl 3020

 remote-address 100.0.0.1

 ike-profile 1

 

 

acl advanced 3020

 description IPsec

 rule 0 permit ip source 20.0.0.2 0 destination 20.0.0.1 0        #这里安全ACl匹配的流和GRE的源目地址一致,即由GRE封装之后的报文。

 

最重要的一步:

 

 ip route-static 192.168.0.0 24 Tunnel0    #不管是去往总部192.168.0.0还是去往其他分支192.168.2.0,下一跳全部指向Tunnle 0,全部指向总部,再由总部转发。

 ip route-static 192.168.2.0 24 Tunnel0

 

 

分支二:

类似分支一

 

ipsec transform-set 1

 esp encryption-algorithm 3des-cbc

 esp authentication-algorithm md5

#

ipsec policy 1 1 isakmp

 transform-set 1

 security acl 3020

 remote-address 100.0.0.1

 ike-profile 1

#

ike profile 1

 keychain 1

 match remote identity address 100.0.0.1 255.255.255.255

#

ike keychain 1

 pre-shared-key address 100.0.0.1 255.255.255.255 key simple 123

 

 

acl advanced 3020

 description IPsec

 rule 0 permit ip source 20.0.0.2 0 destination 20.0.0.1 0

 

 

 ip route-static 192.168.0.0 24 Tunnel0

 ip route-static 192.168.2.0 24 Tunnel0

#

验证效果:

#总部使用模板方式时,只能被动建立IPSEC隧道,不能主动呼叫。

分支一:

 

[H3C]ping -a 192.168.1.1 192.168.0.1

Ping 192.168.0.1 (192.168.0.1) from 192.168.1.1: 56 data bytes, press CTRL_C to break

56 bytes from 192.168.0.1: icmp_seq=0 ttl=255 time=2.000 ms

56 bytes from 192.168.0.1: icmp_seq=1 ttl=255 time=8.000 ms

56 bytes from 192.168.0.1: icmp_seq=2 ttl=255 time=2.000 ms

56 bytes from 192.168.0.1: icmp_seq=3 ttl=255 time=1.000 ms

56 bytes from 192.168.0.1: icmp_seq=4 ttl=255 time=1.000 ms

 

--- Ping statistics for 192.168.0.1 ---

5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss

round-trip min/avg/max/std-dev = 1.000/2.800/8.000/2.638 ms

[H3C]%May  9 18:41:03:921 2018 H3C PING/6/PING_STATISTICS: -COntext=1; Ping statistics for 192.168.0.1: 5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss, round-trip min/avg/max/std-dev = 1.000/2.800/8.000/2.638 ms.

 

[H3C]ping -a 192.168.1.1 192.168.2.1

Ping 192.168.2.1 (192.168.2.1) from 192.168.1.1: 56 data bytes, press CTRL_C to break

56 bytes from 192.168.2.1: icmp_seq=0 ttl=254 time=5.000 ms

56 bytes from 192.168.2.1: icmp_seq=1 ttl=254 time=2.000 ms

56 bytes from 192.168.2.1: icmp_seq=2 ttl=254 time=4.000 ms

56 bytes from 192.168.2.1: icmp_seq=3 ttl=254 time=2.000 ms

56 bytes from 192.168.2.1: icmp_seq=4 ttl=254 time=3.000 ms

 

--- Ping statistics for 192.168.2.1 ---

5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss

round-trip min/avg/max/std-dev = 2.000/3.200/5.000/1.166 ms

[H3C]%May  9 18:41:07:906 2018 H3C PING/6/PING_STATISTICS: -COntext=1; Ping statistics for 192.168.2.1: 5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss, round-trip min/avg/max/std-dev = 2.000/3.200/5.000/1.166 ms.

 

分支二:

 

[H3C]ping -a 192.168.2.1 192.168.0.1

Ping 192.168.0.1 (192.168.0.1) from 192.168.2.1: 56 data bytes, press CTRL_C to break

56 bytes from 192.168.0.1: icmp_seq=0 ttl=255 time=1.000 ms

56 bytes from 192.168.0.1: icmp_seq=1 ttl=255 time=1.000 ms

56 bytes from 192.168.0.1: icmp_seq=2 ttl=255 time=1.000 ms

56 bytes from 192.168.0.1: icmp_seq=3 ttl=255 time=2.000 ms

56 bytes from 192.168.0.1: icmp_seq=4 ttl=255 time=1.000 ms

 

--- Ping statistics for 192.168.0.1 ---

5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss

round-trip min/avg/max/std-dev = 1.000/1.200/2.000/0.400 ms

[H3C]\%May  9 18:42:47:047 2018 H3C PING/6/PING_STATISTICS: -COntext=1; Ping statistics for 192.168.0.1: 5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss, round-trip min/avg/max/std-dev = 1.000/1.200/2.000/0.400 ms.

 

 [H3C]ping -a 192.168.2.1 192.168.1.1

Ping 192.168.1.1 (192.168.1.1) from 192.168.2.1: 56 data bytes, press CTRL_C to break

56 bytes from 192.168.1.1: icmp_seq=0 ttl=254 time=11.000 ms

56 bytes from 192.168.1.1: icmp_seq=1 ttl=254 time=2.000 ms

56 bytes from 192.168.1.1: icmp_seq=2 ttl=254 time=2.000 ms

56 bytes from 192.168.1.1: icmp_seq=3 ttl=254 time=5.000 ms

56 bytes from 192.168.1.1: icmp_seq=4 ttl=254 time=4.000 ms

 

--- Ping statistics for 192.168.1.1 ---

5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss

round-trip min/avg/max/std-dev = 2.000/4.800/11.000/3.311 ms

[H3C]%May  9 18:42:50:726 2018 H3C PING/6/PING_STATISTICS: -COntext=1; Ping statistics for 192.168.1.1: 5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss, round-trip min/avg/max/std-dev = 2.000/4.800/11.000/3.311 ms.

 


配置关键点

总结与建议:

一:注意loopback口的建立,和GRE封装时的源目地址保持一致,而不是GRE Tunnleip地址。

二:安全策略,Tunnle口需要加入安全域并且放通策略

三:这种方式下的IPSEC,后续网段变动时,只需要配置不同的静态路由指向GRE Tunnle口,IPsec的配置无需改变,适合私网地址较大的拓扑。

四:IPsec的各种加密参数注意保持一致。以及IPsec的安全ACL匹配的是GRE封装之后的源目地址。

五:对于各种访问控制,建议IPsec这块不用动,等IPsec成功后,在防火墙的域间策略上统一控制。

 

0 个评论

该案例暂时没有网友评论

编辑评论

举报

×

侵犯我的权益 >
对根叔知了社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔知了社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明

提出建议

    +
<

亲~登录后才可以操作哦!

确定

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作