• 全部
  • 经验案例
  • 典型配置
  • 技术公告
  • FAQ
  • 漏洞说明
  • 全部
  • 全部
  • 大数据引擎
  • 知了引擎
产品线
搜索
取消
案例类型
发布者
是否解决
是否官方
时间
搜索引擎
匹配模式
高级搜索

V7无线控制器WLAN本地转发配置方法

2019-04-08 发表
  • 2关注
  • 5收藏 5197浏览
粉丝:16人 关注:1人

组网及说明

1.配置需求或说明

1.1  适用产品系列

本手册适用于如下产品:V7 WX系列无线控制器产品,包含:WX2500H系列、WX3000H系列、WX3500H系列、WX5500E(V7)系列、WX5500H系列、AC插卡(V7)系、MSG360系列、WAC380系列、WAC381系列。

1.2  需要的工具环境及注意事项

Switch作为DHCP服务器为APClient(客户端)分配IP地址。给ap下发的注册vlanvlan100,注册vlan100网段:192.1.1.0/24,给无线客户端下发的业务vlan200,业务vlan200网段:192.2.1.0/24,交换机充当无线客户端的网关。

现要求:为了使AP能够直接转发Client报文,需要在AC上开启本地转发功能,同时通过下发map-configuration文件来对AP进行配置实现本地转发,使Client的数据流量不经过AC,直接由AP转发给vlan200的网关。

1.3  组网图

配置步骤

2.  配置步骤

2.1.      apcfg.txt的配置并且上传到ac

#提示: 在编辑map-configuration文件时需注意,文件的某个命令行后面不要有Tab键或者大量空格出线,否则会出现该行配置配不成功的情况

#新建一个txt,命名为apcfg.txtapcfg.txt的内容,要求为文本文件,按照命令行配置的顺序编写文本文件上传至AC即可,ACAP关联后,通过map-configuration命令下发至AP生效。从而完成对AP的配置。

# apcfg.txt配置文件为:

system-view

vlan 200

quit

interface GigabitEthernet 1/0/1

port link-type trunk

port trunk permit vlan 200

通过tftp服务器把apcfg.txt传到ac设备上

电脑网卡设置为:10.88.18.160/24 ,如下例子打开TFTP服务器,把apcfg.txt文件放到电脑桌面上,TFTP服务器目录指向电脑桌面,然后点击确定。

Ac配置ip地址保证和电脑网络可达

通过TFTP上传apcfg.txtac上,10.88.18.160是电脑的ip

 <H3C> tftp 10.88.18.160 get apcfg.txt

 

2.2.      配置AC

(1) AC上配置相关VLAN和对应虚接口地址,并放通对应接口。

 配置VLAN接口

# 创建VLAN 100及其对应的VLAN接口,并为该接口配置IP地址。AC将使用该接口的IP地址与AP建立注册隧道。

<AC> system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 192.1.1.1 24

[AC-Vlan-interface100] quit

# 创建VLAN 200作为Client接入的业务VLAN,配置VLAN 200的接口IP地址。

[AC] vlan 200

[AC-vlan200] quit

[AC] interface vlan-interface 200

[AC-Vlan-interface200] ip address 192.2.1.1 24

[AC-Vlan-interface200] quit

配置ACSwitch相连的GigabitEthernet1/0/1Trunk模式,允许VLAN 100VLAN 200通过。

[AC] interface gigabitethernet 1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

[AC-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[AC-GigabitEthernet1/0/1] quit

(2) 配置无线服务名:service,开启对vlan200的本地转发功能

[AC] wlan service-template 1

[AC-wlan-st-1] ssid service

[AC-wlan-st-1] client forwarding-location ap vlan 200

[AC-wlan-st-1] service-template enable

(3) 配置AP

[AC] wlan ap officeap model WA4320i-ACN

[AC-wlan-ap-officeap] serial-id 219801A0T78159E09083

[AC-wlan-ap-officeap] radio 2

[AC-wlan-ap-officeap-radio-2] service-template 1 vlan 200

[AC-wlan-ap-officeap-radio-2] radio enable

(4) 配置AP的配置文件

[AC-wlan-ap-officeap] map-configuration apcfg.txt

2.3     Switch的配置

# 创建相关VLAN,配置switchAP相连的接口为Trunk类型,PVIDAP 管理VLAN,开启DHCP server功能,AP、无线客户端Client都能通过DHCP server自动获取IP地址

# 创建VLAN 100VLAN 200,其中VLAN 100用于转发ACAP间隧道内的流量,VLAN 200为无线客户端接入的VLAN

# 创建VLAN 100及其对应的VLAN接口,并为该接口配置IP地址。AC将使用该接口的IP地址与AP建立注册隧道。

< Switch > system-view

[Switch] vlan 100

[Switch-vlan100] quit

[Switch] interface vlan-interface 100

[Switch-Vlan-interface100] ip address 192.1.1.2 24

[Switch-Vlan-interface100] quit

# 创建VLAN 200作为Client接入的业务VLAN,配置VLAN 200的接口IP地址。

[Switch] vlan 200

[Switch-vlan200] quit

[Switch] interface vlan-interface 200

[Switch-Vlan-interface200] ip address 192.2.1.2 24

[Switch-Vlan-interface200] quit

配置DHCP服务

# 创建名为vlan100DHCP地址池,动态分配的网段为192.1.1.0/24,给ap下发注ip地址,网关地址为192.1.1.2

[Switch] dhcp server ip-pool vlan100

[Switch-dhcp-pool-vlan100] network 192.1.1.0 mask 255.255.255.0

[Switch-dhcp-pool-vlan100] gateway-list 192.1.1.2

[Switch-dhcp-pool-vlan100] quit

# 创建名为vlan200DHCP地址池,动态分配的网段为192.2.1.0/24,给无线客户端下发ip地址,网关地址为192.2.1.2

[Switch] dhcp server ip-pool vlan200

[Switch-dhcp-pool-vlan200] network 192.2.1.0 mask 255.255.255.0

[Switch-dhcp-pool-vlan200] gateway-list 192.2.1.2

[Switch-dhcp-pool-vlan200] quit

# 使能DHCP服务。

[Switch] dhcp enable

# gigabitethernet 1/0/1连接AC的接口,配置SwitchAC连接的GigabitEthernet1/0/1接口属性Trunk,允许VLAN 100VLAN 200通过。

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[Switch-GigabitEthernet1/0/1] quit

# gigabitethernet 1/0/2连接AP的接口,配置SwitchAP相连的GigabitEthernet1/0/2接口属性为Trunk,当前Trunk口的PVID100允许VLAN 1VLAN 200通过。

[Switch] interface gigabitethernet 1/0/2

[Switch-GigabitEthernet1/0/2] port link-type trunk

[Switch-GigabitEthernet1/0/2] port trunk permit vlan 1 200

[Switch-GigabitEthernet1/0/2] port trunk pvid vlan 100

 

3. 验证配置

# Client1Client2上线获取到地址分别是192.2.1.3192.2.1.4,通过抓包可以发现ICMP报文不需要经过ACAP间的隧道封装,直接转发,如图本地转发ICMP报文。

AC上输入<AC >display  arp查看无线客户端的arp表时,对应的接口显示的是物理接口。



配置关键点

0 个评论

该案例暂时没有网友评论

编辑评论

举报

×

侵犯我的权益 >
对根叔知了社区有害的内容 >
辱骂、歧视、挑衅等(不友善)

侵犯我的权益

×

泄露了我的隐私 >
侵犯了我企业的权益 >
抄袭了我的内容 >
诽谤我 >
辱骂、歧视、挑衅等(不友善)
骚扰我

泄露了我的隐私

×

您好,当您发现根叔知了上有泄漏您隐私的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您认为哪些内容泄露了您的隐私?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)

侵犯了我企业的权益

×

您好,当您发现根叔知了上有关于您企业的造谣与诽谤、商业侵权等内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到 zhiliao@h3c.com 邮箱,我们会在审核后尽快给您答复。
  • 1. 您举报的内容是什么?(请在邮件中列出您举报的内容和链接地址)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
  • 3. 是哪家企业?(营业执照,单位登记证明等证件)
  • 4. 您与该企业的关系是?(您是企业法人或被授权人,需提供企业委托授权书)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

抄袭了我的内容

×

原文链接或出处

诽谤我

×

您好,当您发现根叔知了上有诽谤您的内容时,您可以向根叔知了进行举报。 请您把以下内容通过邮件发送到zhiliao@h3c.com 邮箱,我们会尽快处理。
  • 1. 您举报的内容以及侵犯了您什么权益?(请在邮件中列出您举报的内容、链接地址,并给出简短的说明)
  • 2. 您是谁?(身份证明材料,可以是身份证或护照等证件)
我们认为知名企业应该坦然接受公众讨论,对于答案中不准确的部分,我们欢迎您以正式或非正式身份在根叔知了上进行澄清。

对根叔知了社区有害的内容

×

垃圾广告信息
色情、暴力、血腥等违反法律法规的内容
政治敏感
不规范转载 >
辱骂、歧视、挑衅等(不友善)
骚扰我
诱导投票

不规范转载

×

举报说明

提出建议

    +

亲~登录后才可以操作哦!

确定

亲~检测到您登陆的账号未在http://hclhub.h3c.com进行注册

注册后可访问此模块

跳转hclhub

你的邮箱还未认证,请认证邮箱或绑定手机后进行当前操作